Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 15/03/2017, à 19:06

BjD

demande d'authentification douteuse et instabilité (virus ????)

Bonjour
A plusieurs reprises dernièrement j'ai eu la fenêtre de demande d'authentification qui s'est ouverte après avoir démarré mon ordi une fois la session ouverte (avec, de mémoire, une justification du genre "afin de mettre à jour la base logicielle"), sans que cela semble directement lié à la dernière mise à jour effectuée (en effet d'habitude la demande d'authentification est faite préalablement à la mise à jour, pas après un démarrage...). J'étais dubitatif mais sans trop d'élément supplémentaire sur la confiance à accorder ou non au message je me suis exécuté.
Mais suite à ça j'ai eu beaucoup de plantages (gros ralentissements jusqu'au freeze total), à chaque fois peu après un démarrage, et également après chaque démarrage j'ai 2 fenêtre qui s'ouvrent (+ ou - simultanément) m'annonçant "Problème logiciel détecté - Voulez-vous signaler le problème maintenant ?", et si j'accepte on me demande de nouveau de m'identifier avec la justification "pour accéder à des rapports de problème de programmes système" (accompagné de "Détails: -action: com.ubuntu.apport.apport-gtk-root -fournisseur: Apport")

Tout d'abord est-ce normal de devoir s'identifier afin d'envoyer un rapport d'erreur ?? Puis-je accorder ma totale confiance à ces fenêtres ? (chat échaudé craint l'eau froide...)
Du coup pour l'instant je n'ai pas renvoyé ces rapport mais les 2 fenêtres s'ouvrent à chaque démarrage et j'aimerais bien m'en défaire... (mais de toute façon il me semble qu'elles reviendrons quand même si un pb de fond demeure... n'est-ce pas ?)
Pourquoi mon système est-il devenu instable et surtout que dois-je faire si son intégrité a été atteinte ??

Si j'étais sous Windows j'aurais suspecté une attaque par un logiciel malveillant... Pensez-vous que ça puisse être le cas là aussi ?
Du coup j'ai essayé d'installer un antivirus à partir de la Logitèque mais je n'ai trouvé que 2 occurrences de ClamTk, qui donnent le même résultat : une interface graphique dont tous les boutons sont manifestement sans effet, en accord avec les dernières évaluations dans la Logithèque "ne marche pas sur ubuntu 14"... (étant pour ma part sous Ubuntu 16.04 LTS)
Y aurait-il un autre antivirus que je pourrais tester ?

Merci pour toute aide éventuelle.

Hors ligne

#2 Le 16/03/2017, à 00:05

Vobul

Re : demande d'authentification douteuse et instabilité (virus ????)

Salut,

Ouvre un terminal (ce que tu devrais faire plus souvent pour un peu mieux connaître ta machine) et inscris ici ce que retournent ces commandes :

sudo apt-get update
sudo apt-get upgrade

Et je ne m'inquiéterai pas trop à ta place, si quelqu'un a piraté ton ordi, il n'a aucune raison de te le faire savoir en affichant des fenêtres sur ton écran wink

Va aussi lire les fichiers de log pour voir ce qu'il se passe (un indice sur votre écran : /var/log). Notamment ceux d'apt.


Vobul

Hors ligne

#3 Le 16/03/2017, à 12:12

BjD

Re : demande d'authentification douteuse et instabilité (virus ????)

bj@Lin:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Réception de:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]  
Atteint:3 http://archive.canonical.com/ubuntu xenial InRelease                       
Atteint:4 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease               
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease             
102 ko réceptionnés en 0s (143 ko/s)                                                 
Lecture des listes de paquets... Fait

bj@Lin:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcdaudio1 libfaac0 liblavfile-2.1-0 liblavjpeg-2.1-0 liblavplay-2.1-0
  libquicktime2 libslv2-9 linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
  linux-headers-4.4.0-34 linux-headers-4.4.0-34-generic linux-headers-4.4.0-36
  linux-headers-4.4.0-36-generic linux-headers-4.4.0-38
  linux-headers-4.4.0-38-generic linux-headers-4.4.0-42
  linux-headers-4.4.0-42-generic linux-headers-4.4.0-43
  linux-headers-4.4.0-43-generic linux-headers-4.4.0-45
  linux-headers-4.4.0-45-generic linux-headers-4.4.0-47
  linux-headers-4.4.0-47-generic linux-headers-4.4.0-51
  linux-headers-4.4.0-51-generic linux-headers-4.4.0-53
  linux-headers-4.4.0-53-generic linux-headers-4.4.0-57
  linux-headers-4.4.0-57-generic linux-headers-4.4.0-59
  linux-headers-4.4.0-59-generic linux-headers-4.4.0-62
  linux-headers-4.4.0-62-generic linux-headers-4.4.0-63
  linux-headers-4.4.0-63-generic linux-image-4.4.0-31-generic
  linux-image-4.4.0-34-generic linux-image-4.4.0-36-generic
  linux-image-4.4.0-38-generic linux-image-4.4.0-42-generic
  linux-image-4.4.0-43-generic linux-image-4.4.0-45-generic
  linux-image-4.4.0-47-generic linux-image-4.4.0-51-generic
  linux-image-4.4.0-53-generic linux-image-4.4.0-57-generic
  linux-image-4.4.0-59-generic linux-image-4.4.0-62-generic
  linux-image-4.4.0-63-generic linux-image-extra-4.4.0-31-generic
  linux-image-extra-4.4.0-34-generic linux-image-extra-4.4.0-36-generic
  linux-image-extra-4.4.0-38-generic linux-image-extra-4.4.0-42-generic
  linux-image-extra-4.4.0-43-generic linux-image-extra-4.4.0-45-generic
  linux-image-extra-4.4.0-47-generic linux-image-extra-4.4.0-51-generic
  linux-image-extra-4.4.0-53-generic linux-image-extra-4.4.0-57-generic
  linux-image-extra-4.4.0-59-generic linux-image-extra-4.4.0-62-generic
  linux-image-extra-4.4.0-63-generic linux-signed-image-4.4.0-31-generic
  linux-signed-image-4.4.0-34-generic linux-signed-image-4.4.0-36-generic
  linux-signed-image-4.4.0-38-generic linux-signed-image-4.4.0-42-generic
  linux-signed-image-4.4.0-43-generic linux-signed-image-4.4.0-45-generic
  linux-signed-image-4.4.0-47-generic linux-signed-image-4.4.0-51-generic
  linux-signed-image-4.4.0-53-generic linux-signed-image-4.4.0-57-generic
  linux-signed-image-4.4.0-59-generic linux-signed-image-4.4.0-62-generic
  linux-signed-image-4.4.0-63-generic mjpegtools mjpegtools-gtk python-gst0.10
  python-gudev python-simplejson ubuntu-core-launcher
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants ont été conservés :
  linux-generic linux-headers-generic linux-image-generic linux-signed-generic
  linux-signed-image-generic
0 mis à jour, 0 nouvellement installés, 0 à enlever et 5 non mis à jour.

Bon apparemment je devrais entrer « sudo apt autoremove », n'est-ce pas ?
Est-ce une commande à envoyer plus fréquemment pour faire du nettoyage ? Et donc à quelle occasion ??
Si des paquets ne sont plus nécessaires, est-ce normal qu'ils ne soient pas supprimés automatiquement par le système ?
Mais cela n'a sans doute pas de lien avec le pb ci-dessus..., si ??


J'ai trouvé des fichiers de log pleins d'infos potentiellement intéressantes... mais ça ne me dit pas forcément quoi faire pour autant hmm
Entre autres j'ai le fichier .xsession-errors suivant :

openConnection: connect: Aucun fichier ou dossier de ce type
cannot connect to brltty at :0
upstart: Le processus update-notifier-crash (/var/crash/_usr_lib_x86_64-linux-gnu_urfkill_urfkilld.0.crash) main (3195) s'est achevé avec l'état 1

Et j'ai les 3 fichiers suivants qui semblent être générés à chaque crach : upstart-file-bridge.3043.pid, upstart-dbus-bridge.3043.pid, et upstart-udev-bridge.3043.pid (avec le n° qui varie à chaque génération) et qui contiennent juste un autre nombre à 4 chiffre (presque) tjs différent...

D'autres fichiers vous permettraient-ils de m'aider ? (syslog, auth.log... ?)

Merci.

Hors ligne

#4 Le 16/03/2017, à 12:26

nam1962

Re : demande d'authentification douteuse et instabilité (virus ????)

Tu peux passer le

sudo apt autoremove

(pour la fréquence, une fois par trimestre va bien, plus fréquemment si tu installes désinstalles fréquemment des paquets))
Donne aussi :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1
df -Th
df -i

Dernière modification par nam1962 (Le 16/03/2017, à 12:28)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#5 Le 16/03/2017, à 13:27

BjD

Re : demande d'authentification douteuse et instabilité (virus ????)

Merci, voilà :

bj@Lin:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 14.04.1 LTS _Trusty Tahr_ - Release amd64 (20140722.2)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

# deb http://download.ebz.epson.net/dsc/op/stable/debian/ lsb3.2 main # désactivé pour la mise à niveau vers xenial

bj@Lin:~$ ls /etc/apt/sources.list.d -1
mc3man-nauty-mods-trusty.list
mc3man-nauty-mods-trusty.list.save

bj@Lin:~$ df -Th
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
udev             devtmpfs   1,9G       0  1,9G   0% /dev
tmpfs            tmpfs      388M    6,3M  382M   2% /run
/dev/sda2        ext4       456G     12G  422G   3% /
tmpfs            tmpfs      1,9G     25M  1,9G   2% /dev/shm
tmpfs            tmpfs      5,0M    4,0K  5,0M   1% /run/lock
tmpfs            tmpfs      1,9G       0  1,9G   0% /sys/fs/cgroup
/dev/sda1        vfat       511M    2,7M  509M   1% /boot/efi
cgmfs            tmpfs      100K       0  100K   0% /run/cgmanager/fs
tmpfs            tmpfs      388M     60K  388M   1% /run/user/1002

bj@Lin:~$ df -i
Sys. de fichiers   Inœuds IUtil.   ILibre IUti% Monté sur
udev               490494    491   490003    1% /dev
tmpfs              495740    810   494930    1% /run
/dev/sda2        30367744 421609 29946135    2% /
tmpfs              495740     15   495725    1% /dev/shm
tmpfs              495740      7   495733    1% /run/lock
tmpfs              495740     18   495722    1% /sys/fs/cgroup
/dev/sda1               0      0        0     - /boot/efi
cgmfs              495740     14   495726    1% /run/cgmanager/fs
tmpfs              495740     31   495709    1% /run/user/1002

A noter aussi, après avoir fait l'autoremove -mais je ne sais pas si c'était lié ou une coïncidence-, le gestionnaire de mise à jour s'est lancé avec le message suivant :

Toutes les mises à jour ne peuvent être installées

Lancer une mise à niveau partielle afin d'installer autant de mises à jour que possible.
Ceci peut être dû à:
*une précédente mise à jour qui s'est mal terminée
*des problèmes avec un ou plusieurs logiciels installés
*des paquets logiciels non officiels qu'Ubuntu ne fournit pas
*des changements normaux dus à une version bêta d'Ubuntu.

(mise à niveau partielle que j'ai lancée avant les commandes ci-dessus)

Hors ligne

#6 Le 16/03/2017, à 14:20

nam1962

Re : demande d'authentification douteuse et instabilité (virus ????)

..et qui a du réparer des trucs bloqués wink

Ton PPA

ppa:mc3man/nauty-mods

me chiffonne : il n'existe que pour Trusty, tu devrais le virer : il peut-être coupable de ton instabilité.
Le reste ne m'interpelle pas.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#7 Le 17/03/2017, à 11:48

BjD

Re : demande d'authentification douteuse et instabilité (virus ????)

Choux blanc sad

La suppression de ce PPA a donné ça :

bj@Lin:~$ sudo ppa-purge ppa:mc3man/nauty-mods[sudo] Mot de passe de bj : 
Updating packages lists
PPA to be removed: mc3man nauty-mods
Warning:  Could not find package list for PPA: mc3man nauty-mods

Il a déjà dû être viré depuis un bail

Et les symptômes sont tjs là... (avec encore un plantage hier mad )

Hors ligne

#8 Le 17/03/2017, à 12:06

nam1962

Re : demande d'authentification douteuse et instabilité (virus ????)

Il est probablement toujours là :

ls /etc/apt/sources.list.d -1

Le ppa purge ne fonctionnera en principe pas avec la syntaxe classique car le PPA est en trusty et que ppa-purge va chercher du xenial.

Essaie :

sudo ppa-purge "deb http://ppa.launchpad.net/mc3man/nauty-mods/ubuntu trusty main"

Si il ne veut pas de cette syntaxe, tu seras plus brutal :

sudo rm /etc/apt/sources.list.d/mc3man*

Puis à nouveau nettoyage :

sudo apt autoclean
sudo apt clean
sudo apt update && sudo apt full-upgrade
sudo apt autoremove

Pour les plantages, on peut aussi regarder du côté swap en réglant la swappiness :

echo vm.swappiness=5 | sudo tee /etc/sysctl.d/99-swappiness.conf
echo vm.vfs_cache_pressure=50 | sudo tee -a /etc/sysctl.d/99-swappiness.conf
sudo sysctl -p /etc/sysctl.d/99-swappiness.conf

Dernière modification par nam1962 (Le 17/03/2017, à 12:11)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#9 Le 17/03/2017, à 17:03

BjD

Re : demande d'authentification douteuse et instabilité (virus ????)

Pas mieux sad
Encore un freeze total avant le réglage de swappiness, et encore maintenant ces 2 fenêtres simultanées "Problème logiciel détecté"...

La génération des 3 fichiers upstart-udev-bridge.xxxx.pid, upstart-dbus-bridge.xxxx.pid, et upstart-file-bridge.xxxx.pid ne met pas sur une piste ?

Et au passage, je sais la signification de to swap mais je ne sais pas ce qu'est la swappiness... Risque de basculement ?? Entre quoi et quoi ?


En tout cas merci pour l'aide.

Hors ligne

#10 Le 17/03/2017, à 18:13

nam1962

Re : demande d'authentification douteuse et instabilité (virus ????)

Tu ne donnes pas les retours des commandes, alors c'est compliqué... hmm
Pour la swappiness, c'est grosso le taux de RAM libre avant déclenchement de la swap, par défaut c'est 60, là si la commande est bien passée c'est 5.

Pour le "problème logiciel", envoie le rapport d'erreur et coche "ne plus me prévenir"

Dernière modification par nam1962 (Le 17/03/2017, à 18:15)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#11 Le 17/03/2017, à 18:26

BjD

Re : demande d'authentification douteuse et instabilité (virus ????)

Pardon, mais les retours semblaient tout ce qu'il y a de plus normal donc ça ne me paraissait pas pertinent de les redonner là.
Voilà pour la swappiness :

bj@Lin:~$ echo vm.swappiness=5 | sudo tee /etc/sysctl.d/99-swappiness.conf
[sudo] Mot de passe de bj : 
vm.swappiness=5
bj@Lin:~$ echo vm.vfs_cache_pressure=50 | sudo tee -a /etc/sysctl.d/99-swappiness.conf
vm.vfs_cache_pressure=50
bj@Lin:~$ sudo sysctl -p /etc/sysctl.d/99-swappiness.conf
vm.swappiness = 5
vm.vfs_cache_pressure = 50

Tu veux que je refasse le nettoyage pour donner les retours ?

Hors ligne

#12 Le 17/03/2017, à 18:32

nam1962

Re : demande d'authentification douteuse et instabilité (virus ????)

Juste

ls /etc/apt/sources.list.d -1
sudo apt update
sudo apt full-upgrade

pour qu'on soit sûrs.

Pour tes messages d'erreur dis nous si tu en as d'autres.
Pour les freezes aussi


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne