Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/03/2017, à 10:33

vercoucas

[Résolu]Perte connexion DNS après mise en veille

Bonjour à tous,

J'ai installé xubuntu 16.04 sur un PC ACER ASPIRE M1100 il y a quelques mois et après la période de mise au point l'ensemble donne entière satisfaction.
Mais depuis quelques jours le PC perd le connxion DNS après une mise en veille.
Après un arrêt complet tout se passe bien, j'ai la liaison internet sur chromium et firefox, la connexion est stable.
Mais après une mise en veille les 2 navigateurs me donnent un message d'erreur concernant le serveur DNS.

ping 8.8.8.8 passe sans problème, donc la wifi , la box et internet fonctionnent mais
ping www.google.fr me renvoie le message d'erreur :unknown host www.google.fr
J'ai pensé qu'une récente mise à jour pouvait être la source du problème.
J'ai fait l'essai avec les noyaux 4.4.0.62 et 4.4.0.64 et j'ai le même défaut.

Je récupère ma connexion en réactivant network-manager.
sudo service network-manager restart

et après tout fonctionne ... mais bon ce n'est pas satisfaisant

Voilà quelques retours qui détaillent cela.


Chromium

Ce site est inaccessible

Impossible de trouver l'adresse DNS du serveur gw.geneanet.org.
Essayez les suggestions ci-dessous :
Vérifier les configurations du proxy, du pare-feu et du DNS
DNS_PROBE_FINISHED_BAD_CONFIG

Firefox

Firefox ne peut trouver le serveur à l’adresse forum.ubuntu-fr.org.

    Veuillez vérifier la syntaxe de l’adresse (saisie de ww.example.com au lieu de www.example.com par exemple) ;
    Si vous n’arrivez à naviguer sur aucun site, vérifiez la connexion au réseau de votre ordinateur ;
    Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy, assurez-vous que Firefox a l’autorisation d’accéder au Web.
sylvieb@ACER:~$ inxi -Fxz -c 10
System:    Host: ACER Kernel: 4.4.0-67-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Ubuntu 16.04 xenial
Machine:   System: Acer product: Aspire M1100 v: R01-A0
           Mobo: Acer model: F690GVM Bios: Phoenix v: 6.00 PG date: 05/04/2007
CPU:       Single core AMD Sempron 3600+ (-UP-) cache: 256 KB
           flags: (lm nx sse sse2 sse3) bmips: 1995 speed/max: 1000/2000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690 [Radeon X1200] bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1440x900@74.98hz
           GLX Renderer: Gallium 0.4 on ATI RS690
           GLX Version: 2.1 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.4.0-67-generic
Network:   Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: ee00 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter
           driver: ar5523 usb-ID: 001-005
           IF: wlx00184dd30da0 state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (43.7% used)
           ID-1: /dev/sda model: ST3250820AS size: 250.1GB
Partition: ID-1: / size: 32G used: 6.1G (20%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 1.88GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 171 Uptime: 22 min Memory: 394.0/1748.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.461) inxi: 2.2.35 
sylvieb@ACER:~$

sylvieb@ACER:~$ uname -a
Linux ACER 4.4.0-67-generic #88-Ubuntu SMP Wed Mar 8 16:34:45 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
sylvieb@ACER:~$ 


sylvieb@ACER:~$ iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlx00184dd30da0  IEEE 802.11bg  ESSID:"regis"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 02:FD:D7:DD:DE:38   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=30/70  Signal level=-80 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:241  Invalid misc:47   Missed beacon:0

sylvieb@ACER:~$ 

sylvieb@ACER:~$ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 00:01:6c:0e:0d:0d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:19 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:2920 erreurs:0 :0 overruns:0 frame:0
          TX packets:2920 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:208067 (208.0 KB) Octets transmis:208067 (208.0 KB)

wlx00184dd30da0 Link encap:Ethernet  HWaddr 00:18:4d:d3:0d:a0  
          inet adr:192.168.0.11  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::d211:174e:5704:6681/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:23 erreurs:0 :0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:2173 (2.1 KB) Octets transmis:10552 (10.5 KB)

sylvieb@ACER:~$


sylvieb@ACER:~$ ping -c10 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=58 time=37.9 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=58 time=33.6 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=58 time=33.4 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=58 time=33.0 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=58 time=33.1 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=58 time=33.5 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=58 time=33.4 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=58 time=33.1 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=58 time=35.0 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=58 time=32.7 ms

--- 8.8.8.8 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9012ms
rtt min/avg/max/mdev = 32.787/33.910/37.992/1.491 ms
sylvieb@ACER:~$ ping -c10 www.google.fr
ping: unknown host www.google.fr
sylvieb@ACER:~$ 

Ayant vu le fil de moko138 sur à propos du noyau 4.4.0-67, je l'ai désinstallé et je suis maintenant en 4.4.0-66

Merci de votre aide

Dernière modification par vercoucas (Le 17/04/2017, à 16:24)

Hors ligne

#2 Le 29/03/2017, à 10:18

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Bonjour à tous,

En fin de compte j'ai tout réinstallé xubuntu 16.04.
Et là j'ai eu la mauvaise surprise de voir que mon problème est encore présent.
Il ne reste comme noyau que 4.4.0.66 et 4.4.031.
Si je relance network-manager en retour de veille, la connexion s'établit et est parfaitement stable.

Autre élément que je n'avais pas signalé car je ne suis pas sûr qu'il y ait un lien : le voyant de la clé wifi reste allumée quand le PC est mis à l'arrêt.

Pour voir j'ai mis la clé usb de mon autre PC, (TL-WN725N chip 8188eu) en remplacement de la "wpn111 chip ar5523" qui l'équipe normalement ...la liaison wifi fonctionne et je ne perds plus la liaison en retour de veille.

Le problème semble donc lié à ma clé wifi : Card-2: Netgear WPN111 RangeMax Wireless USB 2.0 Adapter
           driver: ar5523 usb-ID: 001-005


Merci de votre aide

Hors ligne

#3 Le 29/03/2017, à 18:06

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

Bonjour vercoucas,

tu peux faire cette manip pour automatiser le restart de network-manager :
1) - Créer un script dans le répertoire /etc/pm/sleep.d :

echo -e '#!/bin/sh\n/etc/init.d/network-manager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh

2) - Rendre le script exécutable:

sudo chmod +x /etc/pm/sleep.d/NWM.sh

Dernière modification par f.x0 (Le 29/03/2017, à 18:07)


SOPI

Hors ligne

#4 Le 30/03/2017, à 10:21

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Bonjour f.x0,

Merci pour ton aide.

J'ai essayé en en copiant les lignes dans le terminal. L'opération s'est bien passée, mais le problème  est resté : toujours pas de connexion après la mise en veille.
J'ai recommencé en rajoutant    service    avant   network-manager restart, mais le problème reste... peut-être que l'exécution de service network-manager restart se fait trop vite et qu'il faudrait ajouter une pause

sylvieb@Aspire-M1100:~$ echo -e '#!/bin/sh\n/etc/init.d/service network-manager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh
[sudo] Mot de passe de sylvieb : 
#!/bin/sh
/etc/init.d/service network-manager restart
exit 0
sylvieb@Aspire-M1100:~$ sudo chmod +x /etc/pm/sleep.d/NWM.sh
sylvieb@Aspire-M1100:~$ cat /etc/pm/sleep.d/NWM.sh 
#!/bin/sh
/etc/init.d/service network-manager restart
exit 0
sylvieb@Aspire-M1100:~$ sudo service network-manager restart
sylvieb@Aspire-M1100:~$ ls -l /etc/pm/sleep.d/NWM.sh
-rwxr-xr-x 1 root root 61 mars  30 09:57 /etc/pm/sleep.d/NWM.sh
sylvieb@Aspire-M1100:~$ 

Hors ligne

#5 Le 30/03/2017, à 10:30

jplemoine

Re : [Résolu]Perte connexion DNS après mise en veille

vercoucas a écrit :
/etc/init.d/service network-manager restart

Attention, tu nous a fais un "remix" de 2 commandes exclusive entre elles.
C'est

/etc/init.d/network-manager restart

ou

service network-manager restart

Cordialement, Jean-Philippe.
Système principal Sous Ubuntu de 2009 à février 2015 - Xubuntu depuis.
Xubuntu 16.04 (poste principal portable) - Ubuntu 16.04 server (desktop converti en serveur DHCP, DNS, dépôt local et supervision (shinken))
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)

Hors ligne

#6 Le 30/03/2017, à 19:00

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

merci jplemoine,

Je rectifie.
J'avais d'abord saisi la bonne commande, mais comme je n'avais pas le résultat attendu, j'ai fait la bêtise d'improviser...

Hors ligne

#7 Le 30/03/2017, à 22:44

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

C'est dommage, cela fonctionne super chez moi
en faisant

/etc/init.d/network-manager restart

dans le script.

que donne

lshw -class network

et

lsmod | sort

Dernière modification par f.x0 (Le 30/03/2017, à 22:45)


SOPI

Hors ligne

#8 Le 31/03/2017, à 09:45

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Oui c'est étonnant, car quand je rentre la phrase magique "sudo service network-manager restart", çà marche à tous les coups et c'est tout à fait stable.
Ce ne serait pas un problème de timing ?


Voici les retours

sylvieb@Aspire-M1100:~$ sudo lshw -class network
[sudo] Mot de passe de sylvieb : 
  *-network               
       description: Ethernet interface
       produit: 88E8056 PCI-E Gigabit Ethernet Controller
       fabriquant: Marvell Technology Group Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: enp2s0
       version: 20
       numéro de série: 00:01:6c:0e:0d:0d
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
       ressources: irq:25 mémoire:fdcfc000-fdcfffff portE/S:ee00(taille=256) mémoire:fdc00000-fdc1ffff
  *-network
       description: Interface réseau sans fil
       identifiant matériel: 1
       information bus: usb@1:7
       nom logique: wlx00184dd30da0
       numéro de série: 00:18:4d:d3:0d:a0
       fonctionnalités: ethernet physical wireless
       configuration: broadcast=yes driver=ar5523 driverversion=4.4.0-70-generic firmware=N/A ip=192.168.0.10 link=yes multicast=yes wireless=IEEE 802.11bg

sylvieb@Aspire-M1100:~$



sylvieb@Aspire-M1100:~$ lsmod | sort
8250_fintek            16384  0
ahci                   36864  2
amd_iommu_v2           20480  1 amdkfd
amdkfd                131072  1
ar5523                 40960  0
arc4                   16384  2
autofs4                40960  2
cfg80211              565248  2 mac80211,ar5523
crc_itu_t              16384  1 firewire_core
drm                   364544  6 ttm,drm_kms_helper,radeon
drm_kms_helper        155648  1 radeon
edac_core              53248  0
edac_mce_amd           24576  0
fb_sys_fops            16384  1 drm_kms_helper
firewire_core          65536  1 firewire_ohci
firewire_ohci          40960  0
fjes                   28672  0
floppy                 73728  0
hid                   118784  2 hid_generic,usbhid
hid_generic            16384  0
i2c_algo_bit           16384  1 radeon
i2c_piix4              24576  0
input_leds             16384  0
k8temp                 16384  0
libahci                32768  1 ahci
lp                     20480  0
mac80211              737280  1 ar5523
mac_hid                16384  0
Module                  Size  Used by
parport                49152  3 lp,ppdev,parport_pc
parport_pc             32768  1
pata_acpi              16384  0
pata_atiixp            16384  0
ppdev                  20480  0
radeon               1515520  3
serio_raw              16384  0
shpchp                 36864  0
sky2                   61440  0
snd                    81920  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
snd_hda_codec         135168  3 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel
snd_hda_codec_generic    77824  1 snd_hda_codec_realtek
snd_hda_codec_realtek    86016  1
snd_hda_core           73728  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hda_intel          40960  3
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               106496  3 snd_hda_codec,snd_hda_intel,snd_hda_core
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
soundcore              16384  1 snd
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
ttm                    94208  1 radeon
uas                    24576  0
usbhid                 49152  0
usb_storage            69632  1 uas
sylvieb@Aspire-M1100:~$

merci encore

Hors ligne

#9 Le 31/03/2017, à 16:22

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

vercoucas a écrit :

peut-être que l'exécution de service network-manager restart se fait trop vite et qu'il faudrait ajouter une pause

Ce ne serait pas un problème de timing ?

Tu as peut-être raison, mais tu peux tester ceci avant de rajouter un délai supplémentaire.

echo "SUSPEND_MODULES=ar5523 " | sudo tee -a /etc/pm/config.d/load
sudo chmod +x /etc/pm/config.d/load

puis dis ce que cela donne après redémarrage du PC et mise veille.

Dernière modification par f.x0 (Le 31/03/2017, à 16:23)


SOPI

Hors ligne

#10 Le 31/03/2017, à 20:43

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Voilà :

sylvieb@Aspire-M1100:~$ cat /etc/pm/config.d/load
SUSPEND_MODULES=ar5523 
sylvieb@Aspire-M1100:~$ 
sylvieb@Aspire-M1100:~$ ls -l /etc/pm/config.d/load
-rwxr-xr-x 1 root root 24 mars  31 19:30 /etc/pm/config.d/load
sylvieb@Aspire-M1100:~$ 

Puis redémarrage et mise en veille : pas de changement le message d'erreur Chromium est le même "Impossible de trouver l'adresse DNS du serveur".

Hors ligne

#11 Le 31/03/2017, à 23:35

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

Tu peux tenter de rajouter un délai
supprimes le fichier

sudo rm -v /etc/pm/sleep.d/NWM.sh

rajoutes un délai

echo -e '#!/bin/sh\nsleep 59\n/etc/init.d/network-manager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh

Rends le script exécutable:

sudo chmod +x /etc/pm/sleep.d/NWM.sh

puis tentes la mise en veille


SOPI

Hors ligne

#12 Le 01/04/2017, à 09:23

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Ok, je fais la modification,

sylvieb@Aspire-M1100:~$ sudo rm -v /etc/pm/sleep.d/NWM.sh
[sudo] Mot de passe de sylvieb : 
'/etc/pm/sleep.d/NWM.sh' supprimé
sylvieb@Aspire-M1100:~$ echo -e '#!/bin/sh\nsleep 59\n/etc/init.d/network-manager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh
#!/bin/sh
sleep 59
/etc/init.d/network-manager restart
exit 0
sylvieb@Aspire-M1100:~$ sudo chmod +x /etc/pm/sleep.d/NWM.sh
sylvieb@Aspire-M1100:~$ 
sylvieb@Aspire-M1100:~$ ls -l  /etc/pm/sleep.d/NWM.sh
-rwxr-xr-x 1 root root 62 avril  1 09:07 /etc/pm/sleep.d/NWM.sh
sylvieb@Aspire-M1100:~$ cat  /etc/pm/sleep.d/NWM.sh
#!/bin/sh
sleep 59
/etc/init.d/network-manager restart
exit 0
sylvieb@Aspire-M1100:~$ 

Je mets en veille et au retour de veille je tente plusieurs fois de me connecter sur le forum. J'obtiens à chaque fois le message :
"Impossible de trouver l'adresse DNS du serveur forum.ubuntu-fr.org."

Hors ligne

#13 Le 01/04/2017, à 11:11

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

Il y a une autre solution, mais avant essaies en supprimant le fichier /etc/pm/config.d/load

sudo rm -v /etc/pm/config.d/load

puis dis ce que cela donne après redémarrage du PC et mise veille.


SOPI

Hors ligne

#14 Le 01/04/2017, à 12:07

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

J'efface le fichier :

sylvieb@Aspire-M1100:/etc/pm/config.d$ ls
sylvieb@Aspire-M1100:/etc/pm/config.d$ 

J'ai arrêté et redémarré, puis mise en veille et retour.
J'ai fais trois opération veille - retour pour bien vérifier et j'ai obtenu à chaque fois le même résultat.
La fenêtre "connexion établie" apparaît quelques secondes et s'efface, mais je n'ai toujours pas de connexion DNS.

Merci pour ton aide

Hors ligne

#15 Le 01/04/2017, à 15:12

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

OK, Ok c'est bien dommage que cela ne fonctionne pas pour toi, chez moi c'est nickel ...

Du coup on va essayer autre chose ...
tapes

sudo rm -v /etc/pm/sleep.d/NWM.sh
sudo apt-get install gksu
echo -e '#!/bin/sh\ngksudo /usr/sbin/service NetworkManager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh

Rends le script exécutable:

sudo chmod +x /etc/pm/sleep.d/NWM.sh

puis redémarres et tentes la mise en veille
tu devrais avoir une demande de mot de passe pour relancer NetworkManager


SOPI

Hors ligne

#16 Le 01/04/2017, à 16:06

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Oui, j'ai refait plusieurs tentatives, mais j'ai toujours le même résultat.
Je fais la modif (sauf gksudo qui est déjà installé)

sylvieb@Aspire-M1100:~$ sudo rm -v /etc/pm/sleep.d/NWM.sh
[sudo] Mot de passe de sylvieb : 
'/etc/pm/sleep.d/NWM.sh' supprimé
sylvieb@Aspire-M1100:~$ echo -e '#!/bin/sh\ngksudo /usr/sbin/service NetworkManager restart\nexit 0' | sudo tee /etc/pm/sleep.d/NWM.sh
#!/bin/sh
gksudo /usr/sbin/service NetworkManager restart
exit 0
sylvieb@Aspire-M1100:~$ 
sylvieb@Aspire-M1100:~$ sudo chmod +x /etc/pm/sleep.d/NWM.sh
sylvieb@Aspire-M1100:~$ 

Redémarrage et 4 séquences de veille-retour pour bien vérifier.
Mais pas de changement, toujours le même message d'erreur.
Je n'ai pas de demande de mot de passe : est-ce parce que je le rentre régulièrement pour réactiver manuellement network-manager?
Pourquoi la commande manuelle agit alors que le lancement automatique semble sans effet ?

Merci pour ton aide, j'apprécie tes conseils.

Hors ligne

#17 Le 01/04/2017, à 18:13

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

Je pense que le script n'est pas pris en compte lors du retour de veille.
le répertoire semble ignoré chez toi, mais pas chez moi.
Cela vient peut-être de notre environnement de bureau différent.

Tu peux faire un lanceur sur ton bureau en mettant la commande

gksudo /usr/sbin/service NetworkManager restart

il te faudra cliquer dessus après ta mise en veille et mettre ton mot de passe.

C'est pas top, mais ça t'évitera de taper à commande à chaque fois.

Je n'ai pas XFCE mais tu peux essayer d'adapter l'astuce en mettant le script
ailleurs dans le répertoire /etc/pm ....

postes le retour de

locate network-manager

Dernière modification par f.x0 (Le 01/04/2017, à 18:13)


SOPI

Hors ligne

#18 Le 01/04/2017, à 19:41

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

J'ai fais un petit script appelé nm que j'ai mis dans le bureau

sylvieb@Aspire-M1100:~$ cat /home/sylvieb/Bureau/nm
#!/bin/bash

gksudo /usr/sbin/service NetworkManager restart

exit 0
sylvieb@Aspire-M1100:~$ 
sylvieb@Aspire-M1100:~$ ls -l /home/sylvieb/Bureau/nm
-rwxrwxr-x 1 sylvieb sylvieb 69 avril  1 19:26 /home/sylvieb/Bureau/nm
sylvieb@Aspire-M1100:~$ 

Et là c'est opérationnel comme lorsque je saisis manuellement la commande !

Voilà le retour de locate network-manager

sylvieb@Aspire-M1100:~$ locate network-manager
/etc/dnsmasq.d/network-manager
/etc/init/network-manager.conf
/etc/init.d/network-manager
/lib/systemd/system/network-manager.service
/usr/share/app-install/desktop/network-manager-gnome:nm-applet.desktop
/usr/share/apport/package-hooks/source_network-manager-applet.py
/usr/share/apport/package-hooks/source_network-manager.py
/usr/share/doc/network-manager
/usr/share/doc/network-manager-gnome
/usr/share/doc/network-manager-pptp
/usr/share/doc/network-manager-pptp-gnome
/usr/share/doc/network-manager/AUTHORS
/usr/share/doc/network-manager/NEWS.Debian.gz
/usr/share/doc/network-manager/NEWS.gz
/usr/share/doc/network-manager/README.Debian
/usr/share/doc/network-manager/README.gz
/usr/share/doc/network-manager/changelog.Debian.gz
/usr/share/doc/network-manager/copyright
/usr/share/doc/network-manager/examples
/usr/share/doc/network-manager/examples/server.conf
/usr/share/doc/network-manager-gnome/NEWS.gz
/usr/share/doc/network-manager-gnome/README.Debian
/usr/share/doc/network-manager-gnome/changelog.Debian.gz
/usr/share/doc/network-manager-gnome/copyright
/usr/share/doc/network-manager-pptp/AUTHORS
/usr/share/doc/network-manager-pptp/NEWS.gz
/usr/share/doc/network-manager-pptp/README
/usr/share/doc/network-manager-pptp/changelog.Debian.gz
/usr/share/doc/network-manager-pptp/copyright
/usr/share/doc/network-manager-pptp-gnome/changelog.Debian.gz
/usr/share/doc/network-manager-pptp-gnome/copyright
/usr/share/polkit-1/rules.d/60-network-manager.rules
/var/lib/app-info/icons/ubuntu-xenial-main/64x64/network-manager-gnome_preferences-system-network.png
/var/lib/app-info/icons/ubuntu-xenial-security-main/64x64/network-manager-gnome_preferences-system-network.png
/var/lib/app-info/icons/ubuntu-xenial-updates-main/64x64/network-manager-gnome_preferences-system-network.png
/var/lib/dpkg/info/network-manager-gnome.conffiles
/var/lib/dpkg/info/network-manager-gnome.list
/var/lib/dpkg/info/network-manager-gnome.md5sums
/var/lib/dpkg/info/network-manager-gnome.postinst
/var/lib/dpkg/info/network-manager-gnome.postrm
/var/lib/dpkg/info/network-manager-gnome.preinst
/var/lib/dpkg/info/network-manager-gnome.prerm
/var/lib/dpkg/info/network-manager-pptp-gnome.list
/var/lib/dpkg/info/network-manager-pptp-gnome.md5sums
/var/lib/dpkg/info/network-manager-pptp.conffiles
/var/lib/dpkg/info/network-manager-pptp.list
/var/lib/dpkg/info/network-manager-pptp.md5sums
/var/lib/dpkg/info/network-manager-pptp.preinst
/var/lib/dpkg/info/network-manager.conffiles
/var/lib/dpkg/info/network-manager.list
/var/lib/dpkg/info/network-manager.md5sums
/var/lib/dpkg/info/network-manager.postinst
/var/lib/dpkg/info/network-manager.postrm
/var/lib/dpkg/info/network-manager.preinst
/var/lib/dpkg/info/network-manager.prerm
sylvieb@Aspire-M1100:~$ 

Hors ligne

#19 Le 01/04/2017, à 20:45

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

vercoucas a écrit :

Et là c'est opérationnel comme lorsque je saisis manuellement la commande !

Ben oui, c'est bête que le script ne fonctionne pas
avec /etc/init.d/network-manager

mais je ne vois pas comment faire mieux qu'avec le lanceur
qui lance gksudo /usr/sbin/service NetworkManager restart.

Bon c'est pas si mal, mais je ne vois pas pourquoi l'autre méthode (plus cool quand même)
ne fonctionne pas.


SOPI

Hors ligne

#20 Le 01/04/2017, à 21:40

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Oui maintenant la solution est opérationnelle. Chaque utilisateur de la famille peut cliquer sur le fichier et rentrer le mot de passe.

Au #14, il est indiqué que le message  "connexion établie" s'affiche à chaque sortie de veille, ce qui montre que le script fonctionnait et que network-manager était bien lancé, peut-être que la perte de DNS arrivait après.


Je te remercie beaucoup pour ton aide

Hors ligne

#21 Le 03/04/2017, à 22:21

milor

Re : [Résolu]Perte connexion DNS après mise en veille

Bonjour, j'ai exactement le même problème avec un Dell XPS15 9550
Merci pour cette solution qui m'évite de rebooter mon pc après chaque mise en veille,
Ce problème est apparu chez moi , il y a environ 1 mois, certainement après une quelconque mise à jour,
je suis en dual boot avec windows  10 ou il n'y a pas ce défaut.
En attendant un correctif Ubuntu......Merci encore !

Hors ligne

#22 Le 17/04/2017, à 16:24

vercoucas

Re : [Résolu]Perte connexion DNS après mise en veille

Bonjour à tous
Le problème a disparu avec la dernière mise à jour et le noyau 4.4.0-72-generic.
J'ai fais une dizaine d'essais "veille /retour" et à chaque fois la connexion s'est parfaitement rétablie.

Merci au forum ... et aux développeurs

Hors ligne

#23 Le 17/04/2017, à 23:15

f.x0

Re : [Résolu]Perte connexion DNS après mise en veille

Je suis content pour toi que cela ait fonctionné vercoucas, bonne continuation sur Gnu/Linux


SI TU PENSES QUE TON PROBLÈME EST SOLUTIONNÉ, AJOUTES [RÉSOLU] DANS LE TITRE DE TON PREMIER POST, CELA POURRA AIDER D'AUTRES UBUNTEROS QUI ONT LE MÊME PROBLÈME QUE TOI. wink


SOPI

Hors ligne