Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 22/03/2017, à 14:56

david974

Re : Problème avec une version Linux + Problème nettoyage /boot

oem@201512834:~$ sudo apt-get -f install
[sudo] Mot de passe de oem : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libsnack-alsa libtcl8.5 libtk8.5 linux-headers-4.4.0-47
  linux-headers-4.4.0-47-generic linux-headers-4.4.0-51
  linux-headers-4.4.0-51-generic linux-image-4.4.0-47-generic
  linux-image-4.4.0-51-generic linux-image-extra-4.4.0-47-generic
  linux-image-extra-4.4.0-51-generic linux-image-generic
  linux-signed-image-4.4.0-47-generic linux-signed-image-4.4.0-51-generic
  tcl-snack tcl-tls tcl8.5 tk8.5
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  linux-image-4.4.0-67-generic
Paquets suggérés :
  fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
Les NOUVEAUX paquets suivants seront installés :
  linux-image-4.4.0-67-generic
0 mis à jour, 1 nouvellement installés, 0 à enlever et 229 non mis à jour.
11 partiellement installés ou enlevés.
Il est nécessaire de prendre 21,8 Mo dans les archives.
Après cette opération, 66,4 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-image-4.4.0-67-generic amd64 4.4.0-67.88 [21,8 MB]
21,8 Mo réceptionnés en 2min 36s (139 ko/s)                                    
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
(Lecture de la base de données... 389156 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-4.4.0-67-generic_4.4.0-67.88_amd64.deb ...
Done.
Dépaquetage de linux-image-4.4.0-67-generic (4.4.0-67.88) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-4.4.0-67-generic_4.4.0-67.88_amd64.deb (--unpack) :
 impossible de copier les données extraites pour « ./boot/System.map-4.4.0-67-generic » vers « /boot/System.map-4.4.0-67-generic.dpkg-new » : échec d'écriture (Aucun espace disponible sur le périphérique)
Aucun rapport « apport » n'a été créé car un disque plein a été signalé
                                                                       dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-67-generic /boot/vmlinuz-4.4.0-67-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-67-generic /boot/vmlinuz-4.4.0-67-generic
The link /initrd.img is a damaged link
Removing symbolic link initrd.img 
 you may need to re-run your boot loader[grub]
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/linux-image-4.4.0-67-generic_4.4.0-67.88_amd64.deb
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)

j'ai ensuite entré la commande indiqué par Christophe C et voilà ce que ça me donne

Hors ligne

#27 Le 22/03/2017, à 21:39

moko138

Re : Problème avec une version Linux + Problème nettoyage /boot

 impossible de copier (...) vers « /boot/(...)  (Aucun espace disponible sur le périphérique)

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#28 Le 22/03/2017, à 21:50

jplemoine

Re : Problème avec une version Linux + Problème nettoyage /boot

moko138 a écrit :
 impossible de copier (...) vers « /boot/(...)  (Aucun espace disponible sur le périphérique)

Oh ! Quelle surprise !!! Je suis vraiment surpris. Je crois que je ne vais pas en dormir de la nuit !!! smile
Et donc maintenant, il y a 2 blocages...
Ça sent la réinstallation à plein nez....


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#29 Le 22/03/2017, à 22:00

moko138

Re : Problème avec une version Linux + Problème nettoyage /boot

Pourquoi "2" (blocages) ?
Et pourquoi réinstaller ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#30 Le 22/03/2017, à 22:22

jamesbad000

Re : Problème avec une version Linux + Problème nettoyage /boot

Ok j'ai pu reproduire le problème de dépendance et le régler. Dans cette situation qui semble plutôt causée non par le boot plein, mais plutôt par une interruption sauvage de apt, il faut supprimer d'un coup tous les paquets qui étaientt en cours d'install, avec ceux qui en dépendent (Ici les paquets parents du kernel generic, qui pilotent les changement de version...)

sudo apt-get -y remove linux-signed-image-generic linux-headers-generic linux-image-generic linux-generic $(echo $(dpkg-query -W --showformat='${Package} ${Status}\n' linux-*-4.4.0-67* linux-*-4.4.0-62*  | cut -d' ' -f1))

Edit Il est possible que je n'ai pas l’exhaustivité des paquets en causes. Donc en cas d'échec, il faudra me retourner en plus le résultat de

sudo dpkg-query -l linux-* | ^i

Edit2: Ne fait pas apt-get autoremove à la suite, il y a un truc que j'ai oublié de vérifié à ce sujet...

moko138 a écrit :

Pourquoi "2" (blocages) ?
Et pourquoi réinstaller ?

C'est le principe de la mystification:  Il y aura des guerres... il y aura des pestes... Alors tremblez mortadelle, ou j'vous coupe en rondelles...
Malheureusement je sais pas le dire en Latin roll

Dernière modification par jamesbad000 (Le 23/03/2017, à 10:14)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#31 Le 22/03/2017, à 23:14

jplemoine

Re : Problème avec une version Linux + Problème nettoyage /boot

2 blocages
- apt
- boot plein.
--> A force d'insister, la partie réservée au système va se remplir.
Si elle est totalement remplie, le système va être "corrompu".
Et plutôt que passer un temps certain à remettre le système d'aplomb, il faudra mieux réinstaller.


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#32 Le 23/03/2017, à 18:04

david974

Re : Problème avec une version Linux + Problème nettoyage /boot

oem@201512834:~$ sudo apt-get -y remove linux-signed-image-generic linux-headers-generic linux-image-generic linux-generic $(echo $(dpkg-query -W --showformat='${Package} ${Status}\n' linux-*-4.4.0-67* linux-*-4.4.0-62*  | cut -d' ' -f1))
[sudo] Mot de passe de oem : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « linux-generic » n'est pas installé, et ne peut donc être supprimé
Le paquet « linux-image-4.4.0-67-generic » n'est pas installé, et ne peut donc être supprimé
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-signed-generic : Dépend: linux-signed-image-generic (= 4.4.0.67.72) mais ne sera pas installé
                        Dépend: linux-headers-generic (= 4.4.0.67.72) mais ne sera pas installé
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
oem@201512834:~$ sudo dpkg-query -l linux-* | ^i
^i : commande introuvable

voici les résultats des deux commandes indiquées jamesbad000

Hors ligne

#33 Le 24/03/2017, à 01:43

jamesbad000

Re : Problème avec une version Linux + Problème nettoyage /boot

Evidemment si j'oublie des bouts de commandes ça marche pas...
Bon de toute façon, après vérif plus approfondi, même si le remove passe quand on lui donne la bonne liste de paquet, il reste encore trop de manip à faire pour que ça soit avantageux de commencer par là. Donc faisons le ménage directement dans /boot.

sudo find /boot -regextype posix-extended -regex  ".*4.4.0-(47|51).*" -exec rm {} \;
sudo find /boot -regextype posix-extended -regex  ".*3.13.0-100.*" -exec rm {} \;
sudo apt-get install -f
sudo apt-get autoremove

Dernière modification par jamesbad000 (Le 24/03/2017, à 09:58)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#34 Le 24/03/2017, à 03:29

moko138

Re : Problème avec une version Linux + Problème nettoyage /boot

Ah ! Je me doute de ce que fait ta ligne, jamesbad smile :

sudo find /boot -regextype posix-extended -regex  ".*4.4.0-(47|51).*" -exec rm {} \;

mais là, je suis syntaxiquement largué !


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#35 Le 24/03/2017, à 08:49

jplemoine

Re : Problème avec une version Linux + Problème nettoyage /boot

jamesbad000 a écrit :
sudo apt-get -f

Parce qu'avec celle-là tu n'es pas largué ? Faut m'expliquer ce qu'elle est censée faire...

Dernière modification par jplemoine (Le 24/03/2017, à 08:49)


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#36 Le 24/03/2017, à 12:32

moko138

Re : Problème avec une version Linux + Problème nettoyage /boot

Zen ! 
smile


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#37 Le 24/03/2017, à 16:48

david974

Re : Problème avec une version Linux + Problème nettoyage /boot

oem@201512834:~$ sudo find /boot -regextype posix-extended -regex  ".*4.4.0-(47|51).*" -exec rm {} \;
[sudo] Mot de passe de oem : 
oem@201512834:~$ sudo find /boot -regextype posix-extended -regex  ".*3.13.0-100.*" -exec rm {} \;
oem@201512834:~$ sudo apt-get install -f
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.
oem@201512834:~$ sudo apt-get autoremove
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.

Hors ligne

#38 Le 24/03/2017, à 18:15

jamesbad000

Re : Problème avec une version Linux + Problème nettoyage /boot

david974 a écrit :
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)

Ce genre d'erreur arrive généralement parce que un autre process de gestion de paquet est en cours (mise à jour auto probablement)
Donc attendre un peu et tenter à nouveau (les 2 dernières commandes seulement)...

Dernière modification par jamesbad000 (Le 24/03/2017, à 19:23)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne