Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 17/03/2008, à 23:11

Ju323

KDE4: Desactiver les Desktop effects en mode texte

Depuis que j ai activé certaines options d'effets dans KDE4, je n ai plus qu un ecran noir sad
Je n ai trouvé nulle part l'information me permettant de desactiver cette option en mode terminal ...
Si quelqu un a une idee.

Y a-t-il un mode failsafe KDE4, qui me permet d'accéder aux options?

J'ai deja essayé de modifier mon xorg.conf pour que les effets 3D ne marchent plus (lol, d habitude on fait le contraire), mais cela n'arrange rien ...

Merci de votre aide.

#2 Le 18/03/2008, à 10:22

thibaut28

Re : KDE4: Desactiver les Desktop effects en mode texte

Salut Ju323,

Tu n'as pas d'autres WM à part KDE4 ? Un gnome, un fluxbox.... Il suffit de lancer systemsettings (celui de kde4) de n'importe où et d'enlever les effets. Au pire connecte toi en mode console, puis "sudo startx" et systemsettings. Ca sera toujours plus propre que d'effacer des fichiers de préférences smile

Dernière modification par thibaut28 (Le 18/03/2008, à 10:25)


Quis custodiet ipsos custodes ¿
Mon DeviantArt :)

Hors ligne

#3 Le 18/03/2008, à 10:40

moi1392

Re : KDE4: Desactiver les Desktop effects en mode texte

Je ne suis pas sous kde4 actuellement, donc je peux pas vérifier, mais tu as 2 solutions

la première (et la plus logique dans ton cas) est d'éditer le fichier $KDEHOME/share/config/kwinrc ($KDEHOME = ~/.kde4 dans l'install ubuntu par défaut) et de virer la ligne qui correspond à l'activation des effets 3D. (de têt de je sais pas c'est laquelle, mais ça devrait être reconnaissable)

la seconde, qui ne marchera pas dans ton cas, car il faut un terminal ouvert dans la session graphique, est d'utiliser l'appel dbus qui va bien.
qdbus est très pratique pour ça.
$>qdbus
te donne la liste des applis qui ont une interface dbus, ensuite
$>qdbus kwin.xxxx
tu rcupereras la bonne valeur "xxxx" grace au retour du premier appel qdbus, celui là te donne la liste des méthodes qui tu peux appeler sur ton objet, et ainsi de suite...
y'a une méthode sur kwin qui permet d'activer/désactiver le compositing (effets 3D) ou plus précisément, d'activer/désactiver un effet en particulier.

Dernière modification par moi1392 (Le 18/03/2008, à 10:41)

Hors ligne

#4 Le 18/03/2008, à 11:13

jajaX

Re : KDE4: Desactiver les Desktop effects en mode texte


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#5 Le 18/03/2008, à 12:00

ju323

Re : KDE4: Desactiver les Desktop effects en mode texte

Merci a tous pour vos réponses rapides.
C'est bon, j ai pu modifier mes pref depuis kde3.
Reste que j essaye de faire pas mal de tests pour voir ce qui me plante, au passage, j ai trouvé une technique plus rapide:
1) Je laisse la fenetre system settings ouverte,
2) J apply mes modifs
3) Si j ai un ecran noir, je swich en mode terminal (ctrl+alt+F1), et je tue kwin
4) Je retourne en mode graphique, la je n ai acces qu a ma premiere fenetre (ca tombe bien, c est system settings)
5) Je remodifie les valeurs.

En option, on peut faire plein de tests en laissant une console graphique ouverte et en relancant le process kwin.

  • Accueil
  • » Forum
  • » KDE
  • » KDE4: Desactiver les Desktop effects en mode texte

Haut de page ↑