Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/04/2017, à 14:15

sageitere

Impossible de trouver le paquet sagemath-upstream-binary

Bonjour
j'ai cru poster deja mon message ce matin, mais comme je ne le vois nulle part j'ai du me planter
je le repose.

quand je lance:

sudo apt-get install sagemath-upstream-binary[sudo]

Mot de passe de admins :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet sagemath-upstream-binary

Hors ligne

#2 Le 24/04/2017, à 14:30

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Effectivement, il n'y a aucun paquet à ce nom dans les dépôts des versions supportées d'Ubuntu (14.04, 16.04, 16.10 et 17.04). Où est-ce que tu as trouvé ce nom de paquet et sur quelle version d'Ubuntu es-tu ?

Hors ligne

#3 Le 24/04/2017, à 14:42

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

c'est ici qu'on parle de ce package
oui habelthorne j'aurais du preciser,:rolleyes:
je suis sur l'OS Ubuntu 17.04

j'ay essayé aussi avec AptUrl, j'ai aussi la réponse: "impossible de trouver le paquet sagemath-upstream-binary"

I posted here as I get no answer yet but somebody give me an answer on sage math forum:
Sage Math Forum

Dernière modification par sageitere (Le 24/04/2017, à 15:36)

Hors ligne

#4 Le 24/04/2017, à 15:00

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Ah, ok, c'est donc une spécificité de packaging d'un PPA, c'est pour ça qu'on ne le trouve pas dans les dépôts de base.

Tu as bien ajouté le PPA à tes sources ? Tu as rechargé la liste (sudo apt-get update) après ?

EDIT : je vois que le PPA en question ne propose pas encore de dépôt zesty (17.04), il faudrait modifier son adresse pour utiliser la version précédente (16.10, yakkety). Commence par confirmer que tu l'as bien ajouté.

Dernière modification par abelthorne (Le 24/04/2017, à 15:02)

Hors ligne

#5 Le 24/04/2017, à 15:22

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

oui j'ai bien lancé la commande:sudo apt-get update

Atteint:1 http://security.ubuntu.com/ubuntu zesty-security InRelease
Ign:2 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty InRelease   
Atteint:3 http://fr.archive.ubuntu.com/ubuntu zesty InRelease                  
Atteint:4 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty InRelease
Atteint:5 http://fr.archive.ubuntu.com/ubuntu zesty-updates InRelease
Ign:6 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty Release
Atteint:7 http://fr.archive.ubuntu.com/ubuntu zesty-backports InRelease        
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages    
Ign:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages
Ign:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages
Ign:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages
Ign:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages
Ign:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all Packages
Err:9 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main i386 Packages
  404  Not Found
Ign:10 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 Packages
Ign:11 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-en
Ign:12 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr
Ign:13 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main all DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main amd64 DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/aims/sagemath/ubuntu zesty/main DEP-11 64x64 Icons
Lecture des listes de paquets... Fait
W: The repository 'http://ppa.launchpad.net/aims/sagemath/ubuntu zesty Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Impossible de récupérer http://ppa.launchpad.net/aims/sagemath/ubuntu/dists/zesty/main/binary-i386/Packages  404  Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Hors ligne

#6 Le 24/04/2017, à 15:29

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Ok. Va dans les paramètres système → Logiciels & mises à jour. Dans l'onglet "Autres logiciels", tu devrais voir le dépôt Sagemath que tu as ajouté. Clique dessus → modifier (il devrait y avoir deux lignes à corriger) et remplace zesty par yakkety pour la distribution. Une fois que c'est fait pour les deux lignes, retente :

sudo apt-get update
sudo apt-get install sagemath-upstream-binary

Hors ligne

#7 Le 25/04/2017, à 09:22

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

Bonjour
en fait, il y a deux lignes coché et 9 non cochées avec l'atribut zesty, je suppose que je dois modifier que les cochées ?

Systeme Logiciel Maj Ubuntu 17.04

Dernière modification par sageitere (Le 25/04/2017, à 09:29)

Hors ligne

#8 Le 25/04/2017, à 09:32

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Non, seulement celles qui correspondent au dépôt Sagemath, l'autre (bluefish) propose apparemment bien un dépôt Zesty. Techniquement, tu n'aurais besoin de modifier que la ligne du dépôt actif mais autant le faire aussi pour celui du code source, au cas où tu l'actives plus tard.

Mais sur ta capture, je vois qu'il y a un autre problème : tu as apparemment le dépôt du code source (désactivé) déclaré plusieurs fois. Il apparaît huit fois alors qu'il ne devrait être présent qu'une fois. On va corriger ça plus proprement : donne-moi le retour de :

ls /etc/apt/sources.list.d
cat /etc/apt/sources.list.d/*.list

Dernière modification par abelthorne (Le 25/04/2017, à 09:34)

Hors ligne

#9 Le 25/04/2017, à 09:40

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

voila:

admins@HP-Z600-Workstation-PFIS:~$ ls /etc/apt/sources.list.d
aims-ubuntu-sagemath-zesty.list
aims-ubuntu-sagemath-zesty.list.save
klaus-vormweg-ubuntu-bluefish-zesty.list
klaus-vormweg-ubuntu-bluefish-zesty.list.save
admins@HP-Z600-Workstation-PFIS:~$ cat /etc/apt/sources.list.d/*.list
deb http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu zesty main
deb http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu yakkety main
# deb-src http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty main
admins@HP-Z600-Workstation-PFIS:~$ 

quand aux deux commandes que tu avais demandé il y a apparement un pb:

$ sudo apt-get update
[sudo] Mot de passe de admins : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu zesty InRelease
Réception de:2 http://security.ubuntu.com/ubuntu zesty-security InRelease [89,2 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu zesty-updates InRelease [89,2 kB]
Réception de:4 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety InRelease [17,5 kB]
Atteint:5 http://fr.archive.ubuntu.com/ubuntu zesty-backports InRelease        
Réception de:6 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu yakkety InRelease [17,5 kB]
Réception de:7 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety/main amd64 Packages [924 B]
Réception de:8 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety/main i386 Packages [924 B]
Réception de:9 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety/main Translation-en [460 B]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 DEP-11 Metadata [208 B]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu zesty-updates/universe Translation-en [2 760 B]
Réception de:12 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu yakkety/main i386 Packages [1 384 B]
Réception de:13 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu yakkety/main amd64 Packages [1 384 B]
Réception de:14 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu yakkety/main Translation-en [1 096 B]
223 ko réceptionnés en 1s (199 ko/s)         
Lecture des listes de paquets... Fait
admins@HP-Z600-Workstation-PFIS:~$ sudo apt-get install sagemath-upstream-binaryLecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  ca-certificates-java dvipng gfortran gfortran-6 icedtea-8-plugin
  icedtea-netx icedtea-netx-common icedtea-plugin java-common
  libatk-wrapper-java libatk-wrapper-java-jni libgfortran-6-dev libgfortran3
  openjdk-8-jre openjdk-8-jre-headless
Paquets suggérés :
  gfortran-multilib gfortran-doc gfortran-6-multilib gfortran-6-doc
  libgfortran3-dbg libcoarrays-dev default-jre fonts-ipafont-gothic
  fonts-ipafont-mincho ttf-wqy-microhei | ttf-wqy-zenhei fonts-indic
Les NOUVEAUX paquets suivants seront installés :
  ca-certificates-java dvipng gfortran gfortran-6 icedtea-8-plugin
  icedtea-netx icedtea-netx-common icedtea-plugin java-common
  libatk-wrapper-java libatk-wrapper-java-jni libgfortran-6-dev libgfortran3
  openjdk-8-jre openjdk-8-jre-headless sagemath-upstream-binary
0 mis à jour, 16 nouvellement installés, 0 à enlever et 12 non mis à jour.
Il est nécessaire de prendre 666 Mo dans les archives.
Après cette opération, 3 927 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 ca-certificates-java all 20161107 [12,6 kB]
Réception de:2 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety/main amd64 sagemath-upstream-binary amd64 7.2~aimsppa1 [629 MB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 java-common all 0.57ubuntu1 [7 492 B]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 openjdk-8-jre-headless amd64 8u121-b13-4 [27,5 MB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 libgfortran3 amd64 6.3.0-12ubuntu2 [270 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 dvipng amd64 1.15-0ubuntu1 [75,4 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 libgfortran-6-dev amd64 6.3.0-12ubuntu2 [303 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 gfortran-6 amd64 6.3.0-12ubuntu2 [6 954 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 gfortran amd64 4:6.3.0-2ubuntu1 [1 272 B]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 libatk-wrapper-java all 0.33.3-13 [34,1 kB]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 libatk-wrapper-java-jni amd64 0.33.3-13 [27,2 kB]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu zesty/main amd64 openjdk-8-jre amd64 8u121-b13-4 [69,6 kB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 icedtea-netx-common all 1.6.2-3.1ubuntu3 [1 373 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 icedtea-netx amd64 1.6.2-3.1ubuntu3 [26,9 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 icedtea-8-plugin amd64 1.6.2-3.1ubuntu3 [189 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 icedtea-plugin all 1.6.2-3.1ubuntu3 [3 702 B]
666 Mo réceptionnés en 13min 26s (826 ko/s)                                    
Sélection du paquet ca-certificates-java précédemment désélectionné.
(Lecture de la base de données... 232966 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-ca-certificates-java_20161107_all.deb ...
Dépaquetage de ca-certificates-java (20161107) ...
Sélection du paquet java-common précédemment désélectionné.
Préparation du dépaquetage de .../01-java-common_0.57ubuntu1_all.deb ...
Dépaquetage de java-common (0.57ubuntu1) ...
Sélection du paquet openjdk-8-jre-headless:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-openjdk-8-jre-headless_8u121-b13-4_amd64.deb ...
Dépaquetage de openjdk-8-jre-headless:amd64 (8u121-b13-4) ...
Sélection du paquet libgfortran3:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libgfortran3_6.3.0-12ubuntu2_amd64.deb ...
Dépaquetage de libgfortran3:amd64 (6.3.0-12ubuntu2) ...
Sélection du paquet sagemath-upstream-binary précédemment désélectionné.
Préparation du dépaquetage de .../04-sagemath-upstream-binary_7.2~aimsppa1_amd64.deb ...
Dépaquetage de sagemath-upstream-binary (7.2~aimsppa1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-0NtI7W/04-sagemath-upstream-binary_7.2~aimsppa1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/bin/sage », qui appartient aussi au paquet sagemath-common 7.4-7ubuntu1
Sélection du paquet dvipng précédemment désélectionné.
Préparation du dépaquetage de .../05-dvipng_1.15-0ubuntu1_amd64.deb ...
Dépaquetage de dvipng (1.15-0ubuntu1) ...
Sélection du paquet libgfortran-6-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../06-libgfortran-6-dev_6.3.0-12ubuntu2_amd64.deb ...
Dépaquetage de libgfortran-6-dev:amd64 (6.3.0-12ubuntu2) ...
Sélection du paquet gfortran-6 précédemment désélectionné.
Préparation du dépaquetage de .../07-gfortran-6_6.3.0-12ubuntu2_amd64.deb ...
Dépaquetage de gfortran-6 (6.3.0-12ubuntu2) ...
Sélection du paquet gfortran précédemment désélectionné.
Préparation du dépaquetage de .../08-gfortran_4%3a6.3.0-2ubuntu1_amd64.deb ...
Dépaquetage de gfortran (4:6.3.0-2ubuntu1) ...
Sélection du paquet libatk-wrapper-java précédemment désélectionné.
Préparation du dépaquetage de .../09-libatk-wrapper-java_0.33.3-13_all.deb ...
Dépaquetage de libatk-wrapper-java (0.33.3-13) ...
Sélection du paquet libatk-wrapper-java-jni:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-libatk-wrapper-java-jni_0.33.3-13_amd64.deb ...
Dépaquetage de libatk-wrapper-java-jni:amd64 (0.33.3-13) ...
Sélection du paquet openjdk-8-jre:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../11-openjdk-8-jre_8u121-b13-4_amd64.deb ...
Dépaquetage de openjdk-8-jre:amd64 (8u121-b13-4) ...
Sélection du paquet icedtea-netx-common précédemment désélectionné.
Préparation du dépaquetage de .../12-icedtea-netx-common_1.6.2-3.1ubuntu3_all.deb ...
Dépaquetage de icedtea-netx-common (1.6.2-3.1ubuntu3) ...
Sélection du paquet icedtea-netx:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../13-icedtea-netx_1.6.2-3.1ubuntu3_amd64.deb ...
Dépaquetage de icedtea-netx:amd64 (1.6.2-3.1ubuntu3) ...
Sélection du paquet icedtea-8-plugin:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../14-icedtea-8-plugin_1.6.2-3.1ubuntu3_amd64.deb ...
Dépaquetage de icedtea-8-plugin:amd64 (1.6.2-3.1ubuntu3) ...
Sélection du paquet icedtea-plugin précédemment désélectionné.
Préparation du dépaquetage de .../15-icedtea-plugin_1.6.2-3.1ubuntu3_all.deb ...
Dépaquetage de icedtea-plugin (1.6.2-3.1ubuntu3) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /tmp/apt-dpkg-install-0NtI7W/04-sagemath-upstream-binary_7.2~aimsppa1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par sageitere (Le 25/04/2017, à 09:54)

Hors ligne

#10 Le 25/04/2017, à 09:51

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Ok. Ouvre le fichier .list de Sagemath en admin :

sudo gedit /etc/apt/sources.list.d/aims-ubuntu-sagemath-zesty.list

Remplace tout son contenu par ça et enregistre :

deb http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety main
# deb-src http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety main

Ensuite, fais de même avec l'autre dépôt (bluefish), parce que je vois que tu l'as passé en version yakkety alors que le problème ne concerne que celui de Sagemath :

sudo gedit /etc/apt/sources.list.d/klaus-vormweg-ubuntu-bluefish-zesty.list

Remets zesty à la place de yakkety. Son contenu ressemblera donc à ça :

deb http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty main
# deb-src http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty main

Une fois que c'est fait, recharge la liste des sources et retente d'installer ton paquet :

sudo apt-get update
sudo apt-get install sagemath-upstream-binary

Hors ligne

#11 Le 25/04/2017, à 10:10

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

ca ne s'est pas vraiment bien passé, de plus j'ai recu un message d'erreur comme quoi je n'avais plus que 400 meg de libre ??

 sudo apt-get update
Réception de:1 http://security.ubuntu.com/ubuntu zesty-security InRelease [89,2 kB]
Atteint:2 http://ppa.launchpad.net/aims/sagemath/ubuntu yakkety InRelease      
Réception de:3 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty InRelease [15,4 kB]
Atteint:4 http://fr.archive.ubuntu.com/ubuntu zesty InRelease                  
Atteint:5 http://fr.archive.ubuntu.com/ubuntu zesty-updates InRelease          
Réception de:6 http://security.ubuntu.com/ubuntu zesty-security/main amd64 DEP-11 Metadata [204 B]
Atteint:7 http://fr.archive.ubuntu.com/ubuntu zesty-backports InRelease        
Réception de:8 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty/main i386 Packages [1 076 B]
Réception de:9 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty/main amd64 Packages [1 072 B]
Réception de:10 http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu zesty/main Translation-en [988 B]
108 ko réceptionnés en 1s (61,3 ko/s)    
Lecture des listes de paquets... Fait
admins@HP-Z600-Workstation-PFIS:~$ sudo apt-get install sagemath-upstream-binaryLecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  sagemath-upstream-binary
0 mis à jour, 1 nouvellement installés, 0 à enlever et 12 non mis à jour.
15 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/629 Mo dans les archives.
Après cette opération, 3 794 Mo d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 233335 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../sagemath-upstream-binary_7.2~aimsppa1_amd64.deb ...
Dépaquetage de sagemath-upstream-binary (7.2~aimsppa1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/sagemath-upstream-binary_7.2~aimsppa1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/bin/sage », qui appartient aussi au paquet sagemath-common 7.4-7ubuntu1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/sagemath-upstream-binary_7.2~aimsppa1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

occupation disque dure

Dernière modification par sageitere (Le 25/04/2017, à 10:20)

Hors ligne

#12 Le 25/04/2017, à 10:17

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Il faut d'abord désinstaller la version d'origine, il y a des fichiers communs avec le nouveau paquet. Tu ne peux pas avoir les deux en même temps :

sudo apt-get remove --purge sagemath sagemath-common
sudo apt-get autoremove --purge
sudo apt-get install -f
sudo apt-get install sagemath-upstream-binary

Si tout se passe bien, tu pourras ensuite faire le reste des mises à jour en attente :

sudo apt-get dist-upgrade

Hors ligne

#13 Le 25/04/2017, à 10:30

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

apparemment j'ai peut etre un pb (avec la cmd:sudo apt-get dist-upgrade) d'espace disque ?

Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-9ubuntu2) ...
Paramétrage de sagemath-upstream-binary (7.2~aimsppa1) ...
Running Sage once as root to set paths
┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 7.2, Release Date: 2016-05-15                     │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
Setting permissions of DOT_SAGE directory so only you can read and write it.
sage: Exiting Sage (CPU time 0m0.02s, Wall time 0m0.07s).
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu5) ...
Paramétrage de icedtea-plugin (1.6.2-3.1ubuntu3) ...
Paramétrage de gfortran-6 (6.3.0-12ubuntu2) ...
Paramétrage de gfortran (4:6.3.0-2ubuntu1) ...
update-alternatives: utilisation de « /usr/bin/gfortran » pour fournir « /usr/bin/f95 » (f95) en mode automatique
update-alternatives: utilisation de « /usr/bin/gfortran » pour fournir « /usr/bin/f77 » (f77) en mode automatique
admins@HP-Z600-Workstation-PFIS:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.10.0-20 linux-headers-4.10.0-20-generic linux-image-4.10.0-20-generic
  linux-image-extra-4.10.0-20-generic
Les paquets suivants seront mis à jour :
  libnss-resolve libpam-systemd libsystemd0 libudev1 linux-generic linux-headers-generic
  linux-image-generic linux-libc-dev snapd systemd systemd-sysv udev
12 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 79,5 Mo/83,4 Mo dans les archives.
Après cette opération, 310 Mo d'espace disque supplémentaires seront utilisés.
E: Pas assez d'espace disponible sur /var/cache/apt/archives/

Hors ligne

#14 Le 25/04/2017, à 10:35

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Effectivement, tu n'as pas assez d'espace libre pour installer le nouveau noyau.

Commence par vider le cache d'APT :

sudo apt-get clean
sudo apt-get autoclean

Ensuite, donne le retour de df -h pour voir ce qu'il en est. Donne aussi le retour de la commande suivante pour voir la liste des noyaux installés. Il y en a peut-être plein qui n'ont pas été supprimés et qui prennent de la place pour rien :

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"

Hors ligne

#15 Le 25/04/2017, à 10:39

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

c'est bete je pouvais prendre plus de disque quand j'ai installé Ubuntu en double boot, j'ai pensé que 30 gigas suffirait !

 df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
udev               1,9G       0  1,9G   0% /dev
tmpfs              393M    6,7M  387M   2% /run
/dev/sda5           20G     17G  1,4G  93% /
tmpfs              2,0G     12K  2,0G   1% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs              2,0G       0  2,0G   0% /sys/fs/cgroup
tmpfs              393M    180K  393M   1% /run/user/1000
/dev/sdc1           15G    7,0G  8,0G  47% /media/admins/REDJPO
/dev/sda2          212G    116G   97G  55% /media/admins/OS
/dev/sda1          2,0G    374M  1,7G  19% /media/admins/SYSTEM
/dev/sdb1          136G    129G  7,3G  95% /media/admins/DATA1
/dev/sdb2           98G     39G   60G  40% /media/admins/DATA2
admins@HP-Z600-Workstation-PFIS:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
ii  linux-generic                                   4.10.0.19.21                                amd64        Complete Generic Linux kernel and headers
ii  linux-headers-4.10.0-19                         4.10.0-19.21                                all          Header files related to Linux kernel version 4.10.0
ii  linux-headers-4.10.0-19-generic                 4.10.0-19.21                                amd64        Linux kernel headers for version 4.10.0 on 64 bit x86 SMP
ii  linux-headers-generic                           4.10.0.19.21                                amd64        Generic Linux kernel headers
ii  linux-image-4.10.0-19-generic                   4.10.0-19.21                                amd64        Linux kernel image for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-extra-4.10.0-19-generic             4.10.0-19.21                                amd64        Linux kernel extra modules for version 4.10.0 on 64 bit x86 SMP
ii  linux-image-generic                             4.10.0.19.21                                amd64        Generic Linux kernel image

que signifie le bar graphe tout rouge dans l'image remplissage disque que j'ai envoyé plus haut ?

Dernière modification par sageitere (Le 25/04/2017, à 10:42)

Hors ligne

#16 Le 25/04/2017, à 10:44

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Bon, tu n'as apparemment qu'une version du noyau d'installé, donc r.à.s. de ce côté-là.

Le vidage du cache a apparemment permis de libérer 1,4 Go, ça devrait suffire pour la mise à jour : retente un sudo apt-get dist-upgrade pour voir ce que ça donne.

Effectivement, tu aurais dû allouer un peu plus de place : le système ne demande pas une place énorme (après, ça dépend de ce que tu installes comme logiciels, bien sûr) mais en stockant des données perso dans ton /home, ça peut vite monter. Apparemment, tu as choisi 20 Go (pas 30) pour ta partition Ubuntu, c'est un peu juste...

EDIT : dans ta capture plus haut, la barre rouge indique que la racine (/) est pleine ou quasiment. Le dossier /home (en jaune) occupe environ 1/3 de l'espace, le dossier /usr (vert) environ 1/4, /var (vert aussi) environ 10 % et les barres devant les autres dossiers sont vides parce que c'est négligeable par rapport au total.
Si tu parles du graphique à droite, je ne sais pas si les couleurs sont attribuées au hasard ou si elles le sont en fonction du pourcentage d'occupation (vert = peu / rouge = beaucoup). Chaque morceau d'anneau représente un dossier, tu peux passer ta souris dessus pour voir lequel.

Tu as 7 Go de données stockées dans ton dossier perso, tu peux aussi essayer de faire de la place dedans si tu es trop juste.

Dernière modification par abelthorne (Le 25/04/2017, à 10:53)

Hors ligne

#17 Le 25/04/2017, à 10:51

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

cette fois ci tout c'est bien passé !

 sudo apt-get dist-upgrade
[sudo] Mot de passe de admins : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.10.0-20 linux-headers-4.10.0-20-generic
  linux-image-4.10.0-20-generic linux-image-extra-4.10.0-20-generic
Les paquets suivants seront mis à jour :
  libnss-resolve libpam-systemd libsystemd0 libudev1 linux-generic
  linux-headers-generic linux-image-generic linux-libc-dev snapd systemd
  systemd-sysv udev
12 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 83,4 Mo dans les archives.
Après cette opération, 310 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libsystemd0 amd64 232-21ubuntu3 [211 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libnss-resolve amd64 232-21ubuntu3 [114 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libpam-systemd amd64 232-21ubuntu3 [116 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 systemd amd64 232-21ubuntu3 [2 362 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 udev amd64 232-21ubuntu3 [1 040 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libudev1 amd64 232-21ubuntu3 [56,4 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 systemd-sysv amd64 232-21ubuntu3 [13,0 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-image-4.10.0-20-generic amd64 4.10.0-20.22 [23,3 MB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-image-extra-4.10.0-20-generic amd64 4.10.0-20.22 [37,3 MB]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-generic amd64 4.10.0.20.22 [1 784 B]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-image-generic amd64 4.10.0.20.22 [2 226 B]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-headers-4.10.0-20 all 4.10.0-20.22 [10,6 MB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-headers-4.10.0-20-generic amd64 4.10.0-20.22 [686 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-headers-generic amd64 4.10.0.20.22 [2 202 B]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 linux-libc-dev amd64 4.10.0-20.22 [912 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu zesty-updates/main amd64 snapd amd64 2.24.1+17.04 [6 664 kB]
83,4 Mo réceptionnés en 2min 5s (664 ko/s)                                     
(Lecture de la base de données... 320599 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsystemd0_232-21ubuntu3_amd64.deb ...
Dépaquetage de libsystemd0:amd64 (232-21ubuntu3) sur (232-21ubuntu2) ...
Paramétrage de libsystemd0:amd64 (232-21ubuntu3) ...
(Lecture de la base de données... 320599 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libnss-resolve_232-21ubuntu3_amd64.deb ...
Dépaquetage de libnss-resolve:amd64 (232-21ubuntu3) sur (232-21ubuntu2) ...
Préparation du dépaquetage de .../libpam-systemd_232-21ubuntu3_amd64.deb ...
Dépaquetage de libpam-systemd:amd64 (232-21ubuntu3) sur (232-21ubuntu2) ...
Préparation du dépaquetage de .../systemd_232-21ubuntu3_amd64.deb ...
Dépaquetage de systemd (232-21ubuntu3) sur (232-21ubuntu2) ...
Préparation du dépaquetage de .../udev_232-21ubuntu3_amd64.deb ...
Dépaquetage de udev (232-21ubuntu3) sur (232-21ubuntu2) ...
Préparation du dépaquetage de .../libudev1_232-21ubuntu3_amd64.deb ...
Dépaquetage de libudev1:amd64 (232-21ubuntu3) sur (232-21ubuntu2) ...
Paramétrage de libudev1:amd64 (232-21ubuntu3) ...
Paramétrage de systemd (232-21ubuntu3) ...
Installation de la nouvelle version du fichier de configuration /etc/systemd/resolved.conf ...
addgroup: Le groupe « systemd-journal » existe déjà en tant que groupe système. Fin de la procédure.
(Lecture de la base de données... 320600 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-systemd-sysv_232-21ubuntu3_amd64.deb ...
Dépaquetage de systemd-sysv (232-21ubuntu3) sur (232-21ubuntu2) ...
Sélection du paquet linux-image-4.10.0-20-generic précédemment désélectionné.
Préparation du dépaquetage de .../1-linux-image-4.10.0-20-generic_4.10.0-20.22_amd64.deb ...
Done.
Dépaquetage de linux-image-4.10.0-20-generic (4.10.0-20.22) ...
Sélection du paquet linux-image-extra-4.10.0-20-generic précédemment désélectionné.
Préparation du dépaquetage de .../2-linux-image-extra-4.10.0-20-generic_4.10.0-20.22_amd64.deb ...
Dépaquetage de linux-image-extra-4.10.0-20-generic (4.10.0-20.22) ...
Préparation du dépaquetage de .../3-linux-generic_4.10.0.20.22_amd64.deb ...
Dépaquetage de linux-generic (4.10.0.20.22) sur (4.10.0.19.21) ...
Préparation du dépaquetage de .../4-linux-image-generic_4.10.0.20.22_amd64.deb ...
Dépaquetage de linux-image-generic (4.10.0.20.22) sur (4.10.0.19.21) ...
Sélection du paquet linux-headers-4.10.0-20 précédemment désélectionné.
Préparation du dépaquetage de .../5-linux-headers-4.10.0-20_4.10.0-20.22_all.deb ...
Dépaquetage de linux-headers-4.10.0-20 (4.10.0-20.22) ...
Sélection du paquet linux-headers-4.10.0-20-generic précédemment désélectionné.
Préparation du dépaquetage de .../6-linux-headers-4.10.0-20-generic_4.10.0-20.22_amd64.deb ...
Dépaquetage de linux-headers-4.10.0-20-generic (4.10.0-20.22) ...
Préparation du dépaquetage de .../7-linux-headers-generic_4.10.0.20.22_amd64.deb ...
Dépaquetage de linux-headers-generic (4.10.0.20.22) sur (4.10.0.19.21) ...
Préparation du dépaquetage de .../8-linux-libc-dev_4.10.0-20.22_amd64.deb ...
Dépaquetage de linux-libc-dev:amd64 (4.10.0-20.22) sur (4.10.0-19.21) ...
Préparation du dépaquetage de .../9-snapd_2.24.1+17.04_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
Dépaquetage de snapd (2.24.1+17.04) sur (2.23.6+17.04.1) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Paramétrage de systemd-sysv (232-21ubuntu3) ...
Paramétrage de linux-libc-dev:amd64 (4.10.0-20.22) ...
Paramétrage de snapd (2.24.1+17.04) ...
Installation de la nouvelle version du fichier de configuration /etc/apparmor.d/usr.lib.snapd.snap-confine.real ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-9ubuntu2) ...
Paramétrage de udev (232-21ubuntu3) ...
addgroup: Le groupe « input » existe déjà en tant que groupe système. Fin de la procédure.
update-initramfs: deferring update (trigger activated)
Paramétrage de linux-headers-4.10.0-20 (4.10.0-20.22) ...
Paramétrage de libnss-resolve:amd64 (232-21ubuntu3) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Traitement des actions différées (« triggers ») pour dbus (1.10.10-1ubuntu2) ...
Paramétrage de linux-image-4.10.0-20-generic (4.10.0-20.22) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.10.0-20-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-20-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-19-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-19-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Windows 7 trouvé sur /dev/sda1
fait
Paramétrage de linux-image-extra-4.10.0-20-generic (4.10.0-20.22) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.10.0-20-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-20-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-19-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-19-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Windows 7 trouvé sur /dev/sda1
fait
Paramétrage de libpam-systemd:amd64 (232-21ubuntu3) ...
Paramétrage de linux-headers-4.10.0-20-generic (4.10.0-20.22) ...
Paramétrage de linux-image-generic (4.10.0.20.22) ...
Paramétrage de linux-headers-generic (4.10.0.20.22) ...
Paramétrage de linux-generic (4.10.0.20.22) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.125ubuntu9) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-20-generic
Traitement des actions différées (« triggers ») pour libc-bin (2.24-9ubuntu2) ...
admins@HP-Z600-Workstation-PFIS:~$ 

Hors ligne

#18 Le 25/04/2017, à 10:53

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Ok. Donc, a priori tout est bon. SageMath fonctionne, c'est la bonne version, tout ça ?

Hors ligne

#19 Le 25/04/2017, à 11:03

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

pour lancer sage je suppose que je dois faire ./sage dans une fenetre de commande ou se trouve le dir SageMath ?

Hors ligne

#20 Le 25/04/2017, à 11:07

abelthorne

Re : Impossible de trouver le paquet sagemath-upstream-binary

Aucune idée, je ne l'utilise pas. Il n'a pas ajouté d'entrée dans le menu des Applications ?

S'il ne s'utilise qu'en ligne de commande et à moins que la version du PPA soit packagée n'importe comment, il suffit normalement de taper la bonne commande depuis n'importe où, pas la peine d'indiquer un dossier spécifique. Après, je ne peux pas te dire quelle est la commande en question : sage ? sagemath ?...

Hors ligne

#21 Le 25/04/2017, à 11:11

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

oui c'est cela il faut taper sagemath !
Merci beaucoup

Dernière modification par sageitere (Le 25/04/2017, à 11:13)

Hors ligne

#22 Le 25/04/2017, à 11:45

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

now I ask a question on sagemath forum (see link above about that site, because I think that maybe a pb)

Hors ligne

#23 Le 25/04/2017, à 11:52

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

Non c'est bon il ne faut pas que je le lance en ligne de commande !
désolé mais avec le bouton Nautilus j'ai simplement taper sagemath  dans la ligne de Nautilus , tout est ok  !!!!! ;-)

SageMath on Ubuntu

Dernière modification par sageitere (Le 25/04/2017, à 11:55)

Hors ligne

#24 Le 25/04/2017, à 12:14

sageitere

Re : Impossible de trouver le paquet sagemath-upstream-binary

en plus il fonctionne impecable !!
Sage Math first Test

Merci, Merci , Merci mille merci abelhorme

Hors ligne

#25 Le 05/06/2017, à 13:40

ft

Re : Impossible de trouver le paquet sagemath-upstream-binary

(Moi je veux juste signaler qu'il y a un paquet sagemath dans Zesty, issu de Debian... Plus besoin de PPA à compter de Zesty pour avoir Sage 7.4 .)
Se lance en terminal par sage -n .


Dell Precision 7510, Ubuntu Gnome 17.10

Hors ligne