Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 02/05/2017, à 17:03

RvCharton

Connexion ethernet partagée : "active connection removed ..."

Bonjour,

Je ne sais pas comment diagnostiquer ce problème, j'aurais besoin de votre aide.

J'ai un ordinateur portable qui tourne avec Ubuntu 17.04 depuis quelques semaines, mais sous Ubuntu depuis très longtemps. Il se connecte à une box par wifi, elle-même connectée à Internet.
J'ai aussi un Raspberry Pi qui me sert d'HTPC.

Pour que ce RPi accède à internet et aux données du réseau (notamment mon NAS), je n'ai pour le moment pas de meilleur moyen que de le relier à mon ordinateur portable par un câble Ethernet. En effet j'ai bien un dongle wifi pour le RPi mais la connexion est beaucoup trop lente pour en faire quoi que ce soit, et ma chambre est trop loin de la box pour le relier directement par câble. D'où l'idée de partager ma connexion wifi sur mon portable avec le RPi.

Cette solution fonctionnait sans souci jusqu'à la dernière mise à jour vers 17.04.

Depuis quand j'essaie d'activer la connexion filaire entre le RPi et mon PC, j'obtiens toujours la même erreur :

L'activation de la connexion a échoué.
(2) Active connection removed before it was initialized.

Je ne sais pas comment diagnostiquer le problème, cette erreur apparemment se retrouve dans un bon paquet de cas, et aucun de ne correspond parfaitement au mien... Par ailleurs, j'avoue ne plus savoir comment j'avais configuré le partage de connexion avant la mise à jour.
Ce que j'essaie de faire fonctionner maintenant, c'est via NetworkManager : j'ai créé une connexion spéciale, "Connexion Framboise", que j'ai configurée pour être "Partagée avec d'autres ordinateurs". J'ai essayé de manipuler les tables de routage, mais rien ne fonctionne pour le moment.

Merci pour l'aide que vous pourriez m'apporter ! :-)

Hors ligne

#2 Le 02/05/2017, à 17:11

xubu1957

Re : Connexion ethernet partagée : "active connection removed ..."

Bonjour,

Tu avais vu ?

Olivier33300 a écrit :

Bonjour,

Here is how to fix this problem.

Edit file /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf and change it's content from :

[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan
To :

[keyfile]
unmanaged-devices=*,except:type:ethernet,except:type:wifi,except:type:wwan
And then run :

sudo service network-manager restart
That's all.

Solution trouvé là :


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#3 Le 02/05/2017, à 18:52

RvCharton

Re : Connexion ethernet partagée : "active connection removed ..."

Merci pour ta réponse. J'avais déjà vu cette solution, avec une petite variation qui était que le fichier à changer était /etc/NetworkManager/conf.d/10-globally-managed-devices.conf . Cela change simplement le message d'erreur :

(nm-applet:19497): nm-applet-WARNING **: L'activation de la connexion a échoué:
(0) Active connection could not be attached to the device

Hors ligne

#4 Le 02/05/2017, à 19:09

xubu1957

Re : Connexion ethernet partagée : "active connection removed ..."


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#5 Le 02/05/2017, à 19:15

RvCharton

Re : Connexion ethernet partagée : "active connection removed ..."

Eh non je ne l'avais pas vu (ma connexion wifi marche bien) mais cela ne change rien au problème. J'obtiens une fois sur deux l'un ou l'autre des messages d'erreur.

Hors ligne

#6 Le 02/05/2017, à 19:24

xubu1957

Re : Connexion ethernet partagée : "active connection removed ..."


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#7 Le 04/05/2017, à 21:36

RvCharton

Re : Connexion ethernet partagée : "active connection removed ..."

xubu1957 a écrit :

Merci pour toutes ces pistes, mais pour le moment il n'y a aucun changement et je ne vois toujours pas quel peut être la source du problème...

Hors ligne

#8 Le 12/07/2017, à 22:25

gdo

Re : Connexion ethernet partagée : "active connection removed ..."

Hello,

dnsmasq est-il installé ?

sudo apt install dnsmasq

Hors ligne

#9 Le 13/07/2017, à 15:47

Compte anonymisé

Re : Connexion ethernet partagée : "active connection removed ..."

Justement, peut-être faudrait-il éviter tout ce qui est masque dns.

que donne

ping forum.ubuntu-fr.org -c3

et

ping 178.20.55.235 -c3

#10 Le 20/07/2017, à 15:51

gdo

Re : Connexion ethernet partagée : "active connection removed ..."

jojo81 a écrit :

Justement, peut-être faudrait-il éviter tout ce qui est masque dns.

que donne

ping forum.ubuntu-fr.org -c3

et

ping 178.20.55.235 -c3

Peut-être faudrait-il éviter d'écrire n'importe quoi...

Un "masque dns", j'attends la définition avec impatience... smile

Pour ton information :

man dnsmasq

te donnera dans les premières lignes :

       Dnsmasq - Un serveur DHCP et cache DNS poids-plume.

dnsmasq est donc le serveur DHCP qui attribura des IPs aux clients de la connexion partagée.
Pas de server DHCP, pas de connexion partagée.

Hors ligne