Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/05/2017, à 20:50

Francky4fingers

Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonjour,

Je rencontre le même problème que celui décrit par Guillaume_rouen dans ce fil.
A savoir pour résumer : A l'ouverture d'un fichier .txt ou .eml j'ai un pop-up qui me demande si je veux  lancer ou afficher le fichier en question. Le fichier est un exécutable. Options "lancer dans un terminal", "afficher", "annuler" et "lancer".
Comme dans la discussion mentionnée, je suis en dual-boot et le problème ne se pose que sur la partition partagée qui est au format ntfs.
Si je déplace ce fichier dans mon /home je ne rencontre plus de problème.
J'ajoute que sur la partition NTFS il est impossible de décocher l'option "Execution" dans les propriétés dudit fichier.
 
Je suis heureux d'avoir lu cette discussion puisque visiblement un solution existe (cf #8). Il faut modfier le fichier /etc/fstab et y inclure l'option umask=111.

Seulement à l'ouverture ma partition concernée est décrite ainsi :

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names	0	0.

La différence avec ce qui est décrit en #8 n'est pas énorme je vous l'accorde mais le fichier étant visiblement sensible (J'en ai fait une copie au cas ou...) quelqu'un saurait il me dire où ajouter l'option en question ?
En remplacement de "windows_names" ce qui donnerait

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,umask=111	0	0.

ou avant, ce qui donnerait :

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,umask=111,windows_names	0	0.

Je suis peut être un peu trop précautionneux mais enfin, si quelqu'un veut bien m'éclairer je le remercie par avance.

Bonne soirée

Dernière modification par Francky4fingers (Le 28/05/2017, à 18:52)

Hors ligne

#2 Le 10/05/2017, à 00:31

Bougron

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir.
Si tu es sur de ton option, mets avant ou après  en commençant par une virgule mais pas à la place.
As-tu essayé avec umask 007 qui est souvent celui utilisé?


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#3 Le 11/05/2017, à 22:30

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir Bougron,

Merci pour ton retour.
Alors j'ai essayé umask=111 et cela m'a valu une grosse frayeur. Tous les dossiers de ma partition NTFS étaient inaccessibles et n'avaient d'ailleurs même plus l'aspect de dossier mais l'icône d'un fichier binaire (Carré blanc avec 0 et 1 en filligrane...). J'ai donc supprimé cette mention d' /etc/fstab et après un re-boot tout était rentré dans l'ordre. Ouf

Mais j'avais d'abord essayé umask=007 et cela n'a rien donné non plus.

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,umask=007,windows_names	0	0

J'ai essayé avant "windows_names" comme ci-dessus mais aussi après mais cela ne change rien. (J'ai redémarré le PC à chaque fois bien qu'il me semble que les modifications d' /etc/fstab soient prises en compte immédiatement...)

Quelqu'un  a-t-il déjà été confronté à ce problème ??

Merci

Hors ligne

#4 Le 11/05/2017, à 22:37

grandtoubab

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

es tu certain que ton user est le 1000?
pour vérifier, utiliser la commande

id

Linux tout seul sur HP Pavilion DV7 et Acer aspire T650
Debian 10 Buster XFCE/Gnome3 sur sda1
Canon MG3650 en wifi

Hors ligne

#5 Le 11/05/2017, à 22:46

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir Grandtoubab,

C'est ce qui figure dans /etc/fstab.
J'ai essayé la commande id et cela renvoie bien uid=1000 gid=1000 groupes=1000

Bonne soirée

Hors ligne

#6 Le 12/05/2017, à 10:12

Bougron

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Francky4fingers a écrit :

J'ai redémarré le PC à chaque fois bien qu'il me semble que les modifications d' /etc/fstab soient prises en compte immédiatement..

Merci

Bonjour
Après modification du FSTAB, Il est nécessaire que tu démontes et remontes la partition

Tu peux le faire sans booter

sudo umount /dev/sda7
sudo  mount /dev/sda7

Je pense qu'il faudrait que tu ajoutes les options ,suid,exec


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#7 Le 13/05/2017, à 23:12

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir Bougron,

à mon grand désespoir ça ne donne rien.
Voila à ce jour la ligne correspondant à la partition en question

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,suid,exec,umask=007,windows_names	0	0

Comme indiqué j'ai ensuite démonté/remonté la partition mais j'ai toujours le message indiqué au #1 lorsque je souhaite ouvrir un fichier .txt ou .eml

Merci pour ton aide en tous cas Bougron

Dernière modification par Francky4fingers (Le 13/05/2017, à 23:20)

Hors ligne

#8 Le 13/05/2017, à 23:26

Rufus T. Firefly

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Salut,

Essaye de ne mettre que ça :

#Entry for /dev/sda7 :
UUID=79A239516CCB83DE	/media/Partage	ntfs-3g	defaults 0 0

La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#9 Le 14/05/2017, à 00:22

Coeur Noir

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bougron a écrit :

Tu peux le faire sans booter

sudo umount /dev/sda7
sudo  mount /dev/sda7

ou encore

sudo mount -a

qui monte automatiquement ce qui se trouve dans fstab ( sauf les lignes contenant l'option noauto )

Hors ligne

#10 Le 14/05/2017, à 11:18

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonjour Rufus T. firefly

Cela m'embait un peu de supprimer ces qques options de mon fstab car je les avait ajouté suite à un précédent problème (Je n'avais pas de corbeille sur la partition NTFS et l'ajout de ces options avait résolu le problème).

Je l'ai fait malgé tout mais cela ne donne rien.
Je l'ai remise à son état initial (que j'avais sauvegardé) qui était :

/media/Partage	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Cela a été sans Succès. J'ai donc essayé cela

/media/Partage	ntfs-3g	defaults	0	0

Sans succès également

J'ai l'impression que je vais devoir continuer à subir ce désagrément.
Je reste évident à l'écoute d'autres suggestions.Bonne journée

Hors ligne

#11 Le 14/05/2017, à 11:47

Coeur Noir

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Peux-tu donner le retour de

sudo blkid

Plutôt qu'utiliser l'uid numérique, utilise l'id en toutes lettres uid=ton_nom_user

Hors ligne

#12 Le 14/05/2017, à 12:10

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonjour Coeur Noir,

Pour la partition qui nous occupe la commande sudo blkid renvoie

/dev/sda7: LABEL="Partage" UUID="79A239516CCB83DE" TYPE="ntfs" PARTUUID="1549f232-07"

Tu veux dire qu'en début de ligne je remplace UUID="79A23......." par UUID="Mon_nom_user" ??

Merci.

Hors ligne

#13 Le 16/05/2017, à 21:22

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir,

Une dernière idée ??

Hors ligne

#14 Le 17/05/2017, à 04:12

moko138

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

S'il subsiste encore, supprime le point final dans

	0	0.

Il n'a pas lieu d'être.

Mais je ne crois pas que cela résolve ton souci qui ressemble au résultat d'un

sudo chmod 777 (...)

    ou d'un

sudo chmod +x (...)

appliqué à l'ensemble de la partition concernée.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#15 Le 18/05/2017, à 22:36

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Bonsoir Moko138,

Non pas de point final sur cette ligne j'avais dû l'ajouter par inadvertance dans le message...
Merci quand même.  Je vais laisser tomber pour l'instant.

Hors ligne

#16 Le 28/05/2017, à 18:52

Francky4fingers

Re : Ouverture des fichiers .txt sur une partition NTFS [Résolu]

Je pense avoir finalement trouvé une solution.
J'ai ajouté l'option noexec à ma partition ntfs. (exec : Autorise l’exécution des fichiers binaires / noexec : N'autorise pas...).
L'exécution n'étant plus autorisé les fichiers .txt mais surtout les .eml s'ouvrent directement.
S'agissant d'une partition qui ne stockent que des documents ou des fichiers de types "media" (musique,film etc...) cela me gêne en rien de me priver de cette option.

Hors ligne