Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 14/05/2017, à 17:34

strike07

KVM crash deuxième instance

Bonjour,
voilà mon problème : j'utilise KVM en lui allouant une carte graphique (une Radeon HD 54xx je crois) en ayant suivi ce tuto et je me retrouve avec le script suivant qui fonctionne -presque- à merveille :

echo '0000:02:00.1' | sudo tee /sys/bus/pci/devices/0000:02:00.1/driver/unbind

modprobe vfio
modprobe vfio_pci

echo 1002 68f9 | sudo tee /sys/bus/pci/drivers/vfio-pci/new_id
echo 1002 aa68 | sudo tee /sys/bus/pci/drivers/vfio-pci/new_id

qemu-system-x86_64 -enable-kvm -M q35 -m 2048 -cpu host -smp 2,sockets=1,cores=2,threads=1 \
-bios /usr/share/qemu/bios.bin \
-vga none -device ioh3420,bus=pcie.0,addr=1c.0,multifunction=on,port=1,chassis=1,id=root.1 \
-device piix4-ide,bus=pcie.0,id=piix4-ide  -device vfio-pci,host=02:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on -device vfio-pci,host=02:00.1,bus=pcie.0 \
-usb -usbdevice host:04f2:1125 -usbdevice host:03f0:8607 -soundhw ac97 \
-drive file=/home/user/ubuntuimage,id=disk,format=raw,if=none -device ide-hd,bus=piix4-ide.0,drive=disk

le système démarre sur mon deuxième écran sur ma Radeon, pas de problème, sur mon écran principale il y a un terminale QEMU, quand j'y saisi quit le système virtualisé s'arrête brutalement, mais je peux aussi l'éteindre "normalement" sur avec "sudo shutdown -h now" par exemple. le problème vient que quand j'essaye de le relancer seulement avec la dernière commande (qemu-system-x86_64...) mon PC crash, même problème quand j'essaye de reboot le système virtualisé...

quelqu'un aurait-il une solution pour remédier à ce problème?
merci par avance pour vos réponses smile

Hors ligne