Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 15/05/2017, à 13:56

Coeur Noir

U14.04, Nautilus : devient lent, ne s'ouvre plus.

Hello,

après boot du pc point de souci, nautilus est réactif. C'est après un certain temps, disons une bonne heure. Si je veux l'ouvrir ça prend du temps. Voire il ne s'ouvre pas. Il faut recommencer et il finit par s'afficher au bout de plusieurs minutes. Lancé depuis un terminal je n'ai que ça :

palace4@ANTEC:~$ nautilus
Impossible d'enregistrer l'application: Le délai d'attente est dépassé
palace4@ANTEC:~$ 

Vers quoi puis-je enquêter ?

Hors ligne

#2 Le 16/05/2017, à 06:41

tarkan99

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

hello,

que donne

free -h
top

quand le problème apparaît ?
(ainsi que

uname -a

pour la version exacte du noyau)


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#3 Le 20/06/2017, à 17:41

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

palace4@ANTEC:~$ nautilus -q
Impossible d'enregistrer l'application: Le délai d'attente est dépassé
palace4@ANTEC:~$ free -h
             total       used       free     shared    buffers     cached
Mem:          7,8G       7,6G       204M        52M       156M       5,1G
-/+ tampons/cache:       2,3G       5,5G
Partition d'échange:       965M       320K       965M
palace4@ANTEC:~$ top

top - 17:38:40 up 20:19,  2 users,  load average: 4,62, 4,75, 4,27
Tâches: 230 total,   3 en cours, 227 en veille,   0 arrêté,   0 zombie
%Cpu(s): 76,9 ut,  6,4 sy,  0,0 ni, 15,0 id,  0,2 wa,  0,0 hi,  1,5 si,  0,0 st
KiB Mem:   8175084 total,  8031692 used,   143392 free,   160552 buffers
KiB Swap:   989180 total,      320 used,   988860 free.  5356576 cached Mem

  PID UTIL.     PR  NI    VIRT    RES    SHR S  %CPU %MEM    TEMPS+ COM.        
 6610 palace4   20   0 3194744 505940  48876 S 321,2  6,2 515:50.61 dcpomatic2  
 2276 palace4   20   0 1855208 421460  67128 S   5,0  5,2  81:05.06 compiz      
 1165 root      20   0  324068  79124  55204 S   2,7  1,0  91:55.09 Xorg        
 9238 palace4   20   0 2490072 359764 105940 S   2,3  4,4   0:48.29 firefox     
 2309 palace4   20   0  684200  46184  22312 R   2,0  0,6  21:45.70 syncthing-+ 
 9212 palace4   20   0  717084  30028  23608 S   2,0  0,4   0:00.83 gnome-term+ 
 2570 palace4   20   0 1122044  11932   5908 S   1,0  0,1   8:13.11 TVGuiSlave+ 
 1263 root      20   0  179652  11612   7500 S   0,7  0,1   6:45.81 teamviewerd 
 2571 palace4   20   0  129832  26948   5616 S   0,7  0,3   8:00.84 TVGuiDeleg+ 
    7 root      20   0       0      0      0 R   0,3  0,0   3:52.64 rcu_sched   
 1268 root     -51   0       0      0      0 S   0,3  0,0   1:59.84 irq/28-nvi+ 
 2503 palace4   20   0   57612  36656   6048 S   0,3  0,4   2:43.51 syncthing   
 9394 palace4   20   0   29284   3156   2572 R   0,3  0,0   0:00.09 top         
    1 root      20   0   34052   4508   2568 S   0,0  0,1   0:01.47 init        
    2 root      20   0       0      0      0 S   0,0  0,0   0:00.02 kthreadd    
    3 root      20   0       0      0      0 S   0,0  0,0   0:10.68 ksoftirqd/0 
    5 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kworker/0:+ 
palace4@ANTEC:~$ uname -a
Linux ANTEC 4.4.0-79-generic #100~14.04.1-Ubuntu SMP Fri May 19 18:36:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
palace4@ANTEC:~$

les 300% d'usage cpu sur dcpomatic2 sont normaux, encodage en cours.

Mais j'ai le pépin de temps en temps même quand rien de costaud ne tourne.

Hors ligne

#4 Le 20/06/2017, à 17:56

nam1962

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

Tu as réglé la swappiness ?


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#5 Le 20/06/2017, à 18:25

erresse

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

Bonjour,
Sur ta RAM de 7,8 Go, tu as 7,6 Go d'utilisés, il ne reste que 204 Mo de disponibles... Est-ce normal que la mémoire soit bourrée à ce point ?
On voit d'ailleurs qu'il utilise le swap, alors qu'avec une RAM de 8 Go, ça ne devrait pas être le cas.
Qu'est-ce que tu fais tourner comme applications dans ta bécane ???


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#6 Le 20/06/2017, à 19:40

tarkan99

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

les 300% d'usage cpu sur dcpomatic2 sont normaux, encodage en cours.
Mais j'ai le pépin de temps en temps même quand rien de costaud ne tourne.

désolé mais dans ce cas, le test ne veut rien dire.

A refaire donc quand rien de costaud ne tourne

le swap fait 1go, un peu juste dans ton cas, non ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#7 Le 20/06/2017, à 21:57

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

Ah oui tiens pourquoi la swap est si petite ?

Et l'usage RAM curieux aussi car à ma connaissance ce n'est pas dcp-o-matic qui l'utilise. Ça aussi j'aurai l'occasion de re-vérifier.

Effectivement le test est bancal, mais comme ça revient souvent ce non accès à Nautilus…

Merci pour les pistes, je continue l'enquête et reviendrai avec des infos + pertinentes ;-)

Hors ligne

#8 Le 21/06/2017, à 18:07

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

palace4@ANTEC:~$ top

top - 18:05:18 up  2:25,  2 users,  load average: 1,03, 0,83, 0,64
Tâches: 233 total,   2 en cours, 231 en veille,   0 arrêté,   0 zombie
%Cpu(s):  4,9 ut,  0,9 sy,  0,0 ni, 94,2 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   8175084 total,  6330392 used,  1844692 free,   370616 buffers
KiB Swap:   989180 total,        0 used,   989180 free.  4075268 cached Mem

  PID UTIL.     PR  NI    VIRT    RES    SHR S  %CPU %MEM    TEMPS+ COM.        
 2260 palace4   20   0 1867684 235672  83120 S  15,3  2,9   7:01.90 compiz      
 1184 root      20   0  324896  79388  55028 S   2,0  1,0   1:53.66 Xorg        
 2290 palace4   20   0  686336  49656  25712 S   1,3  0,6   2:09.73 syncthing-+ 
 2599 palace4   20   0 1050308  14560   8564 S   1,0  0,2   0:55.74 TVGuiSlave+ 
 1268 root      20   0  181696  13992  10372 S   0,7  0,2   0:46.07 teamviewerd 
 1273 root     -51   0       0      0      0 S   0,7  0,0   0:13.98 irq/28-nvi+ 
 2600 palace4   20   0  133036  40648  18716 S   0,7  0,5   0:54.91 TVGuiDeleg+ 
 6263 palace4   20   0   31328   3144   2552 R   0,7  0,0   0:00.04 top         
 1947 palace4   20   0  365344  10668   5720 S   0,3  0,1   0:05.83 ibus-daemon 
 2041 palace4   20   0 2671008  47440  17300 S   0,3  0,6   0:16.29 TeamViewer+ 
 2389 palace4   20   0   72596  49572  12056 S   0,3  0,6   0:27.69 syncthing   
 6075 root      20   0       0      0      0 S   0,3  0,0   0:00.18 kworker/0:1 
 6239 palace4   20   0  719368  30328  23784 S   0,3  0,4   0:00.29 gnome-term+ 
    1 root      20   0   36192   4660   2632 S   0,0  0,1   0:01.46 init        
    2 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kthreadd    
    3 root      20   0       0      0      0 S   0,0  0,0   0:00.05 ksoftirqd/0 
    5 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kworker/0:+ 
palace4@ANTEC:~$

…à un moment où Nautilus a bien mis une bonne minute avant de s'ouvrir…

Hors ligne

#9 Le 22/06/2017, à 06:12

tarkan99

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

as-tu des liens réseaux dans nautilus ?

avec un autre compte, même problème ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#10 Le 22/06/2017, à 11:49

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

Liens réseaux. Oui. Quelques-uns, et bien vu, c'est ça qui bloque Nautilus : si jamais la ressource en question n'est plus sur le réseau → tentative de reconnexion → délai dépassé → et pendant cette / ces tentatives, soit Nautilus fige, se grise, ou je ne peux pas le lancer…

Ces ressources réseaux sont montées au démarrage via fstab, ce sont des partitions ntfs sur des ordis dans l'entreprise, donc si quelqu'un éteint l'un d'eux, crac.

Est-ce que ça se contourne ?

À noter que si l'ordi distant n'est pas dispo au démarrage de mon pc, le montage est simplement zappé. C'est si l'ordi distant disparaît après ma mise en route que ça coince.

Dernière modification par Coeur Noir (Le 22/06/2017, à 12:06)

Hors ligne

#11 Le 22/06/2017, à 11:55

tarkan99

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

il n'y a pas un timeout à régler pour l'attente soit plus courte ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#12 Le 23/06/2017, à 01:57

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

C'est probablement une bonne piste, pour une ressource active.

Dans ce cas, la ressource n'est plus là, donc je me dis que c'est pas une question de timeout, mais de faire en sorte que le système ne cherche plus à s'y connecter ? Puisque c'est déclaré dans fstab, il va toujours la chercher ?

Attends… ok… lui dire « au bout d'un certain temps arrête de chercher à te connecter » c'est une sorte de timeout.

Y-aurait-il sinon un moyen dynamique de gérer cette connexion, genre : l'ordi-ressource est sur le réseau vas-y c'est bon connecte-toi, s'il disparaît t'affole pas, préviens que la ressource est plus là mais lâche l'affaire, et s'il réapparaît bah dis le, et reconnecte-toi gentiment ?

Ce qui m'échappe :
1- c'est qu'au démarrage ça semble se faire de façon transparente,
2- quand la ressource est KO, ça bloque tout Nautilus.

Hors ligne

#13 Le 23/06/2017, à 06:32

tarkan99

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

j'ai trouvé le paramètre x-systemd.device-timeout à ajouter dans fstab (ajouter également nofail)


x-systemd.mount-timeout=

    Configure how long systemd should wait for the mount command to finish before giving up on an entry from /etc/fstab. Specify a time in seconds or explicitly append a unit such as "s", "min", "h", "ms".

    Note that this option can only be used in /etc/fstab, and will be ignored when part of the Options= setting in a unit file.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#14 Le 23/06/2017, à 14:11

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

C'est justement pas au niveau du fstab que je veux faire ça, puisque là les réglages par défaut semblent me convenir.

Les montages au démarrage fonctionnent correctement et si la ressource est manquante, c'est zappé silencieusement.

C'est après coup que ça pose souci, quand la ressource vient à manquer alors qu'elle avait déjà été montée au démarrage…

Hors ligne

#15 Le 23/06/2017, à 14:41

moko138

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

N'utiliserais-tu pas des "bind" ?


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#16 Le 23/06/2017, à 16:52

Coeur Noir

Re : U14.04, Nautilus : devient lent, ne s'ouvre plus.

Non, je posterai le fstab dès que de retour au taf', dimanche.

Hors ligne