Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/05/2017, à 09:22

georgesgiralt

ProblèmeS avec portable MSI GP627QF

Bonjour,
J'ai ce portable équipé des dernières technos : Core i5 7300 carte Optimus nVidia GTX960, etc, etc.
J'ai installé non sans mal la version 16.10 en suivant plusieurs tutos mais j'ai tellement de problèmes que j'ai décidé d'installer "from scratch" la 17.04 sur une autre partition.
La machine ne "fonctionne" que si je démarre avec acpi=off et nouveau.blacklist=1 sinon, je ne peux me logguer et obtenir l'interface Unity car la machine se bloque (pas possible de basculer sur une console texte, nide tuer le serveur X avec <ctrl><alt><backsp>. Je suis obligé de passer par le bouton secteur.
Et bien sur, avec acpi=off j'ai plein de PB avec la machine....

Pourriez vous m'aider, SVP ?

Hors ligne

#2 Le 18/05/2017, à 11:48

LukePerp

Re : ProblèmeS avec portable MSI GP627QF

Donne des détails sur tes nombreux problèmes, que veux tu dire ?
As tu essayé la version stable 16.04 ? Parfois, certaine variante fonctionne mieux que d'autres sur du matériel moderne, essayer Xubuntu ou Mate pour voir


Desktop : Linux Mint Mate 17.3 - Intel i5 - 8 Go - Dual boot Windows 7
Labtop ASUS : Xubuntu 16 - Intel i3 - 4 Go
Labtop de 1993 : Lubuntu 14 - Pentium M - 432 Mo - Thème/icônes changés via www.box-look.org
Mémo : lien

Hors ligne

#3 Le 18/05/2017, à 12:09

malbo

Re : ProblèmeS avec portable MSI GP627QF

Essaie cette procédure (c'est Ubuntu 17.04 qu'il faut, ce n'est pas 16.04) qui a été pratiquée avec bonheur par maximechamp sur son MSI GP62 7QF (la procédure est remise en forme par kholo) : https://forum.ubuntu-fr.org/viewtopic.p … #p21731461

Dernière modification par malbo (Le 18/05/2017, à 12:11)

En ligne

#4 Le 18/05/2017, à 16:24

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Bonjour,
Merci à tous pour vos réponses. Je vais clarifier un peu mes PB.
Ce PC je l'ai depuis début février. J'ai lu les posts le concernant (version 6QF) et ai installé la version 16.10 qui était la version la plus récente. Il a parfaitement fonctionné jusqu'à la mise à jour des drivers nVidia. Là, plus moyen de passer en veille et corruption de l'affichage à chaque rallumage de celui ci. Impossible aussi d'employer le driver Intel (switch de NVidia vers Intel avec l'applet) car l'affichage disparaît.
J'ai donc désinstallé le driver NVidia et ses associés (switchs, bbswitch, etc...) et désinstallé le driver Nouveau. JE me retrouvait donc à utiliser la carte Intel seule. Fonctionnement parfait. Sauf l'autonomie car la carte NVidia est toujours alimentée. J'ai donc installé bbswitch.ko et fait qu'il se lance au démarrage en forçant la carte NVidia à off.
Cela a marché quelque temps. Mais depuis deux trois mises à jours, retour des PBs (pas possible de passer en veille, démarrage super lent, affichage qui clignote très rapidement sans possibilité d'arrêt, .... ) 
J'ai donc décidé de tester la 17.04 sur une autre partition. Avec install depuis un live.
Même problèmes sauf si j'emploie "nouveau.blacklist=1 acpi=off" dans la ligne de boot du noyau. Et toujours pas de veille possible.
Hier, en attendant des réponses, j'ai vérifié le BIOS avec les diverses infos glanées ici et là sans que cela change qui que ce soit. (je suis en UEFI ) Bref, je galère...
Je vais tenter une ré-installation en 17.04 avec la procédure de  Malbo, on va voir. 
Merci pour l'aide.

Hors ligne

#5 Le 19/05/2017, à 09:21

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Résultat des courses :
Bof. Pas mieux.
1) la machine ne marche pas (pas d'affichage après login) si je ne boote pas avec ACPI=off. Et si j'ai ACPI=off aucun accessoire ne marche (touchpad, camera, etc... ).
2) le switch entre carte NVidia et carte Intel marche bien. Je tourne sur la carte Intel et la carte NVidia est coupée. Mais je ne sais pas pourquoi car j'ai ceci dans le dmesg :

[    4.165454] bbswitch: version 0.8
[    4.165457] bbswitch: cannot find ACPI handle for VGA device 0000:00:02.0
[    4.165460] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    4.165461] bbswitch: No discrete VGA device found
[    4.211198] bbswitch: version 0.8
[    4.211200] bbswitch: cannot find ACPI handle for VGA device 0000:00:02.0
[    4.211203] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    4.211204] bbswitch: No discrete VGA device found

Évidemment un pb d'ACPI ....
3) la mise en veille freeze toujours la machine et je n'arrive pas à avoir des logs pour savoir pourquoi...
Question : Que faire pour pouvoir avoir l'ACPI qui marche ?
Merci pour votre aide !

Hors ligne

#6 Le 19/05/2017, à 15:09

LukePerp

Re : ProblèmeS avec portable MSI GP627QF

georgesgiralt a écrit :

Résultat des courses :
Bof. Pas mieux.
!

Pour ma gouverne, pourquoi n'as tu pas essayé 16.04 ?


Desktop : Linux Mint Mate 17.3 - Intel i5 - 8 Go - Dual boot Windows 7
Labtop ASUS : Xubuntu 16 - Intel i3 - 4 Go
Labtop de 1993 : Lubuntu 14 - Pentium M - 432 Mo - Thème/icônes changés via www.box-look.org
Mémo : lien

Hors ligne

#7 Le 19/05/2017, à 17:35

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

"Pour ma gouverne, pourquoi n'as tu pas essayé 16.04 ?"

Ben, si je me souviens bien, j'avais une clef USB avec un live 16.04 dessus (mon précédent portable tournait en 16.04) et elle n'a pas réussi à booter le nouveau portable.. D'où mon essai de 16.10 qui était la plus récente à l'époque (et les commentateurs disaient qu'il fallait une version très récente pour ce matos...)

Hors ligne

#8 Le 20/05/2017, à 19:40

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Bonsoir,
Des nouvelles du front....
Je me suis rendu compte, en allant visiter les forums MSI que mon bios n'était pas le dernier.
J'ai installé le BIOS version  E16J5IMS.308 et l'ACPI semble fonctionner.
Attention, la procédure de mise à jour est assez rock and roll et il FAUT aller resetter les valeurs du BIOS après install et revérifier TOUS les paramètres, surtout le BOOT...
Je reviendrai vers vous une fois le pc un peu plus testé....

Hors ligne

#9 Le 21/05/2017, à 05:51

malbo

Re : ProblèmeS avec portable MSI GP627QF

Bonjour,
Je te prie de faire un rapport Bisnext depuis une session de ton Ubuntu fraîchement installé. Cela donnera un exemple d'installation réussie dans ton modèle.

En ligne

#10 Le 21/05/2017, à 09:49

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Bonjour,
Pour le rapport, on va attendre un peu que j'ai reglé le PB de suspend...  Toujours pareil. Cela se plante et bloqie le PC. Si vous avez des idées pour débugger, je suis preneur !

Hors ligne

#11 Le 22/05/2017, à 16:21

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Bonjour,
Il y a des choses que je ne comprends pas.
Ce matin je démarre le PC et tout vas à peu près bien sauf que la carte NVidia est restée allumée. (ce PC a un voyant sur le bouton secteur. Allumé bleu, carte NVidia éteinte, allumé orange :carte NVidia allumée.... )
Je me dis qu'il doit manquer le module bbswitch j'essaye un

 sudo modprobe bbswitch load-state=0

Et je reçois un message :

modprobe: ERROR: could not insert 'bbswitch': Required key not available

Je me dis donc que j'ai le "secure boot" à ON dans le BIOS.
Reboot pour modifier cela (il n'était pas actif, seul la puce TPM l'était mais pas configurée).
Tentative de boot : KO !
Tentative de boot avec ACPI=off : OK mais rien ne marche.
Reboot avec modif du BIOS : "load optimized defaults" et tentative de boot OK (réactive le chip TPM et met le boot en legacy secure boot à off je change juste le boot en EFI  )
Reboot et impossible de booter si je ne mets pas ACPI=off dans la ligne linux.
Retour dans le BIOS et vérification de TOUT avec désactivation de TPM Boot OK avec acpi ON. Mais pas possible d'insérer bbswitch ....
De plus, quand je boote, je ne peux insérer le module bbswitch quel que soient la valeur de secure boot et/ou ACPI !
A l'aide ! SVP !

EDIT: Si je veux booter proprement (donc avec les options standard (ro quiet splash $vt-...) il me FAUT avoir actif dans le BIOS :
Secure boot à ON et en mode standard
TPM activé (avec chip TMP2.0 détecté) et laisser toutes les options par défaut.
Avec cela la machine marche parfaitement mais je n'ai pas de driver NVidia actif et pas de possibilité d'insérer le module bbswitch (normal, pas de clef correcte  sur ces binaires non signés )

Si je met à off une des options (soit TPM ou secure boot) je ne peux avoir ACPI actif ! Et si l'ACPI est à OFF pas de driver NVIdia possible puisque la carte n'est pas vue (pas de touchpad, pas d'état de la batterie, pas de lecteur de cartes mémoires, .... )
Que faire ? Même Google n'est pas mon ami, sniff...

Dernière modification par georgesgiralt (Le 23/05/2017, à 23:15)

Hors ligne

#12 Le 24/05/2017, à 10:18

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Suite des événements :
Pas de driver NVidia chargé mais la carte est vue. Mon Xorg.0.log dit :

 [     5.232] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     5.232] (II) xfree86: Adding drm device (/dev/dri/card0)
[     5.249] (--) PCI:*(0:0:2:0) 8086:591b:1462:115a rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[     5.249] (--) PCI: (0:1:0:0) 10de:139b:1462:115a rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288

Mais le driver chargé est modeset !!!!!

[     5.255] (==) Matched modesetting as autoconfigured driver 0
[     5.255] (==) Matched fbdev as autoconfigured driver 1
[     5.255] (==) Matched vesa as autoconfigured driver 2
[     5.255] (==) Assigned the driver to the xf86ConfigLayout
[     5.255] (II) LoadModule: "modesetting"
[     5.255] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     5.255] (II) Module modesetting: vendor="X.Org Foundation"
[     5.255]    compiled for 1.19.3, module version = 1.19.3
[     5.255]    Module class: X.Org Video Driver
[     5.255]    ABI class: X.Org Video Driver, version 23.0
[     5.255] (II) LoadModule: "fbdev"
[     5.255] (WW) Warning, couldn't open module fbdev
[     5.255] (II) UnloadModule: "fbdev"
[     5.255] (II) Unloading fbdev
[     5.255] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.255] (II) LoadModule: "vesa"
[     5.255] (WW) Warning, couldn't open module vesa
[     5.255] (II) UnloadModule: "vesa"
[     5.255] (II) Unloading vesa
[     5.255] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.255] (==) Matched modesetting as autoconfigured driver 0
[     5.255] (==) Matched fbdev as autoconfigured driver 1
[     5.255] (==) Matched vesa as autoconfigured driver 2
[     5.255] (==) Assigned the driver to the xf86ConfigLayout
[     5.255] (II) LoadModule: "modesetting"
[     5.255] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     5.255] (II) Module modesetting: vendor="X.Org Foundation"
[     5.255]    compiled for 1.19.3, module version = 1.19.3
[     5.255]    Module class: X.Org Video Driver
[     5.255]    ABI class: X.Org Video Driver, version 23.0
[     5.255] (II) UnloadModule: "modesetting"
[     5.255] (II) Unloading modesetting
[     5.255] (II) Failed to load module "modesetting" (already loaded, 21894)
[     5.255] (II) LoadModule: "fbdev"
[     5.255] (WW) Warning, couldn't open module fbdev
[     5.255] (II) UnloadModule: "fbdev"
[     5.255] (II) Unloading fbdev
[     5.255] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.255] (II) LoadModule: "vesa"
[     5.255] (WW) Warning, couldn't open module vesa
[     5.255] (II) UnloadModule: "vesa"
[     5.255] (II) Unloading vesa
[     5.255] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.255] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.265] (II) modeset(0): using drv /dev/dri/card0
[     5.265] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[     5.265] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[     5.265] (==) modeset(0): RGB weight 888
[     5.265] (==) modeset(0): Default visual is TrueColor
[     5.265] (II) Loading sub module "glamoregl"
[     5.265] (II) LoadModule: "glamoregl"
[     5.265] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[     5.270] (II) Module glamoregl: vendor="X.Org Foundation"
[     5.270]    compiled for 1.19.3, module version = 1.0.0
[     5.270]    ABI class: X.Org ANSI C Emulation, version 0.4
[     5.270] (II) glamor: OpenGL accelerated X.org driver based.
[     5.295] (II) glamor: EGL version 1.4 (DRI2):
[     5.301] (II) modeset(0): glamor initialized
[     5.302] (II) modeset(0): Output eDP-1 has no monitor section
........

Question : Comment faire pour virer le modesetting sans *encore* ré-installer ?
Merci pour votre aide.

Hors ligne

#13 Le 24/05/2017, à 10:45

malbo

Re : ProblèmeS avec portable MSI GP627QF

Bonjour,
Je te prie de passer la commande suivante depuis une session de ton Ubuntu installé :

cat /etc/default/grub

   
et de donner le retour utilisable de cette commande dans ta réponse.

En ligne

#14 Le 24/05/2017, à 12:36

georgesgiralt

Re : ProblèmeS avec portable MSI GP627QF

Et voila :

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Hors ligne

#15 Le 24/05/2017, à 13:20

malbo

Re : ProblèmeS avec portable MSI GP627QF

Ce sont les lignes suivantes extraites de ton résultat qui m'intéressaient :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Elles montrent que tu n'as aucun paramètre de noyau ajouté (en plus des classiques "quiet splash"). Si ça avait été le cas, il aurait le virer mais là c'est parfait. Cela étant vérifié, je ne suis pas compétent en pb graphique pour te faire avancer dans la résolution de ton problème.

Dernière modification par malbo (Le 24/05/2017, à 13:20)

En ligne