Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/06/2017, à 19:22

Manasian

[Résolu] Mélange des environnements graphiques durant le démarrage

Bonjour,

j'ai depuis peu installé sur mon ubuntu l'environnement graphique kde et ubuntu mate, (en passant par synaptic) sauf que maintenant, en démarrant ubuntu j'ai l'écran de chargement de kunbutu et sur la page pour démarrer sa session, j'ai un écran ubuntu mate...

J'ai sans doute du faire une fausse manœuvre, puisque on dirait une sorte d'empilement des environnements.

Dernière modification par Manasian (Le 11/08/2017, à 20:14)

Hors ligne

#2 Le 12/06/2017, à 19:30

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

L'écran animé de démarrage (Plymouth) est purement cosmétique, il n'a aucune influence sur le reste. Comme tu as installé plusieurs environnements qui ont chacun leur propre écran de démarrage, le système en a choisi un, certainement le dernier installé.

Si tu veux en choisir un en particulier, je ne suis pas sûr de la manip mais c'est vraisemblablement via dpkg-reconfigure. Tu peux essayer la commande suivante pour revenir à celui d'Ubuntu :

sudo dpkg-reconfigure plymouth-theme-ubuntu-logo

Hors ligne

#3 Le 13/06/2017, à 06:45

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Désolé, mais en faisant la commande, cela ne fonctionne pas. Et aussi, quand je suis dans le menu pour choisir les différents environnements graphiques en mettant "Unity 8", j'ai un écran noir et je n'a comme solution que de redémarrer. Par contre, quand je prend Ubuntu dans ce menu, tout marche bien pour la config de base (avec unity).

Hors ligne

#4 Le 13/06/2017, à 08:52

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Manasian a écrit :

Désolé, mais en faisant la commande, cela ne fonctionne pas.

Il t'a bien regénéré GRUB ? Après redémarrage, c'est toujours le logo KDE que tu as ?

Et aussi, quand je suis dans le menu pour choisir les différents environnements graphiques en mettant "Unity 8", j'ai un écran noir et je n'a comme solution que de redémarrer. Par contre, quand je prend Ubuntu dans ce menu, tout marche bien pour la config de base (avec unity).

Unity 8 est expérimental, il y a pas mal de problèmes avec. Si tu tiens vraiment à le tester, il faudrait voir du côté des pilotes graphiques pour commencer. Mais de toute façon, le développement d'Unity est maintenant arrêté : à partir de la prochaine version d'Ubuntu, c'est GNOME 3 qui sera utilisé comme environnement par défaut de la distribution. Unity 7 restera dans les dépôts (et sera vraisemblablement diffusé via une variante) et tu ne perdras pas l'environnement, tu pourras continuer à l'utiliser, mais Unity 8 qui est encore une ébauche sera complètement supprimé. À part la curiosité, ça ne sert pas à grand chose de perdre du temps à essayer de résoudre ce problème de lancement d'Unity 8.

Hors ligne

#5 Le 13/06/2017, à 20:45

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

abelthorne a écrit :

Il t'a bien regénéré GRUB ? Après redémarrage, c'est toujours le logo KDE que tu as ?

En démarrant ce matin, j'avais bien le logo KDE au démarrage, alors que j'avais fait la commande hier soir.

Voilà en tout cas ce que j'ai en résultat :

user-X75VC:~$ sudo dpkg-reconfigure plymouth-theme-ubuntu-logo
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour initramfs-tools (0.125ubuntu9) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-22-generic

Hors ligne

#6 Le 13/06/2017, à 20:57

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Alors c'est peut-être avec update-alternatives. Essaie ça :

sudo update-alternatives --config default.plymouth

Hors ligne

#7 Le 14/06/2017, à 14:44

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Bon, ça à l'air d'être rentré dans l'ordre, j'ai même de nouveau le bon écran de démarrage de session.

Hors ligne

#8 Le 14/06/2017, à 15:56

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Tu parles de l'écran de connexion ? Parce que ça, c'est un autre réglage : tu peux avoir l'écran de boot de KDE, l'écran de connexion de MATE tout en utilisant l'environnement Unity, etc. Tout ça, c'est purement cosmétique, ça peut se personnaliser un peu comme on veut.

Si tout est ok, tant mieux, je précise juste ça au cas où tu veuilles une personnalisation un peu spécifique. wink

Hors ligne

#9 Le 16/06/2017, à 20:43

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Bon finalement, c'est revenu mais à moitié, j'ai toujours kde/mate au démarrage mais j'ai bien unity quand j'éteins mon pc.

Hors ligne

#10 Le 16/06/2017, à 20:47

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Si tu parles de l'écran de connexion de MATE, c'est normal : il a une très haute priorité par rapport aux autre et le plus simple est de le supprimer complètement :

sudo apt-get remove --purge ubuntu-mate-lightdm-theme

(Ça ne pose pas de problème pour le reste de MATE.)

Pareil pour les autres (parce qu'en supprimant celui de MATE, c'est fort possible que tu te retrouves avec celui de KDE à la place) mais je ne suis pas sûr qu'ils puissent être supprimés aussi facilement.

Si tu as toujours l'écran de boot de KDE alors qu'à l'extinction du système tu as celui d'Ubuntu, c'est assez curieux, la commande que j'ai donnée devrait gérer les deux...

Hors ligne

#11 Le 17/06/2017, à 06:45

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Bon, je viens de faire la commande que tu as indiqué et supprimé le paquet plymouth-theme-kubuntu-logo avec synaptic (dans la description il est indiqué : Animation d'amorçage graphique et journalisateur) j'ai bon ? Normalement, ça devrait être bon cette fois.

Hors ligne

#12 Le 17/06/2017, à 09:31

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Logiquement, oui. À vérifier.

Hors ligne

#13 Le 20/06/2017, à 20:59

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Bon, après une partie de "toucher-coulé" avec synaptic pour trouver les bons paquets à supprimer je suis arrivé à avoir un résultat à peu près potable. J'ai juste encore le tableau d'identification (là ou l'on doit mettre l'utilisateur et mot de passe) qui est encore celui de mate. Une solution ? Sinon, tant pis, c'est pas bien grave.

Hors ligne

#14 Le 20/06/2017, à 21:02

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Comme je l'ai dit dans le message #10, le plus simple est de supprimer le paquet correspondant.

Hors ligne

#15 Le 22/06/2017, à 20:49

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Oui d'accord, mais est-ce que il y a un moyen plus rapide que de désinstaller/réinstaller chaque paquet de mate installé ? J'en à une cinquantaine, c'est pour ça.

Hors ligne

#16 Le 22/06/2017, à 20:53

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Je ne te suis plus : tu veux supprimer complètement MATE ou juste ne plus avoir son thème visuel à l'écran de connexion ? J'étais parti sur la deuxième idée et pour ça, il suffit de supprimer le paquet ubuntu-mate-lightdm-theme sans toucher aux autres. MATE sera toujours présent, simplement tu auras un autre écran de connexion.

Qu'est-ce que tu veux garder comme environnement(s), en fait ?

Dernière modification par abelthorne (Le 22/06/2017, à 20:54)

Hors ligne

#17 Le 25/06/2017, à 20:42

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Non, en fait je souhaite juste supprimer le paquet qui fait que le tableau d'identification est celui de mate. Juste ce paquet là. Et je me demandais si tu avait une idée (même vague) de quel paquet il peux s'agir car les paquets de mate, j'en à une soixantaine.

Ah et si ça ne te dérange pas, peux tu me dire comment masquer tel ou tel programme d'un environnement des menus ? Il y a bien la documentation (https://doc.ubuntu-fr.org/tutoriel/fair … _des_menus) mais elle n'est pas à jour concernant unity et je n'ai rien trouvé sur le forum. Il y a bien aussi dans paramètres système => détails => applications par défaut mais il n'y a pas tous les programmes.

Hors ligne

#18 Le 25/06/2017, à 21:00

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Manasian a écrit :

Non, en fait je souhaite juste supprimer le paquet qui fait que le tableau d'identification est celui de mate. Juste ce paquet là. Et je me demandais si tu avait une idée (même vague) de quel paquet il peux s'agir car les paquets de mate, j'en à une soixantaine.

C'est le paquet ubuntu-mate-lightdm-theme qui fait que l'écran de connexion utilise le thème de MATE.

Ah et si ça ne te dérange pas, peux tu me dire comment masquer tel ou tel programme d'un environnement des menus ? Il y a bien la documentation (https://doc.ubuntu-fr.org/tutoriel/fair … _des_menus) mais elle n'est pas à jour concernant unity et je n'ai rien trouvé sur le forum. Il y a bien aussi dans paramètres système => détails => applications par défaut mais il n'y a pas tous les programmes.

Il faut modifier le lanceur (fichier .desktop) correspondant qui se trouve dans /usr/share/applications ou, si tu ne veux pas modifier les fichiers système d'origine, en faire une copie dans ~/.local/share/applications et modifier celle-ci plutôt. Les lanceurs perso (~/.local/share/applications) sont prioritaires sur les lanceurs système (/usr/share/applications). Dedans, on peut ajouter l'option OnlyShowIn avec le nom des environnements dans lesquels le lanceur doit s'afficher. Par exemple, avec cette ligne, il s'affichera dans Unity et GNOME mais pas KDE, MATE ou autre :

OnlyShowIn=Unity;GNOME;

Il y a aussi l'option NotShowIn qui permet, à l'inverse, de définir les environnements dans lesquels un lanceur ne doit pas s'afficher.

Toutes les options utilisables sont dans les specs de Freedesktop.

Dernière modification par abelthorne (Le 25/06/2017, à 21:01)

Hors ligne

#19 Le 29/06/2017, à 20:46

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Pour le paquet ubuntu-mate-lightdm-theme je l'ai déjà désinstallé, mais cela persiste peut-être un paquet graphique ?
Et concernant la modif du lanceur, c'est une ligne de commande ou il faut modifier un fichier ? EN ligne de commande j'ai :

user-X75VC:~/.local/share/applications$ OnlyShowIn=Unity;GNOME;
GNOME : commande introuvable

Hors ligne

#20 Le 29/06/2017, à 21:18

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Pour le lanceur, c'était juste un exemple de ligne à l'intérieur de son fichier, ce n'est pas du tout une commande à lancer. Il faut commencer par identifier le lanceur concerné (fichier .desktop qui se trouve soit dans /usr/share/applications, soit dans ~/.local/share/applications − pour les lanceurs qui sont dans le premier dossier, il vaut mieux en faire une copie dans le second), l'ouvrir avec ton éditeur de texte et modifier / rajouter la ligne.

Pour ce qui est de l'autre problème, ce que tu appelles le tableau d'identification est bien l'écran de connexion ? Est-ce que ce que tu as ressemble à la capture suivante : https://ubuntu-mate.org/gallery/Screens … IGHTDM.png ?

Hors ligne

#21 Le 01/07/2017, à 20:50

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Ok, j'ai compris pour éditer les fichiers et pour l'écran de connexion, oui c'est bien cela, j'ai juste le fond d'écran qui n'est pas identique.

Hors ligne

#22 Le 01/07/2017, à 21:17

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Alors je pense que ce n'est pas celui de MATE, vu qu'il intègre le fond d'écran en dur. Donc, à moins que tu aies modifié les options du greeter GTK, c'en est très probablement un autre.

Donne-moi le retour de :

ls -l /etc/lightdm /usr/share/lightdm

Hors ligne

#23 Le 02/07/2017, à 20:46

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

J'ai ceci :

user-X75VC:~$ ls -l /etc/lightdm /usr/share/lightdm
/etc/lightdm:
total 12
drwxr-xr-x 2 root root 4096 juin  19 18:52 lightdm.conf.d
-rw-r--r-- 1 root root 2757 avril 11  2016 lightdm-gtk-greeter.conf
-rw-r--r-- 1 root root  452 avril  5 00:34 users.conf

/usr/share/lightdm:
total 16
drwxr-xr-x 3 root root 4096 mai   12 19:49 guest-session
drwxr-xr-x 2 root root 4096 juin  19 21:02 lightdm.conf.d
drwxr-xr-x 2 root root 4096 juin  12 13:21 lightdm-gtk-greeter.conf.d
drwxr-xr-x 2 root root 4096 avril 12 05:13 sessions

Hors ligne

#24 Le 02/07/2017, à 20:48

abelthorne

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

Ah, je me suis planté, j'ai oublié l'option -R pour avoir la liste récursive (avec le contenu des sous-dossiers). on recommence :

ls -lR /etc/lightdm /usr/share/lightdm

Hors ligne

#25 Le 03/07/2017, à 20:17

Manasian

Re : [Résolu] Mélange des environnements graphiques durant le démarrage

J'ai ceci :

user-X75VC:~$ ls -lR /etc/lightdm /usr/share/lightdm
/etc/lightdm:
total 12
drwxr-xr-x 2 root root 4096 juin  19 18:52 lightdm.conf.d
-rw-r--r-- 1 root root 2757 avril 11  2016 lightdm-gtk-greeter.conf
-rw-r--r-- 1 root root  452 avril  5 00:34 users.conf

/etc/lightdm/lightdm.conf.d:
total 4
-rw-r--r-- 1 root root 37 févr.  5 22:21 50_budgie-desktop.conf

/usr/share/lightdm:
total 16
drwxr-xr-x 3 root root 4096 mai   12 19:49 guest-session
drwxr-xr-x 2 root root 4096 juil.  3 14:31 lightdm.conf.d
drwxr-xr-x 2 root root 4096 juin  12 13:21 lightdm-gtk-greeter.conf.d
drwxr-xr-x 2 root root 4096 avril 12 05:13 sessions

/usr/share/lightdm/guest-session:
total 8
-rwxr-xr-x 1 root root 1361 mai    8 23:32 setup.sh
drwxr-xr-x 3 root root 4096 avril 12 05:10 skel

/usr/share/lightdm/guest-session/skel:
total 0

/usr/share/lightdm/lightdm.conf.d:
total 44
-rw-r--r-- 1 root root  43 mars  23 20:58 40-kde-plasma-kf5.conf
-rw-r--r-- 1 root root 123 mars  28 15:37 45-unity8.conf
-rw-r--r-- 1 root root 152 mai    8 23:32 50-disable-guest.conf
-rw-r--r-- 1 root root  76 avril  4 23:25 50-disable-log-backup.conf
-rw-r--r-- 1 root root  66 avril  4 23:25 50-greeter-wrapper.conf
-rw-r--r-- 1 root root  62 avril  4 23:25 50-guest-wrapper.conf
-rw-r--r-- 1 root root  29 mars  21 00:43 50-ubuntu.conf
-rw-r--r-- 1 root root  27 sept. 30  2016 50-ubuntu-mate.conf
-rw-r--r-- 1 root root  39 oct.  27  2016 50-unity-greeter.conf
-rw-r--r-- 1 root root  45 avril  4 23:25 50-xserver-command.conf
-rw-r--r-- 1 root root  45 août   7  2015 60-lightdm-gtk-greeter.conf

/usr/share/lightdm/lightdm-gtk-greeter.conf.d:
total 4
-rw-r--r-- 1 root root 319 févr. 11  2016 01_ubuntu.conf

/usr/share/lightdm/sessions:
total 4
-rw-r--r-- 1 root root 155 mars  28 15:37 unity8.desktop

Ah et sinon, après quelques tests, en copiant/collant les applications sur mon répertoire perso et en y mettant la ligne OnlyShowIn (ou NotShowIn) ça ne marche pas. A moins qu'il ne faut redémarrer ?

Hors ligne