Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/06/2017, à 02:24

Ascheriit71

[Résolu] Probleme apt-get update impossible!

Bonjour je vous copie mon terminal pour vous montrez ce que j'ai  fait pour en arriver là. j'ai voulu installer un ppa et après impossible de faire une mise à jour en voulant suivre les informations sur le site officiel : https://doc.ubuntu-fr.org/asunder
Si vous avez une reponse merci d'avance

tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo add-apt-repository ppa:landronimirc/asunder
[sudo] password for tamarin: 
 
 Plus d’info : https://launchpad.net/~landronimirc/+archive/ubuntu/asunder
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmpen2vv_2e/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmpen2vv_2e/pubring.gpg » a été créé
gpg: demande de la clef 23A187B2 sur le serveur hkp keyserver.ubuntu.com
?: keyserver.ubuntu.com: Host not found
gpgkeys: HTTP fetch error 7: couldn't connect: No such file or directory
gpg: aucune donnée OpenPGP valable n'a été trouvée.
gpg: Quantité totale traitée : 0
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ apt-transport-httpssudo apt-get update
apt-transport-httpssudo : commande introuvable
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get install apt-transport-https
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
apt-transport-https est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libhdb9-heimdal libkdc2-heimdal libntdb1 python-ntdb
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 25 non mis à jour.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ apt-get autoremove
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libhdb9-heimdal libkdc2-heimdal libntdb1 python-ntdb
0 mis à jour, 0 nouvellement installés, 4 à enlever et 25 non mis à jour.
Après cette opération, 629 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 321700 fichiers et répertoires déjà installés.)
Suppression de libkdc2-heimdal:amd64 (1.6~git20131207+dfsg-1ubuntu1.1) ...
Suppression de libhdb9-heimdal:amd64 (1.6~git20131207+dfsg-1ubuntu1.1) ...
Suppression de python-ntdb (1.0-2ubuntu1) ...
Suppression de libntdb1:amd64 (1.0-2ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-0ubuntu6.11) ...
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get installsudo apt-get install apt-transport-https
E: L'opération installsudo n'est pas valable
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get install apt-transport-https
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
apt-transport-https est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 25 non mis à jour.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo add-apt-repository --remove ppa:landronimirc/asunder
Cannot add PPA: 'ppa:landronimirc/asunder'.
Please check that the PPA name or format is correct.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo ppa-purge ppa:landronimirc/asunder
Updating packages lists
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
Warning:  apt-get update failed for some reason
PPA to be removed: landronimirc asunder
Warning:  Could not find package list for PPA: landronimirc asunder
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.

Dernière modification par Ascheriit71 (Le 01/11/2017, à 22:01)

Hors ligne

#2 Le 19/06/2017, à 06:52

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

up

Hors ligne

#3 Le 19/06/2017, à 08:04

nam1962

Re : [Résolu] Probleme apt-get update impossible!

Le problème de base est que ce PPA n'est plus maintenu depuis 120 semaines et vraisemblablement n'existe pas pour ta version : https://launchpad.net/~landronimirc/+ar … tu/asunder (il faut toujours se renseigner avant d’installer un PPA)

Passe :

sudo rm -f /var/lib/dpkg/lock

Puis donne nous les retours de :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1
df -Th
df -i

Dernière modification par nam1962 (Le 19/06/2017, à 08:04)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#4 Le 19/06/2017, à 11:56

Laurent85

Re : [Résolu] Probleme apt-get update impossible!

nam1962 a écrit :

Passe :

sudo rm -f /var/lib/dpkg/lock

Hmm non il ne faut pas toucher à lock !

Hors ligne

#5 Le 19/06/2017, à 12:24

nam1962

Re : [Résolu] Probleme apt-get update impossible!

Pourquoi ?


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#6 Le 19/06/2017, à 12:36

Laurent85

Re : [Résolu] Probleme apt-get update impossible!

Bah pourquoi tu le supprimes, c'est ça la bonne question. Le message concenant lock dans le retour commande est lié à des droits insuffisants, commande non lancée avec les droits root, le fichier lock n'est pas le problème. Par principe il ne faut pas toucher directement aux fichiers système, ce sont les outils qui les gèrent.

Hors ligne

#7 Le 19/06/2017, à 13:03

nam1962

Re : [Résolu] Probleme apt-get update impossible!

Je n'avais pas vu, effectivement c'est lié à la commande incomplète.
Cela dit, dans l'exercice, supprimer le lock n'aura pas d'effet secondaire et peut accélérer la résolution si il était en état instable.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#8 Le 20/06/2017, à 00:34

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

Ducoup je dois faire quoi dans l'ideal?

Hors ligne

#9 Le 20/06/2017, à 05:53

nam1962

Re : [Résolu] Probleme apt-get update impossible!

Tu redémarres.
Tu passes les commandes du #3 sans la première ligne qui efface le verrou (lock), on l'utilisera éventuellement plus tard si tu es bloqué par ce verrou.

Dernière modification par nam1962 (Le 20/06/2017, à 05:56)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#10 Le 23/10/2017, à 10:47

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ ls /etc/apt/sources.list.d
crebs-ppa-precise.list
crebs-ppa-precise.list.save
dropbox.list
dropbox.list.distUpgrade
dropbox.list.save
falk-t-j-qtsixa-precise.list
falk-t-j-qtsixa-precise.list.distUpgrade
falk-t-j-qtsixa-precise.list.save
freecad-maintainers-freecad-stable-trusty.list
getdeb.list
getdeb.list.distUpgrade
getdeb.list.save
glennric-dolphin-emu-precise.list
glennric-dolphin-emu-precise.list.distUpgrade
glennric-dolphin-emu-precise.list.save
google-chrome.list
google-chrome.list.save
google-earth.list
google-earth.list.distUpgrade
google-earth.list.save
google-talkplugin.list
google-talkplugin.list.distUpgrade
google-talkplugin.list.save
gregory-hainaut-pcsx2_official_ppa-precise.list
gregory-hainaut-pcsx2_official_ppa-precise.list.distUpgrade
gregory-hainaut-pcsx2_official_ppa-precise.list.save
hunter-kaller-ppa-precise.list
hunter-kaller-ppa-precise.list.distUpgrade
hunter-kaller-ppa-precise.list.save
jitsi.list
jitsi.list.distUpgrade
jitsi.list.save
landronimirc-asunder-trusty.list
landronimirc-asunder-trusty.list.save
maarten-baert-simplescreenrecorder-trusty.list
maarten-baert-simplescreenrecorder-trusty.list.save
micove-console-precise.list
micove-console-precise.list.distUpgrade
micove-console-precise.list.save
noobslab-apps-precise.list
noobslab-apps-precise.list.distUpgrade
noobslab-apps-precise.list.save
openshot_developers-ppa-trusty.list
openshot_developers-ppa-trusty.list.save
opera-stable.list
opera-stable.list.distUpgrade
opera-stable.list.save
playonlinux.list
playonlinux.list.distUpgrade
playonlinux.list.save
pmcenery-ppa-precise.list
pmcenery-ppa-precise.list.save
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.distUpgrade
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.save
sven-eckelmann-ppa-mupen64plus-precise.list
sven-eckelmann-ppa-mupen64plus-precise.list.distUpgrade
sven-eckelmann-ppa-mupen64plus-precise.list.save
upubuntu-com-libreoffice64-precise.list
upubuntu-com-libreoffice64-precise.list.distUpgrade
upubuntu-com-libreoffice64-precise.list.save
webupd8team-java-precise.list
webupd8team-java-precise.list.distUpgrade
webupd8team-java-precise.list.save
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get upgrade
[sudo] password for tamarin: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  icedtea-7-jre-jamvm libdrm-dev libdrm-intel1 libdrm-intel1:i386
  libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386
  libdrm2 libdrm2:i386 liboxideqt-qmlplugin liboxideqtcore0 liboxideqtquick0
  linux-generic linux-headers-generic linux-image-generic openjdk-7-jre
  openjdk-7-jre-headless openshot-qt oxideqt-codecs-extra python3-openshot
Les paquets suivants seront mis à jour :
  libcgmanager0 libcgmanager0:i386 screen yelp-xsl
4 mis à jour, 0 nouvellement installés, 0 à enlever et 21 non mis à jour.
Il est nécessaire de prendre 822 ko dans les archives.
Après cette opération, 75,8 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  libcgmanager0:i386 libcgmanager0 screen yelp-xsl
Faut-il installer ces paquets sans vérification ? [o/N] o
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ trusty-backports/main libcgmanager0 i386 0.39-2ubuntu2~ubuntu14.04.1 [29,4 kB]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ trusty-backports/main libcgmanager0 amd64 0.39-2ubuntu2~ubuntu14.04.1 [34,2 kB]
Réception de : 3 http://fr.archive.ubuntu.com/ubuntu/ trusty-backports/main screen amd64 4.2.1-2~ubuntu14.04.1 [533 kB]
Réception de : 4 http://fr.archive.ubuntu.com/ubuntu/ trusty-backports/main yelp-xsl all 3.12.0-1~ubuntu14.04.1 [225 kB]
822 ko réceptionnés en 1s (540 ko/s)
(Lecture de la base de données... 322629 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libcgmanager0_0.39-2ubuntu2~ubuntu14.04.1_i386.deb ...
Déconfiguration de libcgmanager0:amd64 (0.24-0ubuntu7.5) ...
Dépaquetage de libcgmanager0:i386 (0.39-2ubuntu2~ubuntu14.04.1) sur (0.24-0ubuntu7.5) ...
Préparation du dépaquetage de .../libcgmanager0_0.39-2ubuntu2~ubuntu14.04.1_amd64.deb ...
Dépaquetage de libcgmanager0:amd64 (0.39-2ubuntu2~ubuntu14.04.1) sur (0.24-0ubuntu7.5) ...
Préparation du dépaquetage de .../screen_4.2.1-2~ubuntu14.04.1_amd64.deb ...
Dépaquetage de screen (4.2.1-2~ubuntu14.04.1) sur (4.1.0~20120320gitdb59704-9) ...
Préparation du dépaquetage de .../yelp-xsl_3.12.0-1~ubuntu14.04.1_all.deb ...
Dépaquetage de yelp-xsl (3.12.0-1~ubuntu14.04.1) sur (3.10.1-1) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour man-db (2.6.7.1-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour install-info (5.2.0.dfsg.1-2) ...
Paramétrage de libcgmanager0:amd64 (0.39-2ubuntu2~ubuntu14.04.1) ...
Paramétrage de libcgmanager0:i386 (0.39-2ubuntu2~ubuntu14.04.1) ...
Paramétrage de screen (4.2.1-2~ubuntu14.04.1) ...
update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match screen-cleanup Default-Start values (S)
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match screen-cleanup Default-Stop values (none)
Paramétrage de yelp-xsl (3.12.0-1~ubuntu14.04.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-0ubuntu6.11) ...
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get install apt-transport-https
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
apt-transport-https est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 21 non mis à jour.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ sudo apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ ^C
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ cat /etc/apt/sources.list
## DEPOTS OFFICIELS ##
deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
# deb http://archive.getdeb.net/ubuntu/ precise-getdeb games # désactivé pour la mise à niveau vers trusty
# deb http://archive.getdeb.net/ubuntu/ quantal-getdeb games # désactivé pour la mise à niveau vers trusty

## DEPOTS SUPPLEMENTAIRES ##
deb http://archive.canonical.com/ubuntu trusty partner
deb http://extras.ubuntu.com/ubuntu trusty main







tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ ls /etc/apt/sources.list.d -1
crebs-ppa-precise.list
crebs-ppa-precise.list.save
dropbox.list
dropbox.list.distUpgrade
dropbox.list.save
falk-t-j-qtsixa-precise.list
falk-t-j-qtsixa-precise.list.distUpgrade
falk-t-j-qtsixa-precise.list.save
freecad-maintainers-freecad-stable-trusty.list
getdeb.list
getdeb.list.distUpgrade
getdeb.list.save
glennric-dolphin-emu-precise.list
glennric-dolphin-emu-precise.list.distUpgrade
glennric-dolphin-emu-precise.list.save
google-chrome.list
google-chrome.list.save
google-earth.list
google-earth.list.distUpgrade
google-earth.list.save
google-talkplugin.list
google-talkplugin.list.distUpgrade
google-talkplugin.list.save
gregory-hainaut-pcsx2_official_ppa-precise.list
gregory-hainaut-pcsx2_official_ppa-precise.list.distUpgrade
gregory-hainaut-pcsx2_official_ppa-precise.list.save
hunter-kaller-ppa-precise.list
hunter-kaller-ppa-precise.list.distUpgrade
hunter-kaller-ppa-precise.list.save
jitsi.list
jitsi.list.distUpgrade
jitsi.list.save
landronimirc-asunder-trusty.list
landronimirc-asunder-trusty.list.save
maarten-baert-simplescreenrecorder-trusty.list
maarten-baert-simplescreenrecorder-trusty.list.save
micove-console-precise.list
micove-console-precise.list.distUpgrade
micove-console-precise.list.save
noobslab-apps-precise.list
noobslab-apps-precise.list.distUpgrade
noobslab-apps-precise.list.save
openshot_developers-ppa-trusty.list
openshot_developers-ppa-trusty.list.save
opera-stable.list
opera-stable.list.distUpgrade
opera-stable.list.save
playonlinux.list
playonlinux.list.distUpgrade
playonlinux.list.save
pmcenery-ppa-precise.list
pmcenery-ppa-precise.list.save
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.distUpgrade
private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.save
sven-eckelmann-ppa-mupen64plus-precise.list
sven-eckelmann-ppa-mupen64plus-precise.list.distUpgrade
sven-eckelmann-ppa-mupen64plus-precise.list.save
upubuntu-com-libreoffice64-precise.list
upubuntu-com-libreoffice64-precise.list.distUpgrade
upubuntu-com-libreoffice64-precise.list.save
webupd8team-java-precise.list
webupd8team-java-precise.list.distUpgrade
webupd8team-java-precise.list.save
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ df -Th
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
udev             devtmpfs   1,9G    4,0K  1,9G   1% /dev
tmpfs            tmpfs      386M    1,5M  384M   1% /run
/dev/sda6        ext4        92G     15G   73G  17% /
none             tmpfs      4,0K       0  4,0K   0% /sys/fs/cgroup
none             tmpfs      5,0M       0  5,0M   0% /run/lock
none             tmpfs      1,9G     19M  1,9G   1% /run/shm
none             tmpfs      100M     72K  100M   1% /run/user
/dev/sda8        ext4       294G    150G  130G  54% /home
/dev/sdb1        fuseblk    1,9T    871G  993G  47% /media/tamarin/EAGET忆捷
/dev/sdc1        vfat        58G     37G   22G  64% /media/tamarin/EAGET
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ df -i
Sys. de fichiers     Inœuds IUtil.     ILibre IUti% Monté sur
udev                 490395    601     489794    1% /dev
tmpfs                493182    672     492510    1% /run
/dev/sda6           6111232 357878    5753354    6% /
none                 493182      2     493180    1% /sys/fs/cgroup
none                 493182      3     493179    1% /run/lock
none                 493182     49     493133    1% /run/shm
none                 493182     35     493147    1% /run/user
/dev/sda8          19537920 184544   19353376    1% /home
/dev/sdb1        1040584840  10891 1040573949    1% /media/tamarin/EAGET忆捷
/dev/sdc1                 0      0          0     - /media/tamarin/EAGET
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ 

Toujours ce probleme de apt get update quelqu'un pourrait il m'aider?

Hors ligne

#11 Le 23/10/2017, à 11:31

michel_04

Re : [Résolu] Probleme apt-get update impossible!

Bonjour,

Un cocktail de dépôts : precise - quantal - trusty.
Il faut refaire le sources.list et nettoyer le sources.list.d.

A+

Hors ligne

#12 Le 23/10/2017, à 11:40

cqfd93

Re : [Résolu] Probleme apt-get update impossible!

Bonjour,

Et en plus y'a du getdeb…

En ligne

#13 Le 23/10/2017, à 11:51

michel_04

Re : [Résolu] Probleme apt-get update impossible!

Re,

cqfd93 a écrit :

Et en plus y'a du getdeb…

je pense que nam1962 va régler tout ça vite fait. wink

A+

Dernière modification par michel_04 (Le 23/10/2017, à 11:51)

Hors ligne

#14 Le 23/10/2017, à 11:52

cqfd93

Re : [Résolu] Probleme apt-get update impossible!

michel_04 a écrit :

je pense que nam1962 va régler tout ça vite fait. wink

Oui, il aime bien dégommer getdeb smile

En ligne

#15 Le 23/10/2017, à 14:18

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

Je ne suis pas du tout à jour sur les maj et les nouveaux dépôts alors bon si il y a des manip rapides a faire qui actualisent tout je suis preneur!

Hors ligne

#16 Le 23/10/2017, à 14:29

cqfd93

Re : [Résolu] Probleme apt-get update impossible!

Pour le contenu des sources, j'ai une préférence pour cette commande :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Astuce pour copier / coller la commande sans faute de frappe :

  • triple clic gauche pour sélectionner et copier la ligne entière

  • clic molette pour coller dans le terminal

Et pour savoir exactement quelle est ta version d'Ubuntu :

cat /etc/issue
uname -a
echo "${XDG_CURRENT_DESKTOP}"

En ligne

#17 Le 23/10/2017, à 14:35

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/google-talkplugin.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb http://dl.google.com/linux/talkplugin/deb/ stable main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/crebs-ppa-precise.list


/etc/apt/sources.list.d/upubuntu-com-libreoffice64-precise.list

     1	# deb http://ppa.launchpad.net/upubuntu-com/libreoffice64/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/upubuntu-com/libreoffice64/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/noobslab-apps-precise.list

     1	# deb http://ppa.launchpad.net/noobslab/apps/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/noobslab/apps/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/webupd8team-java-precise.list

     1	# deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/gregory-hainaut-pcsx2_official_ppa-precise.list

     1	# deb http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/micove-console-precise.list

     1	# deb http://ppa.launchpad.net/micove/console/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/micove/console/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/falk-t-j-qtsixa-precise.list

     1	# deb http://ppa.launchpad.net/falk-t-j/qtsixa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/falk-t-j/qtsixa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/google-earth.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb http://dl.google.com/linux/earth/deb/ stable main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/openshot_developers-ppa-trusty.list

     1	deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu trusty main
     2	# deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu trusty main

/etc/apt/sources.list.d/freecad-maintainers-freecad-stable-trusty.list

     1	deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu trusty main
     2	# deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu trusty main

/etc/apt/sources.list.d/hunter-kaller-ppa-precise.list

     1	# deb http://ppa.launchpad.net/hunter-kaller/ppa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/hunter-kaller/ppa/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/landronimirc-asunder-trusty.list

     1	deb http://ppa.launchpad.net/landronimirc/asunder/ubuntu trusty main
     2	# deb-src http://ppa.launchpad.net/landronimirc/asunder/ubuntu trusty main

/etc/apt/sources.list.d/jitsi.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb http://download.jitsi.org/deb unstable/ # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/maarten-baert-simplescreenrecorder-trusty.list

     1	deb http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu trusty main
     2	# deb-src http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu trusty main

/etc/apt/sources.list.d/pmcenery-ppa-precise.list


/etc/apt/sources.list.d/opera-stable.list

     1	# This file makes sure that Opera Browser is kept up-to-date
     2	# as part of regular system upgrades
     3	
     4	deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)

/etc/apt/sources.list.d/playonlinux.list

     1	# deb http://deb.playonlinux.com/ trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/dropbox.list

     1	# deb [arch=i386,amd64] http://linux.dropbox.com/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/getdeb.list

     1	# deb http://archive.getdeb.net/ubuntu precise-getdeb apps # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/glennric-dolphin-emu-precise.list

     1	# deb http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/glennric/dolphin-emu/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list

     1	# deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/dofus/ubuntu trusty main #Added by software-center; credentials stored in /etc/apt/auth.conf désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/sven-eckelmann-ppa-mupen64plus-precise.list

     1	# deb http://ppa.launchpad.net/sven-eckelmann/ppa-mupen64plus/ubuntu trusty main # désactivé pour la mise à niveau vers trusty
     2	# deb-src http://ppa.launchpad.net/sven-eckelmann/ppa-mupen64plus/ubuntu trusty main # désactivé pour la mise à niveau vers trusty

/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

/etc/apt/sources.list

     1	## DEPOTS OFFICIELS ##
     2	deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
     3	deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
     4	deb http://fr.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
     5	deb http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
     6	# deb http://archive.getdeb.net/ubuntu/ precise-getdeb games # désactivé pour la mise à niveau vers trusty
     7	# deb http://archive.getdeb.net/ubuntu/ quantal-getdeb games # désactivé pour la mise à niveau vers trusty
     8	
     9	## DEPOTS SUPPLEMENTAIRES ##
    10	deb http://archive.canonical.com/ubuntu trusty partner
    11	deb http://extras.ubuntu.com/ubuntu trusty main
    12	
    13	
    14	
    15	
    16	
    17	
    18	
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ cat /etc/issue
Ubuntu 14.04.5 LTS \n \l

tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ uname -a
Linux tamarin-HP-Pavilion-g7-Notebook-PC 3.13.0-58-generic #97-Ubuntu SMP Wed Jul 8 02:56:15 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ echo "${XDG_CURRENT_DESKTOP}"

Hors ligne

#18 Le 23/10/2017, à 15:43

cqfd93

Re : [Résolu] Probleme apt-get update impossible!

Bon, y'a du boulot !

Il manque celle-là (il fallait appuyer sur Entrée…) :

echo "${XDG_CURRENT_DESKTOP}"

Deux commandes (la deuxième est très longue mais avec l'astuce triple clic, elle se copie facilement) pour supprimer tous les ppa inutiles car désactivés :

cd /etc/apt/sources.list.d/
sudo rm -v google-talkplugin* crebs* upubuntu-com* noobslab* webupd8team* gregory* micove* falk-t* google-earth* hunter* pmcenery* playonlinux* dropbox* getdeb* glennric* private-ppa* sven-eckelmann*

Ensuite suppression de quelques lignes dans sources.list, à n'exécuter qu'une seule fois (elles ne donnent aucun retour) :

sudo sed -i '12,18d' /etc/apt/sources.list
sudo sed -i '6,7d' /etc/apt/sources.list

Enfin les mises à jour :

sudo apt update
sudo apt full-upgrade

En ligne

#19 Le 23/10/2017, à 18:05

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ echo "${XDG_CURRENT_DESKTOP}"
GNOME
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:~$ cd /etc/apt/sources.list.d/
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ sudo rm -v google-talkplugin* crebs* upubuntu-com* noobslab* webupd8team* gregory* micove* falk-t* google-earth* hunter* pmcenery* playonlinux* dropbox* getdeb* glennric* private-ppa* sven-eckelmann*
[sudo] password for tamarin: 
«google-talkplugin.list» supprimé
«google-talkplugin.list.distUpgrade» supprimé
«google-talkplugin.list.save» supprimé
«crebs-ppa-precise.list» supprimé
«crebs-ppa-precise.list.save» supprimé
«upubuntu-com-libreoffice64-precise.list» supprimé
«upubuntu-com-libreoffice64-precise.list.distUpgrade» supprimé
«upubuntu-com-libreoffice64-precise.list.save» supprimé
«noobslab-apps-precise.list» supprimé
«noobslab-apps-precise.list.distUpgrade» supprimé
«noobslab-apps-precise.list.save» supprimé
«webupd8team-java-precise.list» supprimé
«webupd8team-java-precise.list.distUpgrade» supprimé
«webupd8team-java-precise.list.save» supprimé
«gregory-hainaut-pcsx2_official_ppa-precise.list» supprimé
«gregory-hainaut-pcsx2_official_ppa-precise.list.distUpgrade» supprimé
«gregory-hainaut-pcsx2_official_ppa-precise.list.save» supprimé
«micove-console-precise.list» supprimé
«micove-console-precise.list.distUpgrade» supprimé
«micove-console-precise.list.save» supprimé
«falk-t-j-qtsixa-precise.list» supprimé
«falk-t-j-qtsixa-precise.list.distUpgrade» supprimé
«falk-t-j-qtsixa-precise.list.save» supprimé
«google-earth.list» supprimé
«google-earth.list.distUpgrade» supprimé
«google-earth.list.save» supprimé
«hunter-kaller-ppa-precise.list» supprimé
«hunter-kaller-ppa-precise.list.distUpgrade» supprimé
«hunter-kaller-ppa-precise.list.save» supprimé
«pmcenery-ppa-precise.list» supprimé
«pmcenery-ppa-precise.list.save» supprimé
«playonlinux.list» supprimé
«playonlinux.list.distUpgrade» supprimé
«playonlinux.list.save» supprimé
«dropbox.list» supprimé
«dropbox.list.distUpgrade» supprimé
«dropbox.list.save» supprimé
«getdeb.list» supprimé
«getdeb.list.distUpgrade» supprimé
«getdeb.list.save» supprimé
«glennric-dolphin-emu-precise.list» supprimé
«glennric-dolphin-emu-precise.list.distUpgrade» supprimé
«glennric-dolphin-emu-precise.list.save» supprimé
«private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list» supprimé
«private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.distUpgrade» supprimé
«private-ppa.launchpad.net_commercial-ppa-uploaders_dofus_ubuntu.list.save» supprimé
«sven-eckelmann-ppa-mupen64plus-precise.list» supprimé
«sven-eckelmann-ppa-mupen64plus-precise.list.distUpgrade» supprimé
«sven-eckelmann-ppa-mupen64plus-precise.list.save» supprimé
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ sudo sed -i '12,18d' /etc/apt/sources.list
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ sudo sed -i '6,7d' /etc/apt/sources.list
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ 
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ sudo apt update
E: Le pilote pour la méthode /usr/lib/apt/methods/https// n'a pu être trouvé.
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ sudo apt full-upgrade^C
tamarin@tamarin-HP-Pavilion-g7-Notebook-PC:/etc/apt/sources.list.d$ 

Hors ligne

#20 Le 23/10/2017, à 21:08

nam1962

Re : [Résolu] Probleme apt-get update impossible!

tongue Je n'étais pas là, mais je vois que je ne suis pas le seul à karscheriser ! (et il le fallait : là on était dans les sommets !)
Il reste à espérer que tous ces toxiques n'ont pas laissé des librairies pourries dans les coins !


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#21 Le 23/10/2017, à 21:10

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

ahah! j'avoue que ces temps ci j'utilisais pas tellement mon ordinateur pour travailler mais je pense que tout ça le ralentit un peu, je me demande même si un formatage ne serait pas nécessaire T.T

Hors ligne

#22 Le 01/11/2017, à 22:00

Ascheriit71

Re : [Résolu] Probleme apt-get update impossible!

Bon finalement j'ai réinstaller ubuntu par USB!

Hors ligne

#23 Le 02/11/2017, à 07:51

nam1962

Re : [Résolu] Probleme apt-get update impossible!

Et tu laisses les PPA de côté ?


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne