Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 21/06/2017, à 10:39

cguillaumec

Shutdown anormalement long ?

Bonjour à toutes et à tous !

Je possède ubuntu sur deux ordinateurs, et sur l'un d'entre eux (un joli petit Asus), j'ai l'impression qu'Ubuntu met pas mal de temps à s'éteindre. Autant sur l'autre c'est presque immédiat, autant sur l'Asus la phase avec le logo ubuntu prend 35 à 40 secondes avant extinction de l'ordinateur.

J'aimerais donc savoir :
1 - Si c'est effectivement anormal, et si ce n'est pas moi qui surestime les capacités d'Ubuntu à s'éteindre vite en toutes circonstances
2 - Si c'est anormal, comment déterminer la cause du problème et peut-être (Ô, fol espoir !) le régler.

Je vous remercie grandement, infiniment même, à genoux, plein d'humilité, pour toute réponse utile que vous pourrez m'apporter !

Dernière modification par cguillaumec (Le 27/09/2017, à 17:19)

Hors ligne

#2 Le 21/06/2017, à 13:34

J5012

Re : Shutdown anormalement long ?

quelle est ta methode d'extinction ?
→ poweroff
→ bouton alim
→ bouton logiciel
... ?

Hors ligne

#3 Le 21/06/2017, à 14:05

cguillaumec

Re : Shutdown anormalement long ?

J'ai essayé à la fois le bouton logiciel et par la console (commande sudo shutdown).
L'effet est le même.

Hors ligne

#4 Le 21/06/2017, à 21:43

J5012

Re : Shutdown anormalement long ?

et poweroff ?

Hors ligne

#5 Le 26/06/2017, à 09:15

cguillaumec

Re : Shutdown anormalement long ?

Woooooops, désolé du retard

Poweroff éteint effectivement l'ordinateur bien plus rapidement.
Je ne connaissais pas la commande, et je ne sais pas comment elle fonctionne. Il est envisageable de l'utiliser régulièrement pour éteindre l'ordinateur, ou c'est le genre d'issue de secours qu'il vaut mieux éviter de trop emprunter ?

Hors ligne

#6 Le 27/06/2017, à 01:12

J5012

Re : Shutdown anormalement long ?

en fait ce qui est bizarre c'est que shutdown et poweroff utilisent la meme commande halt !
l'un en attendant et l'autre sans attendre ...

en fait poweroff signale à toutes les applications que l'ordi va fermer, mais n'attend pas que toutes les applications signalent  effectivement la fermeture ! == un genre de "fire and forget" ...

→ dangereux si tu as une tache en cours de traitement de donnees ... comme une sauvegarde !

Hors ligne

#7 Le 27/06/2017, à 09:53

cguillaumec

Re : Shutdown anormalement long ?

Si j'ai bien compris, cela veut dire que la lenteur du shutdown serait due à une application qui met du temps à se fermer ?
Si c'est le cas, c'est relativement étrange, parce que la durée de l'extinction de l'ordinateur (via la le bouton "éteindre" ou la commande shutdown) ne varie pratiquement pas, selon que j'ai tout fermé avant ou pas. Ou alors il y aurait des tâches qui resteraient actives même si les programmes semblent fermés ? (Je m'attendrais à ce genre de chose sous Windows, moins sous Ubuntu)

Hors ligne

#8 Le 27/06/2017, à 10:59

Brunod

Re : Shutdown anormalement long ?

Essaie de lancer une commande top en terminal pour voir ce qui tourne, puis lance l'extinction pour voir ce qui "traîne" à se fermer.
Pour info, il existe des options à la commande :
halt -p fait comme poweroff;
halt -w écrit un log d'extinction en var/log/wtmp


Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
37 pc linux convertis

Hors ligne

#9 Le 27/06/2017, à 11:11

moko138

Re : Shutdown anormalement long ?

Il serait utile de voir

lsb_release -d; printenv GDMSESSION ; uname -mr
cat /etc/fstab

et, juste avant une tentative d'éteindre par la méthode normale :

mount

Dernière modification par moko138 (Le 27/06/2017, à 11:12)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#10 Le 27/06/2017, à 11:49

cguillaumec

Re : Shutdown anormalement long ?

Merci pour vos indications !

Brunod > Mon problème est que l'extinction est lente au moment de l'écran noir, avec le signe Ubuntu et la cinq points rouge/blanc ; du coup si je lance une commande top et que j'éteins, je ne vois plus ce qui se passe...
Pour ce qui est de halt -w, comment fait-on pour le lancer ? Quand je veux le faire dans le terminal, j'ai droit à un "Must be root" (Ca fait presque "My name is Groot"...)

moko 138> la première commande que tu proposes me donne :

Description:	Ubuntu 16.04.2 LTS
ubuntu
4.4.0-81-generic x86_64

La seconde :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/mmcblk0p2 during installation
UUID=91ea78c0-38fd-4e65-8c9c-4cd2a6c54eae /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/mmcblk0p1 during installation
UUID=C448-5318  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/mmcblk0p3 during installation
#UUID=a35f844c-d499-43c9-a2a4-5ed20ab0eb3f none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Quant à "mount" avant l'extinction, cela ne change rien à la durée d'extinction

Hors ligne

#11 Le 27/06/2017, à 13:52

Brunod

Re : Shutdown anormalement long ?

Il faut le faire en sudo : sudo halt -w.
Super User DO, c'est encore mieux que Groot wink


Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
37 pc linux convertis

Hors ligne

#12 Le 27/06/2017, à 15:12

maxire

Re : Shutdown anormalement long ?

Salut,

Le plus simple pour analyser l'arrêt de la session système précédente est d'utiliser le journal de SystemD:

journalctl -b -1 -e

Cette commande affiche le journal de la session SystemD -1 (la session courante est numérotée 0) en le positionnant sur sa dernière ligne.
Tu recherches alors en paginant vers l'arrière une ligne de ce genre:

juin 26 22:02:18 asus-arch systemd-logind[314]: System is powering down.

Elle indique que logind vient de lancer le processus d'arrêt système avec la date de cet évènement.
Tu pagines alors vers l'avant et tu analyses la durée de fermeture des différents processus jusqu'à la fin du journal.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#13 Le 27/06/2017, à 16:34

moko138

Re : Shutdown anormalement long ?

bibi a écrit :

voir (...) juste avant une tentative d'éteindre par la méthode normale :

mount
cguillaumec a écrit :

Quant à "mount" avant l'extinction, cela ne change rien à la durée d'extinction

Bien sûr, c'est une commande descriptive.
De même, regarder la jauge d'essence ne fait pas le plein.
Mais si tu ne donnes pas le résultat, le forum ne peut pas le connaître.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#14 Le 27/06/2017, à 17:16

Bougron

Re : Shutdown anormalement long ?

maxire a écrit :

Salut,
Le plus simple pour analyser l'arrêt de la session système précédente est d'utiliser le journal de SystemD:

journalctl -b -1 -e

.

Bonjour
Certainement pas si simple que cela......
Mais c'est facile à activer et beaucoup plus simple que d'aller à la pêche aux vieux syslogs.

 journalctl -b1
Specifying boot ID has no effect, no persistent journal was found

Donc

sudo mkdir -p /var/log/journal : 
u16041@u16041:/var/log$systemd-tmpfiles --create --prefix /var/log/journal
Setting default ACL "u::rwx,g::r-x,g:adm:r-x,m::r-x,o::r-x" on /var/log/journal failed: Operation not permitted
Setting access ACL "u::rwx,g::r-x,g:adm:r-x,m::r-x,o::r-x" on /var/log/journal failed: Operation not permitted
Cannot open '/var/log/journal': Operation not permitted
chmod(/var/log/journal) failed: Operation not permitted

sudo systemd-tmpfiles --create --prefix /var/log/journal

systemctl restart systemd-journald

journalctl  -b1  -e
juin 27 17:04:19 u16041 systemd-journald[304]: Journal stopped
juin 27 17:04:19 u16041 systemd-journald[2689]: Runtime journal (/run/log/journal/) is 7.3M, max 58.5M, 51.2M free.
juin 27 17:04:19 u16041 systemd-journald[2689]: Time spent on flushing to /var is 35.135ms for 1788 entries.
juin 27 17:04:19 u16041 systemd[1]: Stopping Journal Service...
juin 27 17:04:19 u16041 systemd-journald[304]: Received SIGTERM from PID 1 (systemd).
juin 27 17:04:19 u16041 systemd[1]: Stopped Journal Service.
juin 27 17:04:19 u16041 systemd[1]: Starting Journal Service...
juin 27 17:04:19 u16041 systemd-journald[2689]: Journal started
juin 27 17:04:19 u16041 polkitd(authority=local)[1291]: Unregistered Authentication Agent for unix-process:2677:40058 (system bus name :1.71, object path /org/freedeskto
juin 27 17:04:19 u16041 systemd[1]: Started Journal Service.
juin 27 17:04:19 u16041 systemd[1]: Starting Flush Journal to Persistent Storage...
juin 27 17:04:19 u16041 systemd[1]: Started Flush Journal to Persistent Storage.
juin 27 17:06:00 u16041 sudo[2715]:   u16041 : TTY=pts/2 ; PWD=/home/u16041 ; USER=root ; COMMAND=/bin/journalctl -b -1 -e
juin 27 17:06:00 u16041 sudo[2715]: pam_unix(sudo:session): session opened for user root by (uid=0)
juin 27 17:06:00 u16041 sudo[2715]: pam_unix(sudo:session): session closed for user root
juin 27 17:08:32 u16041 hddtemp[1507]: /dev/sda: TOSHIBA MQ01ABD100: 44 C
juin 27 17:10:37 u16041 systemd[1]: Started CUPS Scheduler.
juin 27 17:11:25 u16041 sudo[2758]:   u16041 : TTY=pts/6 ; PWD=/home/u16041 ; USER=root ; COMMAND=/bin/systemd-tmpfiles --create --prefix /var/log/journal
juin 27 17:11:25 u16041 sudo[2758]: pam_unix(sudo:session): session opened for user root by (uid=0)
juin 27 17:11:25 u16041 sudo[2758]: pam_unix(sudo:session): session closed for user root
juin 27 17:12:54 u16041 systemd[1]: Starting Cleanup of Temporary Directories...
juin 27 17:12:54 u16041 systemd-tmpfiles[2766]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path "/var/log", ignoring.
juin 27 17:12:54 u16041 systemd[1]: Started Cleanup of Temporary Directories.

et pour la recherche faire du classique, car le mot clé peut être différent.

juin 27 17:18:36 u16041 systemd[1]: Started Show Plymouth Reboot Screen.
juin 27 17:18:36 u16041 systemd[1]: Stopped Login Service.
juin 27 17:18:36 u16041 systemd[1]: Stopped target User and Group Name Lookups.
juin 27 17:18:36 u16041 systemd[1]: Stopped LSB: minidlna server.
juin 27 17:18:36 u16041 thermald[1112]: terminating on user request ..
juin 27 17:18:36 u16041 smbd[2915]:    ...done.

donc tout bêtement

journalctl -b1 | tail -100 | pg

ou

 journalctl -b1 -e

car ce qui intéresse est bien la fin.
en espérant que le problème n'est pas après

juin 27 17:18:38 u16041 dnsmasq[1370]: sortie sur réception du signal SIGTERM
juin 27 17:18:38 u16041 systemd-journald[2689]: Journal stopped

Dernière modification par Bougron (Le 27/06/2017, à 17:43)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#15 Le 27/06/2017, à 17:25

maxire

Re : Shutdown anormalement long ?

Salut Bougron,

Déjà c'est -b -1 et non -b1 mais il est vrai que la 16.04 est une version bâtarde au sens où elle ménage la chèvre et le chou c'est à dire SystemD (la chèvre) et Upstart (le chou) en sachant que la chèvre finira par manger le chou.
Il faut peut-être passer quelques commandes pour activer le journal permanent de  SystemD.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#16 Le 27/06/2017, à 17:48

Bougron

Re : Shutdown anormalement long ?

J'ai mis dans mon message les trois commandes trouvées sur internet
et
journalctl -eb1 est aussi codifiable!!!! il y a probablement une grande liberté. Cependant journalctl -b -1 -e est bon .

u16041@u16041:~$ journalctl -eb1
juin 27 17:18:38 u16041 systemd[1]: Stopped Remount Root and Kernel File Systems.
juin 27 17:18:38 u16041 systemd[1]: Stopping Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...
juin 27 17:18:38 u16041 systemd[1]: Stopped Create Static Device Nodes in /dev.
juin 27 17:18:38 u16041 systemd[1]: Reached target Shutdown.
juin 27 17:18:38 u16041 systemd[1]: Reached target Final Step.
juin 27 17:18:38 u16041 systemd[1]: Starting Reboot...
juin 27 17:18:38 u16041 systemd[1]: Shutting down.
juin 27 17:18:38 u16041 lvm[3181]:   WARNING: Device for PV kUOdOx-0S4G-IYB7-nnJK-HSg8-ePqu-XBGosW not found or rejected by a filter.
juin 27 17:18:38 u16041 systemd-shutdown[1]: Sending SIGTERM to remaining processes...
juin 27 17:18:38 u16041 dnsmasq[1370]: sortie sur réception du signal SIGTERM
juin 27 17:18:38 u16041 systemd-journald[2689]: Journal stopped

Dernière modification par Bougron (Le 27/06/2017, à 17:53)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#17 Le 27/06/2017, à 19:58

maxire

Re : Shutdown anormalement long ?

Bougron a écrit :

J'ai mis dans mon message les trois commandes trouvées sur internet

Plutôt 2 commandes disponibles dans la page man de systemd-journald (oui man est toujours ton ami!), pas besoin d'internet sur ce coup ci.

man systemd-journald a écrit :

By default, the journal stores log data in /run/log/journal/. Since
       /run/ is volatile, log data is lost at reboot. To make the data
       persistent, it is sufficient to create /var/log/journal/ where
       systemd-journald will then store the data:

           mkdir -p /var/log/journal
           systemd-tmpfiles --create --prefix /var/log/journal

       See journald.conf(5) for information about the configuration of this
       service.

3 commandes si tu inclues le redémarrage de systemd-journald.

Journalctl -b 1 affiche le plus ancien journal, dans mon cas il est daté du  9 janvier 2014!
-b 2 affiche le deuxième plus ancien journal etcetera...

La notation négative prend pour origine la session système en cours donc -1 = le plus récent journal hors le courant, -2 le deuxième plus récent etcetera...

-b ou -b 0, journal de la session en cours et sans option -b tu affiches tous les journaux depuis le plus ancien, dans mon cas du 09 janvier 2014 au 27 juin 2017.
Et comme les journaux sont compressés l'espace disque utilisé n'est que 1,3 GO.

[aspire7730z@asus-arch ~]$ journalctl --disk-usage
Archived and active journals take up 1.3G in the file system.
[aspire7730z@asus-arch ~]$ 

Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#18 Le 27/06/2017, à 21:00

Bougron

Re : Shutdown anormalement long ?

et comme je venais d'activer le journal et donc qu'il n'y a qu'un seul ancien journal, les deux codifs sont identiques uniquement pour le moment!!!!!
Il va juste rester à regarder si l'épuration de ce journal est automatique.
Je crois donc comprendre que non:   Donc une partition /var de 8To est à envisager!!!!!!!!!!!!!!!!(au secours moko)!!!!!!!!!!!!!!
Merci pour cette explication que je mémorise.

AJOUT: En réponse à l'échange qui suit.     Je ne touche à rien!!!!!

u16041@u16041:~$ pg /etc/systemd/journald.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See journald.conf(5) for details.

[Journal]
#Storage=auto
#Compress=yes
#Seal=yes
#SplitMode=uid
#SyncIntervalSec=5m
#RateLimitInterval=30s
#RateLimitBurst=1000
#SystemMaxUse=
#SystemKeepFree=
#SystemMaxFileSize=                                                            
#SystemMaxFiles=100
#RuntimeMaxUse=
#RuntimeKeepFree=
#RuntimeMaxFileSize=
#RuntimeMaxFiles=100
#MaxRetentionSec=
#MaxFileSec=1month
#ForwardToSyslog=yes
#ForwardToKMsg=no
#ForwardToConsole=no
#ForwardToWall=yes
#TTYPath=/dev/console
#MaxLevelStore=debug
#MaxLevelSyslog=debug
#MaxLevelKMsg=notice
#MaxLevelConsole=info
#MaxLevelWall=emerg
u16041@u16041:~$    
u16041@u16041:~$ cd /var/log/jour*
u16041@u16041:/var/log/journal$ ls -ls
total 4
4 drwxr-sr-x+ 2 root systemd-journal 4096 juin  27 17:18 191afee1334b4fb1a234548336625f9a
u16041@u16041:/var/log/journal$ cd *
u16041@u16041:/var/log/journal/191afee1334b4fb1a234548336625f9a$ ls -ls
total 24580
8196 -rw-r-----+ 1 root systemd-journal 8388608 juin  27 23:29 system.journal
8192 -rw-r-----+ 1 root systemd-journal 8388608 juin  27 23:02 user-1000.journal
8192 -rw-r-----+ 1 root systemd-journal 8388608 juin  27 17:24 user-65534.journal
u16041@u16041:/var/log/journal/191afee1334b4fb1a234548336625f9a$

Dernière modification par Bougron (Le 27/06/2017, à 23:31)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#19 Le 27/06/2017, à 22:13

maxire

Re : Shutdown anormalement long ?

@Bougron, si les journaux systemd sont purgés, il existe une taille limite qu'ils ne doivent pas dépasser, le problème est que sa valeur par défaut est définie lors de la compilation des programmes SystemD si j'ai bien compris.
Donc les développeurs étant parfois fantaisistes ou disons taquins cela peut varier d'une distribution à une autre ou même d'une version à une autre au sein d'une même distribution.

Sous Archlinux la taille maximale du journal est de 10% de celle du système de fichiers hébergeur avec une limite de 4GO.
Donc au-delà d'une taille de système de fichiers de 40 GO la taille maximale du journal est de 4 GO.
Ce comportement peut être modifié via /etc/systemd/journald.conf.

Ne pas oublier que ces journaux sont en format compressé donc 4GO c'est énorme pour conserver du texte.

Dernière modification par maxire (Le 27/06/2017, à 22:15)


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#20 Le 28/06/2017, à 10:28

cguillaumec

Re : Shutdown anormalement long ?

Tout plein de message que je ne comprends pas big_smile
En attendant, le résultat de la commande "mount" :

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=955996k,nr_inodes=238999,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=195272k,mode=755)
/dev/mmcblk0p2 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/mmcblk0p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=195272k,mode=700,uid=1000,gid=1000)
/home/.ecryptfs/e/.Private on /home/e type ecryptfs (rw,nosuid,nodev,relatime,ecryptfs_fnek_sig=30c37fb2e099c974,ecryptfs_sig=e582a55d7931d968,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

Hors ligne

#21 Le 28/06/2017, à 11:28

moko138

Re : Shutdown anormalement long ?

mount
/dev/mmcblk0p2 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/mmcblk0p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/home/.ecryptfs/e/.Private on /home/e type ecryptfs (rw,nosuid,nodev,relatime,ecryptfs_fnek_sig=30c37fb2e099c974,ecryptfs_sig=e582a55d7931d968,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs)
(...)

Je note :
- pas de montage réseau (qui était mon suspect a priori) ;
- home chiffré ;
- installation sur support mmcblk0.

Je laisse les spécialistes commenter, s'il y a lieu.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#22 Le 28/06/2017, à 11:40

cguillaumec

Re : Shutdown anormalement long ?

Je ne sais ABSOLUMENT pas si c'est lié, mais j'ai constaté que j'avais assez peu de place sur mon ordinateur, malgré une utilisation très légère de la mémoire disponible (en gros : des fichiers words, et parfois des PDF).
Du coup, j'ai utilisé l'analyseur d'utilisation du disque, et il se trouve que j'ai un dossier ecryptfs qui me prend à peu près 15,8 Go, et qui n'a a priori pas été modifié depuis février 2017, date à laquelle j'ai installé Ubuntu sur mon ordinateur.
Est-ce que cela correspond au fait que le home est chiffré, ou est-ce que ça pourrait être une anomalie.

Par ailleurs, comment faire pour voir du coup ce qu'il y a dans ces dossiers (qui pour le moment ne ressemblent à rien) ?

Hors ligne

#23 Le 28/06/2017, à 12:16

Bougron

Re : Shutdown anormalement long ?

Bonjour
On y va doucement

Maxire a proposé

journalctl -b -1 -e

Merci d'exécuter et de donner le résultat


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#24 Le 28/06/2017, à 12:44

cguillaumec

Re : Shutdown anormalement long ?

Et hop :

Specifying boot ID has no effect, no persistent journal was found

Hors ligne

#25 Le 28/06/2017, à 13:03

Bougron

Re : Shutdown anormalement long ?

OK,
Donc,  tu dans le même cas que moi hier.
1) Tu installes  la journalisation avec ces deux commandes

sudo mkdir -p /var/log/journal
sudo systemd-tmpfiles --create --prefix /var/log/journal

2) Tu l'actives avec cette commande

systemctl restart systemd-journald

3)  Tu arrêtes l'ortdinateur comme tu as l'habitude de faire en chronometrant.

4) Tu relances l'ordinateur

5) Tu donnes le résultat de la commande

journalctl -b -1 -e

6) Et si tu penses qu'il y a pas tout, je propose de faire en remontant le temps, Ce n'est pas très pratique à lire mais je pense qu'on veut y voir les choses anormales

journalctl -b -1 -r

Dernière modification par Bougron (Le 28/06/2017, à 13:41)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne