Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 11/08/2017, à 19:07

Goshi

[RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Bonjour,

Je n'arrive pas à passer à la dernière LTS.

Le gestionnaire de mise à jour ne trouve rien malgré une configuration conforme, je suis donc passé en ligne de commandes :

sudo do-release-upgrade
Recherche d'une nouvelle version d'Ubuntu
Aucune nouvelle version trouvée
sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
sudo update-manager -d
ERROR:root:parse failed for '/var/lib/update-manager/meta-release-lts-development'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 360, in download
    self.parse()
  File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 241, in parse
    "Required key '%s' missing" % required_key)
UpdateManager.Core.MetaRelease.MetaReleaseParseError: Required key 'Dist' missing
sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Mon sources.list était d'origine jusque là. J'ai effacé ensuite tous les fr.old-releases.ubuntu.com qu'il contenait car domaine non déclaré dans les dns donc inutiles mais mon update-manager n'a pas aimé apparemment car il ne m'affichait que des erreurs ensuite alors que pas d'erreur dans le contenu.

J'ai voulu le désinstaller pour corriger ces 2 bugs mais .... même en reprenant un sources.list tout neuf pour 14.10 (qui ne contient pas fr.old-releases.ubuntu.com) trouvé sur le forum, échec à l'install pour update manager (404 pour http://fr.archive.ubuntu.com/ubuntu/) et 404 pour la maj de distri (la plupart dans http://fr.archive.ubuntu.com/ubuntu/dists/)... \ò/ donc c'est pire qu'avant.

Help please.

edit : Rien ne marche de tout ce que je trouve sur Google. Méthode violente, passage à un source-list d'un ubuntu xenial suivi d'un full-upgrade et ça travaille.

Dernière modification par Goshi (Le 12/08/2017, à 18:14)

Hors ligne

#2 Le 11/08/2017, à 20:55

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Le problème, c'est que la 14.10 n'est pas une LTS, elle ne peut passer qu'à la version "normale" suivante, à savoir la 15.04... qui n'est plus supportée depuis longtemps (la 14.10 non plus). Tu ne peux passer à une LTS que depuis la LTS précédente ou la version normale précédente (donc pour la 16.04, soit depuis la 14.04, soit depuis la 15.10).

Là, je ne suis pas sûr que tu puisses faire grand chose à part sauvegarder tes données et refaire une installation propre de la 16.04. Peut-être modifier ton sources.list pour mettre les dépôts xenial et faire un full-upgrade mais il y a de fortes chances que ça se passe mal et que tu te retrouves avec un système complètement inutilisable.

Dernière modification par abelthorne (Le 11/08/2017, à 20:55)

Hors ligne

#3 Le 11/08/2017, à 21:03

J5012

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

la methode manuelle de remplacement des sources de depots par les nouvelles de xenial n'est pas violente, mais demande des aptitudes de comprehension quant aux interactions entres les paquets : c'etait la methode preconisée quand la commande do-release-upgrade n'existait pas ...

quand apt aura terminé les mises à jour : j'espere que tu as demandé une mise à jour et mise à niveau complete : tu devras faire le menage à la main ... tu peux utiliser synaptic ...

Hors ligne

#4 Le 11/08/2017, à 22:05

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

J'avais pas le choix à l'époque. La 14.04 n'avait pas les bons pilotes pour ma souris sans fil alors que la 14.10 les avait.

modifier ton sources.list pour mettre les dépôts xenial et faire un full-upgrade mais il y a de fortes chances que ça se passe mal et que tu te retrouves avec un système complètement inutilisable.

Bingo. Tout s'est très bien passé puis à la fin j'ai eu le droit à un truc du genre "erreur il est possible que votre systeme soit instable" puis un "succes l'installation s'est bien terminé". J'étais bien en 16.04, j'ai tenté un reboot pour voir ce que ça allait donner et c'est mort, ça démarre plus, écran noir avant le bureau.

Je vais tester quelques trucs avant d'abandonner et repartir sur une install fraiche sad.

edit : C'est ptetr pas foutu en fait, j'ai la main avec CTRL+ALT+F1. C'est peut-être juste un probleme de pilote graphique il parait que les nvidia officiels marchent mal sur 16.04

Dernière modification par Goshi (Le 11/08/2017, à 22:16)

Hors ligne

#5 Le 11/08/2017, à 22:22

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Il n'y a pas vraiment de raisons que les pilotes nVidia marchent plus mal en 16.04 que sur une autre version. Depuis la console, tu peux éventuellement essayer de les supprimer avec :

sudo apt-get remove --purge nvidia-*

Fais très attention à la liste des paquets qui vont être supprimés par la commande avant de valider, que ça ne supprime pas la moitié du système. Si c'est bon, redémarre avec sudo reboot pour voir ce que ça donne.

Tu peux aussi essayer un sudo apt-get install -f pour essayer d'installer des dépendances manquantes (mêmes remarques sur ce que la commande va ajouter / supprimer comme paquets).

Enfin, tu peux essayer de lancer une session graphique avec startx pour voir ce que tu as comme erreur.

Si tu dois tout réinstaller, tu pourras au moins accéder à ton disque dur depuis la session live pour sauvegarder tes données.

Goshi a écrit :

J'avais pas le choix à l'époque. La 14.04 n'avait pas les bons pilotes pour ma souris sans fil alors que la 14.10 les avait.

Si tu es sur le cycle des versions normales, il faut être bien conscient que tu dois mettre à jour ton système tous les six mois (environ : chaque version est supportée neuf mois).

Dernière modification par abelthorne (Le 11/08/2017, à 22:27)

Hors ligne

#6 Le 11/08/2017, à 23:07

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

sudo apt-get remove --purge nvidia-*

N'a rien trouvé à enlever

sudo apt-get install -f

N'a rien trouvé à faire

Par contre startx ou sudo startx affichent une impossibilité de se connecter au serveur -> https://centre.soa.ovh/Ubuntu1.jpg idem avec -ignoreABI
Le log dans /var/log/Xorg.1.log -> https://centre.soa.ovh/Ubuntu2.jpg

J'ai testé de créer le fichier /etc/X11/xorg.conf et de mettre des trucs trouvés sur Google (vesa) sans succès.

sudo dpkg-reconfigure -phigh xserver-xorg

Ne fait rien du tout.

sudo nvidia-xconfig

A créé un fichier xorg.conf mais pas mieux

sudo service lightdm stop
sudo X -configure

M'envoie bouler direct avec un "Server terminated with error"

Je cherche toujours, notamment en direction de "This server has a video driver ABI version of 20.0 that is not
supported by this NVIDIA driver." smile J'ai Xorg 1.18.4 pour le moment.

Dernière modification par Goshi (Le 11/08/2017, à 23:31)

Hors ligne

#7 Le 11/08/2017, à 23:30

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Est-ce que tu vois des paquets installés si tu fais ça ?

apt-cache policy nvidia* | more

Vu que tu as l'air d'être sur le pilote nVidia, ça devrait te permettre d'identifier le nom du paquet du pilote installé pour le supprimer (nvidia-xxx). Efface aussi ton xorg.conf.

EDIT : tu peux aussi installer mesa-utils pour avoir glxinfo. Ensuite, lance un glxinfo | grep OpenGL pour avoir la version du pilote installé. Le paquet à supprimer devrait correspondre au numéro de version principal (par exemple nvidia-304 si tu es sur le 304.xx).

Dernière modification par abelthorne (Le 11/08/2017, à 23:33)

Hors ligne

#8 Le 11/08/2017, à 23:51

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Ca affiche une quantité énorme d'info mais aucune ligne ne concernant nvidia.

locate nvidia

Me retourne pas mal de lignes dont une qui ressemble à un dossier de pilotes qui serait le 346.47

dpkg -l | grep nvidia

Ne retourne rien

sudo apt-get remove --purge nvidia-346

Dit qu'il n'est pas installé

J'abandonne pour ce soir. Merci pour le coup de main.

edit : j'avais déjà testé un

glxinfo | grep OpenGL

mais en retour j'ai "unable to open display"

Dernière modification par Goshi (Le 11/08/2017, à 23:53)

Hors ligne

#9 Le 11/08/2017, à 23:55

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Et si tu essaies d'installer ce pilote nVidia ?

sudo apt-get install nvidia-346

Hors ligne

#10 Le 12/08/2017, à 00:02

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

AH ! Bien joué c'était ça.

Pendant l'install il a sorti un truc du genre "Il semblerait que le pilote soit déjà installé mais via une autre méthode, nous allons essayer de corriger cela". Il s'est mis à installer nvidia-375, un sudo reboot et hop ça roule.


Merciiiii big_smile

edit : Ah ben non en fait. Il me laisse pas me connecter. J'entre le mot de passe et paf retour à l'écran d'accueil pour se loguer après un écran nvidia furtif mad
Le mot de passe est bon, quand j'en tape un mauvais il ne se passe pas la même chose. Mais le mode invité lui fonctionne parfaitement...

Bref, dodo.

Dernière modification par Goshi (Le 12/08/2017, à 00:13)

Hors ligne

#11 Le 12/08/2017, à 08:58

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Donc, ce matin.

J'ai testé :

sudo apt-get remove --purge nvidia*
sudo apt-get install xserver-xorg-video-nouveau

Il était déjà installé. Ecran noir après reboot donc pas la solution.

sudo apt-cache search nvidia-

J'ai installé les différentes version nvidia existante chacune leur tour avec un reboot entre chaque

sudo apt-get install nvidia-367
sudo apt-get remove --purge nvidia*
sudo apt-get install nvidia-361

Et je me suis rendu compte que ça allait bien trop vite, je suis en adsl je peux pas installer un paquet de presque 400mo en quelques secondes. En plus, à chaque fois que j'installe une version de pilote, apt-get me dit qu'il va installer cette version et toutes les suivantes jusqu'à la 375... Je pense qu'il se moque de moi et qu'il installe la dernière à chaque fois

Du coup j'ai fait

sudo apt-get clean

pour vider le cache des paquets téléchargés et là c'est le drame, apt-get ne fonctionne plus il me dit pleeeeins de fois qu'il a une "Erreur temporaire de résolution de <<xxxx>>, xxx étant beaucoup d'adresses de mon sources.list.

ping google.fr

me retourne unknown host google.fr............................

Je comprends pas comment j'ai perdu internet sad

edit :
Au demarrage il dit qu'il arrive pas à trouver /etc/resolv.conf
Je suis allé voir, le fichier existe mais est vide.

sudo nano /etc/resolv.conf

J'y ai ajouté nameserver 8.8.8.8 puis j'ai reboot.

Après le reboot, le fichier était à nouveau vide.......

sudo cat /etc/resolv.conf

Me retourne "Aucun fichier ou dossier de ce type", c'est dingue ça il existe bien pourtant...
Bref, en écrivant dans le fichier sans reboot, ça fonctionne j'ai à nouveau internet, je continue mes essais de drivers.

glxinfo | grep OpenGL

me retourne toujours unable to open display sauf quand je suis en interface graphique en mode invité où là il me dit que j'ai la 375.

Fichier xorg.conf inexistant j'ai donc fait un

sudo nvidia-xconfig

suivi d'un reboot, pas mieux.

J'ai installé le pilote nvidia-384 à la main vu qu'il est inexistant dans apt-get (wget du pilote trouvé sur le site de nvidia, puis execution de celui-ci), c'est pire, la session invité ne fonctionne plus non plus avec ce pilote.
La version nvidia-352 installée à la main fait pareil sad.

J'ai plus d'idée.

Dernière modification par Goshi (Le 12/08/2017, à 10:13)

Hors ligne

#12 Le 12/08/2017, à 09:45

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

En fait, si je t'ai fait installer nvidia-346, c'était dans le but de le supprimer après pour repasser à Nouveau et avoir une base propre pour continuer. Si tu t'es amusé ensuite à installer toutes les versions plus ou moins en même temps, ça doit être un merdier...

Ne fais pas de xorg.conf pour le moment (supprime celui que tu as recréé et ne relance plus nvidia-xconfig).

Depuis la session invité, si tu peux lancer un terminal, donne le retour de :

apt-cache policy nvidia*

Vérifie les permissions des fichiers .ICEauthority et .Xauthority de ta session :

ls -la ~ | grep auth

Hors ligne

#13 Le 12/08/2017, à 10:27

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

J'ai plus accès à la session invité pour le moment. Je dois repasser en nvidia-375 pour ça c'est la seule qui me donne accès.

En mode recovery, en root donc ->

apt-cache policy nvidia*

Donne https://centre.soa.ovh/Ubuntu3.jpg

ls -la ~ | grep auth

Ne retourne rien

ls -la /home/nicolas | grep auth

Me retourne un droit en lecture et écriture sur .ICEauthority pour nicolas et un droit en lecture et écriture sur .Xauthority pour root

Hors ligne

#14 Le 12/08/2017, à 10:38

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Goshi a écrit :

En mode recovery, en root donc ->

apt-cache policy nvidia*

Donne https://centre.soa.ovh/Ubuntu3.jpg

Là, on en voit seulement une partie, c'est pour ça que je te demandais de le faire depuis un terminal en session invité, pour pouvoir copier-coller l'ensemble. Si tu es juste sur la console, affiche la commande en plusieurs fois pour pouvoir donner chaque page :

apt-cache policy nvidia* | more

Tu peux aussi essayer de les lister avec dpkg :

dpkg -l | grep nvidia
ls -la /home/nicolas | grep auth

Me retourne un droit en lecture et écriture sur .ICEauthority pour nicolas et un droit en lecture et écriture sur .Xauthority pour root

Les deux fichiers devraient être en rw------- et t'appartenir. Si .Xauthority appartient à root, c'est pas bon, change-le et essaie de te reconnecter (depuis le démarrage normal, pas le mode recovery) :

sudo chown nicolas:nicolas /home/nicolas/.Xauthority

Hors ligne

#15 Le 12/08/2017, à 10:42

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Les deux fichiers devraient être en rw------- et t'appartenir. Si .Xauthority appartient à root, c'est pas bon, change-le et essaie de te reconnecter (depuis le démarrage normal, pas le mode recovery) :

C'est ce que j'avais cru deviner, en voyant le résultat. Le problème venait bien de là, je suis bien en 16.04 avec ma session. Merciiiii smile

Dernière modification par Goshi (Le 12/08/2017, à 10:42)

Hors ligne

#16 Le 12/08/2017, à 10:44

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Attends, on a encore des choses à vérifier. D'abord, un petit point :
1) Tu es sur le pilote nVidia ou tu as pu repasser à Nouveau ?
2) Tu es sur quel environnement de bureau ?
3) Fais un sudo apt-get update et donne le retour. Ne lance pas de mises à jour pour le moment.

Hors ligne

#17 Le 12/08/2017, à 10:58

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

glxinfo | grep OpenGL

Me dit que je suis en nvidia-375

Je suis sur Unity.

Le retour de update ->

Atteint:1 http://repo.steampowered.com/steam precise InRelease
Atteint:2 http://security.ubuntu.com/ubuntu xenial-security InRelease          
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                 
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                   
Ign:5 http://ppa.launchpad.net/nerdherd/cloud/ubuntu utopic InRelease          
Atteint:6 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:7 http://dl.google.com/linux/chrome/deb stable Release                 
Atteint:8 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu utopic InRelease
Ign:9 http://ppa.launchpad.net/pipelight/stable/ubuntu utopic InRelease
Ign:10 http://ppa.launchpad.net/webupd8team/java/ubuntu utopic InRelease
Atteint:11 http://ppa.launchpad.net/nerdherd/cloud/ubuntu utopic Release
Atteint:12 http://ppa.launchpad.net/pipelight/stable/ubuntu utopic Release
Atteint:13 http://ppa.launchpad.net/webupd8team/java/ubuntu utopic Release
Lecture des listes de paquets... Fait
W: http://ppa.launchpad.net/nerdherd/cloud/ubuntu/dists/utopic/Release.gpg: Signature by key B8688B054CD11DD4FFAE298475CC5E1670875DFB uses weak digest algorithm (SHA1)
W: http://ppa.launchpad.net/pipelight/stable/ubuntu/dists/utopic/Release.gpg: Signature by key 37D519856DA17931CD1123FBFB5DF26925396B8E uses weak digest algorithm (SHA1)
W: http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/utopic/Release.gpg: Signature by key 7B2C3B0889BF5709A105D03AC2518248EEA14886 uses weak digest algorithm (SHA1)

Hors ligne

#18 Le 12/08/2017, à 11:01

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Ok. Donne-moi la liste de tes dépôts, il y en a apparemment quelques-uns qui ne sont pas à jour :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
cat /etc/apt/sources.list.d/*.list

Redonne-moi aussi la liste des paquets nVidia demandée plus haut maintenant que tu as un terminal fonctionnel :

apt-cache policy nvidia*

Hors ligne

#19 Le 12/08/2017, à 11:11

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

cat /etc/apt/sources.list
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted


ls /etc/apt/sources.list.d
google-chrome.list                                    nerdherd-ubuntu-cloud-utopic.list.save           steam.list
google-chrome.list.save                               otto-kesselgulasch-ubuntu-gimp-utopic.list       steam.list.save
guilhem-fr-ubuntu-asterisk-11-daily-utopic.list       otto-kesselgulasch-ubuntu-gimp-utopic.list.save  webupd8team-ubuntu-java-utopic.list
guilhem-fr-ubuntu-asterisk-11-daily-utopic.list.save  pipelight-ubuntu-stable-utopic.list              webupd8team-ubuntu-java-utopic.list.save
nerdherd-ubuntu-cloud-utopic.list                     pipelight-ubuntu-stable-utopic.list.save


cat /etc/apt/sources.list.d/*.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
deb http://ppa.launchpad.net/nerdherd/cloud/ubuntu utopic main
# deb-src http://ppa.launchpad.net/nerdherd/cloud/ubuntu utopic main
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu utopic main
# deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu utopic main
deb http://ppa.launchpad.net/pipelight/stable/ubuntu utopic main
# deb-src http://ppa.launchpad.net/pipelight/stable/ubuntu utopic main
deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
deb http://ppa.launchpad.net/webupd8team/java/ubuntu utopic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu utopic main
apt-cache policy nvidia*
nvidia-346-updates:
  Installé : (aucun)
  Candidat : 352.63-0ubuntu3
 Table de version :
     352.63-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-driver-binary:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-331-dev:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-304-updates-dev:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-340-updates-uvm:
  Installé : (aucun)
  Candidat : 340.96-0ubuntu2
 Table de version :
     340.96-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-331-updates-uvm:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-cg-toolkit:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-va-driver:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-legacy-340xx-vdpau-driver:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-opencl-icd-304-updates:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-331-updates:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-352-dev:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-vdpau-driver:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-346-dev:
  Installé : (aucun)
  Candidat : 352.63-0ubuntu3
 Table de version :
     352.63-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-331-uvm:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-prime:
  Installé : 0.8.2
  Candidat : 0.8.2
 Table de version :
 *** 0.8.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
nvidia-current-updates:
  Installé : (aucun)
  Candidat : 304.131-0ubuntu3
 Table de version :
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-340-dev:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-common:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-352-updates:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-current-dev:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-375-dev:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-current:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-367-dev:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-340-updates-dev:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-304-dev:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-331-updates-dev:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-persistenced:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-current-updates-dev:
  Installé : (aucun)
  Candidat : 304.131-0ubuntu3
 Table de version :
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-361-dev:
  Installé : (aucun)
  Candidat : 367.57-0ubuntu0.16.04.1
 Table de version :
     367.57-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-settings-binary:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-361-updates-dev:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-libopencl1-304:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-libopencl1-340:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-libopencl1-361:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-libopencl1-367:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-libopencl1-375:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-352-updates-dev:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-304-updates:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-340-uvm:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-libopencl1-304-updates:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-340-updates:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-361-updates:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-libopencl1-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-libopencl1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
nvidia-opencl-icd-304:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-opencl-icd-340:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-opencl-icd-361:
  Installé : (aucun)
  Candidat : 367.57-0ubuntu0.16.04.1
 Table de version :
     367.57-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-opencl-icd-367:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-opencl-icd-375:
  Installé : 375.66-0ubuntu0.16.04.1
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
 *** 375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
        100 /var/lib/dpkg/status
nvidia-experimental-304:
  Installé : (aucun)
  Candidat : 304.131-0ubuntu3
 Table de version :
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-experimental-304-dev:
  Installé : (aucun)
  Candidat : 304.131-0ubuntu3
 Table de version :
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-304:
  Installé : (aucun)
  Candidat : 304.135-0ubuntu0.16.04.1
 Table de version :
     304.135-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     304.131-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-331:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-340:
  Installé : (aucun)
  Candidat : 340.102-0ubuntu0.16.04.2
 Table de version :
     340.102-0ubuntu0.16.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     340.102-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     340.96-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-346:
  Installé : (aucun)
  Candidat : 352.63-0ubuntu3
 Table de version :
     352.63-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-352:
  Installé : (aucun)
  Candidat : 361.42-0ubuntu2
 Table de version :
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-361:
  Installé : (aucun)
  Candidat : 367.57-0ubuntu0.16.04.1
 Table de version :
     367.57-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     361.42-0ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-367:
  Installé : (aucun)
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
     375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
nvidia-375:
  Installé : 375.66-0ubuntu0.16.04.1
  Candidat : 375.66-0ubuntu0.16.04.1
 Table de version :
 *** 375.66-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
        100 /var/lib/dpkg/status
nvidia-346-updates-dev:
  Installé : (aucun)
  Candidat : 352.63-0ubuntu3
 Table de version :
     352.63-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
nvidia-settings:
  Installé : 361.42-0ubuntu1
  Candidat : 361.42-0ubuntu1
 Table de version :
 *** 361.42-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
nvidia-opencl-icd:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :

Hors ligne

#20 Le 12/08/2017, à 11:27

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Ton sources.list est incomplet (il manque les dépôts universe, multiverse, les backports...), édite-le :

sudo gedit /etc/apt/sources.list

et remplace tout son contenu par ça :

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

Édite ces dépôts tiers :

sudo gedit /etc/apt/sources.list.d/nerdherd-ubuntu-cloud-utopic.list /etc/apt/sources.list.d/otto-kesselgulasch-ubuntu-gimp-utopic.list /etc/apt/sources.list.d/pipelight-ubuntu-stable-utopic.list /etc/apt/sources.list.d/webupd8team-ubuntu-java-utopic.list

et remplace utopic par xenial partout (même dans la ligne deb-src commentée).

Le PPA guilhem-fr-ubuntu-asterisk-11-daily-utopic.list a l'air vide, tu peux confirmer ça ?

cat /etc/apt/sources.list.d/guilhem-fr-ubuntu-asterisk-11-daily-utopic.list

Si c'est bien le cas, supprime-le :

sudo rm /etc/apt/sources.list.d/guilhem-fr-ubuntu-asterisk-11-daily-utopic.list /etc/apt/sources.list.d/guilhem-fr-ubuntu-asterisk-11-daily-utopic.list.save

Pour nVidia, ça a l'air ok.

Une fois que tu as fait les modifs, recharge à nouveau les sources et lance une mise à jour :

sudo apt-get update && sudo apt-get dist-upgrade

Dis-moi si ça s'est bien passé ou si tu as des erreurs.

Hors ligne

#21 Le 12/08/2017, à 11:52

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-backports.ssl-match-hostname_3.4.0.2-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ca m'a installé macchanger aussi, aucune idée de l'intéret d'avoir ce truc par défaut, une mac fixe c'est bien aussi. hmm

Hors ligne

#22 Le 12/08/2017, à 12:16

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Essaie de vider le cache :

sudo apt-get clean
sudo apt-get autoclean

et relance la màj :

sudo apt-get update && sudo apt-get dist-upgrade

Hors ligne

#23 Le 12/08/2017, à 12:28

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Pareil.

sudo apt-get update && sudo apt-get dist-upgrade
Atteint:1 http://repo.steampowered.com/steam precise InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                     
Atteint:3 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                                   
Atteint:4 http://ppa.launchpad.net/nerdherd/cloud/ubuntu xenial InRelease                                                                                                        
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                                                                                                                   
Atteint:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                          
Atteint:7 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease                                                 
Atteint:8 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                             
Atteint:9 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                         
Atteint:10 http://ppa.launchpad.net/pipelight/stable/ubuntu xenial InRelease                     
Réception de:11 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]             
Atteint:12 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease                     
Réception de:14 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [60,0 kB]
Réception de:15 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [57,0 kB]
Réception de:16 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [48,8 kB]
Réception de:17 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [64,2 kB]
332 ko réceptionnés en 1s (235 ko/s)                                 
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-netlib : Dépend: python-backports.ssl-match-hostname mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.



sudo apt-get update && sudo apt-get dist-upgrade -f
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Atteint:2 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                                                                                                                   
Atteint:3 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                                   
Atteint:4 http://repo.steampowered.com/steam precise InRelease                                                                                                                   
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                                                           
Atteint:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                   
Atteint:7 http://ppa.launchpad.net/nerdherd/cloud/ubuntu xenial InRelease                                                                              
Atteint:8 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                                               
Atteint:9 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease                                   
Atteint:10 http://ppa.launchpad.net/pipelight/stable/ubuntu xenial InRelease                                         
Atteint:11 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease                     
Atteint:12 http://security.ubuntu.com/ubuntu xenial-security InRelease                           
Lecture des listes de paquets... Fait                          
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gcc-4.9-base:i386 gnuplot-data gnuplot-qt libamd2.3.1 libboost-filesystem1.55.0 libboost-python1.55.0 libboost-system1.55.0 libboost-thread1.55.0 libc-ares2 libcamd2.3.1
  libccolamd2.8.0 libcholmod2.1.2 libenca0 libept1.4.12 libewf1 libexiv2-12 libexiv2-13 libgegl-0.2-0 libgif4 libgtop2-10 libilmbase6 liblcms1 libmysqlclient18 libobjc-4.9-dev
  libopenexr6 libosmgpsmap2 libqscintilla2-11 libreadline-dev libreadline6-dev libts-0.0-0 libumfpack5.6.2 liburcu2 libusb-dev libv8-3.14.5 libx264-142 libyara2 python-async
  python-backports-ssl-match-hostname python-bluez python-distlib python-lightblue python-oauth python-osmgpsmap ruby-yajl tsconf volatility-profiles
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  python-backports.ssl-match-hostname
Les paquets suivants ont été conservés :
  dh-python
0 mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis à jour.
653 partiellement installés ou enlevés.
Il est nécessaire de prendre 6 258 o dans les archives.
Après cette opération, 61,4 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 python-backports.ssl-match-hostname all 3.4.0.2-1 [6 258 B]
6 258 o réceptionnés en 0s (46,9 ko/s)                         
(Lecture de la base de données... 440981 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-backports.ssl-match-hostname_3.4.0.2-1_all.deb ...
Dépaquetage de python-backports.ssl-match-hostname (3.4.0.2-1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-backports.ssl-match-hostname_3.4.0.2-1_all.deb (--unpack) :
 tentative de remplacement de « /usr/lib/python2.7/dist-packages/backports.ssl_match_hostname-3.4.0.2.egg-info/dependency_links.txt », qui appartient aussi au paquet python-backports-ssl-match-hostname 3.4.0.2-0kali2
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-backports.ssl-match-hostname_3.4.0.2-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#24 Le 12/08/2017, à 12:30

abelthorne

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Essaie de faire un sudo apt-get install -f et donne le retour.

Les paquets Python concernés sont en rapport avec un logiciel que tu as installé et dont tu as besoin ? Apparemment, ils ne le sont pas par défaut.

Hors ligne

#25 Le 12/08/2017, à 13:12

Goshi

Re : [RESOLU]Mise à niveau depuis Ubuntu 14.10 64bits

Je n'ai aucune idée de ce que c'est.

sudo apt-get install -f 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gcc-4.9-base:i386 gnuplot-data gnuplot-qt libamd2.3.1 libboost-filesystem1.55.0 libboost-python1.55.0 libboost-system1.55.0 libboost-thread1.55.0 libc-ares2 libcamd2.3.1
  libccolamd2.8.0 libcholmod2.1.2 libenca0 libept1.4.12 libewf1 libexiv2-12 libexiv2-13 libgegl-0.2-0 libgif4 libgtop2-10 libilmbase6 liblcms1 libmysqlclient18 libobjc-4.9-dev
  libopenexr6 libosmgpsmap2 libqscintilla2-11 libreadline-dev libreadline6-dev libts-0.0-0 libumfpack5.6.2 liburcu2 libusb-dev libv8-3.14.5 libx264-142 libyara2 python-async
  python-backports-ssl-match-hostname python-bluez python-distlib python-lightblue python-oauth python-osmgpsmap ruby-yajl tsconf volatility-profiles
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  python-backports.ssl-match-hostname
Les NOUVEAUX paquets suivants seront installés :
  python-backports.ssl-match-hostname
0 mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis à jour.
653 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/6 258 o dans les archives.
Après cette opération, 61,4 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 440981 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-backports.ssl-match-hostname_3.4.0.2-1_all.deb ...
Dépaquetage de python-backports.ssl-match-hostname (3.4.0.2-1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-backports.ssl-match-hostname_3.4.0.2-1_all.deb (--unpack) :
 tentative de remplacement de « /usr/lib/python2.7/dist-packages/backports.ssl_match_hostname-3.4.0.2.egg-info/dependency_links.txt », qui appartient aussi au paquet python-backports-ssl-match-hostname 3.4.0.2-0kali2
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-backports.ssl-match-hostname_3.4.0.2-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne