Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/08/2017, à 09:14

Eric Bl

Erreur dans la mise à jour automatique des paquets [Résolu]

Bonjour,

Depuis  2 ou 3 mises à jour, mon Kubuntu 16.04.3 échoue dans sa mise à jour système automatique, qui passe par le programme Découvrir (Logithèque).
Message : An error occurred while applying changes.
On aimerait connaître le détail de cette erreur, en appuyant sur le bouton détail. Mais ce bouton n'agit pas !

J'ai essayé :

sudo apt-get update
sudo apt-get dist-upgrade

qui se sont bien déroulés, si l'on considère que les messages suivants ne sont que des avertissements :

W: The repository 'http://ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://download.ebz.epson.net/dsc/op/stable/debian/dists/lsb3.2/Release.gpg: Signature by key E5220FB7014D0FBDA50DFC2BE5E86C008AA65D56 uses weak digest algorithm (SHA1)
E: Impossible de récupérer http://ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Et j'ai effectué le

sudo apt-get remove

qui m'était conseillé.

Je ne sais pas où trouver le détail de l'erreur de mise à jour.

Dernière modification par Eric Bl (Le 12/08/2017, à 10:10)

Hors ligne

#2 Le 12/08/2017, à 09:22

xubu1957

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Bonjour,

Ce PPA :

ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu xenial Release

n'existe pas en 16.04 > ubuntu/pinta-stable/+packages

dernière version en 15.10 14.10 (utopic).

Dernière modification par xubu1957 (Le 12/08/2017, à 09:23)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#3 Le 12/08/2017, à 09:50

??

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Bonjour

W:     signifie Warning      => Attention.....    C'est souvent un changement pas nécessairement bien traité.
N:     signifie Notification =>  Notification.... C'est de l'information liée à un changement de fonctionnement
E:     signifie Error            => Erreur.....L'outil n'a pas su prendre de décision, c'est le message d'alerte qui plante la suite.


Vous devez patienter au minimum 120 heures avant d'effectuer une nouvelle demande. Veuillez patienter un moment et essayer à nouveau.

Hors ligne

#4 Le 12/08/2017, à 09:54

Eric Bl

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Merci pour cette réponse qui soulève d'autres questions ...

  • Que faire dans ce genre de situations ?
    J'ai Pinta depuis longtemps en 16.04. Je n'ai jamais eu de problème avec ou ils étaient mineurs et je les ai oubliés.
    Quand un logiciel n'existe pas dans une nouvelle version, que faire ? Ne pas faire le changement de version ? Faire un démarrage système sur l'ancienne version quand on veut utiliser le logiciel ? Ou bien existe-t-il une procédure pour faire tourner juste un programme dans une ancienne version ?

  • Est-ce que l'erreur W peut justifier le message d'avertissement ?
    Et dans ce cas pourquoi n'ai-je pas eu ce problème depuis que je suis en 16.04 ?

Hors ligne

#5 Le 12/08/2017, à 10:05

??

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Ton plantage est la
E: Impossible de récupérer http://ppa.launchpad.net/pinta-maintain … 4/Packages  404  Not Found

=> https://doc.ubuntu-fr.org/pinta   qui est probablement le successeur

Tu noteras  que ton application  n'existe pas en 16.04 (xenial)  https://launchpad.net/~pinta-maintainer … nta-stable

Tu n'as pas d'autre choix que de l'enlever  et en chercher  une autre équivalente.

Cela se passe en modifiant le répertoire  /etc/apt/sources.list.d en supprimant le fichier qui fait référence à cette application ou dans le  fichier  /etc/apt/sources.list en supprimant la ligne qui fait référence à cette application

Dernière modification par ?? (Le 12/08/2017, à 10:11)


Vous devez patienter au minimum 120 heures avant d'effectuer une nouvelle demande. Veuillez patienter un moment et essayer à nouveau.

Hors ligne

#6 Le 12/08/2017, à 10:09

Eric Bl

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Bon. Merci.

Hors ligne

#7 Le 12/08/2017, à 10:30

abelthorne

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

Pour répondre plus précisément à tes questions :
Dans ton premier message (retour d'APT), il y a plusieurs informations :
- Avertissement : APT te dit qu'il ne trouve pas le fichier Release (qui contient les infos du dépôt) d'un PPA ; c'est le signe qu'il est soit inaccessible, soit inexistant. Les lignes qui commencent par N sont des infos supplémentaires.
- Avertissement : APT te dit que la clé d'authentification d'un dépôt Epson utilise un vieil algorithme considéré comme moins fiable. Tu ne peux rien y faire, c'est au gestionnaire du dépôt de mettre à jour la clé.
- Erreur : APT n'arrive pas à trouver le fichier Packages (liste des paquets) du PPA qui provoquait l'avertissement.

Un avertissement n'empêche pas APT de fonctionner (par exemple, dans le cas de la clé peu fiable, ça n'empêche pas d'utiliser le dépôt). Une erreur le stoppe et doit être corrigée.

Dans ce genre de cas de dépôt inexistant, il y a plusieurs possibilités :
- Dans le cas d'un PPA un peu ancien, c'est possible que les paquets qu'il embarquait soient maintenant dans les dépôts Ubuntu : à vérifier, auquel cas tu peux supprimer purement et simplement le PPA.
- Si les paquets n'existent pas dans les dépôts Ubuntu, chercher un autre PPA qui est à jour.
- S'il n'y a rien aucun autre PPA de disponible, il est possible de continuer à utiliser l'ancienne version en faisant attention : si le PPA est dédié à un logiciel, qui n'a pas de dépendances trop spécifiques sur une version d'Ubuntu en particulier et qui n'embarque pas des tas de paquets accessoires à côté, la version du dépôt n'a pas vraiment d'importance. Bien sûr, s'il est abandonné depuis deux ans, même si c'est possible de l'utiliser, ça implique aussi probablement que le logiciel correspondant n'est pas du tout à jour. En règle générale, un PPA qui est dédié à un logiciel est assez fiable à utiliser tandis qu'un autre qui contient des tas de logiciels divers multiplie les risques d'avoir des problèmes. Il vaut mieux utiliser dix PPA pour dix logiciels uniques qu'un seul PPA qui les regroupe tous.

Dans le cas de Pinta, si j'étais à ta place, je passerais à la version daily à la place de la version stable, le PPA existant pour Xenial. Si cette version est trop instable, alors repasse au PPA stable en version trusty ou utopic, son utilisation ne devrait pas poser de problème.

En tout cas, il faut bien être conscient que les dépôts tiers (en général) sont maintenus sans aucune garantie et qu'ils peuvent être inutilisables du jour au lendemain. C'est très bien d'en utiliser du moment qu'on sait qu'on devra peut-être s'en passer un jour.

Dans le pire des cas, si un logiciel n'est pas packagé dans un dépôt, on peut toujours l'installer et le maintenir manuellement. C'est beaucoup moins pratique, bien sûr, mais ce n'est pas parce qu'il n'est pas disponible dans un dépôt qu'il n'est pas utilisable.

Dernière modification par abelthorne (Le 12/08/2017, à 10:32)

Hors ligne

#8 Le 13/08/2017, à 13:37

Eric Bl

Re : Erreur dans la mise à jour automatique des paquets [Résolu]

merci pour cette réponse détaillée.

Hors ligne