Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 10/10/2017, à 10:47

aiphes

16.04: W10 ne lance pas Grub

Bonjour,

J'ai installer Ubuntu 16.04 sur un pc équipé de W10 EFI.
J'ai fait et refait l'installation plus de 3 fois avec toujours le même résultat:
au démarrage du pc, W10 se lance directement sans présenter l'écran de choix de grub.
Il s'agit d'un HP : https://www.materiel.net/ordinateur-por … 81952.html
Initialement en W8 passé en W10 via l'offre de MS.

Comment faire pour que Grub soit bien lancé au démarrage ?
J'ai déja tenté pas mal de choses à ce niveau sans succés.

Merci


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 16.04 (Gnome)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 14.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#2 Le 10/10/2017, à 11:01

Caribou22

Re : 16.04: W10 ne lance pas Grub

Bonjour smile

Si ça peut aider, j'ai eu un soucis similaire sur un probook HP sous Windows 10 upgradé depuis Windows 8 également. Voir ce post : http://debian-facile.org/viewtopic.php? … 00#p235700

Hors ligne

#3 Le 10/10/2017, à 12:13

aiphes

Re : 16.04: W10 ne lance pas Grub

oui ca y ressemble bien, mais ne serait ce pas possible de tout effacer, installer Ubuntu puis W10 pour éliminer ces problèmes d'EFI ?
je me sens pas trop de me lancer la dedans pour un pc à usage ponctuel...;)


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 16.04 (Gnome)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 14.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#4 Le 10/10/2017, à 12:25

Caribou22

Re : 16.04: W10 ne lance pas Grub

Dans ton boot menu, tu n'as pas une option "Boot from EFI file" ?
Si oui, essaye d'y trouver un fichier EFI/ubuntu/grubx64.efi pour voir si ça boot wink
cf ce post : http://debian-facile.org/viewtopic.php? … 95#p235695

Hors ligne

#5 Le 10/10/2017, à 12:37

aiphes

Re : 16.04: W10 ne lance pas Grub

J'ai installé la version amd64 mais je ne vois pas cette option sans appuyer sur F9. je vais retenter.

Dernière modification par aiphes (Le 10/10/2017, à 12:39)


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 16.04 (Gnome)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 14.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#6 Le 10/10/2017, à 12:40

lucmars

Re : 16.04: W10 ne lance pas Grub

Hp verrouille le bios sur windows en efi. Pour booter buntu faut passer par le boot-menu du bios (echappe puis F9).

Si ton bios permet de faire du tout Legacy cela devrait contourner le verrouillage.

Hors ligne

#7 Le 10/10/2017, à 12:49

aiphes

Re : 16.04: W10 ne lance pas Grub

En passant par F9 puis en naviguant via:
Boot EFI File > 3 choix : EFI / boot / System Volum Info
EFI> Microsoft / Boot / HP / Ubuntu >> choix Ubuntu donne comme options : fwupx64.efi / grubx64.efi / shimx64.efi / mmx64.efi

grubx64 lance W10
shimx64.efi lance grub et donne la liste de choix classique big_smile big_smile

Dernière modification par aiphes (Le 10/10/2017, à 12:50)


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 16.04 (Gnome)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 14.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#8 Le 10/10/2017, à 14:45

Caribou22

Re : 16.04: W10 ne lance pas Grub

aiphes a écrit :

En passant par F9 puis en naviguant via:
Boot EFI File > 3 choix : EFI / boot / System Volum Info
EFI> Microsoft / Boot / HP / Ubuntu >> choix Ubuntu donne comme options : fwupx64.efi / grubx64.efi / shimx64.efi / mmx64.efi

grubx64 lance W10
shimx64.efi lance grub et donne la liste de choix classique big_smile big_smile

Bonne nouvelle à priori ! big_smile
Et grub a bien Ubuntu ET Windows fonctionnels ?

Hors ligne