Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 19/10/2017, à 18:40

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Bonsoir,
Réponse à la commande proposée sur le #23

ls -l /var/lib/dpkg/lock
-rw-r----- 1 root root 0 oct.  16 11:44 /var/lib/dpkg/lock

Hors ligne

#27 Le 19/10/2017, à 19:06

krodelabestiole

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

et celle de moko138 ?

ps --pid $(sudo fuser /var/lib/dpkg/lock)

Hors ligne

#28 Le 19/10/2017, à 19:42

moko138

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Je ne fais que citer, avec le lien, la commande de tiramiseb.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#29 Le 20/10/2017, à 17:54

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

krodelabestiole a écrit :

et celle de moko138 ?

ps --pid $(sudo fuser /var/lib/dpkg/lock)

Réponse:

erreur: la liste des ID de processus doit suivre --pid

Usage:
 ps [options]

 Essayez 'ps --aide <simple|liste|sortie|threads|divers|tous>'
  ou 'ps --aide <s|l|o|h|d|t>'
 pour plus d'aide.

Pour plus de détails, consultez ps(1).

Franchement là je suis carrément découragée et envisage de tout réinstaller...

Hors ligne

#30 Le 20/10/2017, à 18:05

nam1962

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Avais tu passé le post #2 ?
Si non, avant la réinstall, passe le.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#31 Le 20/10/2017, à 19:11

krodelabestiole

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

eoncues a écrit :
erreur: la liste des ID de processus doit suivre --pid

Usage:
 ps [options]

 Essayez 'ps --aide <simple|liste|sortie|threads|divers|tous>'
  ou 'ps --aide <s|l|o|h|d|t>'
 pour plus d'aide.

Pour plus de détails, consultez ps(1).

si c'est tout ce que tu as ça veut effectivement dire que aucun processus n'utilise APT et donc que tu peux supprimer le lock :

sudo rm /var/lib/dpkg/lock

puis

sudo apt update && sudo apt install

Hors ligne

#32 Le 20/10/2017, à 20:17

moko138

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

cd /var/lib/dpkg/ && sudo rm -v lock; cd

limite les risques en cas de faute de frappe. Cf. cqfd93 plus haut.


Mieux : copier-coller toute commande !


Ajout : sudo

Dernière modification par moko138 (Le 21/10/2017, à 02:09)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#33 Le 21/10/2017, à 14:02

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

nam1962 a écrit :

Avais tu passé le post #2 ?
Si non, avant la réinstall, passe le.

J'ai opéré toutes les commandes proposées depuis l'ouverture de cette discussion.

Hors ligne

#34 Le 21/10/2017, à 14:06

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Réponse au #31

~$ sudo rm /var/lib/dpkg/lock

~$ sudo apt update && sudo apt install

Réception de:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Atteint:2 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                 
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:4 http://ppa.launchpad.net/budgie-remix/ppa/ubuntu xenial InRelease
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Réception de:6 http://fr.archive.ubuntu.com/ubuntu xenial/main Translation-fr [597 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu xenial/restricted Translation-fr [2 824 B]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu xenial/universe Translation-fr [2 524 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse Translation-fr [105 kB]
3 332 ko réceptionnés en 4s (778 ko/s)                                
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
11 packages can be upgraded. Run 'apt list --upgradable' to see them.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  arc-firefox-theme budgie-plank budgie-remix-lightdm-theme fonts-dejavu
  fonts-liberation fonts-sil-gentium fonts-sil-gentium-basic libbonobo2-0
  libbonobo2-common libgnome-2-0 libgnome2-common libllvm3.8 libmircommon5
  liborbit-2-0 libreoffice libreoffice-report-builder-bin libsnapd-glib1
  linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
  linux-image-4.4.0-31-generic linux-image-extra-4.4.0-31-generic
  snapd-login-service ubuntu-core-launcher
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 11 non mis à jour.

Hors ligne

#35 Le 21/10/2017, à 14:08

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

moko138 a écrit :
cd /var/lib/dpkg/ && sudo rm -v lock; cd

limite les risques en cas de faute de frappe. Cf. cqfd93 plus haut.


Mieux : copier-coller toute commande !


Ajout : sudo

Pas très clair pour moi ton message ...

~$ sudo cd /var/lib/dpkg/ && sudo rm -v lock; cd
sudo: cd : commande introuvable

Par contre comme ça ...

~$ cd /var/lib/dpkg/ && sudo rm -v lock; cd

'lock' supprimé 

J'ai également fait une mise à jour puis opéré les commandes

 sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove --purge

Serais-je tirée d'affaire?

Dernière modification par eoncues (Le 21/10/2017, à 14:35)

Hors ligne

#36 Le 21/10/2017, à 15:57

moko138

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Montre les retours complets(*) et séparés de

sudo apt-get clean; echo; sudo apt-get autoremove --purge

  - -

eoncues a écrit :
11 non mis à jour.

Donc fais

sudo apt-get dist-upgrade

  - -


(*)  Un retour complet doit contenir toutes les lignes,
depuis celle, entière, de la commande
jusqu'à la ligne attendant la commande suivante
, exemple :

moi@mon-pc~$: ma-commande
son retour
moi@mon-pc~$:

Faute de quoi, il manque souvent à ceux qui tentent de t'aider des éléments essentiels.

(Plus de détails dans ce message-ci Retour utilisable de commande.)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#37 Le 21/10/2017, à 16:03

moko138

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Note :
"autoclean" est complètement inutile quand suivi de "clean",
parce que "autoclean" est inclus dans "clean".
     Source :

man apt-get

%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#38 Le 21/10/2017, à 16:45

nam1962

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Je n'ai par contre jamais compris pourquoi autoclean est verbeux et clean pas.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#39 Le 21/10/2017, à 16:57

krodelabestiole

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

eoncues a écrit :

Serais-je tirée d'affaire?

j'ai l'impression.
essaie un

sudo apt upgrade && sudo apt autoremove

pour mettre ton système à jour.

Hors ligne

#40 Le 22/10/2017, à 18:10

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Réponse aux commandes #36
...bien que je ne vois pas l'intérêt de communiquer TOUT comme suit (depuis le temps que je viens sur le forum cela n'a jamais posé de problème)

eoncues-1005PXD:~$ sudo apt-get clean; echo; sudo apt-get autoremove --purge
[sudo] Mot de passe de eoncues : 

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
eoncues-1005PXD:~$ 

... puis:

eoncues-1005PXD:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construct
ion de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  libsnapd-glib1 snapd-login-service
Les paquets suivants seront mis à jour :
  bcmwl-kernel-source gnome-software gnome-software-common
3 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4 360 ko dans les archives.
Après cette opération, 727 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 bcmwl-kernel-source i386 6.30.223.271+bdcom-0ubuntu1~1.1 [1 519 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 gnome-software i386 3.20.5-0ubuntu0.16.04.6 [256 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 gnome-software-common all 3.20.5-0ubuntu0.16.04.6 [2 520 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 libsnapd-glib1 i386 1.13-0ubuntu0.16.04.1 [52,9 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 snapd-login-service i386 1.13-0ubuntu0.16.04.1 [12,1 kB]
4 360 ko réceptionnés en 2s (1 608 ko/s)  
(Lecture de la base de données... 235300 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~1.1_i386.deb ...
Removing all DKMS Modules
Done.
Dépaquetage de bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.1) sur (6.30.223.248+bdcom-0ubuntu8) ...
Préparation du dépaquetage de .../gnome-software_3.20.5-0ubuntu0.16.04.6_i386.deb ...
Dépaquetage de gnome-software (3.20.5-0ubuntu0.16.04.6) sur (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) ...
Préparation du dépaquetage de .../gnome-software-common_3.20.5-0ubuntu0.16.04.6_all.deb ...
Dépaquetage de gnome-software-common (3.20.5-0ubuntu0.16.04.6) sur (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) ...
Sélection du paquet libsnapd-glib1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../libsnapd-glib1_1.13-0ubuntu0.16.04.1_i386.deb ...
Dépaquetage de libsnapd-glib1:i386 (1.13-0ubuntu0.16.04.1) ...
Sélection du paquet snapd-login-service précédemment désélectionné.
Préparation du dépaquetage de .../snapd-login-service_1.13-0ubuntu0.16.04.1_i386.deb ...
Dépaquetage de snapd-login-service (1.13-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:i386 (2.48.2-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu5.1~xenialubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu9) ...
Traitement des actions différées (« triggers ») pour dbus (1.10.6-1ubuntu3.3) ...
Paramétrage de bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.1) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
Building only for 4.4.0-97-generic
Building for architecture i686
Building initial module for 4.4.0-97-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-97-generic/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Paramétrage de gnome-software-common (3.20.5-0ubuntu0.16.04.6) ...
Paramétrage de libsnapd-glib1:i386 (1.13-0ubuntu0.16.04.1) ...
Paramétrage de gnome-software (3.20.5-0ubuntu0.16.04.6) ...
Installation de la nouvelle version du fichier de configuration /etc/xdg/autostart/gnome-software-service.desktop ...
Paramétrage de snapd-login-service (1.13-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-97-generic
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu9) ...
Traitement des actions différées (« triggers ») pour dbus (1.10.6-1ubuntu3.3) ...
eoncues-1005PXD:~$ 

En tout cas voilà.

Hors ligne

#41 Le 22/10/2017, à 18:13

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

krodelabestiole a écrit :
eoncues a écrit :

Serais-je tirée d'affaire?

j'ai l'impression.
essaie un

sudo apt upgrade && sudo apt autoremove

pour mettre ton système à jour.

eoncues-1005PXD:~$ sudo apt upgrade && sudo apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
eoncues-1005PXD:~$ 

Tout a l'air ok après les commandes de ce post et du précédent..., non?

Hors ligne

#42 Le 22/10/2017, à 18:21

krodelabestiole

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

oui, clairement !

Hors ligne

#43 Le 22/10/2017, à 22:16

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

Merci beaucoup, beaucoup à tous big_smile

Hors ligne

#44 Le 16/11/2017, à 15:07

eoncues

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

sad sad sad sad sad sad sad sad  Mon problème est revenu.
A cela s'ajoute l'impossibilité de mettre à jour un pluggin flash (quelque chose), ainsi que ma carte son externe non reconnue...

Je vais tout réinstaller, ce sera plus simple, car ça fait plus d'un mois de galère sans pouvoir bosser correctement.

Dernière modification par eoncues (Le 16/11/2017, à 15:32)

Hors ligne

#45 Le 20/08/2018, à 09:43

Ayral

Re : [RESOLU]Budgie -"Erreur: nombre de paquets..."/"E: impossible de ..."

As-tu eu le temps de faire ta réinstallation, et où en es-tu ? Merci


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 16.04 sur un Dell Latitude 820

Hors ligne