Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/10/2017, à 15:55

degolarson

RESOLU Dépendances non satisfaites

bonjour
aujourd'hui ma mise à jour ne fonctionne pas :
j'ai commencé par tenter de supprimer les anciens noyaux et nettoyer tout ce qui peut l'être
mais d'après ce que je comprends le noyau 133 n'est pas complètement installé et des dépendancs manquent pour libreoffice calc, core, draw et impress

oel@joel-K70IJ:~$ sudo kclean -k
[sudo] password for joel: 
 
Noyau actuellement en cours d'utilisation : 3.13.0-132
Par defaut, seul ce noyau est conserve.
 
ATTENTION : Au moins un noyau plus recent ( 3.13.0-133 ) a ete detecte.
Ce phenomene peut avoir plusieurs causes mais, par securite,
ce script va s'arreter.
 
Si vous comprenez exactement ce qui se passe,
et si vous souhaitez reelement supprimer tous les noyaux
y compris les plus recents, utilisez l'option -f seule.
joel@joel-K70IJ:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
ii  linux-generic                              3.13.0.133.142                              i386         Complete Generic Linux kernel and headers
ii  linux-headers-3.13.0-128                   3.13.0-128.177                              all          Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-128-generic           3.13.0-128.177                              i386         Linux kernel headers for version 3.13.0 on 32 bit x86 SMP
ii  linux-headers-3.13.0-129                   3.13.0-129.178                              all          Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-129-generic           3.13.0-129.178                              i386         Linux kernel headers for version 3.13.0 on 32 bit x86 SMP
ii  linux-headers-3.13.0-132                   3.13.0-132.181                              all          Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-132-generic           3.13.0-132.181                              i386         Linux kernel headers for version 3.13.0 on 32 bit x86 SMP
ii  linux-headers-3.13.0-133                   3.13.0-133.182                              all          Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-133-generic           3.13.0-133.182                              i386         Linux kernel headers for version 3.13.0 on 32 bit x86 SMP
ii  linux-headers-generic                      3.13.0.133.142                              i386         Generic Linux kernel headers
ii  linux-image-3.13.0-128-generic             3.13.0-128.177                              i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-129-generic             3.13.0-129.178                              i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-132-generic             3.13.0-132.181                              i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-133-generic             3.13.0-133.182                              i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-extra-3.13.0-100-generic       3.13.0-100.147                              i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-128-generic       3.13.0-128.177                              i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-129-generic       3.13.0-129.178                              i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-132-generic       3.13.0-132.181                              i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-133-generic       3.13.0-133.182                              i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-generic                        3.13.0.133.142                              i386         Generic Linux kernel image
ii  syslinux-themes-debian                     12-3ubuntu0.14.04.1                         all          collection of boot loaders (theme metapackage)
ii  syslinux-themes-debian-wheezy              12-3ubuntu0.14.04.1                         all          collection of boot loaders (debian-wheezy theme)
joel@joel-K70IJ:~$ sudo apt-get clean
joel@joel-K70IJ:~$  sudo apt-get autoclean
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
joel@joel-K70IJ:~$  sudo apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libreoffice-calc : Dépend: libreoffice-base-core (= 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) mais 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 est installé
                    Dépend: libreoffice-core (= 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) mais 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 est installé
 libreoffice-core : Casse: libreoffice-calc (< 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) mais 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0 est installé
                    Casse: libreoffice-draw (< 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) mais 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0 est installé
                    Casse: libreoffice-impress (< 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) mais 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0 est installé
 libreoffice-draw : Dépend: libreoffice-core (= 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) mais 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 est installé
 libreoffice-impress : Dépend: libreoffice-core (= 1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) mais 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
joel@joel-K70IJ:~$ 

merci

Dernière modification par degolarson (Le 12/10/2017, à 19:21)


26-08-15 xubuntu 14.04 LTS 32b   Laptop Asus PRO79IJ-TY025E      SSD 250Go   RAM 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009    Freebox V5
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285   
Doucement, nous sommes pressés ! (proverbe chinois ou berrichon ?)
Les jeunes sont ce qu'en font les vieux cons (Pierre Desproges )

Hors ligne

#2 Le 12/10/2017, à 16:04

degolarson

Re : RESOLU Dépendances non satisfaites

La suite :

joel@joel-K70IJ:~$ sudo apt-get -f install
[sudo] password for joel: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libreoffice-pdfimport
Veuillez utiliser « apt-get autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés : 
  libreoffice-calc libreoffice-draw libreoffice-impress
Les paquets suivants seront mis à jour :
  libreoffice-calc libreoffice-draw libreoffice-impress
3 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 10,7 Mo dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Réception de : 1 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main libreoffice-calc i386 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 [6 586 kB]
Réception de : 2 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main libreoffice-draw i386 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 [3 279 kB]
Réception de : 3 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main libreoffice-impress i386 1:5.4.2~rc2-0ubuntu0.14.04.1~lo1 [876 kB]
10,7 Mo réceptionnés en 9s (1 140 ko/s)                                        
(Lecture de la base de données... 265852 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libreoffice-calc_1%3a5.4.2~rc2-0ubuntu0.14.04.1~lo1_i386.deb ...
Dépaquetage de libreoffice-calc (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) sur (1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) ...
Préparation du dépaquetage de .../libreoffice-draw_1%3a5.4.2~rc2-0ubuntu0.14.04.1~lo1_i386.deb ...
Dépaquetage de libreoffice-draw (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) sur (1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) ...
Préparation du dépaquetage de .../libreoffice-impress_1%3a5.4.2~rc2-0ubuntu0.14.04.1~lo1_i386.deb ...
Dépaquetage de libreoffice-impress (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) sur (1:5.4.1~rc2-0ubuntu0.14.04.1~lo0) ...
Traitement des actions différées (« triggers ») pour man-db (2.6.7.1-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Paramétrage de libreoffice-calc (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
Paramétrage de libreoffice-draw (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
Paramétrage de libreoffice-impress (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
Paramétrage de libreoffice (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
Paramétrage de libreoffice-nlpsolver (0.9+LibO5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
Paramétrage de libreoffice-ogltrans (1:5.4.2~rc2-0ubuntu0.14.04.1~lo1) ...
joel@joel-K70IJ:~$ sudo kclean -k
 
Noyau actuellement en cours d'utilisation : 3.13.0-132
Par defaut, seul ce noyau est conserve.
 
ATTENTION : Au moins un noyau plus recent ( 3.13.0-133 ) a ete detecte.
Ce phenomene peut avoir plusieurs causes mais, par securite,
ce script va s'arreter.
 
Si vous comprenez exactement ce qui se passe,
et si vous souhaitez reelement supprimer tous les noyaux
y compris les plus recents, utilisez l'option -f seule.
joel@joel-K70IJ:~$ 

26-08-15 xubuntu 14.04 LTS 32b   Laptop Asus PRO79IJ-TY025E      SSD 250Go   RAM 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009    Freebox V5
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285   
Doucement, nous sommes pressés ! (proverbe chinois ou berrichon ?)
Les jeunes sont ce qu'en font les vieux cons (Pierre Desproges )

Hors ligne

#3 Le 12/10/2017, à 16:05

cqfd93

Re : RESOLU Dépendances non satisfaites

Bonjour,

Première chose à tenter : la commande suggérée !

sudo apt-get -f install

Hors ligne

#4 Le 12/10/2017, à 18:00

degolarson

Re : RESOLU Dépendances non satisfaites

@ cqfd
nos posts se sont croisés
à part ça le site forum est lent et plante par moments je n'avais jamais vu ça

Dernière modification par degolarson (Le 12/10/2017, à 18:14)


26-08-15 xubuntu 14.04 LTS 32b   Laptop Asus PRO79IJ-TY025E      SSD 250Go   RAM 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009    Freebox V5
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285   
Doucement, nous sommes pressés ! (proverbe chinois ou berrichon ?)
Les jeunes sont ce qu'en font les vieux cons (Pierre Desproges )

Hors ligne

#5 Le 12/10/2017, à 18:22

cqfd93

Re : RESOLU Dépendances non satisfaites

degolarson a écrit :

@ cqfd

cqfd93 smile

nos posts se sont croisés

Je n'avais pas vu. Redémarre l'ordinateur avant de lancer kclean et vérifie que tu es bien sur le dernier noyau installé :

uname -a
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"

à part ça le site forum est lent et plante par moments je n'avais jamais vu ça

Pour ça, ouvre un sujet dans la section adéquate si le problème persiste (mais chez moi, pas de problème de lenteur).

Hors ligne

#6 Le 12/10/2017, à 19:19

degolarson

Re : RESOLU Dépendances non satisfaites

J'ai refait la mise à jour et c'est ok
puis

kclean -k 
apt-get autoremove

c'est ok  je conserve toujours le noyau précédent et j'ai viré un dernier fichier inutile comme indiqué
je mets Résolu

merci cqfd93 :>))

PS : le problème de lenteur du site semblait avoir disparu mais finalement revient de façon aléatoire  depuis la mise à jour avec redémarrage
j'ouvre un post sur problèmes généraux

Dernière modification par degolarson (Le 12/10/2017, à 19:32)


26-08-15 xubuntu 14.04 LTS 32b   Laptop Asus PRO79IJ-TY025E      SSD 250Go   RAM 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009    Freebox V5
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285   
Doucement, nous sommes pressés ! (proverbe chinois ou berrichon ?)
Les jeunes sont ce qu'en font les vieux cons (Pierre Desproges )

Hors ligne

#7 Le 12/10/2017, à 19:30

cqfd93

Re : RESOLU Dépendances non satisfaites

Parfait !

Hors ligne