Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1401 Le 23/04/2018, à 18:40

lynn

Re : Nouveautés dans Bionic

Tu peux modifier le comportement de la touche imp-écran en allant dans les paramètres du clavier et de là, tu peux forcer la touche imp-écran a utiliser le presse-papier plutôt qu'enregistrer la capture d'écran.


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#1402 Le 23/04/2018, à 18:56

Jérome38

Re : Nouveautés dans Bionic

j'ai changé de changer crtl+maj-+impr en maj+imp-Ec  dans les paramètres du clavier mais cela ne fonctionne pas.
Du coup j'ai remis les raccourcis clavier par défaut. C'est pas grave j’appuierai sur crtl avant

Dernière modification par Jérome38 (Le 23/04/2018, à 18:58)


Ubuntu 18.04 (Gnome)

Hors ligne

#1403 Le 23/04/2018, à 19:22

bluc

Re : Nouveautés dans Bionic

Oui avec Ctrl + Imp-ecran  ça fonctionne chez moi le collage dans LO et Gimp

Dernière modification par bluc (Le 23/04/2018, à 19:25)


Clevo :  Ubuntu 18.04   ❖  Deepin 15.11 ❖ Ubuntu 19.04 avec partition data commune 

Hors ligne

#1404 Le 23/04/2018, à 19:39

Jérome38

Re : Nouveautés dans Bionic

Sur mon ordinateur, quand je vais dans "extensions" de gnome shell, je vois une extension non activée appelée Ubuntu dock. Est-ce la même chose que Dash-to-dock ? Si je l'active, qu'est- ce que cela va changer ?

Le gestionnaire d'extensions


Ubuntu 18.04 (Gnome)

Hors ligne

#1405 Le 23/04/2018, à 19:45

frenchy82

Re : Nouveautés dans Bionic

Dans la session d'ubuntu par défaut tu as deux extensions qui sont actives, le dock et l'appindicator. Elles sont toutes les deux actives même si ce n'est pas le cas à l'affichage sur cet écran. Les activer ne changera rien.

Hors ligne

#1406 Le 23/04/2018, à 19:48

Jérome38

Re : Nouveautés dans Bionic

ok effectivement. Je l'ai activé et cela ne change rien


Ubuntu 18.04 (Gnome)

Hors ligne

#1407 Le 24/04/2018, à 00:26

Nepenthes

Re : Nouveautés dans Bionic

Il faudrait avertir les utilisateurs que la 18.04 est une catastrophe sur les laptops Nvidia Optimus récents.
Là où la 17.10 brillait par son support de ces configs dès l'installation, la gestion de l'énergie est ici absente.

Le module bbswitch qui servait à économiser de l'énergie et limiter la chaleur dégagée n'est plus utilisé par nvidia-prime, l'outil fourni (le module n'est plus maintenu, donc les devs d'Ubuntu ont choisi de ne plus l'utiliser).
À sa place, le driver nouveau est chargé et tente de désactiver la carte nvidia dédiée... Ce qui ne fonctionne pas et cause un freeze sur les cartes de série 10xx.
Sur les configs récentes, ce comportement est interdit par la configuration par défaut, ce qui revient à admettre qu'Ubuntu ne gère plus l'énergie sur les laptops Nvidia Optimus.

Je suis dégoûté et je pense downgrader mon installation, impossible d'utiliser mon laptop dans ces conditions.

EDIT: J'ai réussi à désactiver la carte intel en créant un service systemd qui appelle bbswitch. Nouveau doit aussi être backlisté pour que ça fonctionne. Si quelqu'un veut des instructions détaillées, je pourrai faire un tuto.

Dernière modification par Nepenthes (Le 24/04/2018, à 01:33)

Hors ligne

#1408 Le 24/04/2018, à 09:44

jnq

Re : Nouveautés dans Bionic

Bonjour il semble y avoir de gros problèmes avec les driver wifi broadcom sous 18.04. Plus de wifi et l'installation du driver part en échec erreur 1.

Dernière modification par jnq (Le 24/04/2018, à 09:44)


Ubuntu 18.04.2

Hors ligne

#1409 Le 24/04/2018, à 10:06

xubu1957

Re : Nouveautés dans Bionic

@ jnq

Le secure-boot est-il désactivé ?

Voir le § 2 > [Tuto] Pas de Wi-fi ? Eléments importants à vérifier


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#1410 Le 24/04/2018, à 10:07

rogn...

Re : Nouveautés dans Bionic

jnq a écrit :

Bonjour il semble y avoir de gros problèmes avec les driver wifi broadcom sous 18.04. Plus de wifi et l'installation du driver part en échec erreur 1.

sad Sans savoir ce que tu as tenté et les retours de commande, nous ne pourrons rien te dire de plus .


Rogn on GitHub
Manjaro MATE / Ubuntu & Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."

Hors ligne

#1411 Le 24/04/2018, à 10:22

jnq

Re : Nouveautés dans Bionic

@xubu1957 Pas de secure boot sur mon portable et tout fonctionnait parfaitement sous 17.10.   
Lors de la tentative d'installation du driver propriétaire subprocees instal error 1
Plein de bug pour les driver broadcomm sur lauchpad pour la version 18.04 la liste est longue.

Dernière modification par jnq (Le 24/04/2018, à 10:23)


Ubuntu 18.04.2

Hors ligne

#1412 Le 24/04/2018, à 10:54

Jérome38

Re : Nouveautés dans Bionic

Bonjour il semble y avoir de gros problèmes avec les driver wifi broadcom sous 18.04. Plus de wifi et l'installation du driver part en échec erreur 1.

Tu avais testé  ubuntu en live avant la mise à jour pour vérifier si le wifi fonctionnait ?

Dernière modification par Jérome38 (Le 24/04/2018, à 10:56)


Ubuntu 18.04 (Gnome)

Hors ligne

#1413 Le 24/04/2018, à 12:14

jnq

Re : Nouveautés dans Bionic

Bonjour non pas de test mais mise a jour direct. Problème résolu ce midi par les dernières mise a jour du noyau.


Ubuntu 18.04.2

Hors ligne

#1414 Le 24/04/2018, à 21:39

ft

Re : Nouveautés dans Bionic

J'ai un gros souci depuis hier/aujourd'hui (?).
Sur mon portable la conso a grimpé nettement (de l'ordre de 5 W -> 15 W), sans doute parce que ma carte Nvidia n'est pas éteinte. Je constate le truc avec Nouveau ou Nvidia. D'ailleurs, quand je boote sous Nvidia, il y a des messages relatifs à Nouveau, ce qui est nouveau... Bref, ce ne peut (ou alors y'a un truc !) être lié à la màj récente des drivers Nvidia, puisque sans ceux-ci, le problème persiste.
Help ! :-)

Dernière modification par ft (Le 24/04/2018, à 21:39)


Thinkpad T480s, Ubuntu GNOME 19.10

Hors ligne

#1415 Le 24/04/2018, à 23:24

GammaDraconis

Re : Nouveautés dans Bionic

Tu as bien installé TLP ? c'est ça qui permet d'économiser de l'énergie.


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#1416 Le 24/04/2018, à 23:27

ft

Re : Nouveautés dans Bionic

Alors oui j'ai TLP installé depuis des lustres, mais ce n'est pas lié.
En revanche je viens de trouver que ne suis pas seul :
https://bugs.launchpad.net/ubuntu/+sour … ug/1765363


Thinkpad T480s, Ubuntu GNOME 19.10

Hors ligne

#1417 Le 25/04/2018, à 14:00

Nepenthes

Re : Nouveautés dans Bionic

@ft Ton problème est lié au changement dans nvidia-prime, le script de sélection de carte graphique et de gestion de l'énergie, que je décris un peu plus haut :
- bbswitch, le module appelé par nvidia-prime pour activer ou désactiver la carte Nvidia sur Ubuntu 17.10, n'est plus maintenu. Les devs d'Ubuntu ont donc choisi de ne plus l'inclure par défaut ;
- nvidia-prime s'appuie à présent sur le pilote libre nouveau pour désactiver la carte graphique dédiée Nvidia ;
- nouveau freeze les systèmes équipés de cartes nvidia de séries 10xx, lorsqu'on tente un login graphique (https://bugs.freedesktop.org/show_bug.cgi?id=101665) ;
- par défaut, Ubuntu 18.04 désactive la gestion de l'énergie par nouveau, pour éviter le bug (nouveau.runpm=0 ajouté aux options du kernel).

On peut en conclure que la gestion de l'énergie sur les systèmes Nvidia Optimus ne sera pas fonctionnelle sur Ubuntu 18.04 (peut être jusqu'en 18.10 ou au delà si nouveau n'est pas corrigé dans une 18.04.1, .2 ou .3...).
Et ouais, je pense qu'une telle régression est un scandale.


Pour contourner le problème et toujours désactiver la carte nvidia dédiée, on peut blacklister nouveau au niveau du kernel, installer manuellement bbswitch, et créer un service systemd qui appelle bbswitch au démarrage.

Hors ligne

#1418 Le 25/04/2018, à 15:12

GammaDraconis

Re : Nouveautés dans Bionic

Nepenthes a écrit :

pour éviter le bug (nouveau.runpm=0 ajouté aux options du kernel).

Donc si on ajoute l'option "nouveau.runpm=0" aux options du kernel, il n'y a plus de problème d'énergie, ça sera comme avant ?
Si oui, tu peux rappeler la procédure (en cli) pour ajouter cette option au noyau stp (fichier de config à modifier).


Nepenthes a écrit :

Pour contourner le problème et toujours désactiver la carte nvidia dédiée, on peut blacklister nouveau au niveau du kernel, installer manuellement bbswitch, et créer un service systemd qui appelle bbswitch au démarrage.

Tu peux donner la procédure pour faire ceci de façon automatisé dans un terminal ? (c'est pour ajouter en option dans mon script)


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#1419 Le 25/04/2018, à 17:18

Nepenthes

Re : Nouveautés dans Bionic

GammaDraconis a écrit :

Donc si on ajoute l'option "nouveau.runpm=0" aux options du kernel, il n'y a plus de problème d'énergie, ça sera comme avant ?

Non, ça désactive complètement la gestion de l'énergie par nouveau sad
On peut alors se connecter en mode graphique sans causer de freeze, mais la carte nvidia consommera de l'énergie et chauffera.

Par contre, chez moi, même avec cette option, j'ai des gros ralentissements... La seule solution a été de blacklister totalement nouveau.


J'ai pas mal tâtonné pour trouver une config qui fonctionnait... Je vais essayer de retrouver toutes les étapes.

Dernière modification par Nepenthes (Le 25/04/2018, à 17:20)

Hors ligne

#1420 Le 25/04/2018, à 17:27

ft

Re : Nouveautés dans Bionic

C'est bon, j'ai de nouveau une conso basse avec les drivers proprio (gpu M1000M) :
- régler Prime sur Intel
- dans /etc/default/grub, virer l'option "nouveau.runpm=0" puis ne pas oublier de faire update-grub
- dans /etc/default/tlp, ne pas exclure nouveau du PM par :  RUNTIME_PM_DRIVER_BLACKLIST=""
- ne rien changer dans /etc/modprobe.d
- rebooter


Thinkpad T480s, Ubuntu GNOME 19.10

Hors ligne

#1421 Le 25/04/2018, à 18:00

zephirin

Re : Nouveautés dans Bionic

Alors, c'est demain le grand jour ? smile


iMac 27" fin 2009 i5 16gb ssd2T cg 512 High Sierra - 2 MacBook Air 13 2014&2017 i5 8gb ssd120 Catalina  - MacBook Pro mi 2012 SSD 256 16GB DDR3 Catalina- Mac mini i5 2415M 2,26GHz mi 2012 - 16gb ddr3 ssd500 High Sierra
Tour Gaming 2010 Amd Phénom 4core 955BE 3,20GHz 8gb ddr3 dd1T cg GTX1060 6gb W10+Voyager Xfce18.04.1

Hors ligne

#1422 Le 25/04/2018, à 18:02

GammaDraconis

Re : Nouveautés dans Bionic

ft a écrit :

C'est bon, j'ai de nouveau une conso basse avec les drivers proprio (gpu M1000M) :
- régler Prime sur Intel
- dans /etc/default/grub, virer l'option "nouveau.runpm=0" puis ne pas oublier de faire update-grub
- dans /etc/default/tlp, ne pas exclure nouveau du PM par :  RUNTIME_PM_DRIVER_BLACKLIST=""
- ne rien changer dans /etc/modprobe.d
- rebooter

Bah en faite il n'y a aucun problème alors puisque ça c'est le comportement par défaut pour mon utilisation cad :
- évidemment le chipset intel sélectionné dans nvidia-prime
- pas d'option spéciale dans la conf de grub
- pas d'option spéciale à mettre dans la confg de TLP
- pas d'option spéciale pour modprobe.d

donc au finale ça fonctionne bien... il faut justement pas modifier la config.


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#1423 Le 25/04/2018, à 18:18

frenchy82

Re : Nouveautés dans Bionic

zephirin a écrit :

Alors, c'est demain le grand jour ? smile

Oui et pourtant encore pas mal de mises à jour aujourd'hui!

Hors ligne

#1424 Le 25/04/2018, à 20:37

ft

Re : Nouveautés dans Bionic

GammaDraconis a écrit :
ft a écrit :

C'est bon, j'ai de nouveau une conso basse avec les drivers proprio (gpu M1000M) :
- régler Prime sur Intel
- dans /etc/default/grub, virer l'option "nouveau.runpm=0" puis ne pas oublier de faire update-grub
- dans /etc/default/tlp, ne pas exclure nouveau du PM par :  RUNTIME_PM_DRIVER_BLACKLIST=""
- ne rien changer dans /etc/modprobe.d
- rebooter

Bah en faite il n'y a aucun problème alors puisque ça c'est le comportement par défaut pour mon utilisation cad :
- évidemment le chipset intel sélectionné dans nvidia-prime
- pas d'option spéciale dans la conf de grub
- pas d'option spéciale à mettre dans la confg de TLP
- pas d'option spéciale pour modprobe.d

donc au finale ça fonctionne bien... il faut justement pas modifier la config.

Je ne comprends pas du tout ta remarque :
- supprimer l'option de grub
- supprimer nouveau de la ligne de config TLP
ces deux actions reviennent sur des réglages par défaut.
Donc OUI il faut modifier la config.


Thinkpad T480s, Ubuntu GNOME 19.10

Hors ligne

#1425 Le 25/04/2018, à 21:01

Nepenthes

Re : Nouveautés dans Bionic

Si nouveau fonctionne chez vous (au moins pour éteindre la carte) vous avez de la chance !
https://nouveau.freedesktop.org/wiki/CodeNames/
https://nouveau.freedesktop.org/wiki/FeatureMatrix/

Comme on peut le voir en croisant les infos fournies par ces deux liens, pour les GTX 1050 et 1050 Ti on en est encore loin...

Hors ligne