Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 30/10/2017, à 10:57

Ayral

Scanners sous 17.10

Il a été constaté une série de remarques sur la difficulté à faire fonctionner les scanners sous 17.04. 17.10
La documentation sur les scanners et leur installation a été annotée à ce sujet.
Sans doute des mises à jour résoudront le problème mais pour le moment ce n'est pas encore le cas.

Dernière modification par Ayral (Le 01/11/2017, à 11:10)


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#2 Le 31/10/2017, à 12:10

arverne73

Re : Scanners sous 17.10

Imprimante DCP-J4110DW en réseau (WIFI)
Après mise à niveau de 17.04 à 17.10, le scanner n'était plus trouvé.

Réinstallation du pilote de scanner (je ne sais pas si cela était utile), ce qui donnait pour moi :

sudo dpkg -i --force-all '/home/jpaul/Téléchargements/brscan4-0.4.4-4.amd64.deb'

Spécification de l'adresse réseau :

brsaneconfig4 -a name=Scanner model=DCP-J4110DW ip=192.168.0.51

Et il marche à nouveau.
Ce ne sont que les informations fournies sur le site de Brother quand on télécharge le pilote.


J-Paul - Utilisateur Ubuntu depuis 2006
Xenial 17.10 AMD FX et carte graphique AMD Radeon HD 6850

Hors ligne

#3 Le 01/11/2017, à 09:00

Isaric

Re : Scanners sous 17.10

Passage de 17-04 à 17-10, pour ma part c'est résolu là :
[Résolu]Installation scanner DCP-L2500D Brother


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.
ma config

Hors ligne

#4 Le 01/11/2017, à 11:10

Ayral

Re : Scanners sous 17.10

moko138 a écrit :

17.04 ? Pas 17.10, plutôt ?

Si, merci moko !


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#5 Le 01/11/2017, à 12:01

Roschan

Re : Scanners sous 17.10

J'ai l'impression qu'avec cette histoire de driverless printing, ils en ont oublié qu'on scannait

Hors ligne

#6 Le 05/11/2017, à 18:00

moreje

Re : Scanners sous 17.10

Bon, et ben moi, ma HP Photosmart 5525 me pose pas mal de problemes:
- HPLIP ne veut plus se lancer
- j'ai des notifications tous les jours : une nouvelle imprimante a été installée (elle est wifi)
- scanner pas visible
c'est pas du tout pratique sad


***************************
PC NUC Intel I5 - 8 Go RAM
Ubuntu 17.10 x64
+++++++++++++++++

Hors ligne

#7 Le 05/11/2017, à 18:41

grigouille

Re : Scanners sous 17.10

moreje a écrit :

HPLIP ne veut plus se lancer

Qu'est-ce que cela signifie ? Je ne connais pas de programme hplip.


Xubuntu 16.04

Hors ligne

#8 Le 05/11/2017, à 23:48

Ayral

Re : Scanners sous 17.10

grigouille a écrit :

Qu'est-ce que cela signifie ? Je ne connais pas de programme hplip.

Hplip est une application créée par HP pour installer ses imprimantes et multifonctions sur Linux.
Elle est disponible ici chez HP (j'ai l'habitude d'aller là plutôt que sur sourceforge)
Il est recommandé de supprimer l'imprimante ou le scanner avant de commencer l'utilisation d'hplip.
Il est impératif de faire ça avec patience (bien lire le texte c'est de l'anglais très simple) et rigueur pour ne rien louper. J'ai toujours réussi mes install en choisissant les propositions par défaut de l'application.
Le fichier va se mettre dans le dossier Téléchargement, copies le sur le bureau et avant de lancer la commande il faut faire

cd Bureau

dans le terminal, puis démarrer le programme comme indiqué dans la doc.

Dernière modification par Ayral (Le 05/11/2017, à 23:49)


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#9 Le 06/11/2017, à 08:34

moreje

Re : Scanners sous 17.10

Ayral a écrit :
grigouille a écrit :

Qu'est-ce que cela signifie ? Je ne connais pas de programme hplip.

Hplip est une application créée par HP pour installer ses imprimantes et multifonctions sur Linux.
Elle est disponible ici chez HP (j'ai l'habitude d'aller là plutôt que sur sourceforge)
Il est recommandé de supprimer l'imprimante ou le scanner avant de commencer l'utilisation d'hplip.
Il est impératif de faire ça avec patience (bien lire le texte c'est de l'anglais très simple) et rigueur pour ne rien louper. J'ai toujours réussi mes install en choisissant les propositions par défaut de l'application.
Le fichier va se mettre dans le dossier Téléchargement, copies le sur le bureau et avant de lancer la commande il faut faire

cd Bureau

dans le terminal, puis démarrer le programme comme indiqué dans la doc.


j'utilise aussi cette page pour récupérer hplip...mais l'installateur avorte car 17.10 n'est pas supporté et qu'il manque des dépendances.


***************************
PC NUC Intel I5 - 8 Go RAM
Ubuntu 17.10 x64
+++++++++++++++++

Hors ligne

#10 Le 06/11/2017, à 11:44

Ayral

Re : Scanners sous 17.10

moreje a écrit :

j'utilise aussi cette page pour récupérer hplip...mais l'installateur avorte car 17.10 n'est pas supporté et qu'il manque des dépendances.

Tu as de bonnes raisons d'utiliser la 17.10 au lieu de la 16.04 LTS, la seule recommandée en production ...


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#11 Le 06/11/2017, à 13:33

grigouille

Re : Scanners sous 17.10

moreje a écrit :

j'utilise aussi cette page pour récupérer hplip...mais l'installateur avorte car 17.10 n'est pas supporté et qu'il manque des dépendances.

Je commence à y voir plus clair. Quand tu dis

moreje a écrit :

HPLIP ne veut plus se lancer

tu veux parler du fichier pour installer le dernier hplip. Je me trompe ?

Envoie plutôt un retour de commande dans ce cas, c'est beaucoup plus clair.


Xubuntu 16.04

Hors ligne

#12 Le 06/11/2017, à 13:35

grigouille

Re : Scanners sous 17.10

Pourquoi vouloir installer le dernier hplip ? Celui des dépôts ne fonctionne pas ?


Xubuntu 16.04

Hors ligne

#13 Le 06/11/2017, à 15:45

moreje

Re : Scanners sous 17.10

à cause de ça:
Capture_du_2017_11_06_15_43_16.png


***************************
PC NUC Intel I5 - 8 Go RAM
Ubuntu 17.10 x64
+++++++++++++++++

Hors ligne

#14 Le 06/11/2017, à 18:04

Ayral

Re : Scanners sous 17.10

Il faut avouer que l'application "logiciels" qui a remplacé "Logithèque Ubuntu" (Ubuntu Software) me déçoit depuis le début. Je ne sais pas pourquoi effectivement quand j'utilise cette logithèque j'ai bien hplip de trouvé, et toi avec "Logiciels" il ne le trouve pas. En général sur les installs que je fais, je rajoute Ubuntu software et vire logiciels.
Ceci étant dit, le mieux c'est d'aller à la source indiquée au post 8.
Mais je réitère ma question: pourquoi avoir installée la 17.10 ? Il faut en rester à la 16.04 !!!


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#15 Le 06/11/2017, à 18:23

bipede

Re : Scanners sous 17.10

Ayral a écrit :

Mais je réitère ma question: pourquoi avoir installée la 17.10 ? Il faut en rester à la 16.04 !!!

Pourquoi un ordinateur ? Fallait garder le boulier !!! roll

Hors ligne

#16 Le 06/11/2017, à 18:44

Ayral

Re : Scanners sous 17.10

J'ai la flemme de rechercher toutes les sources dans la documentation et le forum affirmant unanimement que les versions intermédiaires n'ont pas d'autres utilité que de préparer et tester les versions LTS à venir. Et qu'elles ne sont pertinentes QUE pour ça.
Après tu fais ce que tu veux mais tu ne viens pas pleurer que ça ne marche pas, les contributeurs du forum te le confirmeront. En plus du reste cette fois ci les scanners ont particulièrement du mal avec la 17.10.

Dernière modification par Ayral (Le 06/11/2017, à 20:51)


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 14.04 sur un Dell Latitude 820

Hors ligne

#17 Le 06/11/2017, à 19:22

grigouille

Re : Scanners sous 17.10

Moi je ne crois que la ligne de commande. Relis la page hplip.


Xubuntu 16.04

Hors ligne

#18 Le 07/11/2017, à 08:30

bipede

Re : Scanners sous 17.10

Ayral a écrit :

J'ai la flemme de rechercher toutes les sources dans la documentation et le forum affirmant unanimement que les versions intermédiaires n'ont pas d'autres utilité que de préparer et tester les versions LTS à venir. Et qu'elles ne sont pertinentes QUE pour ça.
Après tu fais ce que tu veux mais tu ne viens pas pleurer que ça ne marche pas, les contributeurs du forum te le confirmeront. En plus du reste cette fois ci les scanners ont particulièrement du mal avec la 17.10.

Les gens qui ont un problème viennent sur le forum pour qu'on les aide à le régler, pas pour qu'on leur donne des leçons...
Tu restes en LTS c'est ton droit, mais de quoi tu te mêles quand tu leur expliques que si ils font pas comme toi ils n'ont qu'à ce démerder.
Tu n'a pas compétence sur les problèmes des versions intermédiaires ?  Alors laisse la main à ceux qui peuvent l'aider...
Moi je n'ai pas de dual boot avec la daube de Microsoft, donc je ne mêle pas des problèmes de dual boot...
Pour ta gouverne, je suis sur Ubuntu depuis sa première version et je passe de versions en versions tous les six mois sans jamais avoir eu de problème. La seule fois ou j'ai du réinstaller c'était suite au passage à une LTS...
Quant aux problèmes de scanners, mon scanner en réseau a été immédiatement reconnu par la 17.10 sans que j'ai eu à faire quoi que ce soit.
Les versions intermédiaires sont désignées comme stables par Canonical et sont également utiles à ceux qui veulent des versions plus récentes de logiciels ou des drivers pour du matériel récent non reconnu par les versions antérieures...

Hors ligne

#19 Le 07/11/2017, à 12:06

sberthelot

Re : Scanners sous 17.10

Pour les gens qui comme moi ont des problèmes depuis la 17.10 avec les drivers propriétaires ou binaires (ex: Brother), la solution est en fait assez simple. Je ne l'ai pas trouvée ailleurs donc si vous pouvez l'indiquer sur le wiki ou à un endroit visible je pense que ça pourrait aider pas mal de monde.

Depuis Ubuntu 17.10 SANE ne cherche plus les bibliothèques au même endroit (ou alors la compatibilité a été supprimée)
Il faut donc déplacer les bibliothèques binaires de
/usr/lib64/sane vers /usr/lib/x86_64-linux-gnu/sane
(si comme moi et pour les drivers Brother vous avez du monde également dans /usr/lib64 il faut le déplacer dans /usr/lib/x86_64-linux-gnu )
Attention, avec cette méthode les liens symboliques des versions de bibliothèques (.so et .so.1) sont à recréer avec le "bon" chemin.

Avec ces modifications tout marche chez moi ensuite.
Note: si vous voulez simplifier la procédure il est possible de tout simplement faire un lien symbolique de /usr/lib/x86_64-linux-gnu vers /usr/lib64 et réinstaller les drivers mais ce n'est pas très propre et probablement hasardeux à moyen terme (mais plus simple à expliquer et à faire faire à des néophytes smile )

Hors ligne

#20 Le 07/11/2017, à 12:59

moko138

Re : Scanners sous 17.10

bipede a écrit :

Les versions intermédiaires (...) sont également utiles à ceux qui veulent des versions plus récentes de logiciels ou des drivers pour du matériel récent non reconnu par les versions antérieures...

Je dirais même que les versions intermédiaires sont indispensables mais dans ce cas, et celui-ci seul, où le matériel, récent, n'est pas reconnu par la dernière LTS mais bien reconnu par la dernière version intermédiaire.

= =

bipede a écrit :

Les versions intermédiaires sont désignées comme stables par Canonical (...)

Il est exact que les versions intermédiaires sont désignées comme stables par Canonical.
Mais "stable" au sens de Canonical n'est pas du tout synonyme de "opérationnel".

Au contraire, à chaque sortie d'une nouvelle version, les demandes d'aide du genre
« wifi (ou scanner ou écran ou appareil photo ou lecteur de DVD ou autre périphérique, quand ce n'est pas le disque externe !) ne fonctionne plus depuis mise à niveau » foisonnent.

Et ça se vérifie même à la sortie des LTS !
Ainsi,
en mai 2012, 8.900 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

en mai 2014, 2.400 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

En mai 2016, 3.400 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

C'est pourquoi le forum conseille souvent d'attendre plusieurs mois après la sortie d'une LTS avant de l'installer.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#21 Le 07/11/2017, à 13:46

bipede

Re : Scanners sous 17.10

moko138 a écrit :
bipede a écrit :

Les versions intermédiaires (...) sont également utiles à ceux qui veulent des versions plus récentes de logiciels ou des drivers pour du matériel récent non reconnu par les versions antérieures...

Je dirais même que les versions intermédiaires sont indispensables mais dans ce cas, et celui-ci seul, où le matériel, récent, n'est pas reconnu par la dernière LTS mais bien reconnu par la dernière version intermédiaire.

= =

bipede a écrit :

Les versions intermédiaires sont désignées comme stables par Canonical (...)

Il est exact que les versions intermédiaires sont désignées comme stables par Canonical.
Mais "stable" au sens de Canonical n'est pas du tout synonyme de "opérationnel".

Au contraire, à chaque sortie d'une nouvelle version, les demandes d'aide du genre
« wifi (ou scanner ou écran ou appareil photo ou lecteur de DVD ou autre périphérique, quand ce n'est pas le disque externe !) ne fonctionne plus depuis mise à niveau » foisonnent.

Et ça se vérifie même à la sortie des LTS !
Ainsi,
en mai 2012, 8.900 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

en mai 2014, 2.400 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

En mai 2016, 3.400 résultats sortent de https://www.google.fr/search?q=%2205%2F … cher&gbv=1

C'est pourquoi le forum conseille souvent d'attendre plusieurs mois après la sortie d'une LTS avant de l'installer.

Ok, toute nouvelle version apporte sa dose de désagréments ...
Mais je n'ai jamais vu un problème matériel créé par une nouvelle version sauf si le matériel en cause était géré par du propriétaire...
Quand on doit compiler un driver à chaque nouveau noyau, on n'a pas à se plaindre on doit changer de matériel ou attendre que le reverse egineering ait été réalisé.
Le matériel non supporté est à éviter quand on est sous linux et il ne faut pas mettre sur le dos d'une nouvelle version les dysfonctionnement de matériels conçus exclusivement pour Miciosoft.
Pour les gamers qu'ils restent sous Windows ou qu'ils se cantonnent à Valve qui est le seul à se casser le cul pour openGL.

Hors ligne

#22 Le 10/11/2017, à 12:36

Apollonaute

Re : Scanners sous 17.10

Salut à tous,

J'ai aussi une imprimante HP avec HPLIP d'installé.
J'ai trouvé ! Il faut lancer la commande "hp-check" et résoudre les différentes erreurs.

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'python-qt4-dbus' package is missing/incompatible 
error: 'hpaio' package is missing/incompatible)

Missing Optional Dependencies
-----------------------------
None


Total Errors: 2
Total Warnings: 1


Done.

Pour ma part, un rapide

sudo apt install python-qt4-dbus

a résolu le premier problème.

Pour le second, on reprend un peu plus haut dans la console le message complet :

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -
'/etc/sane.d/dll.d/hpaio' not found.
'/etc/sane.d/dll.d/hplip' not found.
error: 'hpaio' not found in SANE conf files. Is SANE installed?
 error: hpaio         HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         MISSING    'hpaio not found in /etc/sane.d/dll.conf. hpaio needs to be added in this file.'

Bon ben ok : on t'ajouter "hpaio" dans la liste du ficher "/etc/sane.d/dll.conf"

NOTA : préalablement, j'avais aussi fait la manip suivante :

sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane/
cd /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s libsane-hpaio.so.1.0.0 libsane-hpaio.so
sudo ln -s libsane-hpaio.so.1.0.0 libsane-hpaio.so.1

Car vu dans dans la réponse de sberthelot.

Et voilà !

Dernière modification par Apollonaute (Le 11/11/2017, à 16:01)

Hors ligne

#23 Le 11/11/2017, à 15:20

libelul

Re : Scanners sous 17.10

sberthelot a écrit :

Pour les gens qui comme moi ont des problèmes depuis la 17.10 avec les drivers propriétaires ou binaires (ex: Brother), la solution est en fait assez simple. Je ne l'ai pas trouvée ailleurs donc si vous pouvez l'indiquer sur le wiki ou à un endroit visible je pense que ça pourrait aider pas mal de monde.

Depuis Ubuntu 17.10 SANE ne cherche plus les bibliothèques au même endroit (ou alors la compatibilité a été supprimée)
Il faut donc déplacer les bibliothèques binaires de
/usr/lib64/sane vers /usr/lib/x86_64-linux-gnu/sane
(si comme moi et pour les drivers Brother vous avez du monde également dans /usr/lib64 il faut le déplacer dans /usr/lib/x86_64-linux-gnu )
Attention, avec cette méthode les liens symboliques des versions de bibliothèques (.so et .so.1) sont à recréer avec le "bon" chemin.

Avec ces modifications tout marche chez moi ensuite.
Note: si vous voulez simplifier la procédure il est possible de tout simplement faire un lien symbolique de /usr/lib/x86_64-linux-gnu vers /usr/lib64 et réinstaller les drivers mais ce n'est pas très propre et probablement hasardeux à moyen terme (mais plus simple à expliquer et à faire faire à des néophytes smile )

La grande classe, cela fonctionne pour un epson perfection V500 Photo
Merci beaucoup.

Hors ligne

#24 Le 15/11/2017, à 18:50

moreje

Re : Scanners sous 17.10

Apollonaute a écrit :

Salut à tous,

J'ai aussi une imprimante HP avec HPLIP d'installé.
J'ai trouvé ! Il faut lancer la commande "hp-check" et résoudre les différentes erreurs.

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'python-qt4-dbus' package is missing/incompatible 
error: 'hpaio' package is missing/incompatible)

Missing Optional Dependencies
-----------------------------
None


Total Errors: 2
Total Warnings: 1


Done.

Pour ma part, un rapide

sudo apt install python-qt4-dbus

a résolu le premier problème.

Pour le second, on reprend un peu plus haut dans la console le message complet :

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -
'/etc/sane.d/dll.d/hpaio' not found.
'/etc/sane.d/dll.d/hplip' not found.
error: 'hpaio' not found in SANE conf files. Is SANE installed?
 error: hpaio         HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         MISSING    'hpaio not found in /etc/sane.d/dll.conf. hpaio needs to be added in this file.'

Bon ben ok : on t'ajouter "hpaio" dans la liste du ficher "/etc/sane.d/dll.conf"

NOTA : préalablement, j'avais aussi fait la manip suivante :

sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane/
cd /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s libsane-hpaio.so.1.0.0 libsane-hpaio.so
sudo ln -s libsane-hpaio.so.1.0.0 libsane-hpaio.so.1

Car vu dans dans la réponse de sberthelot.

Et voilà !

Hp-check ne marche pas chez moi:

hp-check
error: Unable to locate models.dat file
Saving output in log file: /usr/hp-check.log

HP Linux Imaging and Printing System (ver. 0.0.0)
Dependency/Version Check Utility ver. 15.1

ensuite , j'ai voulu copier les fichiers comme indiqué, mais:
pas de /usr/lib64
ça commence mal...

/usr$ ls
bin  games  include  lib  local  locale  sbin  share  src

du coup...toujours bloqué avec mon imprimante/scanner


***************************
PC NUC Intel I5 - 8 Go RAM
Ubuntu 17.10 x64
+++++++++++++++++

Hors ligne

#25 Le 15/11/2017, à 22:04

grigouille

Re : Scanners sous 17.10

moreje a écrit :
HP Linux Imaging and Printing System (ver. 0.0.0)

Et tu t'étonnes que cela ne fonctionne pas ?


Xubuntu 16.04

Hors ligne