Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 02/11/2017, à 18:03

nonsolum

Impossible de lancer l’interface graphique après une mise à jour

Bonjour à tous,

Je ne sais pas si je suis dans la bonne rubrique du forum. mais je tente.

J’ai plusieurs machines virtuelles sous VirtualBox avec diverses distributions Linux dont deux serveurs Ubuntu.
Tout d’abord ma configuration (identique pour les deux serveurs Ubuntu).
Un « uname –a » me donne :

Linux serv-u1 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Mon interface graphique est « xfce »
Tout fonctionnait bien jusqu’à présent.
J’ai procédé alors à une mise à jour avec  quelques erreurs (j’y reviens ci-après)
Puis j’ai rebouté mon système.
Le processus de boot semble se dérouler normalement.
Mais toutefois à l’issue de la séquence de boot l’interface graphique ne se lance pas et j’obtiens un écran noir.

Je développe :

Premier problème
La mise à jour du système.
Un « apt-get update » me  donne

…
AppStream cache update completed, but some metadata was ignored due to errors.
Lecture des listes de paquets... Fait

Une recherche sur Internet me révèle un bug documenté :
https://askubuntu.com/questions/854168/ … -ignored-d

Je procède donc  aux trois commandes indiquées

# apt install appstream/xenial-backports
…
# appstreamcli –version
…
# appstreamcli refresh --force

Sur le premier serveur « serv-u1 » tout se passe normalement :
J’obtiens bien une mise à niveau du package de « appstream »
Par contre, sur le deuxième serveur « serv-u2 », c’est un échec pour des raisons que j’ignore.

Deuxième problème

Je procède à un « apt-get upgrade » sur mes deux serveurs
Puis je reboot chaque machine.
J’obtiens alors, comme je l’ai indiqué précédemment, en fin de cycle un écran noir.
L’interface graphique ne se lance pas.
Et je n’ai pas la main : pas de console.

Pas de lien semble-t-il avec mon premier problème comme je l’avais supposé un premier moment.
En effet pour mon serveur « serv-u1 » le bug « apt-get update » a bien été fixé.
Alors que pour mon serveur « serv-u2 » cela n’a pas été le cas.
Or, après le « upgrade » les deux serveurs plantent au reboot  tous deux,  « appstream » fixé ou non.

Je décide alors d’effectuer, sur choix du menu GRUB, un   « boot upstart »
Le boot s’effectue correctement et j’obtiens bien  une console active pour les deux serveurs Ubuntu.
Toutefois au prompt d’invite lorsque je me connecte (user + mdp), j’ai ce retour :

[312.610609] systemd-logind [4232] : Failed to enable subscription :
Launch helper exited without unkown return code 1
[312.612157] systemd-logind [4232] : Failed to fully start up daemon :
Input/output error

Je passe outre, car j’obtiens bien le prompt de l’utilisateur et je peux rentrer des commandes.

Le réseau est disponible.
Mes serveurs DHCP et DNS que j’avais implantés sur mes deux serveurs sont opérationnels.
Le Load Balancing  sous «heartbeat » fonctionne.

Je souhaite toutefois un environnement graphique.
(je rappelle que j’avais installé l’interface graphique XFCE)
Tout d’abord  (pour en savoir plus)
#  Xorg –version   me donne :

X.Org X Server 1.18.4
Release Date : 2016-07-19
X protocol Version 11, Revision 0
Build Operating System : Linux 4.4.0-97-generic x86_64 Ubuntu
Current Operating System :  Linux serv-u1 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 
Kernel command line : BOOT_IMAGE=/boot/vmlinuz-4.4.0-59-generic  root=UUID=26699a94-b873-438d-8eed-203d73ac737b roi nit=/sbin/upstart
Build Date : 13 October 2017 01:57:05PM
Xorg-server 2 :1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.comm/support)
Current version of pixman : 0.33.6
	Before reporting problems, check http://wiki.x.org
	To make sure that you have the latest version.

Je lance ensuite :
# startx
J’ai après différentes infos concernant la version du serveur X puis un retour semblable à celui constaté précédemment lorsque je me connecte.

[……..] systemd-logind […..] : Failed to enable subscription :
Launch helper exited without unkown return code 1
[…….] systemd-logind […..] : Failed to fully start up daemon :
Input/output error

Puis tout se bloque et je n’ai plus la main sur ma console.
Je ne possède plus de prompt utilisateur.
Je suis obligé de fermer brutalement ma fenêtre VirtualBox.

Je ne suis pas sûr que ma démarche soit la bonne.
Un « # less  /var/log/Xorg.0.log » ne me donne rien.
Le fichier est vide.
(ce qui est peut-être normal car j’y accède après reboot en mode « upstart » et sans lancer le serveur X)

J’ai donc besoin de vos lumières.
Merci pour votre aide.

Dernière modification par nonsolum (Le 03/11/2017, à 12:11)

Hors ligne

#2 Le 03/11/2017, à 10:50

nonsolum

Re : Impossible de lancer l’interface graphique après une mise à jour

Juste quelques infos complémentaires.
J'ai réussi finalement à avoir des logs dans
/var/log/Xorg.0.log

Voici ce que cela donne:

[  4096.009] X.Org X Server 1.18.4  Release Date: 2016-07-19
[  4096.019] X Protocol Version 11, Revision 0
[  4096.023] Build Operating System: Linux 4.4.0-97-generic x86_64 Ubuntu
[  4096.034] Current Operating System: Linux serv-u1 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64
[  4096.035] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-59-generic root=UUID=26699a94-b873-438d-8ee2-203d73ac737b ro init=/sbin/upstart
[  4096.047] Build Date: 13 October 2017  01:57:05PM
[  4096.051] xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.com/support) 
[  4096.061] Current version of pixman: 0.33.6
[  4096.070] 	Before reporting problems, check http://wiki.x.org	to make sure that you have the latest version.
[  4096.070] Markers: (--) probed, (**) from config file, (==) default setting,	(++) from command line, (!!) notice, (II) informational,	(WW) warning, (EE) error, (NI) Not implemented, (??) unknown.
[  4096.091] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov  2 13:06:40 2017
[  4096.193] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4096.411] (==) No Layout section.  Using the first Screen section.
[  4096.411] (==) No screen section available. Using defaults.
[  4096.411] (**) |-->Screen "Default Screen Section" (0)
[  4096.411] (**) |   |-->Monitor "<default monitor>"
[  4096.416] (==) No monitor specified for screen "Default Screen Section".Using a default monitor configuration.
[  4096.416] (==) Automatically adding devices
[  4096.416] (==) Automatically enabling devices
[  4096.417] (==) Automatically adding GPU devices
[  4096.417] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  4096.604] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  4096.604] 	Entry deleted from font path.
[  4096.604] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  4096.604] 	Entry deleted from font path.
[  4096.604] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  4096.604] 	Entry deleted from font path.
[  4096.605] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  4096.605] 	Entry deleted from font path.
[  4096.605] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  4096.605] 	Entry deleted from font path.
[  4096.605] (==) FontPath set to:/usr/share/fonts/X11/misc,	/usr/share/fonts/X11/Type1,	built-ins
[  4096.605] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules, /usr/lib/xorg/modules"
[  4096.605] (II) The server relies on udev to provide the list of input devices.If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4096.605] (II) Loader magic: 0x5597c0d06dc0
[  4096.605] (II) Module ABI versions:
[  4096.605] 	X.Org ANSI C Emulation: 0.4
[  4096.605] 	X.Org Video Driver: 20.0
[  4096.605] 	X.Org XInput driver : 22.1
[  4096.605] 	X.Org Server Extension : 9.0
[  4096.609] (++) using VT number 1
[  4096.700] (EE) systemd-logind: failed to get session: Launch helper exited with unknown return code 1
[  4096.701] (II) xfree86: Adding drm device (/dev/dri/card0)
[  4096.712] (--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 rev 0, Mem @ 0xe0000000/16777216
[  4096.712] (II) LoadModule: "glx"
[  4096.808] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  4097.477] (II) Module glx: vendor="X.Org Foundation"
[  4097.477] 	compiled for 1.18.4, module version = 1.0.0
[  4097.477] 	ABI class: X.Org Server Extension, version 9.0
[  4097.477] (==) AIGLX enabled
[  4097.477] (==) Matched vboxvideo as autoconfigured driver 0
[  4097.477] (==) Matched vboxvideo as autoconfigured driver 1
[  4097.477] (==) Matched modesetting as autoconfigured driver 2
[  4097.477] (==) Matched fbdev as autoconfigured driver 3
[  4097.477] (==) Matched vesa as autoconfigured driver 4
[  4097.477] (==) Assigned the driver to the xf86ConfigLayout
[  4097.477] (II) LoadModule: "vboxvideo"
[  4097.600] (II) Loading /usr/lib/xorg/modules/drivers/vboxvideo_drv.so
[  4097.665] (II) Module vboxvideo: vendor="Oracle Corporation"
[  4097.665] 	compiled for 1.18.0, module version = 1.0.1
[  4097.665] 	Module class: X.Org Video Driver
[  4097.665] 	ABI class: X.Org Video Driver, version 20.0
[  4097.666] (**) Load address of symbol "VBOXVIDEO" is 0x7fc35353a2e0
[  4097.666] (II) LoadModule: "modesetting"
[  4097.666] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  4097.776] (II) Module modesetting: vendor="X.Org Foundation"
[  4097.776] 	compiled for 1.18.4, module version = 1.18.4
[  4097.776] 	Module class: X.Org Video Driver
[  4097.776] 	ABI class: X.Org Video Driver, version 20.0
[  4097.776] (II) LoadModule: "fbdev"
[  4097.777] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  4097.819] (II) Module fbdev: vendor="X.Org Foundation"
[  4097.819] 	compiled for 1.18.1, module version = 0.4.4
[  4097.819] 	Module class: X.Org Video Driver
[  4097.819] 	ABI class: X.Org Video Driver, version 20.0
[  4097.819] (II) LoadModule: "vesa"
[  4097.820] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  4097.825] (II) Module vesa: vendor="X.Org Foundation"
[  4097.825] 	compiled for 1.18.1, module version = 2.3.4
[  4097.825] 	Module class: X.Org Video Driver
[  4097.825] 	ABI class: X.Org Video Driver, version 20.0
[  4097.825] (II) VBoxVideo: guest driver for VirtualBox: vbox
[  4097.825] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  4097.825] (II) FBDEV: driver for framebuffer: fbdev
[  4097.825] (II) VESA: driver for VESA chipsets: vesa
[  4097.826] (II) vboxvideo: kernel driver found, not loading.
[  4097.828] (II) vboxvideo: kernel driver found, not loading.
[  4097.828] (II) modeset(0): using drv /dev/dri/card0
[  4097.829] (WW) Falling back to old probe method for fbdev
[  4097.829] (II) Loading sub module "fbdevhw"
[  4097.829] (II) LoadModule: "fbdevhw"
[  4097.829] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  4097.889] (II) Module fbdevhw: vendor="X.Org Foundation"
[  4097.889] 	compiled for 1.18.4, module version = 0.0.2
[  4097.889] 	ABI class: X.Org Video Driver, version 20.0
[  4097.889] (WW) Falling back to old probe method for vesa
[  4097.890] (II) modeset(0): Creating default Display subsection in Screen section "Default Screen Section" for depth/fbbpp 24/32
[  4097.890] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[  4097.890] (==) modeset(0): RGB weight 888
[  4097.890] (==) modeset(0): Default visual is TrueColor
[  4097.890] (II) Loading sub module "glamoregl"
[  4097.890] (II) LoadModule: "glamoregl"
[  4097.890] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[  4098.316] (II) Module glamoregl: vendor="X.Org Foundation"
[  4098.317] 	compiled for 1.18.4, module version = 1.0.0
[  4098.317] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  4098.317] (II) glamor: OpenGL accelerated X.org driver based.
[  4103.386] (EE) 
[  4103.386] (EE) Backtrace:

Je ne suis pas sûr que cette log apporte des réponses à mon problème.
mais j'ai trouvé cela

[  4096.700] (EE) systemd-logind: failed to get session: Launch helper exited with unknown return code 1

Peu-être aucun rapport avec l'interface graphique ?

Hors ligne

#3 Le 05/11/2017, à 12:26

nonsolum

Re : Impossible de lancer l’interface graphique après une mise à jour

Me revoilà,

J’ai finalement trouvé une solution.
Après avoir effectué un « apt-get update » suivi d’un « apt-get upgrade » j’ai lancé un
apt-get  dist-upgrade
et là, bingo, j’ai retrouvé après reboot mon interface graphique.

Par la même occasion je suis passé à une version du noyau supérieure
« uname-a » me donne :

Linux serv-u 1  4.4.0-98-generic #121-Ubuntu SMP Tue Oct 10 14:24:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

(avant j’avais « Linux serv-u1  4.4.0-59-generic… »

Reste que sur le fond je ne comprends pas ce qui est arrivé.
Et quel est le lien avec  l’erreur signalée

[  4096.700] (EE) systemd-logind: failed to get session: Launch helper exited with unknown return code 1

et l’environnement graphique ?

Une recherche sur Internet me montre que je ne suis pas le seul à avoir rencontré ce problème.
Toutefois je n’ai pas trouvé de réponses satisfaisantes.
Quelqu’un aurait-il une idée ?
Et quel package concerné par cette mise à niveau de « apt-get dist-upgrade »  que n’a pu solutionner un simple « apt-get upgrade » ?

Dernière modification par nonsolum (Le 05/11/2017, à 12:27)

Hors ligne

#4 Le 05/11/2017, à 12:33

michel_04

Re : Impossible de lancer l’interface graphique après une mise à jour

Bonjour,

nonsolum a écrit :

J’ai finalement trouvé une solution.
Après avoir effectué un « apt-get update » suivi d’un « apt-get upgrade » j’ai lancé un
apt-get  dist-upgrade

Ce qui explique l'installation d'un nouveau noyau.

Doc a écrit :
sudo apt-get upgrade

    L'option upgrade met à jour tous les paquets installés sur le système vers les dernières versions (couramment utilisé).

sudo apt-get dist-upgrade

    L'option dist-upgrade met à jour tous les paquets installés vers les dernières versions en installant de nouveaux paquets si nécessaire, par opposition à l'upgrade simple qui n'ajoute pas de nouveaux paquets.

nonsolum a écrit :

Et quel package concerné par cette mise à niveau de « apt-get dist-upgrade »  que n’a pu solutionner un simple « apt-get upgrade » ?

Ce n'est pas une mise à niveau, c'est une mise à jour.

A+

Dernière modification par michel_04 (Le 05/11/2017, à 12:35)

Hors ligne

#5 Le 06/11/2017, à 11:30

nonsolum

Re : Impossible de lancer l’interface graphique après une mise à jour

@michel_04

Oui, merci, je sais faire la différence entre « apt-get dist-upgrade » et « apt-get upgrade »
C’est pourquoi j’ai  tenté un « apt-get dist-upgrade » pensant que cela pouvait résoudre mon problème.
Ce qui a été effectivement le cas.

Il reste que j’aimerais bien trouvé une réponse à ma question.
Juste par curiosité intellectuelle.

Cordialement

Hors ligne