Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/11/2017, à 19:10

denis4

Mise à jour impossible

Bonjour,
Je ne parviens plus à faire les mise à jour.
Après le message d'erreur j'ai fait la commande suivante  : sudo apt-get install -f

Et le résultat :

denis@denis-Dell-DV051:~$ apt-get -f install
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
denis@denis-Dell-DV051:~$ sudo apt-get -f install
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.4.0-96 linux-headers-4.4.0-96-generic
  linux-image-4.4.0-96-generic linux-image-extra-4.4.0-96-generic
  mplayer-skins
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  systemd
Paquets suggérés :
  systemd-ui systemd-container
Les paquets suivants seront mis à jour :
  systemd
1 mis à jour, 0 nouvellement installés, 0 à enlever et 67 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/3 874 ko dans les archives.
Après cette opération, 8 192 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
dpkg: erreur de traitement du paquet libsystemd0:i386 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Des erreurs ont été rencontrées pendant l'exécution :
 libsystemd0:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
denis@denis-Dell-DV051:~$ 

Hors ligne

#2 Le 12/11/2017, à 21:00

lann

Re : Mise à jour impossible

sudo apt-get install libsystemd0 

Hors ligne

#3 Le 12/11/2017, à 21:14

denis4

Re : Mise à jour impossible

Resultat :

denis@denis-Dell-DV051:~$ sudo apt-get install libsystemd0 
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libsystemd0 is already the newest version (229-4ubuntu21).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 devra être installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 devra être installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
denis@denis-Dell-DV051:~$ 

Hors ligne

#4 Le 13/11/2017, à 21:03

lann

Re : Mise à jour impossible

Il faudrait voir le fichier sources.list et les fichiers présents dans sources.list.d
Que donne cette commande :

apt-cache policy libsystemd0 libpam-systemd systemd

Hors ligne

#5 Le 14/11/2017, à 19:02

denis4

Re : Mise à jour impossible

Voici :

denis@denis-Dell-DV051:~$ apt-cache policy libsystemd0 libpam-systemd systemd
libsystemd0:
  Installé : 229-4ubuntu21
  Candidat : 229-4ubuntu21
 Table de version :
 *** 229-4ubuntu21 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status
     229-4ubuntu10 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     229-4ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
libpam-systemd:
  Installé : 229-4ubuntu21
  Candidat : 229-4ubuntu21
 Table de version :
 *** 229-4ubuntu21 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status
     229-4ubuntu10 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     229-4ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
systemd:
  Installé : 229-4ubuntu19
  Candidat : 229-4ubuntu21
 Table de version :
     229-4ubuntu21 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
 *** 229-4ubuntu19 100
        100 /var/lib/dpkg/status
     229-4ubuntu10 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     229-4ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
denis@denis-Dell-DV051:~$ 

Hors ligne

#6 Le 15/11/2017, à 12:18

denis4

Re : Mise à jour impossible

Bonjour,
Je relance mon post au cas ou quelques pourrait m'aider. Je suis vraiment dans la m.... car non seulement je ne peux pas faire les mise à jour mais je ne peux pas non plus installer d'autres logiciel.
Merci

Hors ligne

#7 Le 15/11/2017, à 12:22

cqfd93

Re : Mise à jour impossible

Bonjour,

denis4 a écrit :

Je relance mon post au cas ou quelques pourrait m'aider. Je suis vraiment dans la m.... car non seulement je ne peux pas faire les mise à jour mais je ne peux pas non plus installer d'autres logiciel.
Merci

lann t'a demandé de donner le fichier sources.list et les fichiers présents dans sources.list.d :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Hors ligne

#8 Le 15/11/2017, à 14:25

denis4

Re : Mise à jour impossible

J'ai fait.
La réponse à la commande de Iann du post 5 et dans mon post 6
Et pour ta commande voici :

denis@denis-Dell-DV051:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/freecad-maintainers-ubuntu-freecad-stable-xenial.list

     1	# deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main
     2	# deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main

/etc/apt/sources.list

     1	# deb cdrom:[Xubuntu 16.04.1 LTS _Xenial Xerus_ - Release i386 (20160719)]/ xenial main multiverse restricted universe
     2	# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release i386 (20120817.3)]/ precise main restricted
     3	
     4	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     5	# newer versions of the distribution.
     6	deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     7	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     8	
     9	## Major bug fix updates produced after the final release of the
    10	## distribution.
    11	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    12	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    13	
    14	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    15	## team. Also, please note that software in universe WILL NOT receive any
    16	## review or updates from the Ubuntu security team.
    17	deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    18	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    19	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
    20	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
    21	
    22	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    23	## team, and may not be under a free licence. Please satisfy yourself as to 
    24	## your rights to use the software. Also, please note that software in 
    25	## multiverse WILL NOT receive any review or updates from the Ubuntu
    26	## security team.
    27	deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    28	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    29	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    30	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    31	
    32	## N.B. software from this repository may not have been tested as
    33	## extensively as that contained in the main release, although it includes
    34	## newer versions of some applications which may provide useful features.
    35	## Also, please note that software in backports WILL NOT receive any review
    36	## or updates from the Ubuntu security team.
    37	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    38	deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    39	
    40	deb http://security.ubuntu.com/ubuntu xenial-security main restricted
    41	deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    42	deb http://security.ubuntu.com/ubuntu xenial-security universe
    43	deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    44	deb http://security.ubuntu.com/ubuntu xenial-security multiverse
    45	deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
    46	
    47	## Uncomment the following two lines to add software from Canonical's
    48	## 'partner' repository.
    49	## This software is not part of Ubuntu, but is offered by Canonical and the
    50	## respective vendors as a service to Ubuntu users.
    51	# deb http://archive.canonical.com/ubuntu precise partner
    52	# deb-src http://archive.canonical.com/ubuntu precise partner
    53	
    54	
    55	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    56	# newer versions of the distribution.
    57	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
    58	
    59	## Major bug fix updates produced after the final release of the
    60	## distribution.
    61	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    62	
    63	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    64	## team, and may not be under a free licence. Please satisfy yourself as to
    65	## your rights to use the software. Also, please note that software in
    66	## universe WILL NOT receive any review or updates from the Ubuntu security
    67	## team.
    68	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    69	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
    70	
    71	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    72	## team, and may not be under a free licence. Please satisfy yourself as to 
    73	## your rights to use the software. Also, please note that software in 
    74	## multiverse WILL NOT receive any review or updates from the Ubuntu
    75	## security team.
    76	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    77	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    78	
    79	## N.B. software from this repository may not have been tested as
    80	## extensively as that contained in the main release, although it includes
    81	## newer versions of some applications which may provide useful features.
    82	## Also, please note that software in backports WILL NOT receive any review
    83	## or updates from the Ubuntu security team.
    84	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    85	
    86	## Uncomment the following two lines to add software from Canonical's
    87	## 'partner' repository.
    88	## This software is not part of Ubuntu, but is offered by Canonical and the
    89	## respective vendors as a service to Ubuntu users.
    90	# deb http://archive.canonical.com/ubuntu xenial partner
    91	# deb-src http://archive.canonical.com/ubuntu xenial partner
    92	
    93	# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    94	# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    95	# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
denis@denis-Dell-DV051:~$ 

Hors ligne

#9 Le 15/11/2017, à 21:12

lann

Re : Mise à jour impossible

Tu peux réessayer

sudo apt-get update
sudo apt-get upgrade

Hors ligne

#10 Le 15/11/2017, à 21:36

denis4

Re : Mise à jour impossible

Ca donne ça :

denis@denis-Dell-DV051:~$ sudo apt-get update
[sudo] Mot de passe de denis : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Réception de:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [622 kB]
Réception de:6 http://security.ubuntu.com/ubuntu xenial-security/main Sources [99,8 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 DEP-11 Metadata [307 kB]
Réception de:8 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [356 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [238 kB]
Réception de:10 http://security.ubuntu.com/ubuntu xenial-security/main i386 DEP-11 Metadata [60,2 kB]
Réception de:11 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [57,6 kB]
Réception de:12 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [154 kB]
Réception de:13 http://security.ubuntu.com/ubuntu xenial-security/universe i386 DEP-11 Metadata [51,3 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [8 112 B]
Réception de:15 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [80,2 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [520 kB]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe i386 DEP-11 Metadata [175 kB]
Réception de:18 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [249 kB]
Réception de:19 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 DEP-11 Metadata [7 076 B]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main i386 DEP-11 Metadata [3 328 B]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe i386 DEP-11 Metadata [4 588 B]
3 299 ko réceptionnés en 3s (922 ko/s)                              
Lecture des listes de paquets... Fait
denis@denis-Dell-DV051:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 est installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
denis@denis-Dell-DV051:~$ 

Hors ligne

#11 Le 15/11/2017, à 21:46

??

Re : Mise à jour impossible

Bonsoir.
Tu pourrais tenter la commande proposée

 sudo    apt-get -f install   

Dernière modification par ?? (Le 15/11/2017, à 22:09)


Inutile de répondre que vous allez faire le plus rapidement possible  l'action qui vous est demandée, vous perdez du temps à répondre, je perds du temps à consulter votre réponse. Pourtant c'est sympathique mais ce n'est pas pratique.
Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Faire un état des lieux Avec https://doc.ubuntu-fr.org/tutoriel/boot-info

Hors ligne

#12 Le 15/11/2017, à 21:54

denis4

Re : Mise à jour impossible

Je l'ai fait regarde dans mon post 1

Sinon je refait :

denis@denis-Dell-DV051:~$  sudo    apt-get -f install
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.4.0-96 linux-headers-4.4.0-96-generic
  linux-image-4.4.0-96-generic linux-image-extra-4.4.0-96-generic
  mplayer-skins
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  systemd
Paquets suggérés :
  systemd-ui systemd-container
Les paquets suivants seront mis à jour :
  systemd
1 mis à jour, 0 nouvellement installés, 0 à enlever et 78 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/3 874 ko dans les archives.
Après cette opération, 8 192 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
dpkg: erreur de traitement du paquet libsystemd0:i386 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Des erreurs ont été rencontrées pendant l'exécution :
 libsystemd0:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
denis@denis-Dell-DV051:~$ 

Hors ligne

#13 Le 15/11/2017, à 22:06

??

Re : Mise à jour impossible

sudo apt install  --reinstall libsystemd0
 sudo apt autoremove 

Dernière modification par ?? (Le 15/11/2017, à 22:08)


Inutile de répondre que vous allez faire le plus rapidement possible  l'action qui vous est demandée, vous perdez du temps à répondre, je perds du temps à consulter votre réponse. Pourtant c'est sympathique mais ce n'est pas pratique.
Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Faire un état des lieux Avec https://doc.ubuntu-fr.org/tutoriel/boot-info

Hors ligne

#14 Le 15/11/2017, à 22:15

denis4

Re : Mise à jour impossible

Pour : sudo apt install  --reinstall libsystemd0

denis@denis-Dell-DV051:~$ sudo apt install  --reinstall libsystemd0
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 devra être installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 devra être installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
denis@denis-Dell-DV051:~$ 

Pour :   sudo apt autoremove

denis@denis-Dell-DV051:~$  sudo apt autoremove 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 est installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
denis@denis-Dell-DV051:~$ 

Hors ligne

#15 Le 15/11/2017, à 22:34

??

Re : Mise à jour impossible

peut-être

 sudo apt install  --reinstall  libpam-systemd 
 sudo apt-get -f install
 sudo apt autoremove

Dernière modification par ?? (Le 15/11/2017, à 23:40)


Inutile de répondre que vous allez faire le plus rapidement possible  l'action qui vous est demandée, vous perdez du temps à répondre, je perds du temps à consulter votre réponse. Pourtant c'est sympathique mais ce n'est pas pratique.
Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Faire un état des lieux Avec https://doc.ubuntu-fr.org/tutoriel/boot-info

Hors ligne

#16 Le 15/11/2017, à 22:42

denis4

Re : Mise à jour impossible

La reinstall ne passe pas :

denis@denis-Dell-DV051:~$ sudo apt install  -- reinstall  libpam-systemd
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet reinstall
denis@denis-Dell-DV051:~$ 

Hors ligne

#17 Le 15/11/2017, à 23:06

cqfd93

Re : Mise à jour impossible

?? a écrit :
 sudo apt install  -- reinstall  libpam-systemd 

Ça sera mieux sans espace avant reinstall.

Hors ligne

#18 Le 15/11/2017, à 23:43

??

Re : Mise à jour impossible

Bonsoir

Bien sur.
j'espère qu'il n'y aura pas d'autres surprises car je suis à la limite de ce que je sais proposer.
Deux librairies de cassées!

Dernière modification par ?? (Le 15/11/2017, à 23:45)


Inutile de répondre que vous allez faire le plus rapidement possible  l'action qui vous est demandée, vous perdez du temps à répondre, je perds du temps à consulter votre réponse. Pourtant c'est sympathique mais ce n'est pas pratique.
Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Faire un état des lieux Avec https://doc.ubuntu-fr.org/tutoriel/boot-info

Hors ligne

#19 Le 16/11/2017, à 07:20

denis4

Re : Mise à jour impossible

Avec ou sans espace c'est pareil :

denis@denis-Dell-DV051:~$ sudo apt install  -- reinstall  libpam-systemd
[sudo] Mot de passe de denis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet reinstall
denis@denis-Dell-DV051:~$ sudo apt install  --reinstall  libpam-systemd
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 devra être installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 devra être installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
denis@denis-Dell-DV051:~$ sudo apt install  --reinstall  libpam-systemd
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 229-4ubuntu21) mais 229-4ubuntu19 devra être installé
 systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 devra être installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
denis@denis-Dell-DV051:~$ 

On peut faire une installation complète ?

Hors ligne

#20 Le 16/11/2017, à 07:23

xubu1957

Re : Mise à jour impossible


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#21 Le 16/11/2017, à 21:34

denis4

Re : Mise à jour impossible

Bonjour,
Tu vas me prendre pour un nul que je suis mais tu peux m'en dire plus stp ?

Hors ligne

#22 Le 16/11/2017, à 22:11

xubu1957

Re : Mise à jour impossible

Il y a le signalement d'une anomalie dans le programme et dans l'attente d'une correction.

On ne sait pas quand cela sera corrigé.

package libpam-systemd:amd64 229-4ubuntu21 failed to install/upgrade: package libpam-systemd:amd64 is already installed and configured

This bug affects 2 people
            Affects    Status        Importance       Assigned to    Milestone
dpkg (Ubuntu)    Confirmed     Undecided    Unassigned

Dernière modification par xubu1957 (Le 16/11/2017, à 22:18)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#23 Le 16/11/2017, à 22:30

denis4

Re : Mise à jour impossible

Ok merci

Hors ligne

#24 Le 17/11/2017, à 06:46

moko138

Re : Mise à jour impossible

systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 est installé

Ne conviendrait-il pas de désinstaller la version 21 et de réinstaller le paquet en version 19 ?
C'est une question, hein ! Pas un conseil !


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#25 Hier à 17:27

denis4

Re : Mise à jour impossible

Perso je saurai pas dire mais si je tape ta ligne de commande ça ne passe pas :

denis@denis-Dell-DV051:~$ systemd : Dépend: libsystemd0 (= 229-4ubuntu19) mais 229-4ubuntu21 est installé
bash: erreur de syntaxe près du symbole inattendu « ( »
denis@denis-Dell-DV051:~$ 

Hors ligne