Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 02/12/2017, à 21:30

chrisauf

Impossible d'installer Viber

Bonsoir,

J'essaie de réinstaller Viber sur mon laptop sous Ubuntu 14.04.2 LTS sans succès. J'ai téléchargé la version Linux Debian sur le site de Viber mais au moment de l'ouvrir avec la logithèque j'obtiens continuellement " Erreur Interne". J'ai essayé de l'installer manuellement via un terminal et voilà ce que j'obtiens :

marina@marina-UX303LN:~$ dpkg --install viber.deb
dpkg : erreur : l'opération demandée requiert les privilèges du superutilisateur
marina@marina-UX303LN:~$ sudo dpkg--install viber.deb
[sudo] password for marina:
sudo: dpkg--install: command not found
marina@marina-UX303LN:~$

Comment résoudre ce problème d'installation? Merci pour votre aide
Cordialement

Dernière modification par chrisauf (Le 02/12/2017, à 21:31)


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#2 Le 02/12/2017, à 21:40

nam1962

Re : Impossible d'installer Viber

Essaie (dans le répertoire ou est le .deb) :

sudo dpkg -i viber.deb

(source )


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#3 Le 03/12/2017, à 08:43

chrisauf

Re : Impossible d'installer Viber

Bonjour,
Merci pour cette réponse que j'ai suivie. J'ai d'abord dû déplacer le fichier viber.de téléchargé depuis tmp de mozilla dans le dossier Téléchargements avant de pouvoir suivre les indications données ici ( sudo dpkg -i viber.deb ne fonctionne pas). Voilà ce que j'obtiens :
marina@marina-UX303LN:~$ cd ~/Téléchargements/
marina@marina-UX303LN:~/Téléchargements$ sudo dpkg -i viber.deb
[sudo] password for marina:
Sélection du paquet viber précédemment désélectionné.
(Lecture de la base de données... 2499849 fichiers et répertoires déjà installés.)ue
Préparation du dépaquetage de viber.deb ...
Dépaquetage de viber (7.0.0.1035) ...
Paramétrage de viber (7.0.0.1035) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
marina@marina-UX303LN:~/Téléchargements$

puis plus rien depuis 20 minutes..... L'icône Viber se trouve bien dans les applications mais impossible de la lancer.
Que dois-je faire maintenant?


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#4 Le 03/12/2017, à 14:15

nam1962

Re : Impossible d'installer Viber

Redémarre et essaie de lancer Viber


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#5 Le 03/12/2017, à 17:13

cqfd93

Re : Impossible d'installer Viber

Bonjour,

Et mets les retours de tes messages 1 et 3 entre balises code…

En ligne

#6 Le 03/12/2017, à 20:41

chrisauf

Re : Impossible d'installer Viber

Bonsoir nam1962

J'ai redémarré mais impossible de lancer Viber. J'ai désinsallé, réinstallé, je suis retombée sur la même configuration qu'en #3 ci-dessus, redémarré et relancé à nouveau et toujours rien.


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#7 Le 03/12/2017, à 20:43

chrisauf

Re : Impossible d'installer Viber

Bonsoir cqfd93

Que signifie "Et mets les retours de tes messages 1 et 3 entre balises code…" ? Comment dois-je le faire?


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#8 Le 03/12/2017, à 20:53

xubu1957

Re : Impossible d'installer Viber

Bonsoir,

cqfd93 a écrit :

Utilisation des balises code - Voilà la marche à suivre :

  1. Ouvre le terminal avec ctrl-alt-t

  2. Sélectionne la commande voulue avec un triple clic (ça sélectionne toute la ligne, même la fin si on ne la voit pas)

  3. Colle-la dans le terminal avec un clic molette, valide avec Entrée

  4. Sélectionne et copie tout ce que te dit le terminal depuis la commande jusqu'à le dernière ligne incluse

  5. Clique sur le <> de l'éditeur de message
    1485703524.png

  6. Colle là où se trouve le curseur (entre le < ICI et le >)

  7. Refais toutes les étapes depuis la 2 pour les autres commandes.

lire aussi > Retour utilisable de commande


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

En ligne

#9 Le 03/12/2017, à 21:04

nam1962

Re : Impossible d'installer Viber

Et peux tu nous donner le retour de :

viber

dans le terminal (attends 30 secondes)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#10 Le 03/12/2017, à 21:38

chrisauf

Re : Impossible d'installer Viber

Alors si j'ai bien compris , pour #1 c'est

marina@marina-UX303LN:~$ sudo dpkg -i viber.deb
[sudo] password for marina: 
dpkg: erreur de traitement de l'archive viber.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 viber.deb
marina@marina-UX303LN:~$ 

pour # 3 c'est

marina@marina-UX303LN:~$ cd ~/Téléchargements/
marina@marina-UX303LN:~/Téléchargements$ sudo dpkg -i viber.deb
[sudo] password for marina: 
(Lecture de la base de données... 2501464 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de viber.deb ...
Dépaquetage de viber (7.0.0.1035) sur (7.0.0.1035) ...
Paramétrage de viber (7.0.0.1035) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
marina@marina-UX303LN:~/Téléchargements$ ^C
marina@marina-UX303LN:~/Téléchargements$ 

et pour # 9 c'est

marina@marina-UX303LN:~$ viber
La commande « viber » est introuvable, vouliez-vous dire :
 La commande « viper » du paquet « python-viper » (universe)
 La commande « biber » du paquet « biber » (universe)
viber : commande introuvable
marina@marina-UX303LN:~$ 

Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#11 Le 03/12/2017, à 21:45

chrisauf

Re : Impossible d'installer Viber

Pour #6 (désinstallation)

marina@marina-UX303LN:~$ sudo apt-get remove viber
[sudo] password for marina: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  esound-common kde-l10n-el kde-l10n-fr libasound2:i386
  libasound2-plugins:i386 libasyncns0:i386 libaudio2:i386 libaudiofile1
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libcups2:i386 libdbusmenu-qt2:i386 libesd0 libflac8:i386 libfontconfig1:i386
  libfreetype6:i386 libgconf2-4 libgcrypt11:i386 libglib2.0-0:i386
  libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libice6:i386
  libjack-jackd2-0:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  libmysqlclient18:i386 libogg0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpulse0:i386 libqt4-dbus:i386 libqt4-declarative:i386 libqt4-network:i386
  libqt4-opengl:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-sql-mysql:i386
  libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libqtwebkit4:i386 libsamplerate0:i386 libsane-perl
  libsm6:i386 libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libsvga1 libtasn1-6:i386 libtiff5:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwrap0:i386 libxi6:i386 libxml2:i386 libxrender1:i386
  libxslt1.1:i386 libxss1:i386 libxt6:i386 libxv1:i386 mysql-common
  sni-qt:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  viber
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 431 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 2501462 fichiers et répertoires déjà installés.)
Suppression de viber (7.0.0.1035) ...
oTraitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...

Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
marina@marina-UX303LN:~$ apt-get autoremove
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
marina@marina-UX303LN:~$ 

Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#12 Le 03/12/2017, à 21:51

chrisauf

Re : Impossible d'installer Viber

Voilà ce que je viens de faire, j'espère que je n'ai pas fait une patate.....

marina@marina-UX303LN:~$ sudo apt-get remove viber
[sudo] password for marina: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet viber
marina@marina-UX303LN:~$ sudo apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  esound-common kde-l10n-el kde-l10n-fr libasound2:i386
  libasound2-plugins:i386 libasyncns0:i386 libaudio2:i386 libaudiofile1
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libcups2:i386 libdbusmenu-qt2:i386 libesd0 libflac8:i386 libfontconfig1:i386
  libfreetype6:i386 libgconf2-4 libgcrypt11:i386 libglib2.0-0:i386
  libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libice6:i386
  libjack-jackd2-0:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  libmysqlclient18:i386 libogg0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpulse0:i386 libqt4-dbus:i386 libqt4-declarative:i386 libqt4-network:i386
  libqt4-opengl:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-sql-mysql:i386
  libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libqtwebkit4:i386 libsamplerate0:i386 libsane-perl
  libsm6:i386 libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libsvga1 libtasn1-6:i386 libtiff5:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwrap0:i386 libxi6:i386 libxml2:i386 libxrender1:i386
  libxslt1.1:i386 libxss1:i386 libxt6:i386 libxv1:i386 mysql-common
  sni-qt:i386
0 mis à jour, 0 nouvellement installés, 74 à enlever et 0 non mis à jour.
Après cette opération, 184 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 2499847 fichiers et répertoires déjà installés.)
Suppression de libesd0:amd64 (0.2.41-11) ...
Suppression de esound-common (0.2.41-11) ...
Suppression de kde-l10n-el (4:4.13.0-0ubuntu1) ...
Suppression de kde-l10n-fr (4:4.13.0-0ubuntu1) ...
Suppression de libasound2-plugins:i386 (1.0.27-2ubuntu2) ...
Suppression de libasound2:i386 (1.0.27.2-3ubuntu7) ...
Suppression de libpulse0:i386 (1:4.0-0ubuntu11.1) ...
Suppression de libasyncns0:i386 (0.8-4ubuntu2) ...
Suppression de libqtwebkit4:i386 (2.3.2-0ubuntu7) ...
Suppression de libqt4-opengl:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libaudiofile1:amd64 (0.3.6-2ubuntu0.14.04.2) ...
Suppression de libcups2:i386 (1.7.2-0ubuntu1.8) ...
Suppression de libavahi-client3:i386 (0.6.31-4ubuntu1.1) ...
Suppression de libavahi-common3:i386 (0.6.31-4ubuntu1.1) ...
Suppression de libavahi-common-data:i386 (0.6.31-4ubuntu1.1) ...
Suppression de sni-qt:i386 (0.2.6-0ubuntu1) ...
Suppression de libdbusmenu-qt2:i386 (0.9.3+14.04.20140314-0ubuntu1) ...
Suppression de libsndfile1:i386 (1.0.25-7ubuntu2.2) ...
Suppression de libflac8:i386 (1.3.0-2ubuntu0.14.04.1) ...
Suppression de libgconf2-4:amd64 (3.2.6-0ubuntu2) ...
Suppression de libxslt1.1:i386 (1.1.28-2ubuntu0.1) ...
Suppression de libgnutls26:i386 (2.12.23-12ubuntu2.8) ...
Suppression de libgcrypt11:i386 (1.5.3-2ubuntu4.5) ...
Suppression de libgstreamer-plugins-base1.0-0:i386 (1.2.4-1~ubuntu2.1) ...
Suppression de libgstreamer1.0-0:i386 (1.2.4-0ubuntu1.1) ...
Suppression de libgpg-error0:i386 (1.12-0.2ubuntu1) ...
Suppression de libgssapi-krb5-2:i386 (1.12+dfsg-2ubuntu5.3) ...
Suppression de libjack-jackd2-0:i386 (1.9.9.5+20130622git7de15e7a-1ubuntu1) ...
Suppression de libkrb5-3:i386 (1.12+dfsg-2ubuntu5.3) ...
Suppression de libk5crypto3:i386 (1.12+dfsg-2ubuntu5.3) ...
Suppression de libkeyutils1:i386 (1.5.6-1) ...
Suppression de libkrb5support0:i386 (1.12+dfsg-2ubuntu5.3) ...
Suppression de libqt4-sql-mysql:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libmysqlclient18:i386 (5.5.58-0ubuntu0.14.04.1) ...
Suppression de libvorbisenc2:i386 (1.3.2-1.3ubuntu1) ...
Suppression de libvorbis0a:i386 (1.3.2-1.3ubuntu1) ...
Suppression de libogg0:i386 (1.3.1-1ubuntu1) ...
Suppression de liborc-0.4-0:i386 (1:0.4.18-1ubuntu1) ...
Suppression de libp11-kit0:i386 (0.20.2-2ubuntu2) ...
Suppression de libqt4-dbus:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libsamplerate0:i386 (0.1.8-7) ...
Suppression de libsane-perl (0.05-3~ppa1trusty) ...
Suppression de libspeexdsp1:i386 (1.2~rc1.1-1ubuntu1) ...
Suppression de libsqlite3-0:i386 (3.8.2-1ubuntu2.1) ...
Suppression de libssl1.0.0:i386 (1.0.1f-1ubuntu2.23) ...
Suppression de libsvga1:amd64 (1:1.4.3-33) ...
Suppression de libtasn1-6:i386 (3.4-3ubuntu0.5) ...
Suppression de libwrap0:i386 (7.6.q-25) ...
Suppression de libxml2:i386 (2.9.1+dfsg1-3ubuntu4.10) ...
Suppression de libxss1:i386 (1:1.2.2-1) ...
Suppression de libxv1:i386 (2:1.0.10-1) ...
Suppression de mysql-common (5.5.58-0ubuntu0.14.04.1) ...
Suppression de libqtgui4:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libaudio2:i386 (1.9.4-1) ...
Suppression de libfontconfig1:i386 (2.11.0-0ubuntu4.2) ...
Suppression de libfreetype6:i386 (2.5.2-1ubuntu2.8) ...
Suppression de libxt6:i386 (1:1.1.4-1) ...
Suppression de libsm6:i386 (2:1.2.1-2) ...
Suppression de libice6:i386 (2:1.0.8-2) ...
Suppression de libtiff5:i386 (4.0.3-7ubuntu0.7) ...
Suppression de libjbig0:i386 (2.0-2ubuntu4.1) ...
Suppression de libjpeg8:i386 (8c-2ubuntu8) ...
Suppression de libjpeg-turbo8:i386 (1.3.0-0ubuntu2) ...
Suppression de libxi6:i386 (2:1.7.1.901-1ubuntu1.1) ...
Suppression de libxrender1:i386 (1:0.9.8-1build0.14.04.1) ...
Suppression de libqt4-declarative:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqt4-script:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqt4-xmlpatterns:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqt4-network:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqtdbus4:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqt4-xml:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqt4-sql:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libqtcore4:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) ...
Suppression de libglib2.0-0:i386 (2.40.2-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-0ubuntu6.13) ...
Traitement des actions différées (« triggers ») pour man-db (2.6.7.1-1ubuntu1) ...
marina@marina-UX303LN:~$ 

Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#13 Le 03/12/2017, à 21:53

cqfd93

Re : Impossible d'installer Viber

Bonjour,

Après avoir installé le paquet avec dpkg, il aurait fallu régler les éventuels problèmes des dépendances avec:

sudo apt install -f

En ligne

#14 Le 03/12/2017, à 22:00

bishop

Re : Impossible d'installer Viber

Grillé par cqfd93 yikeswinkcool

Salut chrisauf !
Sur Ubuntu 16.04 il n'y a pas de problème.

1) J'ai téléchargé le paquet viber.deb.

2) Je suis entré dans le dossier où j'avais déplacé le paquet :

cd ~/Viber

3) J'ai installé le paquet avec la commande classique plus la vérification et l'installation des dépendances le cas échéant :

sudo dpkg -i viber.deb && sudo apt-get install -f

L'exemple :

bishop@bishop:~/Viber$ sudo dpkg -i viber.deb && sudo apt-get install -f
[sudo] Mot de passe de bishop : 
Sélection du paquet viber précédemment désélectionné.
(Lecture de la base de données... 749522 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de viber.deb ...
Dépaquetage de viber (7.0.0.1035) ...
Paramétrage de viber (7.0.0.1035) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

4) Pour lancer Viber en ligne de commande :

/opt/viber/Viber

L'exemple :
Quelques message not found qui n'empêche pas le fonctionnement de Viber

bishop@bishop:~$ /opt/viber/Viber
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.

Les lanceurs dans le Menu (ClassicMenu Indicator) et dans le Dash fonctionnent.
1512334704.jpg


À savoir si cette version de Viber est opérationnelle sur Ubuntu 14.04 "voir la version des lib QT5 utilisées par Viber".

Dernière modification par bishop (Le 04/12/2017, à 06:51)

Hors ligne

#15 Le 03/12/2017, à 22:32

chrisauf

Re : Impossible d'installer Viber

Bonsoir bishop,
Voici ma nouvelle installation

marina@marina-UX303LN:~$ cd ~/Téléchargements/
marina@marina-UX303LN:~/Téléchargements$ sudo dpkg -i viber.deb
[sudo] password for marina: 
Sélection du paquet viber précédemment désélectionné.
(Lecture de la base de données... 2496032 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de viber.deb ...
Dépaquetage de viber (7.0.0.1035) ...
Paramétrage de viber (7.0.0.1035) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
marina@marina-UX303LN:~/Téléchargements$ sudo apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
marina@marina-UX303LN:~/Téléchargements$ sudo dpkg -i viber.deb && sudo apt-get install -f
(Lecture de la base de données... 2497647 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de viber.deb ...
Dépaquetage de viber (7.0.0.1035) sur (7.0.0.1035) ...
Paramétrage de viber (7.0.0.1035) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.54ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
marina@marina-UX303LN:~/Téléchargements$ 

L'icône est bien dans le dossier des applications, comme à chaque fois, mais en cliquant sur "Lancer" rien ne se passe, comme à chaque fois.
Voici le lancement en ligne de commande

marina@marina-UX303LN:~$ cd /opt/viber/Viber
bash: cd: /opt/viber/Viber: N'est pas un dossier
marina@marina-UX303LN:~$ 

et bien sûr pas de résultat.


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#16 Le 04/12/2017, à 06:51

bishop

Re : Impossible d'installer Viber

J'ai fait une erreur... (que j'ai corrigé) roll
Pour lancer Viber, ce n'est pas :

cd: /opt/viber/Viber

Mais :

/opt/viber/Viber

Mea Culpa yikes

Tu peux poster le résultat de la commande, s'il te plait.

Dernière modification par bishop (Le 04/12/2017, à 06:53)

Hors ligne

#17 Le 04/12/2017, à 07:25

chrisauf

Re : Impossible d'installer Viber

Bonjour,
Voilà le résultat

marina@marina-UX303LN:~$ /opt/viber/Viber
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Location.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicui18n.so.52)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicuuc.so.52)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5WebEngineCore.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5Qml.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Core.so.5)
marina@marina-UX303LN:~$ 

Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#18 Le 04/12/2017, à 08:14

bishop

Re : Impossible d'installer Viber

Le problème vient des versions inadéquates de librairies installées sur une 14.04.
Si tu fais une recherche GLIBCXX_3.4.20 tu obtiens GLIBCXX_3.4.20' not found.

Le premier lien "ppa - GLIBCXX_3.4.20 not found, how to fix this error? - Ask Ubuntu" propose l'installation du "“PPA for Ubuntu Toolchain Uploads (restricted)” team".

Maintenant c'est à toi de décider si tu veux installer ce PPA qui fait une très importante mise à jour (upgrade) des librairies.
La procédure est proposée dans le commentaires :

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

À tes risques et périls, c'est le message que l'on envoie quand on propose d'installer ce type de PPA.
Si tu l'installes il te faudra peut être aussi relancer la commande :

sudo apt install -f

Ou réinstaller Viber.
À toi de choisir... roll ou de parcourir les différents postes proposés dans la recherche.

Dernière modification par bishop (Le 04/12/2017, à 11:43)

Hors ligne

#19 Le 04/12/2017, à 08:48

nam1962

Re : Impossible d'installer Viber

Il semblerait aussi y avoir moins périlleux : http://www.roydoer.com/viber-on-ubuntu-14-04-64bit/ (curieusement ne cite pas GLIBCXX_3.4.20..)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#20 Le 04/12/2017, à 08:49

chrisauf

Re : Impossible d'installer Viber

@bishop
Merci pour ces précisions. Comme je suis parachutée en informatique en général et Linux en particulier,  et que j'apprends sur le tas,  ce "À tes risques et périls"  m'incite à ne pas prendre de risques et à abandonner l'idée de Viber sur laptop. Dommage, car je l'avais jusqu'au printemps et m'en servais plus qu'avec celui sur mon smartphone, jusqu'à une mise à jour qui a tout fait capoter. Je me demande si une mise a niveau de ubuntu 14.04 *lTS à 16.04 LTS ne résoudrait pas mieux ce problème? Y aurait-il des risques, par rapport à tout ce que j'ai déjà sur mon ordi, à procéder de la sorte?


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#21 Le 04/12/2017, à 12:15

bishop

Re : Impossible d'installer Viber

chrisauf a écrit :

@bishop
... ... ...
Je me demande si une mise a niveau de ubuntu 14.04 *lTS à 16.04 LTS ne résoudrait pas mieux ce problème? Y aurait-il des risques, par rapport à tout ce que j'ai déjà sur mon ordi, à procéder de la sorte?

Ce serait une bonne idée de mettre à niveau ta distribution.
Tu peux savoir si ton ordi supporte la version 16.04 en testant un live-cd sans installer Ubuntu.
Si tu n'es pas familier avec ce type de support tu peux te référer à ces tutoriels dans la doc ubuntu-fr.

Quand aux risques sur ce qui est installé sur ton ordi, cela dépend de comment tu as installé ces logiciels, si ce sont des logiciels courants ou exotiques.
Normalement il n'y a pas de problème, si ce n'est de les désinstaller, parfois de supprimer la conf. dans le dossier caché, puis de les réinstaller.
Si tu utilises des PPAs, tu dois les désactiver avant la mise à niveau vers 16.04. Tu peux vérifier si les PPAs proposent une MAJ pour la 16.04, ce qui est généralement le cas. Sinon tu cherches un PPA qui fournit le logiciel pour la 16.04.

Sache que ton ordi avec tes logiciels et outils perso ne sera pas fonctionnel en 20/30 minutes, ce qui et le temps moyen de la migration 14.04 vers 16.04. Il te faudra peaufinner ton installation.
Il y a peu de temps que j'ai migré mon ordi principal vers 16.04 et il m'a fallu deux bonnes journées pour tout réinstaller. J'ai un portable qui est toujours sur 14.04 et qui attend la migration.
Et tu as toujours le recours de poster sur ubuntu-fr pour demander un coup de mains... wink

Vois aussi le poste #19 de nam1962.

Dernière modification par bishop (Le 04/12/2017, à 12:58)

Hors ligne

#22 Le 04/12/2017, à 12:24

bishop

Re : Impossible d'installer Viber

Quant au PPA Toolchain test builds il ne semble pas y avoir signalement de problèmes. Il est même proposé dans la doc ubuntu-fr pour : GCC, le jeu de compilateurs GNU.

Hors ligne

#23 Le 05/12/2017, à 00:28

chrisauf

Re : Impossible d'installer Viber

@nam1962 #19
J'ai suivi ces indications  et voilà ce que j'obtiens

marina@marina-UX303LN:~$ sudo apt-get install libqt5gui5
[sudo] password for marina: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libqt5gui5 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
marina@marina-UX303LN:~$ sudo dpkg -i viber.deb && sudo apt-get install -f
dpkg: erreur de traitement de l'archive viber.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 viber.deb
marina@marina-UX303LN:~$ 

Je crois que je vais laisser tomber...

@bishop#21
merci pour ces conseils. Si la migration n'équivaut pas à un reformatage avec perte de données, j'opterai pour cette solution. Je ne me rappelle pas avoir utilisé des PPA mais je vérifierai d'après les tutoriels de la doc. Quant à mes logiciels, la grande majorité provient de la logithèque, ils sont donc courants. A l'exception de Tor, de Skype et de Google Earth, mais qui sont tous réinstallables. Par précaution je travaille uniquement sur disque dur externe, donc le seul contenu important de mon ordinateur que je ne veux pas perdre est celui de Thunderbird. Concernant le #22, j'ai bien lu mais j'avoue que je n'ai rien compris...
Je reviendrai avec de nouvelles informations dès que j'aurai avancé un peu, et très probablement pour redemander un coup de main.... En tout cas, merci à tous les deux pour vos efforts et votre aide jusqu'ici.


Ubuntu 14.04.2 LTS 64 bits sur Asus Zenbook UX303LN-R4203H 64 bits (en dual boot W8)

Hors ligne

#24 Le 05/12/2017, à 07:00

bishop

Re : Impossible d'installer Viber

Pour le poste #22...
Si tu envisages de passer à la 16.04 ce qui est de toute façon la meilleure décision, tu peux toujours tester le PPA Toolchain test builds :

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Si tu installes ce PPA il te faudra peut être aussi relancer la commande :

sudo apt install -f

Et peut-être installer une version supérieure de certaines librairies requises par Viber.
Et réinstaller Viber.

Hors ligne

#25 Le 05/12/2017, à 07:07

bishop

Re : Impossible d'installer Viber

Pour :

marina@marina-UX303LN:~$ sudo dpkg -i viber.deb && sudo apt-get install -f
dpkg: erreur de traitement de l'archive viber.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 viber.deb

Tu n'es pas entré dans le dossier contenant le paquet viber.deb.
Exemple si viber.deb est dans le dossier Téléchargement :

cd ~/Téléchargements

Puis tu exécutes la commande pour installer viber.deb :

sudo dpkg -i viber.deb && sudo apt-get install -f

Hors ligne