Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 05/12/2017, à 12:45

nubiboros

Re : GIMP répond « no such file or directory »

EDIT :
En fait, la situation est encore pire : les trois partitions que je voulais voir montées  n'aparaîssent plus ni sur le bureau, ni dans l'explorateur de fichiers, et Gimp n'y accède plus : le contraire de ce que je souhaitais.
voici le fstab :

neitoeb@Zeus:~$ cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=9eb0c0a5-4c8f-48d9-9d51-eb70e4f8b568 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw,nofail              0       0
/dev/disk/by-uuid/14F22C1FF22C0796  /mnt/14F22C1FF22C0796  ntfs-3g  defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names 0  0
/dev/disk/by-uuid/EC0E56610E5624BC  /mnt/EC0E56610E5624BC  ntfs-3g  defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names 0  0
/dev/disk/by-uuid/8E4C67EE4C67CF8F  /mnt/8E4C67EE4C67CF8F  ntfs-3g  defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names 0  0
neitoeb@Zeus:~$ 

Pourtant, les trois partitions apparaîssent bien comme montées :

neitoeb@Zeus:~$ df -Th | grep -Ev "devpts|none|proc|tmpfs|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sda5        ext4        42G    7,7G   32G  20% /
/dev/loop0       squashfs    84M     84M     0 100% /snap/core/3440
/dev/sdb1        fuseblk     50G     18G   33G  36% /mnt/14F22C1FF22C0796
/dev/sdb2        fuseblk     98G     23G   75G  24% /mnt/EC0E56610E5624BC
/dev/sdb3        fuseblk    1,7T    1,3T  437G  75% /mnt/8E4C67EE4C67CF8F
/dev/sdj1        fuseblk    932G    308G  625G  33% /media/neitoeb/WORK1
neitoeb@Zeus:~$ 

J'en perds mon linux (le peu que j'en avais)


RESOLU

Hors ligne

#27 Le 05/12/2017, à 13:06

pingouinux

Re : GIMP répond « no such file or directory »

Si les partitions sont montées, tu dois les voir avec cette commande

cat /etc/mtab

En ligne

#28 Le 05/12/2017, à 14:00

moko138

Re : GIMP répond « no such file or directory »

Pourquoi tes partitions montées ne sont momentanément pas visibles :
Tu as choisi de les monter sous /mnt.
Or /mnt est en principe dévolu aux montages temporaires (source : http://refspecs.linuxfoundation.org/FHS … s-2.3.html  > /mnt ). Oui, je sais, cette norme n'est pas toujours respectée...


Remède :
Dans ton gestionnaire de fichiers (nautilus ?) tu remontes à la racine et tu redescends à /mnt.
Puis à chacune des 3 partitions ntfs.
Et pour chacune d'elle tu fais "Ajouter un marque-pages".

Comme je n'utilise pas nautilus, je ne te garantis pas l'exactitude de l'intitulé, je ne sais pas si tu le trouveras dans un menu "Marque-pages" (comme dans pcmanfm de Lubuntu) ou par un clic droit sur 14F22C1FF22C0796. Mais l'idée est là.

Après quoi, tu trouveras 14F22C1FF22C0796 (et les 2 autres points de montage) dans le volet de gauche de ton gestionnaire de fichiers.
smile


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#29 Le 05/12/2017, à 14:13

erresse

Re : GIMP répond « no such file or directory »

Hello,
Lorsque tu déclares les volumes à monter automatiquement dans fstab, par défaut ils n'apparaissent pas sur le bureau (ce sont les montages de volumes externes qui sont visibles de cette façon).
Normalement, il suffit de parcourir l'arborescence avec ton gestionnaire de fichiers pour aller jusqu'aux fichiers contenus dans ces volumes en suivant le chemin depuis la racine de la structure (/) jusqu'au point de montage (/mnt/UUID ou /media/$USER/UUID).
Cela, bien sûr, à condition que tu ne sois pas empêché d'ouvrir un répertoire système (cas signalé précédemment pour accéder à /mnt = permission refusée). Dans ce cas, il y a effectivement un problème de droits à résoudre pour toi.
Enfin, comme disait moko138, tu peux ensuite créer des marque-pages (raccourcis) pour aller directement à l'emplacement souhaité et aussi, accessoirement, "voir" les volumes dans la partie gauche du gestionnaire de fichiers...
Courage, on va y arriver à force !
smile


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#30 Le 05/12/2017, à 15:45

nubiboros

Re : GIMP répond « no such file or directory »

le système des marques-pages (accessible pour moi par PcManFm) me montre bien mes partitions, mais avec leur nom UUID, qui n'est pas très parlant.
J'ai trouvé dans l'utilitaire Disques de Gnome une case à cocher pour faire apparaître les noms sous la forme Label, c'est à dire explicite.
Thunderbird fonctionne pour le moment, donc tout est provisoirement OK.
Demain, si tout va bien, je déclarerai la discussion close (au fait, comment fait-on pour modifier le titre?)
Merci à tous, cette discussion m'a permis de me familiariser un peu plus avec linux.


RESOLU

Hors ligne

#31 Le 05/12/2017, à 15:57

erresse

Re : GIMP répond « no such file or directory »

Demain, si tout va bien, je déclarerai la discussion close (au fait, comment fait-on pour modifier le titre?)

cf ma signature...

En général, pour éviter le problème de l'UUID comme nom du volume, on préconise de donner un nom (une étiquette) aux partitions du disque, afin que le système les monte avec ce nom en clair au lieu de l'UUID comme point de montage.
Mais cela ne vaut que pour les volumes montés en plug-n-play, puisque ceux montés par fstab n'apparaissent pas sur le bureau.
Par contre, lorsqu'on crée un marque-pages, ne peut-on pas lui donner le nom qu'on veut ?

Dernière modification par erresse (Le 05/12/2017, à 16:01)


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#32 Le 05/12/2017, à 18:27

nubiboros

Re : GIMP répond « no such file or directory »

Je n'ai pas pu renommer les marque-pages (access denied)
Les volumes montés par fstab apparaîssent sur mon bureau.
En fait, au départ, mon problème était avec Gimp, pas fstab. J'ai cru que c'était un problème de montage, car Gimp me disait "no such file or directory", mais en fait c'était Gimp qui était vérolé. Je l'ai désinstallé, puis réinstallé, et ça marche.

Voici mon fstab, il peut intéresser ceux qui comme moi sont en dual-boot :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=9eb0c0a5-4c8f-48d9-9d51-eb70e4f8b568 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw,nofail              0       0
/dev/disk/by-uuid/14F22C1FF22C0796 /mnt/14F22C1FF22C0796 ntfs-3g defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names,x-gvfs-show 0 0
/dev/disk/by-uuid/EC0E56610E5624BC /mnt/EC0E56610E5624BC ntfs-3g defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names,x-gvfs-show 0 0
/dev/disk/by-uuid/8E4C67EE4C67CF8F /mnt/8E4C67EE4C67CF8F ntfs-3g defaults,locale=fr_FR.UTF-8,nofail,uid=1000,gid=1000,windows_names,x-gvfs-show 0 0

On voit que grâce à x-gvfs-show, les partitions s'affichent sur le bureau.


RESOLU

Hors ligne