Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 08/12/2017, à 02:39

Emmnl

GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Bonjour,

Cela fait quelques semaines que je suis passé sous Ubuntu (17.10). Je viens régulièrement voir le forum pour trouver des réponses ou des astuces, c'est la première fois que j'y pose une question. smile

J'essaie de suivre un cours en ligne sur les réseaux qui nécessite l'utilisation de GNS3 0.8.x, ça tombe bien, c'est celle qui est disponible dans les dépôts d'Ubuntu.
Tout fonctionne impeccablement, installation du logiciel (« sudo apt-get install gns3 ») des dépendances, lancement, lien avec une machine virtuelle dedans, création de projets, sauvegardes, manipulation d'objets etc.

Sauf… un plantage systématique. Quand je crée des liens entre deux objets et que je fais un clic droit, le logiciel quitte brusquement. Quand il a été lancé avec le terminal, celui-ci affiche « Erreur de segmentation (core dumped) »
(Il affiche également « libpng warning: iCCP: known incorrect sRGB profile », mais au lancement de l'application et entretemps elle tourne.)

Dans les journaux (via l'application « Journeaux »), je vois les erreurs suivantes :
Window manager warning: Invalid WM_TRANSIENT_FOR window 0x5000004 specified for 0x5000002 (gns3).
Window manager warning: Invalid WM_TRANSIENT_FOR window 0x5000004 specified for 0x5000043 (gns3).
gns3[17835]: segfault at 8 ip 00007f7adb9347c8 sp 00007fffc64d5e48 error 4 in libQtCore.so.4.8.7[7f7adb797000+2e7000]

J'ai fait des recherches sur les différents mots-clés et messages d'erreurs, mais je ne trouve rien de très concluant ou qui s'approche de mon cas de figure.
J'ai juste vu quelque part peut-être un lien avec libqt et Wayland peut-être ? (Mais honnêtement je commence à peine à comprendre tout ça donc je sais pas.)

Est-ce que quelqu'un à une idée de ce que je peux faire ? De ce que je peux regarder (si on m'indique où se trouve les logs intéressants, je suis juste allé trouver les erreurs ci-dessus à tâtons) ?

Merci !

Hors ligne

#2 Le 08/12/2017, à 12:41

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

J'ai essayé sous une session « Ubuntu sur Xorg », j'ai le même comportement.
Il est spécifié que GNS3 doit tourner sur la session d'un utilisateur qui a les droits administrateurs. Je ne sais pas si l'application elle-même doit avoir les droits ni s'il y a quelque chose à faire pour qu'elle les ai (mais l'erreur étant vraiment très spécifique et le reste tournant bien, je suis pas sûr que ce soit ça).

Hors ligne

#3 Le 08/12/2017, à 13:41

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Je vois deux pistes :
  Si le message « Erreur de segmentation (core dumped) » se répète au fil des démarrages et concerne toujours la même libQtCore.so,
alors c'est la libQtCore qui est mal installée ou boguée. Il faut la réinstaller et si son problème persiste, attendre une prochaine mise à jour.

  Si le message « Erreur de segmentation (core dumped) » se répète au fil des démarrages mais concerne (comme chez moi) des bibliothèques changeantes,
alors il est urgent de montrer

sudo smartctl -s on -a /dev/sda

(si ton disque système est à ce moment-là sda).


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#4 Le 08/12/2017, à 13:56

inbox

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Salut,

En complément de la réponse de Moko, voir ce sujet sur le site de GNS3 concernat un "segfault" sous 17.10.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 09/12/2017, à 13:30

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

moko138 a écrit :

Je vois deux pistes :
  Si le message « Erreur de segmentation (core dumped) » se répète au fil des démarrages et concerne toujours la même libQtCore.so,
alors c'est la libQtCore qui est mal installée ou boguée. Il faut la réinstaller et si son problème persiste, attendre une prochaine mise à jour.

  Si le message « Erreur de segmentation (core dumped) » se répète au fil des démarrages mais concerne (comme chez moi) des bibliothèques changeantes,
alors il est urgent de montrer

sudo smartctl -s on -a /dev/sda

(si ton disque système est à ce moment-là sda).

Merci pour ta réponse !

C'est inlassablement la même bibliothèque libQtCore qui est en cause.
Je l'ai désinstallée (sudo apt remove libqtcore4, qui automatiquement retire toute une série d'autres paquets, dont gns3) et réinstallée (et gns3 aussi), sans changement.
Si je comprends bien, c'est tout de même rassurant que ce soit la même. smile

Est-ce un bug qu'il faut remonter quelque part ?

Dernière modification par Emmnl (Le 09/12/2017, à 13:34)

Hors ligne

#6 Le 09/12/2017, à 13:33

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

inbox a écrit :

Salut,

En complément de la réponse de Moko, voir ce sujet sur le site de GNS3 concernat un "segfault" sous 17.10.

A+

Comment pourrais-je vérifier avoir le même conflit (« Apparently, GNS3 was using a shared library installed with pip3 (SIP) when it should be using its own. I fixed it by uninstalling SIP using pip3. ») ? Je ne comprends pas tout. tongue
Est-ce que ce serait une bonne piste de voir si SIP est installé aussi, le désinstaller éventuellement (et comment le réinstaller ensuite si ça n'était pas ça) ?

Merci !

Hors ligne

#7 Le 09/12/2017, à 19:45

inbox

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Je ne suis pas certain, car j'entre en terrain inconnu, mais à priori, "pip3" viendrait du paquet python3-pip.

Si l'on suit ce qui est indiqué, il faut supprimer python3-pip et relancer GNS3...


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#8 Le 10/12/2017, à 01:11

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

inbox a écrit :

Je ne suis pas certain, car j'entre en terrain inconnu, mais à priori, "pip3" viendrait du paquet python3-pip.

Si l'on suit ce qui est indiqué, il faut supprimer python3-pip et relancer GNS3...

OK, merci. Apparemment il n'est même pas installé chez moi, donc s'il y a conflit à cause d'une bibliothèque partagée, ce n'est pas avec ça.

Je ne sais pas s'il y a moyen de voir avec quoi la bibliothèque serait partagée.

Merci pour vos réponses en tous cas. smile

Hors ligne

#9 Le 10/12/2017, à 04:03

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

inbox a écrit :

voir ce sujet sur le site de GNS3 concernat un "segfault" sous 17.10.

Cette page n'affiche que 2 lignes d'en-tête, chez moi. (Et je me refuse à autoriser plus que deux des 112.234 javascripts inclus).
Que dit-elle ?

  - -

Allons-y à tâtons. Que montrent :

apt-cache show pip3* | grep -iE "package|depends|confli" | grep pip3
apt-cache show libqtcore* | grep -iE "package|depends|confli" | grep pip3
apt-cache show python3-pip* | grep -iE "package|depends|confli" | grep pip3

?


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#10 Le 10/12/2017, à 04:28

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

En cherchant avec

"gns3"  libQtCore  segmentation OR segfault OR "core dumped"

on voit que tu n'es pas seul !   Bug déjà signalé en... 2013 !

...et "résolu" en 2013 selon https://bugs.launchpad.net/ubuntu/+sour … ug/1152884 qui dit :

This bug was fixed in the package gns3 - 0.8.6-2

À propos, montre

dpkg -l | grep gns3
cat /etc/apt/sources.list.d/*.list | grep -v ^#

Et peut-être que tu devras ajouter ce ppa :
https://launchpad.net/~gns3/+archive/ubuntu/ppa ?

Dernière modification par moko138 (Le 10/12/2017, à 04:29)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#11 Le 10/12/2017, à 13:38

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

moko138 a écrit :
inbox a écrit :

voir ce sujet sur le site de GNS3 concernat un "segfault" sous 17.10.

Cette page n'affiche que 2 lignes d'en-tête, chez moi. (Et je me refuse à autoriser plus que deux des 112.234 javascripts inclus).
Que dit-elle ?

Le bug a été copié ici : https://github.com/GNS3/gns3-gui/issues/2331
Mais l'erreur ne concerne pas libQtcore apparemment.


moko138 a écrit :

Allons-y à tâtons. Que montrent :

apt-cache show pip3* | grep -iE "package|depends|confli" | grep pip3
apt-cache show libqtcore* | grep -iE "package|depends|confli" | grep pip3
apt-cache show python3-pip* | grep -iE "package|depends|confli" | grep pip3

?

Les trois me renvoient rien.

Hors ligne

#12 Le 10/12/2017, à 13:50

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

moko138 a écrit :

En cherchant avec

"gns3"  libQtCore  segmentation OR segfault OR "core dumped"

on voit que tu n'es pas seul !   Bug déjà signalé en... 2013 !

...et "résolu" en 2013 selon https://bugs.launchpad.net/ubuntu/+sour … ug/1152884 qui dit :

This bug was fixed in the package gns3 - 0.8.6-2

J'ai la version 0.8.7. Par contre le segmentation fault n'apparait pas au lancement de l'application, mais seulement lors d'un clic droit sur certains objets, autrement elle tourne.

moko138 a écrit :

À propos, montre

dpkg -l | grep gns3

Voilà :

ii  gns3                                       0.8.7-2                                                    
all          Graphical Network Simulator
moko138 a écrit :
cat /etc/apt/sources.list.d/*.list | grep -v ^#

Voilà :

deb http://ppa.launchpad.net/certbot/certbot/ubuntu artful main
deb http://ppa.launchpad.net/gns3/ppa/ubuntu artful main
deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu artful main
deb http://ppa.launchpad.net/pbek/qownnotes/ubuntu artful main
moko138 a écrit :

Et peut-être que tu devras ajouter ce ppa :
https://launchpad.net/~gns3/+archive/ubuntu/ppa ?

Lors de la première installation, je ne l'avais pas ajouté. Je l'ai fait par la suite, désinstallé et réinstallé gns3, mais pas de changement.

GNS3 0.8.7 étant relativement ancien et Ubuntu 17.10 récent, je me demande si c'est pas lié aux changements liés à la 17.10, j'aimerais tester sous la 16.04 pour en avoir le cœur net.

(Je vois qu'il y a moyen de faire tourner le logiciel sous VirtualBox (avec VM préconfigurée), donc j'ai une éventuelle solution de secours, même si c'est moins « élégant ».)

Dernière modification par Emmnl (Le 10/12/2017, à 13:58)

Hors ligne

#13 Le 10/12/2017, à 14:06

??

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Bonjour
Il me semble que cette librairie ne fonctionne pas bien non plus en version 16.04 https://github.com/3liz/QuickOSM/issues/84 ( 7e échange en date du 31 juillet ).
commenter les lignes 106 et 107 d'un plugin???

Dernière modification par ?? (Le 10/12/2017, à 14:19)


Inutile de répondre que vous allez faire le plus rapidement possible  l'action qui vous est demandée, vous perdez du temps à répondre, je perds du temps à consulter votre réponse. Pourtant c'est sympathique mais ce n'est pas pratique.
Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Faire un état des lieux Avec https://doc.ubuntu-fr.org/tutoriel/boot-info

Hors ligne

#14 Le 10/12/2017, à 17:03

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Ce commentaire :

robinpaulson commented Aug 11, 2016
If you comment out lines 106 and 107 in
~/.qgis2/python/plugins/QuickOSM/ui/main_window_dialog.py
the plugin appears to work fine;
I haven't 100% tested it. No help though, but you can still navigate to the html files and display them in a proper web browser.

Dernière modification par moko138 (Le 10/12/2017, à 17:18)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#15 Hier à 02:43

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Je n'ai pas ce dossier « ~/.qgis2 ». Je ne sais pas s'il peut être ailleurs ou s'il y a des fichiers similaires autre part.

Hors ligne

#16 Hier à 05:33

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

cd ; ls -la | grep qgis

ne retourne rien ?

  - -

le segmentation fault n'apparait pas au lancement de l'application, mais seulement lors d'un clic droit sur certains objets, autrement elle tourne.

Je ne sais pas l'interpréter, mais ça me paraît important. Peut-être à mettre en rapport avec le commentaire qui voyait plutôt le bug en rapport avec libqtgui.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#17 Hier à 13:00

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

moko138 a écrit :
cd ; ls -la | grep qgis

ne retourne rien ?

Non, vide.


moko138 a écrit :

le segmentation fault n'apparait pas au lancement de l'application, mais seulement lors d'un clic droit sur certains objets, autrement elle tourne.

Je ne sais pas l'interpréter, mais ça me paraît important. Peut-être à mettre en rapport avec le commentaire qui voyait plutôt le bug en rapport avec libqtgui.

L'erreur est effectivement précédée dans les logs de « window manager warnings » (Invalid WM_TRANSIENT_FOR window 0x5000004 specified for 0x5000002).

Hors ligne

#18 Hier à 15:44

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

On reprend au début.
Montre les retours complets de

lsb_release -d; printenv GDMSESSION ; uname -mr
cat /etc/apt/sources.list | grep -v ^#
cat /etc/apt/sources.list.d/*.list | grep -v ^#
sudo apt-get update
sudo apt-get clean ; sudo apt-get autoremove --purge -y
dpkg -l | grep -Ei "gns|qgis"

et sépare bien les retours

comme

ceci.

%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#19 Hier à 23:37

Emmnl

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

moko138 a écrit :

On reprend au début.
Montre les retours complets de

lsb_release -d; printenv GDMSESSION ; uname -mr
cat /etc/apt/sources.list | grep -v ^#
cat /etc/apt/sources.list.d/*.list | grep -v ^#
sudo apt-get update
sudo apt-get clean ; sudo apt-get autoremove --purge -y
dpkg -l | grep -Ei "gns|qgis"

et sépare bien les retours

comme

ceci.

Voilà, dans l'ordre, et j'ai bien mis l'intégral de ce que j'ai dans le terminal (avec la commande) :

emmnl@ORDI:~$ lsb_release -d; printenv GDMSESSION ; uname -mr
Description:	Ubuntu 17.10
ubuntu
4.13.0-19-generic x86_64
emmnl@ORDI:~$ cat /etc/apt/sources.list | grep -v ^#

deb http://be.archive.ubuntu.com/ubuntu/ artful main restricted

deb http://be.archive.ubuntu.com/ubuntu/ artful-updates main restricted

deb http://be.archive.ubuntu.com/ubuntu/ artful universe
deb http://be.archive.ubuntu.com/ubuntu/ artful-updates universe

deb http://be.archive.ubuntu.com/ubuntu/ artful multiverse
deb http://be.archive.ubuntu.com/ubuntu/ artful-updates multiverse

deb http://be.archive.ubuntu.com/ubuntu/ artful-backports main restricted universe multiverse


deb http://security.ubuntu.com/ubuntu artful-security main restricted
deb http://security.ubuntu.com/ubuntu artful-security universe
deb http://security.ubuntu.com/ubuntu artful-security multiverse
deb https://dl.winehq.org/wine-builds/ubuntu/ artful main
emmnl@ORDI:~$ cat /etc/apt/sources.list.d/*.list | grep -v ^#
deb http://ppa.launchpad.net/certbot/certbot/ubuntu artful main
deb http://ppa.launchpad.net/gns3/ppa/ubuntu artful main
deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu artful main
emmnl@ORDI:~$ sudo apt-get update
[sudo] Mot de passe de emmnl : 
Atteint:1 http://ppa.launchpad.net/certbot/certbot/ubuntu artful InRelease
Atteint:2 http://be.archive.ubuntu.com/ubuntu artful InRelease                                          
Atteint:3 http://be.archive.ubuntu.com/ubuntu artful-updates InRelease                                  
Atteint:4 http://be.archive.ubuntu.com/ubuntu artful-backports InRelease                                
Atteint:5 http://ppa.launchpad.net/gns3/ppa/ubuntu artful InRelease                                     
Atteint:6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu artful InRelease                        
Atteint:7 https://dl.winehq.org/wine-builds/ubuntu artful InRelease                                     
Atteint:8 http://security.ubuntu.com/ubuntu artful-security InRelease                           
Lecture des listes de paquets... Fait                          
emmnl@ORDI:~$ sudo apt-get clean ; sudo apt-get autoremove --purge -y
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
emmnl@ORDI:~$ dpkg -l | grep -Ei "gns|qgis"
ii  gns3                                       0.8.7-2                                                    all          Graphical Network Simulator

Hors ligne

#20 Aujourd'hui à 03:31

moko138

Re : GNS3 : plantage avec « Erreur de segmentation (core dumped) »

Parfait !
Toujours séparément :

apt-cache show gns3

et

sudo apt-get dist-upgrade

%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne