Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#26 Le 20/12/2017, à 15:50

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

J' ai donc relancé la cde en la modifiant comme suit :

root@mdu02-Lenovo-G70-70:/home/mdu02# mv /lib/modules/`uname -r`/kernel/drivers/net/ethernet/realtek
mv: opérande de fichier cible manquant après '/lib/modules/4.10.0-42-generic/kernel/drivers/net/ethernet/realtek'
Saisissez « mv --help » pour plus d'informations.

La cde complète doit-être celle-ci :

root@mdu02-Lenovo-G70-70:/home/mdu02# mv /lib/modules/`uname -r`/kernel/drivers/net/ethernet/realtek/r8169.ko ~/r8169.ko.backup

?

Hors ligne

#27 Le 20/12/2017, à 15:56

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

Je ne sais pas te répondre, il faudrait du renfort.

Je mets une autre réponse :

Au message # 25, Fauqui a écrit :

Je préfère détaillé les démarches que j'ai du suivre ça pourrait servir si quelqu'un tombe sur ce topic et rencontre les mêmes problèmes :

$ make clean modules
The program 'make' can be found in the following packages :
*make
*make-guile (You will have to enable component called 'universe')
Try: sudo apt install <selected package>

J'ai donc du faire :

$ sudo apt install make

Sauf que la compilation échoue car GCC n'est pas installé donc :

$ sudo apt install gcc
$ make clean modules

Et voilà la compilation fonctionne.
Je continue.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#28 Le 20/12/2017, à 16:07

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Merci pour votre aide mais là je suis "coincé".
Besoin de renfort (si @fauqui passe par ici).
Merci

Hors ligne

#29 Le 20/12/2017, à 18:00

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

J'ai trouvé un vieux tutoriel > astuces/reseau-ethernet-realtek-rtl8111-8168


Et la Doc > compression_avec_bzip2_tarbz2

Dernière modification par xubu1957 (Le 20/12/2017, à 18:30)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#30 Le 20/12/2017, à 20:29

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

J' avais vu ce tutoriel mais je l' ai trouvé "vieillot", je ne l' ai donc pas suivi.

Hors ligne

#31 Le 21/12/2017, à 07:56

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

Bonjour,

Essayer :

Le 30/04/2016, Adelin a écrit :

Re,

Encore mieux, problème résolu:

http://askubuntu.com/questions/622470/d … untu-14-04

sudo rm /etc/resolv.conf
sudo ln -s ../run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u

Les deux portables marchent maintenant sur le câble en wifi et ethernet.
Merci à toutes les communautés GNU-LINUX d'exister,

Je me suis inspiré des réponses postés sur les forums divers, et ça m'a beaucoup aidé/ appris.

> [RESOLU] Network-Manager pas de connexion câble kubuntu16.04[


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#32 Le 21/12/2017, à 10:41

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Bonjour,
J' ai donc tapé les trois commandes, pas d' erreur.
J' ai relancé le PC. J' ai toujours le problème.

Hors ligne

#33 Le 21/12/2017, à 11:35

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Je cherche à changer de pilote r8169--->r8168.

mdu02@mdu02-Lenovo-G70-70:~$ locate r8169
/lib/modules/4.10.0-28-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/lib/modules/4.10.0-32-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/lib/modules/4.10.0-33-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/lib/modules/4.10.0-37-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/lib/modules/4.10.0-40-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/lib/modules/4.10.0-42-generic/kernel/drivers/net/ethernet/realtek/r8169.ko
/usr/src/linux-headers-4.10.0-28-generic/include/config/r8169.h
/usr/src/linux-headers-4.10.0-32-generic/include/config/r8169.h
/usr/src/linux-headers-4.10.0-33-generic/include/config/r8169.h
/usr/src/linux-headers-4.10.0-37-generic/include/config/r8169.h
/usr/src/linux-headers-4.10.0-40-generic/include/config/r8169.h
/usr/src/linux-headers-4.10.0-42-generic/include/config/r8169.h

En autre, je m' aperçois que j' ai plusieurs noyaux d' installés.

Hors ligne

#34 Le 21/12/2017, à 11:38

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

Fournis le noyau actif :

uname -a

et les noyaux présents :

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#35 Le 21/12/2017, à 11:46

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

mdu02@mdu02-Lenovo-G70-70:~$ uname -a
Linux mdu02-Lenovo-G70-70 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
mdu02@mdu02-Lenovo-G70-70:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-headers-4.10.0-28              4.10.0-28.32~16.04.2
ii  linux-image-extra-4.10.0-28-generic  4.10.0-28.32~16.04.2
ii  linux-headers-4.10.0-28-generic      4.10.0-28.32~16.04.2
ii  linux-image-4.10.0-28-generic        4.10.0-28.32~16.04.2
ii  linux-headers-4.10.0-32              4.10.0-32.36~16.04.1
ii  linux-image-extra-4.10.0-32-generic  4.10.0-32.36~16.04.1
ii  linux-headers-4.10.0-32-generic      4.10.0-32.36~16.04.1
ii  linux-image-4.10.0-32-generic        4.10.0-32.36~16.04.1
ii  linux-headers-4.10.0-33              4.10.0-33.37~16.04.1
ii  linux-image-extra-4.10.0-33-generic  4.10.0-33.37~16.04.1
ii  linux-headers-4.10.0-33-generic      4.10.0-33.37~16.04.1
ii  linux-image-4.10.0-33-generic        4.10.0-33.37~16.04.1
ii  linux-headers-4.10.0-37              4.10.0-37.41~16.04.1
ii  linux-image-extra-4.10.0-37-generic  4.10.0-37.41~16.04.1
ii  linux-headers-4.10.0-37-generic      4.10.0-37.41~16.04.1
ii  linux-image-4.10.0-37-generic        4.10.0-37.41~16.04.1
ii  linux-headers-4.10.0-40              4.10.0-40.44~16.04.1
ii  linux-image-extra-4.10.0-40-generic  4.10.0-40.44~16.04.1
ii  linux-headers-4.10.0-40-generic      4.10.0-40.44~16.04.1
ii  linux-image-4.10.0-40-generic        4.10.0-40.44~16.04.1
ii  linux-generic-hwe-16.04              4.10.0.42.44
ii  linux-headers-generic-hwe-16.04      4.10.0.42.44
ii  linux-image-generic-hwe-16.04        4.10.0.42.44
ii  linux-headers-4.10.0-42              4.10.0-42.46~16.04.1
ii  linux-image-extra-4.10.0-42-generic  4.10.0-42.46~16.04.1
ii  linux-headers-4.10.0-42-generic      4.10.0-42.46~16.04.1
ii  linux-image-4.10.0-42-generic        4.10.0-42.46~16.04.1

Hors ligne

#36 Le 21/12/2017, à 11:59

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

Pour dégager les noyaux anciens, en suivant la Doc > kernel#suppression_des_anciens_noyaux

sudo apt-get autoremove --purge

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#37 Le 21/12/2017, à 15:45

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Après avoir fait le "ménage":

mdu02@mdu02-Lenovo-G70-70:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-headers-4.10.0-40              4.10.0-40.44~16.04.1
ii  linux-image-extra-4.10.0-40-generic  4.10.0-40.44~16.04.1
ii  linux-headers-4.10.0-40-generic      4.10.0-40.44~16.04.1
ii  linux-image-4.10.0-40-generic        4.10.0-40.44~16.04.1
ii  linux-generic-hwe-16.04              4.10.0.42.44
ii  linux-headers-generic-hwe-16.04      4.10.0.42.44
ii  linux-image-generic-hwe-16.04        4.10.0.42.44
ii  linux-headers-4.10.0-42              4.10.0-42.46~16.04.1
ii  linux-image-extra-4.10.0-42-generic  4.10.0-42.46~16.04.1
ii  linux-headers-4.10.0-42-generic      4.10.0-42.46~16.04.1
ii  linux-image-4.10.0-42-generic        4.10.0-42.46~16.04.1

Hors ligne

#38 Le 21/12/2017, à 18:28

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

Dans le fil de Mylano > Plus d'internet après la mise à jour, il est mentionné dans un des liens, un pilote r8168-dkms for Ubuntu .

J'ai cherché le pilote pour la version 17.04 > launchpad.net/ubuntu/+source/r8168/8.043.02-1.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#39 Le 21/12/2017, à 22:43

xubu1957

Re : [RESOLU] Je n'ai plus de connection filaire.

J'ai trouvé un tutoriel plus récent > how-to-get-your-realtek-rtl8111rtl8168-working-updated-guide


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#40 Le 22/12/2017, à 10:18

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

xubu1957 a écrit :

Dans le fil de Mylano > Plus d'internet après la mise à jour, il est mentionné dans un des liens, un pilote r8168-dkms for Ubuntu .

J'ai cherché le pilote pour la version 17.04 > launchpad.net/ubuntu/+source/r8168/8.043.02-1.

Je suis sous une version 16.04.

Hors ligne

#41 Le 22/12/2017, à 10:25

michel_04

Re : [RESOLU] Je n'ai plus de connection filaire.

Bonjour,

mdu a écrit :

Je suis sous une version 16.04.

Oui, mais avec un noyau issu de 17.04.

mdu a écrit :
mdu02@mdu02-Lenovo-G70-70:~$ uname -a
Linux mdu02-Lenovo-G70-70 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

A+

En ligne

#42 Le 22/12/2017, à 10:26

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

xubu1957 a écrit :

J'ai trouvé un tutoriel plus récent > how-to-get-your-realtek-rtl8111rtl8168-working-updated-guide

[…] WARNING: This post is really old and it happens that it doesn’t work with newer Kernels ( >= 4.0). You should check out my new article if you want to install the driver for your RTL8111/RTL8168.

Cette procédure n' est pas valable pour une version >=4.0

Hors ligne

#43 Le 22/12/2017, à 10:28

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

michel_04 a écrit :

Bonjour,

mdu a écrit :

Je suis sous une version 16.04.

Oui, mais avec un noyau issu de 17.04.

mdu a écrit :
mdu02@mdu02-Lenovo-G70-70:~$ uname -a
Linux mdu02-Lenovo-G70-70 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

A+

Ok et merci pour l' info.

Hors ligne

#44 Le 22/12/2017, à 15:19

moko138

Re : [RESOLU] Je n'ai plus de connection filaire.

mdu a écrit :
xubu1957 a écrit :

Pour ce noyau copié de la version 17.04, regarde > Anomalies réseaux en Ethernet et Wifi sur la version 17.04

mdu02@mdu02-Lenovo-G70-70:~$ sudo nano /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

Le fichier est vide.

mdu,
il n'y a aucun rapport entre ta réponse et le lien de xubu1957.
Alors, lis-le et applique-le
.

Erreur de ma part, voir ci-dessous.

Dernière modification par moko138 (Le 23/12/2017, à 08:55)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#45 Le 22/12/2017, à 15:57

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Le lien de @xubu1957 (perte de réseau filaire) me dirige vers : https://mementolinux.wordpress.com/2017 … 4-dubuntu/

Dernière modification par mdu (Le 22/12/2017, à 15:58)

Hors ligne

#46 Le 23/12/2017, à 08:54

moko138

Re : [RESOLU] Je n'ai plus de connection filaire.

Mille excuses, mdu !
C'est moi qui avais zappé le mot "filaire".  sad


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#47 Le 23/12/2017, à 10:45

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

moko138 a écrit :

Mille excuses, mdu !
C'est moi qui avais zappé le mot "filaire".  sad

Bonjour, pas de problème, je regarde ton lien.
Merci.

Hors ligne

#48 Le 23/12/2017, à 10:49

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

J' ai déjà essayé de suivre cette procédure mais la première commande

mdu02@mdu02-Lenovo-G70-70:~$ sudo nano /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

me donne un fichier vide.

Hors ligne

#49 Le 23/12/2017, à 13:23

moko138

Re : [RESOLU] Je n'ai plus de connection filaire.

Oui, j'avais vu, mais je ne suis pas un spécialiste de la connexion-réseau et j'ignore s'il faut créer ce fichier (ce qui serait très facile) ou s'il faut au contraire en déduire que le tuto n'est pas assez sûr.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#50 Le 23/12/2017, à 14:26

mdu

Re : [RESOLU] Je n'ai plus de connection filaire.

Le 13/07/2014, maffpool a écrit :

    Problème résolu !!!

    Driver r8169 en cause, il faut télécharger et compiler le r8168.
    Solution complète trouvée sur ce thread : http://ubuntuforums.org/showthread.php?t=1022411

Je vais suivre cette procédure en modifiant le chemin où ce trouve le r8169.
Je détaille la procédure :

mdu02@mdu02-Lenovo-G70-70:~$ lsmod | grep r816
r8169                  81920  0
mii                    16384  1 r8169
mdu02@mdu02-Lenovo-G70-70:~$ lspci -v
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
        Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        Flags: bus master, fast devsel, latency 0, IRQ 44
        I/O ports at 3000 [size=256]
        Memory at c0504000 (64-bit, non-prefetchable) [size=4K]
        Memory at c0500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169
mdu02@mdu02-Lenovo-G70-70:~$ sudo rmmod r8169
[sudo] Mot de passe de mdu02 :
mdu02@mdu02-Lenovo-G70-70:~$ sudo mv /lib/modules/`uname -r`/kernel/drivers/net/ethernet/realtek/r8169.ko ~/r8169.ko.backup
mdu02@mdu02-Lenovo-G70-70:~$ 
mdu02@mdu02-Lenovo-G70-70:~/Téléchargements$ bzip2 -d 0010-r8168-8.045.08.tar.bz2
mdu02@mdu02-Lenovo-G70-70:~/Téléchargements$
mdu02@mdu02-Lenovo-G70-70:~/Téléchargements$ tar -xf 0010-r8168-8.045.08.tar
mdu02@mdu02-Lenovo-G70-70:~/Téléchargements$
mdu02@mdu02-Lenovo-G70-70:~/Téléchargements$ cd 0010-r8168-8.045.08
bash: cd: 0010-r8168-8.045.08: Aucun fichier ou dossier de ce type

Et là çà "coince"...

Hors ligne