Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/01/2018, à 09:44

minizebr95

Serveur VPS : page blanche

Bonjour,

J'ai loué un serveur VPS chez arubacloud. J'ai monté un Wordpress dessus et j'ai fait quelques manip, sauf qu'après en touchant aux hôtes virtuels et à des commandes apache, le serveur me renvoie systématiquement une page blanche :

Voici l'ip du serveur :
http://94.177.236.250/

Entre temps j'ai envoyé des tickets à leur service technique qui m'a conseillé de réinistialiser via leur interface, ce que j'ai fait en changeant carrément le système de centOS vers Ubuntu mais c'est toujours pareil.

Vous auriez une idée pour me venir en aide à réinstaller le serveur au propre ?


Je pose plein de questions

Hors ligne

#2 Le 16/01/2018, à 11:50

elcastor

Re : Serveur VPS : page blanche

Bonjour,

c'est manifestement lié aux "quelques manips" que tu as faites ^^.
comment as-tu défini tes hôtes virtuels ? As-tu activé le ou les sites via a2ensite et redémarré Apache ?

Hors ligne

#3 Le 16/01/2018, à 18:47

minizebr95

Re : Serveur VPS : page blanche

Bonjour,

C'était un serveur centOS et j'avais suivi ce tutoriel en ligne pour les hôtes virtuels :

J'ai réinstallé Apache et ça fonctionne, j'ai aussi installé PHP mais apparemment il y a toujours un soucis : http://94.177.236.250/blog/wordpress/wp … nstall.php

error : php not running

php -v

root@kkwetsukre:~# php -v
PHP 7.0.22-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.22-0ubuntu0.16.04.1, Copyright (c) 1999-2017, by Zend Technologies

Je pose plein de questions

Hors ligne

#4 Le 16/01/2018, à 19:00

bruno

Re : Serveur VPS : page blanche

Ce qui montre que PHP en ligne de commande fonctionne, mais est-ce que le module Apache est installé ?

apt install libapache2-mod-php

Hors ligne

#5 Le 16/01/2018, à 19:14

minizebr95

Re : Serveur VPS : page blanche

bruno a écrit :

Ce qui montre que PHP en ligne de commande fonctionne, mais est-ce que le module Apache est installé ?

apt install libapache2-mod-php

Bin du coup ça fonctionne sauf

Votre installation PHP ne dispose pas de MySQL. Extension requise pour WordPress.

J'ai essayé

root@kkwetsukre:/# sudo apt install mysql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
mysql-server is already the newest version (5.7.20-0ubuntu0.16.04.1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-104 linux-headers-4.4.0-104-generic
  linux-headers-4.4.0-91 linux-headers-4.4.0-91-generic
  linux-image-4.4.0-104-generic linux-image-4.4.0-91-generic
  linux-image-extra-4.4.0-104-generic linux-image-extra-4.4.0-91-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Mais toujours pas neutral


Je pose plein de questions

Hors ligne

#6 Le 16/01/2018, à 19:51

krodelabestiole

Re : Serveur VPS : page blanche

tu as essayé de suivre cette doc : https://doc.ubuntu-fr.org/lamp ?

Hors ligne

#7 Le 16/01/2018, à 19:57

krodelabestiole

Re : Serveur VPS : page blanche

je demande ça parce que là il manque le paquet php-mysql, mais ça ira plus vite que tu tapes simplement les 2 lignes de commande de la doc, plutôt qu'on te dise un par un quel paquet installer pour résoudre l'erreur que tu rencontres à chaque fois (et au final avoir un wordpress bancal, sans les extensions PHP appropriées).

Hors ligne

#8 Le 16/01/2018, à 20:38

minizebr95

Re : Serveur VPS : page blanche

Non je n'ai pas essayé comme ça. Là j'ai entré

sudo apt install apache2 php mysql-server libapache2-mod-php php-mysql

Comme indiqué dans la doc
Et je vois une ligne :

mysql-server is already the newest version (5.7.20-0ubuntu0.16.04.1).

Et j'obtiens toujours cette erreur :

Votre installation PHP ne dispose pas de MySQL. Extension requise pour WordPress.

Je pose plein de questions

Hors ligne

#9 Le 16/01/2018, à 20:47

bruno

Re : Serveur VPS : page blanche

Essaie :

sudo a2enmod mysqli
sudo a2enmod pdo_mysql
sudo systemctl restart apache2

Hors ligne

#10 Le 16/01/2018, à 22:24

krodelabestiole

Re : Serveur VPS : page blanche

visiblement MySQL était déjà installé.

assures toi aussi de ne pas avoir plusieurs versions de PHP installées : https://doc.ubuntu-fr.org/lamp#plusieur … ultanement
si ton apache n'utilise pas la version de PHP officielle de ta distro, ça causera par ex. ce message d'erreur relatif au module php-mysql

donc :

apt list php* | grep install

Hors ligne

#11 Le 17/01/2018, à 09:01

minizebr95

Re : Serveur VPS : page blanche

Merci, tout est OK, smile

K'en reprends à mes hôtes virtuels. smile Mon objectif est de diviser le VPS de telle sorte qu'un seul serveur puisse donner plusieurs sites différents. J'ai déjà un site dans /var/www/html sur le serveur (pour tester).

J'ai décidé de suivre cette doc :  https://doc.ubuntu-fr.org/tutoriel/virt … ec_apache2 peut-être une erreur car on parle d'hôtes "virtuels" mais bref, j'essaie :


root@kkwetsukre:/etc/apache2/sites-enabled# sudo vi /etc/hosts
127.0.0.1       localhost
127.0.1.1       ubuntu
94.177.236.250  cryptozero.cloud
<VirtualHost *:80>
	ServerAdmin terrence@cryptozero.cloud
	ServerName cryptozero.cloud
	ServerAlias www.cryptozero.cloud
	
	DocumentRoot /var/www/html/cryptozero
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	
	<Directory /var/www/html/cryptozero>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Pour l'instant mon domaine continue de pointer vers la racine d'Apache comme vous pouvez le constater :

http://cryptozero.cloud/

Je demande un peu d'aide encore smile


Je pose plein de questions

Hors ligne

#12 Le 17/01/2018, à 12:01

elcastor

Re : Serveur VPS : page blanche

Bonjour,

comme dans le bas de la page que tu as indiqué, as-tu configuré tes hôtes virtuels ?
par exemple dans un fichier cryptozero.conf avec son chargement par  a2ensite et releaod d'apache ?

Manifestement, ton serveur fonctionne bien mais ne redirige rien. (Et je supprimerais également ta ligne dans /etc/hosts)

Hors ligne

#13 Le 17/01/2018, à 12:37

minizebr95

Re : Serveur VPS : page blanche

Bonjour, j'ai fait ceci :

root@kkwetsukre:/etc/apache2/sites-available# ls -ila
total 48
263702 drwxr-xr-x 2 root root  4096 Jan 17 07:48 .
263566 drwxr-xr-x 8 root root  4096 Jan 17 10:14 ..
263703 -rw------- 1 root root 12288 Jan 17 07:18 .default.swo
262063 -rw------- 1 root root 12288 Jan 16 20:07 .default.swp
264120 -rw-r--r-- 1 root root  1332 Jan 17 07:14 000-default.conf
264121 -rw-r--r-- 1 root root  1099 Jan 17 07:48 cryptozero.conf
263704 -rw-r--r-- 1 root root  6338 Apr  5  2016 default-ssl.conf
root@kkwetsukre:/etc/apache2/sites-available# 

Il y a bien un fichier cryptozero.conf qui contient cela :

<VirtualHost *:80>
	ServerAdmin terrence@cryptozero.cloud
	ServerName cryptozero.cloud
	ServerAlias www.cryptozero.cloud
	
	DocumentRoot /var/www/html/cryptozero
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	
	<Directory /var/www/html/cryptozero>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
root@kkwetsukre:/etc# cd /etc/apache2/sites-available/
root@kkwetsukre:/etc/apache2/sites-available# ls -ila
total 48
263702 drwxr-xr-x 2 root root  4096 Jan 17 07:48 .
263566 drwxr-xr-x 8 root root  4096 Jan 17 10:14 ..
263703 -rw------- 1 root root 12288 Jan 17 07:18 .default.swo
262063 -rw------- 1 root root 12288 Jan 16 20:07 .default.swp
264120 -rw-r--r-- 1 root root  1332 Jan 17 07:14 000-default.conf
264121 -rw-r--r-- 1 root root  1099 Jan 17 07:48 cryptozero.conf
263704 -rw-r--r-- 1 root root  6338 Apr  5  2016 default-ssl.conf
root@kkwetsukre:/etc/apache2/sites-available# sudo vi cryptozero.conf 
root@kkwetsukre:/etc/apache2/sites-available# cd /etc/apache2/sites-enabled/
root@kkwetsukre:/etc/apache2/sites-enabled# ls
000-default.conf  cryptozero.conf
root@kkwetsukre:/etc/apache2/sites-enabled# sudo a2ensite cryptozero.conf
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "en_US:en",
	LC_ALL = (unset),
	LC_PAPER = "fr_FR.UTF-8",
	LC_ADDRESS = "fr_FR.UTF-8",
	LC_MONETARY = "fr_FR.UTF-8",
	LC_NUMERIC = "fr_FR.UTF-8",
	LC_TELEPHONE = "fr_FR.UTF-8",
	LC_IDENTIFICATION = "fr_FR.UTF-8",
	LC_MEASUREMENT = "fr_FR.UTF-8",
	LC_TIME = "fr_FR.UTF-8",
	LC_NAME = "fr_FR.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
Site cryptozero already enabled
root@kkwetsukre:/etc/apache2/sites-enabled# 

Je ne vois pas où j'ai pu me planter j'ai tout suivi à la lettre. sad smile


Je pose plein de questions

Hors ligne

#14 Le 17/01/2018, à 12:45

bruno

Re : Serveur VPS : page blanche

Tu peux donner le contenu de 000-default.conf ?

Ton hôte virtuel semble correct mais inutilement compliqué, pour Ubuntu 16.04, ceci est suffisant :
(tu as visiblement suivi un tuto obsolète)


<VirtualHost *:80>
	ServerAdmin terrence@cryptozero.cloud
	ServerName cryptozero.cloud
	ServerAlias [url=http://www.cryptozero.cloud]www.cryptozero.cloud[/url]
	
	DocumentRoot /var/www/html/cryptozero
	
	<Directory /var/www/html/cryptozero>
		Options +Indexes +FollowSymLinks +MultiViews
		AllowOverride None
		Require all granted
	</Directory>

	# logs : il est préférable d'avoir des logs séparés pour les différents vhosts, à ajuster donc…
        ErrorLog /var/log/apache2/error.log
	LogLevel warn
	CustomLog /var/log/apache2/access.log combined
</VirtualHost>

Dernière modification par bruno (Le 17/01/2018, à 12:46)

Hors ligne

#15 Le 17/01/2018, à 13:35

minizebr95

Re : Serveur VPS : page blanche

Ça a l'air de fonctionner : :http://cryptozero.cloud mais pas sur l'alias http://www.cryptozero.coud
Faudrait-il que j'enregistre le www. comme un sous-domaine dans mon interface d'hébergement (enregistrement A ou quelque chose comme ça) ou bien est-ce dû à une erreur / oubli de configuration ?


Je pose plein de questions

Hors ligne

#16 Le 17/01/2018, à 13:57

krodelabestiole

Re : Serveur VPS : page blanche

minizebr95 a écrit :

J'ai décidé de suivre cette doc :  https://doc.ubuntu-fr.org/tutoriel/virt … ec_apache2 peut-être une erreur car on parle d'hôtes "virtuels"

non il s'agit bien d'hôtes virtuels (rien à voir avec les VM) malheureusement ce tuto est obsolète. il faudrait le mettre à jour.

Hors ligne

#17 Le 17/01/2018, à 14:49

bruno

Re : Serveur VPS : page blanche

Oui il faut que tu aies un enregistrement DNS pour www.crptozero.cloud (de préférence un A, mais tu peux aussi utiliser un CNAME)

Hors ligne

#18 Le 18/01/2018, à 09:19

minizebr95

Re : Serveur VPS : page blanche

Bonjour. D'accord. smile

Je me pose une autre question, j'ai voulu installer phpmyadmin avec

sudo apt-get install phpmyadmin

Dans la doc ubuntu il est dit que pma serait accessible à localhost/pma, soit dans mon cas http://94.177.236.250/phpmyadmin mais rien. sad


Je pose plein de questions

Hors ligne

#19 Le 18/01/2018, à 11:18

elcastor

Re : Serveur VPS : page blanche

re-

perso je te déconseille très fortement de mettre phpmyadmin en frontal sur l'internet...

Hors ligne

#20 Le 18/01/2018, à 12:32

bruno

Re : Serveur VPS : page blanche

Tu as bien répondu aux questions posées lors de l'installation de phpmyadmin (voir la doc https://doc.ubuntu-fr.org/phpmyadmin) ?

Si ce n'est pas le cas, le plus simple et de refaire l'installation :

sudo apt purge phpmyadmin
sudo apt install phpmyadmin

@elcastor : évidemment il y a toujours un risque à mettre phpmyadmin en accès public, mais avec quelques précautions simple le risque est quasi nul :
- mot de passe fort ;
- si possible accès en HTTPS uniquement ;
- si possible restriction d'accès par IP.

Hors ligne

#21 Le 27/01/2018, à 06:57

minizebr95

Re : Serveur VPS : page blanche

Bonjour,

pour PHPmyadmin j'ai ceci :

Configuring phpmyadmin ├─────────────────────────┐  
 │                                                                           │  
 │ An error occurred while installing the database:                             
 │                                                                              
 │ mysql said: mysql: [Warning] mysql: Empty value for 'port' specified.        
 │ Will throw an error in future versions ERROR 1045 (28000): Access denied     
 │ for user 'phpmyadmin'@'localhost' (using password: YES) . Your options       
 │ are:                                                                         
 │  * abort - Causes the operation to fail; you will need to downgrade,         
 │    reinstall, reconfigure this package, or otherwise manually intervene      
 │    to continue using it. This will usually also impact your ability to       
 │    install other packages until the installation failure is resolved.        
 │  * retry - Prompts once more with all the configuration questions            
 │    (including ones you may have missed due to the debconf priority           
 │    setting) and makes another attempt at performing the operation.           
 │                                                                              
 │                                  <Ok>                                        
 │                                                                     

Dernière modification par minizebr95 (Le 29/01/2018, à 11:02)


Je pose plein de questions

Hors ligne

#22 Le 03/02/2018, à 10:53

minizebr95

Re : Serveur VPS : page blanche

J'ai résolu ce problème en donnant la valeur '0' pour le port dans le fichier /etc/dbconfig-common/phpmyadmin.conf
Maintenant j'ai ça :

ERROR 1045 (28000): Access denied for user 'phpmyadmin'@'localhost'     

Ce que je ne comprends pas c'est que dans le wizard je ne donne pas "phpmyadmin" comme identifiant, si je comprends bien cette erreur...


Je pose plein de questions

Hors ligne

#23 Le 03/02/2018, à 11:38

bruno

Re : Serveur VPS : page blanche

Effectivement il ya avait ce bug : https://bugs.launchpad.net/ubuntu/+sour … ug/1563274 mais c'est censé être résolu depuis des mois (depuis mysql-server-5.7.11). Est-ce que tu utilises bien une 16.04 avec des paquets à jour ?

Le contournement du bug est plutôt étrange, il vaudrait mieux mettre le port standard de mysql 3306. Et attention parce que dbconfg-common est susceptible d'être utilisé par d'autres paquets, donc futurs problèmes en perspective…

Dernière modification par bruno (Le 04/02/2018, à 11:43)

Hors ligne

#24 Le 04/02/2018, à 11:37

minizebr95

Re : Serveur VPS : page blanche

Je ne sais pas de quels paquets tu parles ni comment savoir s'ils sont à jour. En ce qui concerne mon (nouveau) problème pour PHPMyAdmin, je pense que si je n'arrive pas à l'installer (je n'arrive pas à résoudre mon problème ni à obtenir aucun support ici ou ailleurs) je devrais utiliser SQL en ligne de commandes... smile

Je crois que maintenant mon problème se concentre plutôt sur Laravel vu que j'essaie de déposer un site codé avec ce framework. J'ai envie de dire, tant pis pour PMA, si je peux tout faire via le terminal c'est aussi bien...

Dernière modification par minizebr95 (Le 04/02/2018, à 11:46)


Je pose plein de questions

Hors ligne

#25 Le 04/02/2018, à 11:49

bruno

Re : Serveur VPS : page blanche

Quand on loue un serveur dédié il faut avoir un minimum de compétences en administration système. Savoir faire une mise à jour des dépôts et des paquets installés c'est indispensable (au moins pour les mises à jour de sécurité) !

phpmyadmin c'est juste une interface web pour visualiser et éventuellement créer/modifier les bases de données MySQL. La ligne de commande mysql c'est le moyen le plus rapide et le plus efficace pour les opérations sur les bases de données.

Hors ligne