Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/01/2018, à 13:22

yaujard

Règlage impossible des vitesses de ventilos

Bonjour,
je précise d'abord que je suis assez novice d'Ubuntu, mais ce site et ce forum sont bien faits et permettent d'avancer dans la compréhension des problèmes rencontrés.
Bon, ces jours-ci je bute sur un problème de réglage de vitesse des ventilos, tout cela en lien avec cette page de la doc.

Tout d'abord, j'ai essayé de suivre les manips indiquées dans la doc : précédemment, mes ventilos tournaient trop haut en permanence, je crois à cause d'une température détectée anormalement trop haute de ma carte graphique.
Et cela c'était même sans lancer de gros jeu, film, ou autre... La carte graphique n'est d'ailleurs jamais à une température abusive, selon les capteurs (selon le programme psensor, j'ai des temp de 15 à 60°C environ selon les composants).

J'ai donc essayé de détecter les capteurs

sudo sensors-detect

puis de réguler ma vitesse de ventilo via fancontrol, mais depuis les ventilos font n'importe quoi : se lancent à vitesse max dès qu'une page web charge un peu lentement, notamment.
Si j'essaye de relancer "sudo pwmconfig" dans un terminal, il m'affiche :

File /var/run/fancontrol.pid exists. This typically means that the
fancontrol deamon is running. You should stop it before running pwmconfig.
If you are certain that fancontrol is not running, then you can delete
/var/run/fancontrol.pid manually.

Et sinon, la commande "sudo service kmod start" donne :

Job for systemd-modules-load.service failed because the control process exited with error code. See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

Je suis perdu dans tout ça... Merci par avance pour votre aide.

Dernière modification par yaujard (Le 16/04/2018, à 09:52)


Ubuntu 16.04.03 LTS
Acer Predator | AMD Athlon(tm) II X4 645 Processor × 4 | 16GB RAM

Hors ligne

#2 Le 22/01/2018, à 13:50

thegamer94400

Re : Règlage impossible des vitesses de ventilos

Pour sensors detect tu peux arrêter le démon en faisant la commande

sudo kill sensors-detect

Passionné d'informatique et de photographie. J'essaie d'utiliser le plus possible linux
Mon site photo : http://alexandrejublotphotographie.website

Hors ligne

#3 Le 22/01/2018, à 14:24

yaujard

Re : Règlage impossible des vitesses de ventilos

Merci de la réponse, j'ai essayé mais...
1- il me donne :

kill: échec de l'analyse de l'argument: 'sensors-detect'

2- et pourquoi arrêter la détection des capteurs ?


Ubuntu 16.04.03 LTS
Acer Predator | AMD Athlon(tm) II X4 645 Processor × 4 | 16GB RAM

Hors ligne

#4 Le 22/01/2018, à 14:28

yaujard

Re : Règlage impossible des vitesses de ventilos

Je pense plutôt que le problème vienne de la config de fancontrol, non ?

En l’occurrence j'ai un fichier /etc/fancontrol qui a l'air d'être le fichier de config généré par pwmconfig, il contient :

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=1
DEVPATH=hwmon0= hwmon1=devices/pci0000:00/0000:00:02.0/0000:01:00.0
DEVNAME=hwmon0=acpitz hwmon1=nouveau
FCTEMPS=hwmon1/pwm1=hwmon0/temp1_input
FCFANS=hwmon1/pwm1=hwmon1/fan1_input
MINTEMP=hwmon1/pwm1=20
MAXTEMP=hwmon1/pwm1=50
MINSTART=hwmon1/pwm1=150
MINSTOP=hwmon1/pwm1=0

Si c'est la bonne piste, est-ce que je ne modifierais pas les valeurs manuellement ? Mais en trouvant le bon réglage sans mettre en danger de surchauffe mon pc, bien sûr.
Qu'en pensez-vous ?


Ubuntu 16.04.03 LTS
Acer Predator | AMD Athlon(tm) II X4 645 Processor × 4 | 16GB RAM

Hors ligne

#5 Le 22/01/2018, à 15:53

thegamer94400

Re : Règlage impossible des vitesses de ventilos

Supprime ton fichier /var/run/fan control.pid afin de redémarrer sensors detect proprement


Passionné d'informatique et de photographie. J'essaie d'utiliser le plus possible linux
Mon site photo : http://alexandrejublotphotographie.website

Hors ligne

#6 Le 22/01/2018, à 16:40

yaujard

Re : Règlage impossible des vitesses de ventilos

Ok c'est fait,
j'ai ensuite relancé sensors detect, accepté l'ajout automatique des lignes au fichier de config,
mais après aoir entré la commande "sudo service kmod start", j'ai encore le message d'erreur :

Job for systemd-modules-load.service failed because the control process exited with error code. See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

En même temps, le ventilo ne s'emballe plus. Peut-être est-ce résolu. C'est à n'y rien comprendre...
Merci pour tes réponses successives.


Ubuntu 16.04.03 LTS
Acer Predator | AMD Athlon(tm) II X4 645 Processor × 4 | 16GB RAM

Hors ligne

#7 Le 16/04/2018, à 10:06

yaujard

Re : Règlage impossible des vitesses de ventilos

Je relance ce sujet de forum car je bute sur ce problème.
Je n'arrive pas à configurer fancontrol de manière à limiter la vitesse de les ventilateurs : elle s'emballe complètement dès qu'une page internet met un peu de temps à charger, par exemple. C'est réellement gênant...

L'éxecution de "sudo pwmconfig" n'a pas d'effet sur les ventilos... la commande me donne :

# pwmconfig revision 6243 (2014-03-20)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following devices:
   hwmon0 is acpitz
   hwmon1 is nouveau
   hwmon2 is k10temp

Found the following PWM controls:
   hwmon1/pwm1           current value: 25

Giving the fans some time to reach full speed...
Found the following fan sensors:
   hwmon1/fan1_input     current speed: 1650 RPM

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue:      

Testing pwm control hwmon1/pwm1 ...
  hwmon1/fan1_input ... speed was 1650 now 1650
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon1/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n

Une précision, sur cette page de la doc, je ne suis pas arrivé à effectuer la configuration de "sensors" (le point 2.2), notamment car le site "lmsensors.org" n'est plus en ligne, donc impossibilité de mener à bien la configuration...

Merci par avance pour votre aide. C'est le flou et c'est bien embêtant.


Ubuntu 16.04.03 LTS
Acer Predator | AMD Athlon(tm) II X4 645 Processor × 4 | 16GB RAM

Hors ligne