Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/03/2018, à 11:33

NKNX

OMV-NAS Probleme de dique.

Bonjour a tous.


Je pose mon problème ici au cas ou ... Mais si mon sujet n'a rien a faire ici , pas de soucie smile

J'ai un soucie sur mon nas qui tourne sous OMV. quand je démarre mon système, pas de souci, tout fonctionne.J'utilise des services comme PLEX, SMB, TRANSMISSION, ect...
Puis au bout de quelques heures ( environ 6/8h ) je perd l'acces a un de mes disques, celui ou il y a tout les médias..
Mon disque media s’appelle "4T"  (4 to) et il est en NTFC, je sais pas si cela peut posé problème.
Sur l'interface web d'OMV , j'ai le message d’erreur :

Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; df -PT '/srv/dev-disk-by-label-4T' 2>&1' with exit code '1': df: '/srv/dev-disk-by-label-4T': Transport endpoint is not connected

et en detail :

Erreur #0:
exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; df -PT '/srv/dev-disk-by-label-4T' 2>&1' with exit code '1': df: '/srv/dev-disk-by-label-4T': Transport endpoint is not connected' in /usr/share/php/openmediavault/system/process.inc:175
Stack trace:
#0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(620): OMV\System\Process->execute(Array)
#1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(132): OMV\System\Filesystem\Filesystem->getStatistics()
#2 [internal function]: OMVRpcServiceFileSystemMgmt->enumerateFilesystems(NULL, Array)
#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
#4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(288): OMV\Rpc\ServiceAbstract->callMethod('enumerateFilesy...', NULL, Array)
#5 [internal function]: OMVRpcServiceFileSystemMgmt->getList(Array, Array)
#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
#7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
#8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getList', Array, Array, 1)
#9 {main}


J'aimerai savoir si la déconnexion est réel (HDD) ou alors dans OMV.

Dans quel fichier .log je peux voir ceci ?

Dans tous les cas je remercie la communauté car, vous m'avez sauvé quelques fois smile
NKNX


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 03/03/2018, à 12:12)

Hors ligne

#2 Le 03/03/2018, à 11:36

NKNX

Re : OMV-NAS Probleme de dique.

j'ai oublier de précisé mais quand je reboot, je récupére la connexion avec mon dique sans problème...

et voici ce que j'ai trouvé avec fdisk:

Disk /dev/sdc: 3,7 TiB, 4000787030016 bytes, 7814037168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 5E056F10-3B65-4780-BA86-366E7C7C65C2

Device      Start        End    Sectors  Size Type
/dev/sdc1      34     262177     262144  128M Microsoft reserved
/dev/sdc2  264192 7814035455 7813771264  3,7T Microsoft basic data

Partition 2 does not start on physical sector boundary.

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 03/03/2018, à 12:12)

Hors ligne

#3 Le 04/03/2018, à 08:42

NKNX

Re : OMV-NAS Probleme de dique.

Bonjour encore .. toujours le même problème.Je cherche un peu de partout mais je ne comprend pas tous...
j'ai ca dans mtab:

/dev/sdc2 /srv/dev-disk-by-label-4T fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0

et quand il plante j'ai ca en boucle dans syslog :

Mar  3 07:35:29 NKN-NAS monit[1103]: 'fs_srv_dev-disk-by-label-4T' unable to read filesystem '/srv/dev-disk-by-label-4T' state
Mar  3 07:35:35 NKN-NAS collectd[1147]: statvfs(/srv/dev-disk-by-label-4T) failed: Transport endpoint is not connected
Mar  3 07:35:45 NKN-NAS collectd[1147]: statvfs(/srv/dev-disk-by-label-4T) failed: Transport endpoint is not connected
Mar  3 07:35:55 NKN-NAS collectd[1147]: statvfs(/srv/dev-disk-by-label-4T) failed: Transport endpoint is not connected
Mar  3 07:35:59 NKN-NAS monit[1103]: Device /srv/dev-disk-by-label-4T not found in /etc/mtab

j'amerai juste savoir pourquoi avec OMV ca me fait ca, alors que avant j'avais un "serveur multimedia" sous ubuntu et j'ai jamais eu ce problème...
Config a effectuer dans OMV ? Partition du dique qui est pas bonne ? ....
J'ai déjà reintall OMV dans le doute dune mauvaise manip mais c'est la même chose...

Merci d'avance smile

Hors ligne

#4 Le 30/03/2018, à 03:30

white_mike

Re : OMV-NAS Probleme de dique.

Pourrais tu donner le contenu de ton fichier /etc/fstab ?

Tu souhaites monter un volume NTFS à priori, as tu installer tout le nécessaire pour pouvoir le faire ?

Hors ligne