Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/04/2018, à 22:31

neck75

Libgnat [resolu]

Bonjour,
tout est dans le titre ou presque !

Alors je suis sous Ubuntu 16.04  et je cherche à installer Ghdl et Gtkwaves. Pour le second pas de pb mais le premier après cette commande :

wget https://github.com/tgingold/ghdl/releases/download/v0.33/ghdl_0.33-1ubuntu1_amd64.deb

J'ai eu un message qu'il y a un paquet manquant je pense :

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait ghdl is already the newest version (0.33-1ubuntu1). Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes : Les paquets suivants contiennent des dépendances non satisfaites : ghdl : Dépend: libgnat-4.8 (>= 4.8.2-8ubuntu3) mais il n'est pas installable E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet (ou indiquez une solution)

Ma question j'ai vu sur internet des propositions de 4.8 du 4.9 ou 5 de Libgnat mais je me méfie si c'est pas proposé et validé par le site Ubuntu.

Merci de vos conseils.

Dernière modification par neck75 (Le 03/05/2018, à 19:36)

Hors ligne

#2 Le 03/04/2018, à 22:34

neck75

Re : Libgnat [resolu]

j'avais oublié j'ai fait la commande :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo apt install libgnat
[sudo] Mot de passe de michel : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libgnat

Hors ligne

#3 Le 05/04/2018, à 21:02

neck75

Re : Libgnat [resolu]

Bonsoir,
pas de nouvelles bonnes nouvelles, bon je vais installer la dernière version la 5 et je croise le doigts.

Hors ligne

#4 Le 05/04/2018, à 21:18

eric63

Re : Libgnat [resolu]

salut
libgnat tout seul il va pas trouver mais libgnat-5 ou -6 ou -7 il va te l'installer


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#5 Le 05/04/2018, à 21:38

neck75

Re : Libgnat [resolu]

Bonsoir eric63,

j'ai commencé à faire cela sous console :

sudo apt-get update 
sudo apt-get install libgnatcoll-gmp-dbg

ça m'a dépaqueté un tas de choses...et aucune erreur.
donc maintenant je re essaye cela :

wget https://github.com/tgingold/ghdl/releases/download/v0.33/ghdl_0.33-1ubuntu1_amd64.deb

Pas de pb

et cela après et là pb toujours le même...

sudo dpkg --install ghdl_0.33-1ubuntu1_amd64.deb
Sélection du paquet ghdl précédemment désélectionné.
(Lecture de la base de données... 204778 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de ghdl_0.33-1ubuntu1_amd64.deb ...
Dépaquetage de ghdl (0.33-1ubuntu1) ...
dpkg: des problèmes de dépendances empêchent la configuration de ghdl :
 ghdl dépend de libgnat-4.8 (>= 4.8.2-8ubuntu3) ; cependant :
  Le paquet libgnat-4.8 n'est pas installé.

dpkg: erreur de traitement du paquet ghdl (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour install-info (6.1.0.dfsg.1-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 ghdl

Où ce trouve mon erreur car je pense que c'est moi qui doit pas faire ce qu'il faut.

Hors ligne

#6 Le 05/04/2018, à 21:40

neck75

Re : Libgnat [resolu]

j'oubliais en dernier :

sudo apt-get install libgnat-4.8
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libgnat-4.8 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libgnat-4.8 » n'a pas de version susceptible d'être installée

Et donc je ne comprends pas comment installer ce libgnat 4.8

Hors ligne

#7 Le 05/04/2018, à 22:03

eric63

Re : Libgnat [resolu]

la version de ghdl 0.33 demande le paquet libgnat 4.8 mais le minimum trouvé sur ubuntu est la libgnat-5 donc problème de dépendances non compatibles.
il te demande une version >= libgnat 4.8.2 donc la 5 devrait faire l'affaire
1 soit essayer d'installer quand même la version 5
2 soit trouver une version ghdl plus récente qui supporte libgnat-5 au minimum
il y a encore deux versions de ghdl la 0.34 et la 0.35

sudo apt-get -f install

tu l'as fait ?


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#8 Le 05/04/2018, à 22:21

neck75

Re : Libgnat [resolu]

Merci je n'arrivais plus à retrouver la commande, donc je l'ai faite à l'instant,  si je fais un redémarrage en principe le petit sens interdit en haut à droite devrait disparaître.
ok je comprends donc en premier j'installe libgnat 5 et après j'essaye les version ghdl et espérant qu'une devrait passer.
Par contre pour la libgnat 5 je suis embêté parce que il y en a plusieurs me semble t il.

Hors ligne

#9 Le 05/04/2018, à 22:29

neck75

Re : Libgnat [resolu]

j'ai été sur ce lien :

https://www.ubuntuupdates.org/package/core/xenial/universe/base/libgnat-5

j'ai choisi

apt install 

et fait le choix

logitec ubuntu

tout c'est bien passé je passe à l'étape suivante.

Hors ligne

#10 Le 05/04/2018, à 22:35

neck75

Re : Libgnat [resolu]

Question bête : j'ai téléchargé ça :

ghdl-0.35-llvm-3.8-ubuntu14.tgz

MAis comment fait on pour installer ?

Hors ligne

#11 Le 06/04/2018, à 12:45

eric63

Re : Libgnat [resolu]

mais heu qu'est que tu fait ?

Sur linux en général et ubuntu en particulier
il faut aller dans le gestionnaire de paquets pour installer un paquet

s'il n'y est pas il y a peut être des sources à ajouter (suivant les partenaires ou soumis à des licences)
où éventuellement des sources spécifiques PPA viables à chercher sur le net
où des paquets .deb directement sur le site du fournisseur
où des fichiers binaires (tar.gz) qu'il faudra décompresser et exécuter
où des fichiers sources qu'il faudra compilé pour ta machine

donc ton fichier libgnat -5 est dans ta logithèque ou ton gestionnaire de paquets
tu vas dans cette logithèque
tu cherches libgnat
tu l'installes graphiquement

puis tu installes ghdl_0.33-1ubuntu1_amd64.deb

pour les fichiers en .tgz se sont des fichiers à décompresser
qui peuvent contenir des binaires qui s'execute directement
mais qui peuvent contenir des fichiers à compiler (tout est à faire)
là c'est une autre histoire


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#12 Le 06/04/2018, à 12:55

Toobuntu

Re : Libgnat [resolu]

Bonjour

Il faut activer les dépôts universe.


Ubuntu 18.04 , 16.04 , 14.04
Sur galere PC : HP ENVY 17 J107SF jack :/ , bluetooth :/ , EFI qui est une calamité , son à configurer :/ Wifi rtl3290 :/
Les vignettes des fichiers geogebra 4, 5, 6 : https://framadrive.org/s/jcr6wjY0IAsZh9u
Zsync est ton ami : https://doc.ubuntu-fr.org/zsync

Hors ligne

#13 Le 07/04/2018, à 09:05

neck75

Re : Libgnat [resolu]

eric63 a écrit :

mais heu qu'est que tu fait ?

Sur linux en général et ubuntu en particulier
il faut aller dans le gestionnaire de paquets pour installer un paquet

oui c'est là première chose que j'ai regardé, mais il n'y est pas c'est pour cela que j'ai été sur un lien, pour le télécharger, mais apparemment en retournant dans la logitec il n’apparaît pas comme quoi il est installé ( ?? )

Hors ligne

#14 Le 07/04/2018, à 09:06

neck75

Re : Libgnat [resolu]

Toobuntu a écrit :

Bonjour

Il faut activer les dépôts universe.

Bonjour Toobuntu,

j'ai pas compris, je suis allé dans la logitech,  mais pas de paquets universe, mais c'est pas là que je dois aller ?

Hors ligne

#15 Le 07/04/2018, à 09:14

neck75

Re : Libgnat [resolu]

J'ai trouvé cela :

 deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-proposed main restricted universe multiverse
 deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
 deb http://archive.canonical.com/ubuntu/ xenial partner
 deb http://extras.ubuntu.com/ubuntu/ xenial main

Mis dans une console et j'ai eu le massage :

deb commande introuvable

Pas tout compris....

Hors ligne

#16 Le 07/04/2018, à 09:22

neck75

Re : Libgnat [resolu]

En faite si il y est bien maintenant dans la logiech ! Mais sous un nom totalement différent, et donc en re essayant :

ghdl_0.33-1ubuntu1_amd64.deb

Que dalle ! Même message d'erreur il y a un problème avec libgnat.

Hors ligne

#17 Le 07/04/2018, à 11:30

eric63

Re : Libgnat [resolu]

neck75 a écrit :
Toobuntu a écrit :

Bonjour

Il faut activer les dépôts universe.

Bonjour Toobuntu,

j'ai pas compris, je suis allé dans la logitech,  mais pas de paquets universe, mais c'est pas là que je dois aller ?

il faut aller dans la logithèque - trouver paramètres -sources de logiciels - cocher la case universe
et pas aller je ne sais où et comment sur le net

En fait si; il y est bien maintenant dans la logithèque ! Mais sous un nom totalement différent,

sous quel nom ?

J'ai trouvé cela :

deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-proposed main restricted universe multiverse
 deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
 deb http://archive.canonical.com/ubuntu/ xenial partner
 deb http://extras.ubuntu.com/ubuntu/ xenial main
 deb http://fr.archive.ubuntu.com/ubuntu/ xenial-proposed main restricted universe multiverse

tu devrais décocher cette ligne si elle est activée chez toi elle peut induit des crashes


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#18 Le 09/04/2018, à 19:50

neck75

Re : Libgnat [resolu]

Voilà le nom sous lequel c'est installé :

Runtime for applications compiled with GNAT (shared library)

Pour universe je ne vois pas du tout quand j'ouvre la logitech de - trouver paramètres-  et  - sources logiciels-
Il y a une série très importante de paquets qui sont triés en fonction de leur application, je ne vois pas ce que tu veux dire.

Hors ligne

#19 Le 09/04/2018, à 20:41

eric63

Re : Libgnat [resolu]

quand tu ouvres sources de logiciels
il y a plusieurs onglets
onglet mise à jour - décoche mises à jour en préversion
1523302615.png
onglet logiciels ubuntu - coche logiciels restreints par des droits d'auteur ou des question juridiques (multiverse)
d'ailleurs tu peux cocher les autres aussi sans soucis (sauf code source) qui ne te sera que très peu utile pour l'instant
1523302645.png


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#20 Le 09/04/2018, à 22:06

neck75

Re : Libgnat [resolu]

J'ai vérifié c'était déjà comme tu l'indiques

Hors ligne

#21 Le 10/04/2018, à 20:43

eric63

Re : Libgnat [resolu]

en fin de compte tu as installé lignat-5 maintenant que multiverse est visible ?


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#22 Le 11/04/2018, à 19:03

neck75

Re : Libgnat [resolu]

Bonsoir,
alors là je ne sais pas comment le vérifier, mais en tous les cas j'ai toujours le même pb quand je fait ça par une console :

ghdl_0.33-1ubuntu1_amd64.deb

Si je peux installer libgnat 4.8 peut être que cela fonctionnera.

Hors ligne

#23 Le 11/04/2018, à 20:31

eric63

Re : Libgnat [resolu]

alors là je ne sais pas comment le vérifier,

1 pour vérifier si libgnat est installé il faut aller dans ta logithèque et en recherchant le paquet c'est écrit sur le coté si la paquet est installé ou pas.
2 pour le verifier tu peux aussi faire l'install direct

sudo apt install libgnat-5

ca te dira aussi s'il est installé ou pas

mais en tous les cas j'ai toujours le même pb quand je fait ça par une console :

ghdl_0.33-1ubuntu1_amd64.deb

3 j'espère que tu ne tapes pas que ça dans ta console, c'est pour ça qu'il faut les retours complet des commandes pour qu'on puisse évaluer ce qui va bien de ce qui ne va pas
un retour complet ça ressemble à ça

kubu@kubu-desktop:~$ libgnat-5
libgnat-5 : commande introuvable
kubu@kubu-desktop:~$

Si je peux installer libgnat 4.8 peut être que cela fonctionnera.

il te faut pour installer ghld une version supérieure ou egale a 4.8.2 de libgnat


kdeïste convaincu avec Kubuntu 18.10 + backports = plasma 5.13.5 et KDE framaworks 5.50.0 Qt 5.11.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#24 Le 12/04/2018, à 14:22

neck75

Re : Libgnat [resolu]

ok merci beaucoup je refais tout cela vendredi soir et je mets sur le forum, tout ce qui est ''raconté''.

Hors ligne

#25 Le 13/04/2018, à 21:07

neck75

Re : Libgnat [resolu]

alors me voilà revenu et donc première commande voici le résultat :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo apt install libgnat-5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgnat-5 est déjà la version la plus récente (5.4.0-6ubuntu1~16.04.9).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.4.0-112-generic linux-image-extra-4.4.0-112-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
michel@michel-W54-55-94-95-97AU-AUQ:~$ 

puis la deuxième :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo dpkg --install ghdl_0.33-1ubuntu1_amd64.deb
Sélection du paquet ghdl précédemment désélectionné.
(Lecture de la base de données... 204675 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de ghdl_0.33-1ubuntu1_amd64.deb ...
Dépaquetage de ghdl (0.33-1ubuntu1) ...
dpkg: des problèmes de dépendances empêchent la configuration de ghdl :
 ghdl dépend de libgnat-4.8 (>= 4.8.2-8ubuntu3) ; cependant :
  Le paquet libgnat-4.8 n'est pas installé.

dpkg: erreur de traitement du paquet ghdl (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour install-info (6.1.0.dfsg.1-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 ghdl
michel@michel-W54-55-94-95-97AU-AUQ:~$ 

et voilà donc maintenant je laisse les "maîtres de la console" ma dire qu'est ce que je merde quelques parts....

Hors ligne