Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 15/04/2018, à 14:04

petitpanda14

[Résolu] Serveur Minecraft lag

Bonjour,

Je joue au modpack SkyFactory 3 et j'ai 2 PC : 1 pour jouer (i3 4030U, 12Go de RAM), et l'autre (i7 3630QM, 8Go de RAM) qui sert de serveur car le premier n'est pas assez puissant pour faire tourner correctement un monde. Ils tournent tous les deux sous la dernière version d'OpenJDK (1.8.0_162). Mais quand je joue, il y a souvent des rollbacks. Dans le moniteur système, lors de ces rollbacks, on voit qu'il n'y a plus d'activité réseau alors que personne n'utilise le réseau.
1523795092.png
Je vois aussi, avec htop, que le serveur n'est pas surchargé. Est-ce que quelqu'un aurait la réponse ?

Merci d'avance.

Dernière modification par petitpanda14 (Le 19/04/2018, à 16:52)

Hors ligne

#2 Le 15/04/2018, à 14:14

Naziel

Re : [Résolu] Serveur Minecraft lag

Bonjour,

Les deux pc sont sur le même réseau? Comment sont reliés les deux pc? Que par wifi? Une partie wifi, une partie ethernet?

Hors ligne

#3 Le 15/04/2018, à 15:07

petitpanda14

Re : [Résolu] Serveur Minecraft lag

Les PC sont sur le même réseau reliés en WiFi.

Hors ligne

#4 Le 15/04/2018, à 15:56

Naziel

Re : [Résolu] Serveur Minecraft lag

A première vue, je pense à une économie d'énergie de la part d'une carte wifi.
Peux tu essayer de mettre les deux pc branchés sur la box en filaire pour voir si ça vient du wifi?

Hors ligne

#5 Le 15/04/2018, à 17:06

petitpanda14

Re : [Résolu] Serveur Minecraft lag

Après, quand je fais un wget d'un fichier assez lourd que je trouve sur internet (~100Mo), ça télécharge à 800ko/s, mais je testerais le filaire ^^

Hors ligne

#6 Le 15/04/2018, à 17:27

Naziel

Re : [Résolu] Serveur Minecraft lag

Le filaire, c'est pas forcément une solution, c'est juste pour éviter de chercher dans cette direction si ça vient pas du wifi (et aussi pas avoir à lire deux rapports wificheck).
800ko/s, c'est ce que tu as habituellement?

Si ça vient du wifi, il peut y avoir des paramètres à passer pour empêcher de passer en économie d'énergie.

Dernière modification par Naziel (Le 15/04/2018, à 17:42)

Hors ligne

#7 Le 16/04/2018, à 18:56

petitpanda14

Re : [Résolu] Serveur Minecraft lag

800ko/s est habituel (j'ai l'ADSL), je n'ai pas encore testé le filaire car je dois tout déplacer (et la batterie de mon PC est morte), après j'ai vu dans le bios, ya pas de paramètre pour l'économie d'énergie pour le Wifi (si ça se configure sur le bios ^^).

Dernière modification par petitpanda14 (Le 16/04/2018, à 18:56)

Hors ligne

#8 Le 16/04/2018, à 21:48

Naziel

Re : [Résolu] Serveur Minecraft lag

Moi aussi, perso, je suis à 450/500 ko/s. Sinon, tu peux donner le retour de

lspci

sur les 2 pc (j'aimerais connaître les cartes wifi en question)

Hors ligne

#9 Le 18/04/2018, à 14:15

petitpanda14

Re : [Résolu] Serveur Minecraft lag

Voici les retours du lspci :
-Client :

petitpanda14@Ordi-Portable:~$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 08)
0a:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 830M] (rev a2)
petitpanda14@Ordi-Portable:~$ 

-Serveur :

petitpanda14@Xubuntu-envy:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
24:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller (rev 30)
24:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
24:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
25:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
petitpanda14@Xubuntu-envy:~$ 

Hors ligne

#10 Le 18/04/2018, à 15:30

Naziel

Re : [Résolu] Serveur Minecraft lag

Ok, je vais plutôt me pencher sur la carte wifi du client (qui est assez capricieuse): rtl8723be
Tu peux donner le retour de

cat /etc/modprobe.d/rtl8723be.conf

Hors ligne

#11 Le 18/04/2018, à 17:45

petitpanda14

Re : [Résolu] Serveur Minecraft lag

Voici le retour :

petitpanda14@Ordi-Portable:~$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be bt_coex_active=N
petitpanda14@Ordi-Portable:~$ 

Hors ligne

#12 Le 18/04/2018, à 18:28

Naziel

Re : [Résolu] Serveur Minecraft lag

Euh, c'est pas un paramètre valide bt_coex_active=N pour le module rtl8723be. Les paramètres valides:

modinfo rtl8723be
filename:       /lib/modules/4.14.6/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw_36.bin
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         PageHe	<page_he@realsil.com.cn>
srcversion:     21605942C3963CD342F1A33
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
name:           rtl8723be
vermagic:       4.14.6 SMP mod_unload modversions 
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

Commence par tester

sudo modprobe -r rtl8723be ; sudo modprobe rtl8723be fwlps=0 ips=1 ant_sel=1

puis

sudo modprobe -r rtl8723be ; sudo modprobe rtl8723be fwlps=0 ips=1 ant_sel=2

pour voir quelle antenne est la plus efficace (tu verras bien en fonction de la distance au routeur)

echo "options rtl8723be fwlps=1 ips=0 ant_sel=X" | sudo tee /etc/modprobe.d/rtl8723be.conf

pourrait résoudre les problèmes de gestion d'énergie (avec X remplacé par 1 ou 2 selon le résultat précédent) . Cette dernière commande permet de garder les paramètres au redémarrage.

Dernière modification par Naziel (Le 18/04/2018, à 18:29)

Hors ligne

#13 Le 18/04/2018, à 18:54

petitpanda14

Re : [Résolu] Serveur Minecraft lag

Oui, en effet, le paramètre n'est pas normal, mais j'avais changé pour un problème de bluetooth (qui ne c'est pas corrigé) et j'ai enfin changé les paramètres (avec ant_sel=1), est-ce fini ? Si oui, je vais tester ^^.

Hors ligne

#14 Le 18/04/2018, à 18:58

Naziel

Re : [Résolu] Serveur Minecraft lag

J'ai réussi à faire fonctionner le bluetooth avec le noyau 4.14.6 installé via ukuu (voir la doc), mais c'est pas non plus exceptionnel: la distance entre la carte et le matériel à appairer doit vraiment être petite. Si tu veux utiliser du bluetooth, je te conseille d'acheter une clé bluetooth moins chiante à configurer.
Oui, au cas où redémarre, cette carte peut être surprenante des fois.

Dernière modification par Naziel (Le 18/04/2018, à 19:00)

Hors ligne

#15 Le 18/04/2018, à 19:05

petitpanda14

Re : [Résolu] Serveur Minecraft lag

J'avais réussi à mettre le bluetooth, mais la connexion internet, quand le bluetooth était connecté, était TRÈS lente.

Hors ligne

#16 Le 18/04/2018, à 19:12

Naziel

Re : [Résolu] Serveur Minecraft lag

Fatalement, 2 antennes dont une qui fonctionne mal (l'antenne en question dépend bizarrement du pilote), deux antennes utilisées (le bluetooth n'utilise pas les mêmes fréquences que le wifi) => le bluetooth ou le wifi qui fonctionne mal

Dernière modification par Naziel (Le 18/04/2018, à 19:13)

Hors ligne