Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/06/2018, à 09:15

LukePerp

[Résolu] Impossible masquer Grub

Bonjour,
Sur une machine sous Ubuntu 18.04, le menu Grub est toujours affiché alors qu'il devrait être masqué. En suivant la documentation (lien) sur le menu Grub, les différentes combinaisons ne changes rien et le menu Grub est toujours affiché au démarrage, alors que je veux le masquer. Je veux le laissé cacher et l'afficher au besoin en tapotant shift, mais je n'y arrive pas. Après chaque modif du fichier /etc/default/grub, j'exécute sudo update-grub. Je ne sais pas si c'est utile, mais la machine est connecté en hdmi à une TV et en DP à un moniteur. Au démarrage de la machine, le menu Grub est affiché sur la TV puis après, l'image permute sur le moniteur pour Ubuntu. Pourriez-vous m'aider svp à masquer le menu Grub, merci d'avance.
Edit : je précise que les trois cas indiqué par la documentation ont le même effet, à savoir affiché le menu Grub.

Voici mon fichier grub actuel, qui affiche le menu Grub au démarrage alors qu'il devrait être caché :

:~$ cat /etc/default/grub
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=2
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
:~$

Edit : solution = ajouter GRUB_DISABLE_OS_PROBER=true

Dernière modification par LukePerp (Le 28/08/2018, à 17:02)


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne

#2 Le 11/06/2018, à 15:23

LukePerp

Re : [Résolu] Impossible masquer Grub

Je tiens à souligner que toutes les configurations du fichier Grub m'affiche le menu Grub. Les trois cas de la documentation ci-dessous ainsi que ton conseil en post 2 ont le même effet : affichage du menu Grub. Je ne sais pas comment l'expliquer autrement. La sauvegarde du fichier Grub fonctionne, l'exécution de sudo update-grub fonctionne sans problème, et pourtant, au démarrage, le menu Grub reste affiché même avec la configuration des cas 1 et 2. La machine est en dual-boot windows linux, linux en défaut.

Documentation a écrit :

Afficher/Masquer le menu
Pour afficher ou non le menu Grub, on utilisera les paramètres GRUB_HIDDEN_TIMEOUT et GRUB_HIDDEN_TIMEOUT_QUIET du fichier /etc/default/grub.
cas 1 Caché.
Grub lance sans attendre le choix par défaut.

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0	# dépendance: lorsque GRUB_HIDDEN_TIMEOUT est actif, ce paramètre doit être défini à 0

cas 2 Caché.
Un décompte de 5 secondes est lancé pendant lequel on peut appuyer sur les touches Échap ou majuscule (Shift) pour afficher le menu. Sans action de notre part, le choix par défaut est lancé.

GRUB_HIDDEN_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=0	# dépendance: lorsque GRUB_HIDDEN_TIMEOUT est actif, ce paramètre doit être défini à 0

cas 3
Affiché directement.

#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10	# ne pas laisser à zéro si vous voulez avoir le temps de sélectionner éventuellement un autre système.

Dernière modification par LukePerp (Le 11/06/2018, à 15:24)


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne

#3 Le 12/06/2018, à 17:55

LukePerp

Re : [Résolu] Impossible masquer Grub

golgoth63 a écrit :

Et sans la connexion hdmi avec la config 1 ?

Même problème


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne

#4 Le 12/06/2018, à 18:43

grandtoubab

Re : [Résolu] Impossible masquer Grub

y aurait il sur cette machine d'autres Linux installés à l'insu de ton plein gré ? lol
sinon comme indiqué

info -f grub -n 'Simple configuration'
This option is unset by default, and is deprecated in favour of the
     less confusing 'GRUB_TIMEOUT_STYLE=countdown' or
     'GRUB_TIMEOUT_STYLE=hidden'.

Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#5 Le 13/06/2018, à 09:53

LukePerp

Re : [Résolu] Impossible masquer Grub

grandtoubab a écrit :

y aurait il sur cette machine d'autres Linux installés à l'insu de ton plein gré ? lol
sinon comme indiqué

Je suis un peu expérimenté sur Ubuntu, donc non il n'y a pas d'autres système installé. Je ne comprends pas la suite de ta réponse. Quel réglage me suggère tu de faire ?


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne

#6 Le 13/06/2018, à 10:58

grandtoubab

Re : [Résolu] Impossible masquer Grub

comme indiqué dans

info -f grub -n 'Simple configuration'

GRUB_TIMEOUT'
     Boot the default entry this many seconds after the menu is
     displayed, unless a key is pressed.  The default is '5'.  Set to
     '0' to boot immediately without displaying the menu, or to '-1' to
     wait indefinitely.

     If 'GRUB_TIMEOUT_STYLE' is set to 'countdown' or 'hidden', the
     timeout is instead counted before the menu is displayed.

'GRUB_TIMEOUT_STYLE'
     If this option is unset or set to 'menu', then GRUB will display
     the menu and then wait for the timeout set by 'GRUB_TIMEOUT' to
     expire before booting the default entry.  Pressing a key interrupts
     the timeout.
If this option is set to 'countdown' or 'hidden', then, before
     displaying the menu, GRUB will wait for the timeout set by
     'GRUB_TIMEOUT' to expire

GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden

Ceci dit personne n'est parfait et pour être certain que tu utilises bien le grub que tu crois mieux vaut le reinstaller,
identifier le disque

sudo fdisk -l

Exemple si Ubuntu est dans sda

sudo grub-install /dev/sda

Vérifier que Grub est bien dans le MBR

root@debian:/# dd if=/dev/sda bs=512 count=1 | strings
1+0 enregistrements lus
1+0 enregistrements écrits
512 bytes copied, 0,000247207 s, 2,1 MB/s
GRUB
ZRr=
`|f	
\|f1
GRUB 
Geom
Hard Disk
Read
 Error
root@debian:/# 

La chîne GRUB est éditée , tout va bien

Dernière modification par grandtoubab (Le 13/06/2018, à 11:22)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#7 Le 15/06/2018, à 09:06

LukePerp

Re : [Résolu] Impossible masquer Grub

Les réglages étaient correctes et l'aide de grandtoubab ne m'a pas permis d'y arriver. A force de chercher, j'ai finis par trouver la solution. Pour une raison que je ne comprends pas, il fallait ajouter :

GRUB_DISABLE_OS_PROBER=true

Mon fichier grub est donc passé de :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=2
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

à

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=2
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=0
GRUB_DISABLE_OS_PROBER=true
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Avec ce dernier, le menu est enfin masqué et peut être affiché à la demande en pressant la touche shift.
Merci de vos participations. Je constate que c'est le 4è sujet consécutif que je résolve tout seul, je vais donc éviter de polluer le forum en posant mes prochaines questions d'aide ;-)

Dernière modification par LukePerp (Le 28/08/2018, à 17:03)


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne

#8 Le 17/06/2018, à 17:06

ylag

Re : [Résolu] Impossible masquer Grub

@LukePerp:

Salut,

Est-tu tombé sur ce lien dans tes recherches:
https://gist.github.com/LeahCim/9332432

?

Hors ligne

#9 Le 18/06/2018, à 15:27

LukePerp

Re : [Résolu] Impossible masquer Grub

ylag a écrit :

@LukePerp:
Est-tu tombé sur ce lien dans tes recherches:
https://gist.github.com/LeahCim/9332432 ?

Non, mais mes recherches ont aboutis avec l'ajout cité plus haut. Je n'ai pas creusé, ni analysé, je ne sais pas ce que fait l'ajout de la valeur. Je fais simple, je ne me casse pas la tête pour une fois.


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Vieux laptop de 1993 : Bodhi Linux - Pentium M - 432 Mo

Hors ligne