Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/06/2018, à 22:24

Kzrwork

[RESOLU] Erreur installation + démarage

Bonsoir à tous!


Je me permet de venir poster sur votre forum parce que j'ai cherché par tout les moyens, a régler mon soucis.. pendant une heure mais rien n'y fait!

J'espère recevoir une aide de votre part, ça serai fort apprécié smile



J'ai voulu boot Ubuntu 18.04 (dernière version) sur ma clé UsB pour avoir un Dual Boot avec Windows 7 et Ubuntu sur le même ordinateur.
(je précise que dans mon bios il y a marqué "LEGACY+UFEI" a un endroit je ne sais pas si ça joue)
(mon disque windows principal est NFIS, et je ne sais pas si j'ai installé en legacy ou autre...)

Je procède a la gravure de l'iso sur la clé, je redémarre l'ordinateur

J'ouvre le bios et je place USB disk en première ligne,

L'installation de Ubuntu démarre, tout ce passe bien!

Je crée donc mes partitions, en faisant attention, en suivant les tuto.

Je crée donc le swap, le "/" et le "/home"
trois partitions du coup...




L'installation commence, et arrivé a 60% une erreur s'ouvre "Grub error" comme quoi il n'a pas pu s'installer...
J'envoi le rapport, et boum je tombe sur le bureau de ubuntu..

Et comme je suis bête j'ai redémarré directement l'ordinateur avant d'utiliser le fameux "boot repair" ...

Résultat, je n'ai plus du tout accès a ma partition ubuntu, quand je démarre l'ordinateur.. j'arrive directement sur mes sessions windows7...



Comment lancer Ubuntu maintenant? Avec ou sans choix au démarage?
J'aimerai savoir si je peux repair-boot via mon windows7?
Ou encore si je peux démarrer Ubuntu d'une façon pour pouvoir repair-boot dessus...


Dsl pour mes explications, il se fait tard, merci pour votre futur aide!




Bonne soirée, KZR.

Dernière modification par Kzrwork (Le 15/06/2018, à 16:53)

Hors ligne

#2 Le 12/06/2018, à 22:30

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Peut-être que cette version n'est pas supporté par mon ordinateur, ou qu'elle comporte encore des bugs d'install...

Il y a une version qui évite au maximum les problèmes de grub?

Merci

Hors ligne

#3 Le 13/06/2018, à 10:55

malbo

Re : [RESOLU] Erreur installation + démarage

Bonjour,
Je te prie de démarrer ton ordi sur la LiveUSB qui t'a servi pour l'installation mais il faudra sélectionner "Try Ubuntu without installing" (Essayer Ubuntu..." si c'est en français) afin de faire une session live (et non pas refaire une installation). Depuis cette session live, tu feras un Boot-Info et tu donneras l'URL de ce Boot-Info dans ta réponse.

Quelques compléments :
Le principe de fonctionnement de l'installateur de Ubuntu est le suivant : si l'installation est lancée alors que l'ordi a démarré sur la LiveUSB en mode UEFI, l'installateur tente l'installation dans ce mode UEFI. Par contre, si le démarrage se fait sur la LiveUSB en mode non-EFI (Legacy), l'installateur tente l'installation dans ce même mode non-EFI (Legacy). Comme tu as signalé que ton paramétrage du Boot Mode dans le "Bios" est sur "LEGACY+UFEI", tu as la possibilité de démarrer l'ordi sur ta LiveUSB dans un mode ou l'autre. Comme tu n'y connais rien, tu n'as même pas cherché à maîtriser la chose et je pense que tu as fait le mauvais choix. Je pense que ton Windows est installé en mode "Legacy" et de ce fait tu aurais dû installer dans ce même mode "Legacy" (voir mon tuto sur le sujet). Mais tu as laissé le démarrage se faire en mode UEFI sur la LiveUSB. J'attends ton Boot-Info pour savoir si mes hypothèses sont confirmées ou pas.

Dernière modification par malbo (Le 13/06/2018, à 11:13)

Hors ligne

#4 Le 13/06/2018, à 12:50

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Merci beaucoup pour ta réponse Malbo,

J'ai fais la manipulation du tutoriel pour pouvoir installer le boot-info mais j'ai un soucis dans le terminal, ce qui fait que je ne peux pas écrire la commande "sudo boot-info".


ubuntu@ubuntu:~$ sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt update && sudo apt install -y boot-info
Ign:1 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic InRelease
Ign:2 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty InRelease
Hit:3 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic Release
Err:4 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty Release
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Hit:6 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease  
Hit:7 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Hit:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                
Hit:9 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Reading package lists... Done
E: The repository 'cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Peut-être que c'est a cause de ça que GRUB ne s'est pas installé.. je ne sais pas..

Merci


( Ceci dit ubuntu a l'air de marcher parfaitement, hormis que je n'ai pas le choix au démarrage... et cette petite erreur.., assez chiant de devoir BIOS a chaque fois que je veux me co sur ma session linux a vrai dire lol)

Dernière modification par Kzrwork (Le 13/06/2018, à 12:56)

Hors ligne

#5 Le 13/06/2018, à 14:43

malbo

Re : [RESOLU] Erreur installation + démarage

Dans ton post #4, je vois cette ligne :

Err:4 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty Release

on y voit mentionné "trusty". Moi je ne comprends pas ce que ça vient faire là parce que Trusty correspond à la version 14.04 de Ubuntu.
Ce que tu as collé dans le post #4, est-ce que c'est depuis l'ordi démarré sur une LiveUSB ou bien sur un LiveDVD ?

Dernière modification par malbo (Le 13/06/2018, à 14:43)

Hors ligne

#6 Le 13/06/2018, à 14:56

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Ce que je viens de copié/collé ici, je l'ai copié sur ma session ubuntu, et je l'ai ensuite mis sur pastebin...
Je n'ai touché a aucune ligne ni rien, juste rentrer la commande pour le boot-info..

Tu crois que je dois relancer le bios et peut-être faire un repair a l'écran d'affichage? Ou reinstaller une autre version que 18.04... plus anterieur peut être?

Dsl mais je suis débutant, étant un windowsien depuis bcp d'années

Hors ligne

#7 Le 13/06/2018, à 15:05

malbo

Re : [RESOLU] Erreur installation + démarage

C'est quoi ton ordi ? Si c'est un modèle du commerce, donne seulement son nom complet et son fabricant et j'irai voir sur le net ses caractéristiques.

Hors ligne

#8 Le 13/06/2018, à 15:21

Kzrwork

Re : [RESOLU] Erreur installation + démarage

C'est un ordi gamer, le nom exact je ne sais pas alors je te met la config en dessous,
Encore merci de prendre du temps pour m'aider, peut-être qu'une version sera plus adapté a ma config, en usbboot (pour dual)...



http://prntscr.com/juhiha

http://prntscr.com/juhiq4

ça peut être une erreur du au GB que j'ai réservé au partition? Ou aucun rapport..

Dernière modification par Kzrwork (Le 13/06/2018, à 15:34)

Hors ligne

#9 Le 13/06/2018, à 15:46

malbo

Re : [RESOLU] Erreur installation + démarage

Je te suggère d'utiliser le paramètre de noyau nomodeset pour parvenir à démarrer ta session live. Pour cela, consulte le paragraphe "Modifier les paramètres du noyau pour une session-live" dans le chapitre 7. Paramètres du noyau (il y a des blaireaux qui ont foutu le binz dans cette doc. Elle est défigurée) j'ai rayé ça. Ce serait utile si tu avais un affichage tout pourri en session live mais ce n'est pas ton problème...

Dernière modification par malbo (Le 13/06/2018, à 15:49)

Hors ligne

#10 Le 13/06/2018, à 15:51

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Exact.. mon seul problème est le grub... que je ne puisse pas ouvrir ubuntu sans passer par le bios et la clé USB ce qui est a vrai dire, super chiant..
Mon affichage en session live est assez propre ^^

Dernière modification par Kzrwork (Le 13/06/2018, à 15:52)

Hors ligne

#11 Le 15/06/2018, à 04:10

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Je me permet de up le topic, quelqu'un aurai une idée, je n'ai toujours pas reussi a afficher ou réparer mon ubuntu.. au démarrage


merci

Dernière modification par Kzrwork (Le 15/06/2018, à 04:10)

Hors ligne

#12 Le 15/06/2018, à 07:40

malbo

Re : [RESOLU] Erreur installation + démarage

Bonjour,
Moi sans le Boot-Info, je ne sais pas quoi te conseiller. Déjà, peux-tu vérifier que depuis ta session live tu as accès à internet ? Raconte.

Hors ligne

#13 Le 15/06/2018, à 11:31

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Bonjour malbo,

Oui bien sur internet marche parfaitement sur la session ubuntu, peut-être que je peux télécharger quelque chose qui pourrait reparer le boot-info ou le grub... ?

Hors ligne

#14 Le 15/06/2018, à 11:42

malbo

Re : [RESOLU] Erreur installation + démarage

Pas la peine. Depuis ta session live, repasse la commande (ne la tape pas pour ne pas risquer une erreur de frappe : puisque tu as un accès internet fonctionnel, viens sur cette page, copie la commande que je donne ici et colle-la dans un terminal) :

sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt update && sudo apt install -y boot-info

Quel que soit le résultat que tu obtiens après avoir passé cette commande, copie l'intégralité de ce qui est affiché dans la terminal. L'intégralité attendue si tout se passe bien, c'est ce que tu peux voir dans ce post (j'ai fait la manip hier) : http://forum.ubuntu-fr.org/viewtopic.ph … #p21930854
Et colle le paquet cadeau complet dans ta réponse en encadrant le tout avec les balises comme tu as su le faire pour le paquet que tu as collé dans le post #4

Dernière modification par malbo (Le 15/06/2018, à 11:44)

Hors ligne

#15 Le 15/06/2018, à 11:54

Kzrwork

Re : [RESOLU] Erreur installation + démarage

ubuntu@ubuntu:~$ sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt update && sudo apt install -y boot-info
Ign:1 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic InRelease
Ign:2 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty InRelease
Hit:3 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) bionic Release
Err:4 cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty Release
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Get:6 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]               
Get:7 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease [15.4 kB]
Get:8 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]    
Get:9 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic/main amd64 Packages [1708 B]
Get:10 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic/main Translation-en [1576 B]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [83.2 kB]     
Get:12 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [99.7 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic/main amd64 DEP-11 Metadata [477 kB]
Get:14 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [37.0 kB]
Get:15 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:16 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [29 B]
Get:17 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [29 B]
Get:18 http://archive.ubuntu.com/ubuntu bionic/main DEP-11 48x48 Icons [118 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic/main DEP-11 64x64 Icons [245 kB]
Get:20 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [142 kB]
Get:21 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [56.0 kB]
Get:22 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [105 kB]
Get:23 http://archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [18.0 kB]
Get:24 http://archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [34.2 kB]
Reading package lists... Done                                      
E: The repository 'cdrom://Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426) trusty Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Voila! smile  je précise que la commande sudo boot-info ou repair n'est toujours pas reconnu par mon live

Dernière modification par Kzrwork (Le 15/06/2018, à 11:59)

Hors ligne

#16 Le 15/06/2018, à 14:23

malbo

Re : [RESOLU] Erreur installation + démarage

Je vois toujours trusty mentionné dans ce dernier résultat, comme je le voyais dans le résultat de ton post #4. Moi je dis que trusty n'a rien à faire dans un support d'installation de la version 18.04 donc je t'invite à télécharger l'ISO qui va bien ( ubuntu-18.04-desktop-amd64.iso ) à cette adresse : http://releases.ubuntu.com/releases/bio … -amd64.iso
Puis à prendre une autre clé USB et de l'utiliser pour faire une nouvelle LiveUSB en utilisant de préférence UNetbootin (voir doc) en suivant le paragraphe Créer une clé usb-live Ubuntu à partir d'une image ISO précédemment téléchargée

Dernière modification par malbo (Le 15/06/2018, à 14:26)

Hors ligne

#17 Le 15/06/2018, à 14:52

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Bizarrement c'est exactement ce que j'ai fais, j'ai mis l'iso "ubuntu-18.04-desktop-amd64" telechargé sur le site que tu cites, sur ma clé, tout en suivant le tutoriel....

Du coup si j'essaye avec une autre version de ubuntu, je dois faire refaire des partitions.. ? Ou reinstaller par dessus? Comment je dois m'y prendre vu que mes partitions sont déjà rempli avec ce liveubuntu..

ça me semble louche comme problème alors que j'ai tout fais comme les tuto...


Merci

Dernière modification par Kzrwork (Le 15/06/2018, à 14:52)

Hors ligne

#18 Le 15/06/2018, à 14:58

malbo

Re : [RESOLU] Erreur installation + démarage

Prends une autre clé et refais ta LiveUSB comme je t'ai proposé dans le post #16. C'est vrai que ça peut paraître crétin de proposer de prendre une autre clé USB mais j'ai proposé ça souvent et ça donne de bons résultats (dernier exemple récent ici)

Hors ligne

#19 Le 15/06/2018, à 16:19

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Bonne nouvelle!

J'ai désactivé le "fast boot" dans mon bios, puis j'ai ensuite re-installer exactement avec la même clé USB la même version... ( sur le bureau de mon live )
Du coup elle a remplacer l'ancienne, sans aucune erreur cette fois-ci !

Par contre je ne peux toujours pas installer le boot-repair dans mon terminal...

Mais MIRACLE le GRUB est maintenant actif au démarage de mon ordi, résultat problème reglé sans avoir a regler le problème du "boot-repair"

Hors ligne

#20 Le 15/06/2018, à 16:52

malbo

Re : [RESOLU] Erreur installation + démarage

Bonne nouvelle. C'était donc le paramètre "fast boot" dans le Bios qui n'était pas désactivé. Juste par curiosité, je te prie de passer la commande suivante depuis une session de ton Ubuntu installé (source) :

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

et indiquer dans ta réponse le résultat obtenu.

Hors ligne

#21 Le 15/06/2018, à 16:53

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Je vois... erreur de débutant j'imagine.. lol


"Session non-EFI"

Je viens de faire les mises à jour depuis le terminal tout fonctionne bien ! Merci beaucoup pour l'aide apporté, et ton temps passé sur mon post smile

Dernière modification par Kzrwork (Le 15/06/2018, à 16:58)

Hors ligne

#22 Le 15/06/2018, à 19:08

malbo

Re : [RESOLU] Erreur installation + démarage

Comme tu as installé Ubuntu en mode non-EFI, je suppose que Windows 7 était déjà installé en mode non-EFI. Du coup, tu dois avoir une entrée dans le menu Grub qui te permet de démarrer Windows 7, c'est bien le cas ?

Dernière modification par malbo (Le 15/06/2018, à 19:09)

Hors ligne

#23 Le 15/06/2018, à 19:15

Kzrwork

Re : [RESOLU] Erreur installation + démarage

Franchement j'ai installé au hasard... et pour le coup ça marche! Windows a été installé en iso aussi si je me souviens bien..
Oui maintenant dans le menu grub j'ai w7 et ubuntu, et d'autre trucs inutiles!

Par contre mon horloge de windows 7 revient toujours 2h en arrière quand je switch o.O

Hors ligne

#24 Le 15/06/2018, à 19:21

malbo

Re : [RESOLU] Erreur installation + démarage

Tu peux faire comme j'explique dans ce post pour régler le pb de l'horloge : http://forum.ubuntu-fr.org/viewtopic.ph … #p21794422
Moi je choisis "Action sur Ubuntu seulement".

Hors ligne

#25 Le 15/06/2018, à 19:21

lucmars

Re : [RESOLU] Erreur installation + démarage

Kzrwork a écrit :

Franchement j'ai installé au hasard... et pour le coup ça marche! Windows a été installé en iso aussi si je me souviens bien..
Oui maintenant dans le menu grub j'ai w7 et ubuntu, et d'autre trucs inutiles!

Par contre mon horloge de windows 7 revient toujours 2h en arrière quand je switch o.O

P'tete ta pile interne qui faiblit, vois si le bios affiche le meme retard, si oui c'est la pile.

Hors ligne