Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/06/2018, à 13:34

Wrench

Impossible d'utiliser apt-get update

Bonjour ,

Depuis ce matin lorsque je souhaite utilser la commande suivante:

sudo apt-get update

S'en suit le message suivant :

Te* » est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list.d/appgrid-stable.list
E: La liste des sources ne peut être lue.

*Ceci apparaît comme un caractère spécial avec des 0 et des 1

J'utilse appgrid à la place de la logithèque d'Ubuntu et lorsque que je souhaite installer un soft depuis celle-ci le message suivant apparaît:

"Impossible de charger la liste des paquets"

Merci pour votre futur aide smile

Dernière modification par Wrench (Le 19/06/2018, à 13:39)

Hors ligne

#2 Le 19/06/2018, à 13:50

nam1962

Re : Impossible d'utiliser apt-get update

Donne nous :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#3 Le 19/06/2018, à 14:47

Wrench

Re : Impossible d'utiliser apt-get update

Merci pour ta réponse rapide , voilà ce que tu as demandé :

Pour : cat /etc/apt/sources.list

# deb cdrom:[Ubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

Et pour : ls /etc/apt/sources.list.d -1

appgrid-stable.list
appgrid-stable.list.save
jonathonf-ubuntu-python-3_6-xenial.list
jonathonf-ubuntu-python-3_6-xenial.list.save
modycz-ubuntu-heimdall-xenial.list
noobslab-ubuntu-themes-xenial.list
noobslab-ubuntu-themes-xenial.list.save
numix-ubuntu-ppa-xenial.list
numix-ubuntu-ppa-xenial.list.save
sublime-text.list
sublime-text.list.save
vscode.list
vscode.list.save

Hors ligne

#4 Le 19/06/2018, à 14:49

michel_04

Re : Impossible d'utiliser apt-get update

Bonjour,

Et :

cat /etc/apt/sources.list.d/appgrid-stable.list

A+

Dernière modification par michel_04 (Le 19/06/2018, à 14:50)

Hors ligne

#5 Le 19/06/2018, à 14:55

Wrench

Re : Impossible d'utiliser apt-get update

Voila pour : cat /etc/apt/sources.list.d/appgrid-stable.list

Tecۘ6Vh)jEp~=:rCWËU
   D¢

Malheureusement il n'y a que des caractères spécials qui ne peuvent pas s'afficher correctement

Dernière modification par Wrench (Le 19/06/2018, à 14:59)

Hors ligne

#6 Le 19/06/2018, à 14:59

nam1962

Re : Impossible d'utiliser apt-get update

Je propose le nettoyage radical, puis tu nous diras quels PPA tu veux et pourquoi.

sudo rm /etc/apt/sources.list.d/*
sudo apt clean
[[ $(dpkg -l | grep ^rc) ]] && sudo dpkg -P $(dpkg -l | grep ^rc | tr -s " " | cut -d " " -f 2)
sudo apt update
sudo apt full-upgrade
sudo apt autoremove --purge

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#7 Le 19/06/2018, à 15:16

Wrench

Re : Impossible d'utiliser apt-get update

Pendant l'execution de :

sudo apt full-upgrade

j'obtient cette erreur :

Des erreurs ont été rencontrées pendant l'exécution :
 python3.6-minimal
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et je vais prendre les PPA officiels pour l'instant , il me suffiront je pense.

Hors ligne

#8 Le 19/06/2018, à 15:25

michel_04

Re : Impossible d'utiliser apt-get update

Re,


Wrench a écrit :

Pendant l'execution de :

sudo apt full-upgrade

j'obtient cette erreur :

Des erreurs ont été rencontrées pendant l'exécution :
 python3.6-minimal
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et je vais prendre les PPA officiels pour l'instant , il me suffiront je pense.

Donne les retours complets, merci. ---> Retour utilisable de commande

Il n'y a pas de PPA officiel. ---> Les dépôts personnels de paquets logiciels ou Personal Package Archives (PPA)

Etrait doc PPA a écrit :

Avertissements à lire avant toute utilisation des PPA :

    Bien que proposé dans le cadre de la plate-forme Launchpad, chaque PPA est maintenu par des contributeurs et des équipes de développement spécifiques à chaque projet. En activant l'accès dans votre ordinateur à un PPA, vous reconnaissez faire confiance aux mainteneurs de ce PPA spécifique.

    En aucun cas, les paquets en provenance d'un PPA ne sont maintenus par Canonical, Ils ne bénéficient pas non plus de la validation officielle Ubuntu, ni du support des développeurs des équipes officielles Ubuntu.
    N'activez l'accès qu'à des PPA essentiels et pour lesquels vous avez confiance.1)

A+

Hors ligne

#9 Le 19/06/2018, à 15:31

Wrench

Re : Impossible d'utiliser apt-get update

Voilà pour : sudo apt full-upgrade

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de python3.6-minimal (3.6.5-5~16.04.york1) ...
Sorry: ValueError: source code string cannot contain null bytes
dpkg: erreur de traitement du paquet python3.6-minimal (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de python3.6 :
 python3.6 dépend de python3.6-minimal (= 3.6.5-5~16.04.york1) ; cependant :
 Le paquet python3.6-minimal n'est pas encore configuré.

dpkg: erreur de traitement du paquet python3.6 (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 python3.6-minimal
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)

Merci pour l'info je savais pas vraiment ce qu'étais les PPA comme tu la bien compris smile

Hors ligne

#10 Le 19/06/2018, à 15:37

nam1962

Re : Impossible d'utiliser apt-get update

On ne sait pas bien où on en est.... comme dit michel_04, donne TOUS les retours.
Passe

software-properties-gtk

et coches les dépôts "Partenaires de Canonical"
Redonne :

ls /etc/apt/sources.list.d -1

Puis repasse (en donnant les retours)

sudo apt update
sudo dpkg --configure -a 

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#11 Le 19/06/2018, à 15:50

Wrench

Re : Impossible d'utiliser apt-get update

Excusez moi pour mes erreurs qui vous font perdre du temps , alors voila tous les retours que vous me demandez:

thomas@thomas-Pc:~$ ls /etc/apt/sources.list.d -1
thomas@thomas-Pc:~$
thomas@thomas-Pc:~$ sudo apt update
[sudo] Mot de passe de thomas : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://archive.canonical.com/ubuntu xenial InRelease        
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease
Réception de:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease
107 ko réceptionnés en 2s (43,5 ko/s)                                 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
thomas@thomas-Pc:~$
thomas@thomas-Pc:~$ sudo dpkg --configure -a 
Paramétrage de python3.6-minimal (3.6.5-5~16.04.york1) ...
Sorry: ValueError: source code string cannot contain null bytes
dpkg: erreur de traitement du paquet python3.6-minimal (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de python3.6 :
 python3.6 dépend de python3.6-minimal (= 3.6.5-5~16.04.york1) ; cependant :
 Le paquet python3.6-minimal n'est pas encore configuré.

dpkg: erreur de traitement du paquet python3.6 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python3.6-minimal
 python3.6
thomas@thomas-Pc:~$

Hors ligne

#12 Le 19/06/2018, à 15:56

nam1962

Re : Impossible d'utiliser apt-get update

Ca résiste !

sudo dpkg --force-all --configure -a 

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#13 Le 19/06/2018, à 15:58

Wrench

Re : Impossible d'utiliser apt-get update

Le retour complet wink

thomas@thomas-Pc:~$ sudo dpkg --force-all --configure -a 
Paramétrage de python3.6-minimal (3.6.5-5~16.04.york1) ...
Sorry: ValueError: source code string cannot contain null bytes
dpkg: erreur de traitement du paquet python3.6-minimal (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: python3.6 : problèmes de dépendances, mais configuration comme demandé :
 python3.6 dépend de python3.6-minimal (= 3.6.5-5~16.04.york1) ; cependant :
 Le paquet python3.6-minimal n'est pas encore configuré.

Paramétrage de python3.6 (3.6.5-5~16.04.york1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 python3.6-minimal
thomas@thomas-Pc:~$ 

Hors ligne

#14 Le 19/06/2018, à 16:09

nam1962

Re : Impossible d'utiliser apt-get update

et :

sudo dpkg -P --force-all python3.6-minimal

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#15 Le 19/06/2018, à 16:17

Wrench

Re : Impossible d'utiliser apt-get update

Voilà

thomas@thomas-Pc:~$ sudo dpkg -P --force-all python3.6-minimal
[sudo] Mot de passe de thomas : 
dpkg: python3.6-minimal : problème de dépendance, mais suppression comme demandé :
 python3.6 dépend de python3.6-minimal (= 3.6.5-5~16.04.york1).

(Lecture de la base de données... 240664 fichiers et répertoires déjà installés.)
Suppression de python3.6-minimal (3.6.5-5~16.04.york1) ...
Unlinking and removing bytecode for runtime python3.6
Purge des fichiers de configuration de python3.6-minimal (3.6.5-5~16.04.york1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
thomas@thomas-Pc:~$ 

Hors ligne

#16 Le 19/06/2018, à 16:17

ylag

Re : Impossible d'utiliser apt-get update

@nam1962:

Salut,

Vu au #11:

Sorry: ValueError: source code string cannot contain null bytes
dpkg: erreur de traitement du paquet python3.6-minimal (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1


Le script: /var/lib/dpkg/info/python3.6-minimal.postinst qui serait en cause ?
Dans cette discussion: https://stackoverflow.com/questions/312 … null-bytes
...on passe cette commande pour retirer les "null bytes" du fichier:

sudo sed -i 's/\x0//g' /var/lib/dpkg/info/python3.6-minimal.postinst

...qui pourrait être suivi de la commande sudo dpkg --configure -a ?

A+

Dernière modification par ylag (Le 19/06/2018, à 16:21)

Hors ligne

#17 Le 19/06/2018, à 16:23

nam1962

Re : Impossible d'utiliser apt-get update

@ylag, là on dirat que c'est passé sans avoir à utiliser ta judicieuse astuce wink
@Wrench, redonne :

sudo apt clean
[[ $(dpkg -l | grep ^rc) ]] && sudo dpkg -P $(dpkg -l | grep ^rc | tr -s " " | cut -d " " -f 2)
sudo apt update
sudo apt full-upgrade
sudo apt autoremove --purge

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#18 Le 19/06/2018, à 16:30

Wrench

Re : Impossible d'utiliser apt-get update

Voila nams , je test ce qu'a dit ylag ?

thomas@thomas-Pc:~$ sudo apt clean
thomas@thomas-Pc:~$ [[ $(dpkg -l | grep ^rc) ]] && sudo dpkg -P $(dpkg -l | grep ^rc | tr -s " " | cut -d " " -f 2)
thomas@thomas-Pc:~$ sudo apt update
Atteint:1 http://archive.canonical.com/ubuntu xenial InRelease
Réception de:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial InRelease        
Atteint:4 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease
Réception de:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67,7 kB]
Réception de:7 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [68,0 kB]
Réception de:8 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Réception de:9 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [142 kB]
491 ko réceptionnés en 1s (252 ko/s)                                
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
thomas@thomas-Pc:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python3.6 : Dépend: python3.6-minimal (= 3.6.5-5~16.04.york1) mais il n'est pas installable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
thomas@thomas-Pc:~$ sudo apt autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python3.6 : Dépend: python3.6-minimal (= 3.6.5-5~16.04.york1) mais il n'est pas installable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
thomas@thomas-Pc:~$ 

Hors ligne

#19 Le 19/06/2018, à 16:31

nam1962

Re : Impossible d'utiliser apt-get update

Oui !!! En fait tu es toujours coincé, donc ca peut le faire !


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#20 Le 19/06/2018, à 16:37

Wrench

Re : Impossible d'utiliser apt-get update

La tentative fût un échec ...

thomas@thomas-Pc:~$ sudo sed -i 's/\x0//g' /var/lib/dpkg/info/python3.6-minimal.postinst
sed: impossible de lire /var/lib/dpkg/info/python3.6-minimal.postinst: Aucun fichier ou dossier de ce type
thomas@thomas-Pc:~$ 

Hors ligne

#21 Le 19/06/2018, à 16:41

nam1962

Re : Impossible d'utiliser apt-get update

A propos, pourquoi python 3.6 ?


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#22 Le 19/06/2018, à 16:43

ylag

Re : Impossible d'utiliser apt-get update

@nam1962:

Salut,

sed: impossible de lire /var/lib/dpkg/info/python3.6-minimal.postinst: Aucun fichier ou dossier de ce type

Le paquet aurait été emporté ?

Peut-être tenter:

sudo apt install --reinstall python3.6-minimal

...si la commande dpkg --configure -a ne fonctionne pas ?

A+

Dernière modification par ylag (Le 19/06/2018, à 16:44)

Hors ligne

#23 Le 19/06/2018, à 16:44

nam1962

Re : Impossible d'utiliser apt-get update

+1 !


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#24 Le 19/06/2018, à 16:50

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Le paquet python3.6-minimal ne semble pas dans les dépôts principaux de xenial, ça viendrait d'un ppa ?

A+

Hors ligne

#25 Le 19/06/2018, à 16:54

nam1962

Re : Impossible d'utiliser apt-get update

...d'où ma question sur pourquoi 3.6 wink
Le problème vient peut-être d'un résidu de jonathonf-ubuntu-python-3_6-xenial.list qu'on a viré plus haut


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne