Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 19/06/2018, à 16:57

ylag

Re : Impossible d'utiliser apt-get update

...un coup de:

dpkg --audit

...pour voir l'état du système ?

En ligne

#27 Le 19/06/2018, à 16:58

Wrench

Re : Impossible d'utiliser apt-get update

J'utilise python 3.6 pour programmer mais je sais pas pourquoi il intervient ici ...

et @ylag voilà le retour

thomas@thomas-Pc:~$ sudo apt install --reinstall python3.6-minimal
[sudo] Mot de passe de thomas : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet python3.6-minimal n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « python3.6-minimal » n'a pas de version susceptible d'être installée
thomas@thomas-Pc:~$ 

Hors ligne

#28 Le 19/06/2018, à 17:00

michel_04

Re : Impossible d'utiliser apt-get update

Re,

Dans les dépôts de Xenial : python-minimal (= 2.7.12-1~16.04).
Donc le 3.6 est celui de jonathonf-ubuntu-python-3_6-xenial.list.

A+

Dernière modification par michel_04 (Le 19/06/2018, à 17:01)

En ligne

#29 Le 19/06/2018, à 17:00

Wrench

Re : Impossible d'utiliser apt-get update

@ylag

thomas@thomas-Pc:~$ dpkg --audit
thomas@thomas-Pc:~$ 

Hors ligne

#30 Le 19/06/2018, à 17:02

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Retour vide, donc pas de paquets cassés, il semblerait...
Peut-être retenter les mises à jour ?

A+

En ligne

#31 Le 19/06/2018, à 17:04

ylag

Re : Impossible d'utiliser apt-get update

@michel_04

Salut,

michel_04 a écrit :

Donc le 3.6 est celui de jonathonf-ubuntu-python-3_6-xenial.list.

+1, bien vu...

A+

En ligne

#32 Le 19/06/2018, à 17:04

nam1962

Re : Impossible d'utiliser apt-get update

Autre soluce, réinstaller le PPA, réinstaller python 3.6.
Et savoir pourquoi python 3.6 !!!!


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#33 Le 19/06/2018, à 17:05

Wrench

Re : Impossible d'utiliser apt-get update

Toujours des erreurs

thomas@thomas-Pc:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python3.6 : Dépend: python3.6-minimal (= 3.6.5-5~16.04.york1) mais il n'est pas installable
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
thomas@thomas-Pc:~$ 

Je vais tenter ce que me propose le terminal « apt-get -f install » et je vous redit

Hors ligne

#34 Le 19/06/2018, à 17:06

ylag

Re : Impossible d'utiliser apt-get update

@nam1962:

Salut,

nam1962 a écrit :

Autre soluce, réinstaller le PPA, réinstaller python 3.6.

+1, si les mises à jour passent sans encombre ?

A+

En ligne

#35 Le 19/06/2018, à 17:08

michel_04

Re : Impossible d'utiliser apt-get update

Re,

nam1962 a écrit :

Autre soluce, réinstaller le PPA, réinstaller python 3.6.

+1.

nam1962 a écrit :

Et savoir pourquoi python 3.6 !!!!

@ nam1962

Wrench a écrit :

J'utilise python 3.6 pour programmer

A+

En ligne

#36 Le 19/06/2018, à 17:08

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Les paquets suivants contiennent des dépendances non satisfaites :
 python3.6 : Dépend: python3.6-minimal (= 3.6.5-5~16.04.york1) mais il n'est pas installable

Il faut probablement restaurer le ppa pour terminer la réparation...?

Dernière modification par ylag (Le 19/06/2018, à 17:09)

En ligne

#37 Le 19/06/2018, à 17:08

Wrench

Re : Impossible d'utiliser apt-get update

Tous semble être rentré dans l'ordre , "sudo apt-get upgrade" ne pose plus de problème , y a t'il un autre moyen de vérifier si tout est OK ?

Hors ligne

#38 Le 19/06/2018, à 17:10

nam1962

Re : Impossible d'utiliser apt-get update

sudo apt install --reinstall python3
sudo apt install ppa-purge
sudo add-apt-repository ppa:jonathonf/python-3.6
sudo apt update
sudo apt install python3.6
sudo apt full-upgrade

Et la réponse pour python 3.6 wink

Dernière modification par nam1962 (Le 19/06/2018, à 17:12)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#39 Le 19/06/2018, à 17:11

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Wrench a écrit :

y a t'il un autre moyen de vérifier si tout est OK ?

Essaie peut-être:

dpkg -l |grep -v ^ii

?

Ajout: Note que python3.6 est dans les dépôts de Ubuntu Bionic 18.04, pas besoin de ppa pour l'avoir dans ce cas.

Dernière modification par ylag (Le 19/06/2018, à 17:19)

En ligne

#40 Le 19/06/2018, à 17:15

Wrench

Re : Impossible d'utiliser apt-get update

@nam j'utilse python3.6 pour programmer voilà tout wink

@ylag voilà ce que tu ma dit

thomas@thomas-Pc:~$ dpkg -l |grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                                      Architecture Description
+++-==========================================-============================================-============-================================================================================
rc  libpython3.6-minimal:amd64                 3.6.5-5~16.04.york1                          amd64        Minimal subset of the Python language (version 3.6)
thomas@thomas-Pc:~$ 

Hors ligne

#41 Le 19/06/2018, à 17:19

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Ton retour au #40 est propre, pas de paquets rapportés comme problématiques.
Regarde mon ajout au #39.

A+

Dernière modification par ylag (Le 19/06/2018, à 17:22)

En ligne

#42 Le 19/06/2018, à 17:22

Wrench

Re : Impossible d'utiliser apt-get update

Merci pour votre aide à vous trois , problème résolu smile

Je note pour ton ajout , peut tu m'expliquer brièvement comment le réinstaller avec Bionic? Je suis pas très à l'aise avec les dépôt..

Hors ligne

#43 Le 19/06/2018, à 17:27

ylag

Re : Impossible d'utiliser apt-get update

Salut,

Wrench a écrit :

Je note pour ton ajout , peut tu m'expliquer brièvement comment le réinstaller avec Bionic?

Là, c'est une tout autre histoire: il te faudrait complètement réinstaller ton système en Ubuntu Bionic 18.04 !!!
Ce n'est peut-être pas ce que tu recherches présentement, sinon retente ce que nam1962 te suggère au #38.

A+

En ligne

#44 Le 19/06/2018, à 17:30

Wrench

Re : Impossible d'utiliser apt-get update

Bon alors puisque tout marche je vais rester comme ca smile

A+ et encore merci

Hors ligne