Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/07/2018, à 23:39

Rakkham

[RESOLU] Intel graphics extinction très lente

Bonjour tout le monde,

de retour sous linux (ouf) après longtemps, je cherche à peaufiner un peu mon dual boot Win10/Ubuntu sur mon dell XPS 15 9570

Jusqu'ici tout roule, mais j'ai un souci avec le passage sur la carte graphique Intel :

l'extinction de l'ordinateur (le logout plutôt) est très très long. Comme si un programme empêchait la fermeture, ou si le système avant une espèce de délai (le temps est globalement toujours le même).
La chose ne se produit pas quand je switche sur la carte Nvidia avec Prime dans le panneau de contrôle Nvidia.

Je me demandais s'il ne fallait pas mettre à jour le microcode intel, mais qu'en pensez-vous ?
La commande
apt list intel-microcode -a

Me répond ça :
En train de lister... Fait
intel-microcode/bionic-updates,bionic-security,now 3.20180425.1~ubuntu0.18.04.1 amd64  [installé, automatique]
intel-microcode/bionic 3.20180312.0~ubuntu18.04.1 amd64

Qu'en penser ?

J'ai tenté d'éditer /etc/systemd/system.conf
en changeant le defauttimeout...mais sans grand résultat...à moins que j'ai raté quelque chose ou que je n'ai pas changé la bonne ligne.

Du côté de TLP ? Je ne maîtrise pas trop...

Bref, si vous avez des idées....

Par ailleurs, et sur le même thème, quand je suis sur la GPU dédiée, powertop m'indique 30W vs 20W sur Intel....Des pistes pour optimiser encore mieux la chose ? J'aimerai pouvoir maximiser le temps sur batterie sachant que les programmes gourmands tournent surtout ou bien sur Dauze, ou bien sur secteur.

Merci à tutti d'avance,
R

EDIT :
Le problème venait en fait de la persistance du driver "Nouveau" qui continuait à tourner en plus du GPU d'intel et retardait, je ne sais pourquoi, l'extinction.
Je ne sais plus où j'ai trouvé l'astuce, mais en gros :

J'ai édité Grub comme ça

sudo gedit /etc/default/grub

ajouté

nouveau.modeset=0

à la fin de l'avant dernière ligne (la ligne default)

puis

sudo update grub

et zoo ça marche
Pour vérifier taper la commande

sudo lshw -c video

Le premier display indique maintenant "non réclamé" et ne fait plus mention du driver Nouveau.

Dernière modification par Rakkham (Le 08/07/2018, à 11:57)

Hors ligne