Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 17/07/2018, à 18:39

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Oui ylag, j'ai tenté tout ça...
Comme très souvent maintenant la demande de sortie de veille débouche sur un écran noir, je tente les "touches magiques" pour redémarrer.
J'ai vérifié qu'elles étaient bien installées:

# The magic SysRq key enables certain keyboard combinations to be
# interpreted by the kernel to help with debugging. The kernel will respond
# to these keys regardless of the current running applications.
#
# In general, the magic SysRq key is not needed for the average Ubuntu
# system, and having it enabled by default can lead to security issues on
# the console such as being able to dump memory or to kill arbitrary
# processes including the running screen lock.
#
# Here is the list of possible values:
#   0 - disable sysrq completely
#   1 - enable all functions of sysrq
#  >1 - enable certain functions by adding up the following values:
#          2 - enable control of console logging level
#          4 - enable control of keyboard (SAK, unraw)
#          8 - enable debugging dumps of processes etc.
#         16 - enable sync command
#         32 - enable remount read-only
#         64 - enable signalling of processes (term, kill, oom-kill)
#        128 - allow reboot/poweroff
#        256 - allow nicing of all RT tasks
#
#   For example, to enable both control of console logging level and
#   debugging dumps of processes: kernel.sysrq = 10
#
kernel.sysrq = 176

Je ne comprends pas le détail mais la dernière ligne semble indiquer que les touches magiques sont installées.
Mais quand l'écran reste noir, si j'applique ta proposition:

En l'occurrence, tu pouvais repasser en session graphique : Ctrl Alt F7
puis employer ces touches magiques.

Concrètement, pour redémarrer:
Alt+Sys  r e i s  (*)    u (*)    b

(*) attendre quelques secondes.

Rien ne se passe.
Je suis donc contraint d'arrêter en force.

Dernière modification par jemo (Le 17/07/2018, à 18:39)

Hors ligne

#27 Le 17/07/2018, à 20:39

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Ça devrait fonctionner avec la valeur kernel.sysrq =176.
Sans régler ton problème d'écran noir, ça te permettrait de redémarrer ou d'arrêter plus proprement ta machine.

Il faut tenir enfoncées simultanément les clés Alt et <ImprÉcran Sys>, puis faire successivement r, e, i, s, u et b. (en gardant enfoncées les deux premières clés...) ?
Si tu fais la lettre o à la place de b, la machine devrait s'arrêter au lieu de redémarrer.

A+

Dernière modification par ylag (Le 18/07/2018, à 20:48)

Hors ligne

#28 Le 17/07/2018, à 21:24

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Une solution que tu pourrais tenter: Remplacer le gestionnaire d'affichage et de login gdm3 par lightdm, si bien sûr tu es présentement sous gdm3.
Chez-moi sur une vieille tour datant de 2009, Ubuntu 16.04 ainsi que la 18.04 et une distro Debian testing fonctionnent toutes les trois passablement mieux avec lightdm...

Pour ce faire, installer lightdm:

sudo apt install lightdm

Puis reconfigurer le gestionnaire d'affichage:

sudo dpkg-reconfigure lightdm

...une fenêtre semi-graphique devrait alors s'ouvrir dans le terminal, y mettre en surbrillance lightdm en se déplacant à l'aide des flèches du clavier, puis faire la touche <Entrée> pour valider le choix. Le redémarrage subséquent devrait alors se faire sous lightdm, et tu pourrais tester le fonctionnement de la mise en veille.
Note que l'installataion de lightdm pourrait tirer un bon nombre de dépendances (désolé, je ne m'en souviens pas vraiment...), à toi de voir si tu tentes le coup.

Pour revenir sous gdm3:

sudo dpkg-reconfigure lightdm

...ou:

sudo dpkg-reconfigure gdm3

...les deux feront aussi bien l'affaire.
Remettre alors en surbrillance gdm3 et valider le choix avec la touche Entrée.
Un redémarrage devrait alors se faire sous gdm3 et il est ensuite possible de virer lightdm, si désiré, en faisant:

sudo apt purge lightdm

Je vois plusieurs sujets de discussion concernant un écran noir en sortie de veille, mais peu de solutions...  neutral

A+

Dernière modification par ylag (Le 17/07/2018, à 21:38)

Hors ligne

#29 Le 17/07/2018, à 22:48

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonsoir ylag,
En regardant sur Synaptic, je vois que je suis déjà sous lightdm.
Serait-il intéressant de passer au contraire sous gdm3 ?
Utiliser Synaptic pour le changement est-ce aussi bien?
Je constate que l'écran noir devient systématique!...

Hors ligne

#30 Le 17/07/2018, à 23:00

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Si tu fais:

sudo dpkg-reconfigure lightdm

...as-tu le choix de gdm3 dans la fenêtre qui s'ouvre ?
Si oui, tu pourrais le sélectionner et ainsi tenter de redémarrer sous gdm3.
S'il n'est pas déjà installé, tu peux certainement le faire via Synaptic, mais je ne sais pas si sa configuration en sera faite automatiquement, ou si tu devras passer par un sudo dpkg-reconfigure pour l'activer.

Si tu as les deux gestionnaires d'installés, et que tu ne te souviennes pas de les avoir installé manuellement, je te conseillerais de n'en virer aucun des deux, contrairement à ce que je t'ai suggéré au commentaire #28.
Les deux peuvent cohabiter, il suffit de reconfigurer pour passer de l'un à l'autre.

Sauf erreur de ma part, Synaptic indique l'état d'un paquet (installé, non-installé, brisé, etc...) mais ne donne pas d'indications quant à son utilisation ?

A+

Dernière modification par ylag (Le 17/07/2018, à 23:15)

Hors ligne

#31 Le 17/07/2018, à 23:08

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci
La fenêtre qui s'ouvre n'offre pas de choix.
Si j'installe gdm3 avec synaptic, dois-je désinstaller ligthdm avant de faire sudo dpkg-reconfigure

Hors ligne

#32 Le 17/07/2018, à 23:14

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Désolé, nos messages se sont croisés.
Pas nécessaire de désinstaller, voir mon commentaire #30.
Si lightdm fait partie de l'installation de base de XFCE, il vaut mieux ne pas le désinstaller.

Note que n'ayant aucune expérience de XFCE, je ne sais si gdm3 y est bien supporté.

Pour avoir une idée exacte de quel gestionnaire tourne actuellement sur ta machine, tu peux faire:

ps aux | grep -E "gdm|lightdm"

Chez-moi, sous lightdm ça donne:

yvan@yvan-maison:~$ ps aux| grep -E "gdm|lightdm"
root       740  0.0  0.1 364356  6844 ?        SLsl 05:47   0:00 /usr/sbin/lightdm
root       755  1.9  2.2 427188 91760 tty7     Ssl+ 05:47  13:44 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
root      1046  0.0  0.1 250544  7268 ?        Sl   05:47   0:00 lightdm --session-child 12 19
yvan     15465  0.0  0.0  15664  1116 pts/0    R+   17:34   0:00 grep --color=auto -E gdm|lightdm
yvan@yvan-maison:~$

Si c'est installé chez-toi (c'est le paquet gnome-system-monitor), tu peux aussi regarder dans le "Moniteur système", onglet "Processus" pour voir ce qui tourne sur ta machine...

A+

Dernière modification par ylag (Le 17/07/2018, à 23:45)

Hors ligne

#33 Le 18/07/2018, à 00:08

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

gdm3 est compatible selon Synaptic, mais tous les paquets ne peuvent pas être chargés!
J'ai tenté toutefois, mais sans succès! La mise en veille devenait impossible!

Chez moi ligthdm donne ça (avant que je ne supprime gdm3) :

cactusc@cactusc-H81H3-EM2:~$ ps aux | grep -E "gdm|lightdm"
root      1194  0.0  0.1 308824  9088 ?        SLsl 23:43   0:00 /usr/sbin/lightdm
root      1212 17.5  1.5 757980 125124 tty7    Ssl+ 23:43   0:41 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
root      3100  0.0  0.0 250544  7088 ?        Sl   23:43   0:00 lightdm --session-child 12 19
cactusc   4020  0.0  0.0  22000  1148 pts/0    S+   23:47   0:00 grep --color=auto -E gdm|lightdm
cactusc@cactusc-H81H3-EM2:~$ 

Actuellement, je n'ai plus d'autre solution que d'éteindre et d'allumer à chaque fois, ce que je trouve très fastidieux!
Merci pour ton aide.

Dernière modification par jemo (Le 18/07/2018, à 00:16)

Hors ligne

#34 Le 18/07/2018, à 01:43

Coeur Noir

Re : Mise en veille curieuse et lenteur de la mise en route

As-tu essayé de démarrer ton pc sur un noyau Linux plus ancien ( c'est à dire pas sur le 4.15.0-24 ) ?

Si ce choix ( via un écran qu'on appelle grub ) n'apparaît pas au démarrage de ta machine, un appui sur la touche majuscule ( ou Echap, parfois ) pendant le démarrage devrait le faire apparaître.

Peux-tu donner les retours de :

lsb_release -a
uname -a
cat /etc/default/grub

Toute modification du fichier grub, pour être répercutée, doit être suivie de la commande

sudo update-grub

Dernière modification par Coeur Noir (Le 18/07/2018, à 02:11)

Hors ligne

#35 Le 18/07/2018, à 09:43

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour Coeur Noir,
Oui, j'ai tenté avec la version antérieure du noyau : sans succès.
voici le retour:

cactusc@cactusc-H81H3-EM2:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04 LTS
Release:	18.04
Codename:	bionic
cactusc@cactusc-H81H3-EM2:~$ uname -a
Linux cactusc-H81H3-EM2 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
cactusc@cactusc-H81H3-EM2:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
cactusc@cactusc-H81H3-EM2:~$ 
cactusc@cactusc-H81H3-EM2:~$ 

Hors ligne

#36 Le 18/07/2018, à 13:32

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

jemo a écrit :

gdm3 est compatible selon Synaptic, mais tous les paquets ne peuvent pas être chargés!

Si tu ne parviens pas à installer correctement gdm3 et que l'ajout de l'option scsi_mod.scan=sync à la ligne de commande du démarrage, comme suggéré au commentaire #12, ne semble pas plus fonctionner, je n'aurai alors pas d'autres suggestions à te faire, désolé.
Peut-être que @Coeur Noir pourra arriver à dénicher une solution pour toi.

A+

Hors ligne

#37 Le 18/07/2018, à 14:54

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

J'ai tenté, à nouveau, d'ajouter scsi_mod.scan=sync à la ligne de commande du démarrage en suivant la procédure 7.10.1
Cela donne le résultat suivant à  /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash Valeur Option Validée "
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

j'ai validé jusqu'au bout comme indiqué en 7.10.2 jusqu'à : sudo update-grub
La mise en veille fonctionne, mais la sortie de veille reste systématiquement impossible.

Les touches magiques n'ont aucun effet alors qu'elles sont bien actives en principe: je pense avoir pourtant compris la procédure:
Appuyer en même temps sur Alt et Syst et, tout en maintenant ces touches enfoncées, appuyer successivement sur r puis e puis i puis s (laisser passer quelques secondes) puis u (laisser passer quelques secondes et enfin b .
L'écran reste noir sans la moindre manifestation.

Hors ligne

#38 Le 18/07/2018, à 15:17

Coeur Noir

Re : Mise en veille curieuse et lenteur de la mise en route

Euh… c'est quoi ça :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash Valeur Option Validée "

Valeur Option validée ???

Est-ce que ça ne devrait pas plutôt ressembler à :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="scsi_mod.scan=sync"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Dernière modification par Coeur Noir (Le 18/07/2018, à 15:19)

Hors ligne

#39 Le 18/07/2018, à 15:25

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Tu t'es laissé induire en erreur par la doc: il faut remplacer Valeur Option Validée par  scsi_mod.scan=sync. La doc donne cette valeur en exemple, à remplacer par celle que tu désires ajouter.
Pour réparer, ouvre le fichier /etc/default/grub en mode administrateur dans un éditeur de fichiers (je te conseille de le faire à l'aide de nano):

sudo nano /etc/default/grub

...déplace le curseur à l'aide des flèches du clavier à la fin de Valeur Option Validée, efface en faisant "backspace", puis remplace par  scsi_scan.mode=sync
La ligne GRUB_CMDLINE_LINUX_DEFAULT devrait se lire comme suit:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash scsi_scan.mode=sync"

Faire ensuite Ctrl+o (lettre o) pour enregistrer les modifications au fichier, suivi de la touche "Enter" pour fermer le fichier, et enfin Ctrl+x pour fermer nano.
Consulte l'aide de nano pour en savoir plus (man nano dans le terminal....)
Ajout: La page de la doc concernant nano: https://doc.ubuntu-fr.org/nano

Une fois le fichier modifié, il faut passer:

sudo update-grub

...avant de redémarrer.

Dans la nouvelle session, fait:

dmesg|grep -i command

...pour voir la ligne de commande du démarrage, ta nouvelle option devrait y apparaître.

Pour revenir à l'état normal de base du fichier grub, tu pourras le rééditer en enlevant l'option ajoutée pour que la ligne ne contienne plus que les valeurs "quiet splash".
N'oublie pas de toujours faire sudo update-grub après avoir modifié ce fichier.

Edit: grillé par Coeur Noir, désolé, je te laisse continuer, si tu le désires....

A+

Dernière modification par ylag (Le 18/07/2018, à 16:45)

Hors ligne

#40 Le 18/07/2018, à 15:41

Coeur Noir

Re : Mise en veille curieuse et lenteur de la mise en route

Nope nope no problem… justement tu expliques mieux, et moi je n'avais peut-être pas mis l'option au bon endroit… donc jemo essaie ce que propose ylag #39.

Hors ligne

#41 Le 18/07/2018, à 16:23

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

@Coeur Noir:

Salut,

Tu as certainement une bien plus grande connaissance du système Linux que moi, n'hésite jamais à intervenir. smile
Ces problèmes de sortie de veille semblent bigrement coriaces !
Se pourrait-il que son pilote graphique soit impliqué...?

Ajout: Pour la différence entre les lignes GRUB_CMDLINE_LINUX_DEFAULT et GRUB_CMDLINE_LINUX, je crois que les options passées à la première sont prises en compte durant un démarrage normal seulement et que celles passées à la seconde le sont pour tout démarrage, y compris en mode "recovery"...?
Vaut peut-être mieux utiliser la ligne DEFAULT pour ne pas nuire au démarrage en "recovery", si une option coince le démarrage normal...?

A+

Dernière modification par ylag (Le 18/07/2018, à 20:16)

Hors ligne

#42 Le 18/07/2018, à 16:34

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

@jemo:

Salut,

Si possible, donne-nous le retour de:

lspci -nn -k | grep -i vga -A3

...qui permettra de voir de quelle carte vidéo tu disposes ainsi que le pilote utilisé.

A+

Hors ligne

#43 Le 18/07/2018, à 20:17

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci à vous deux.
Voici les retours.

cactusc@cactusc-H81H3-EM2:~$ dmesg|grep -i command
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic root=UUID=d9b4d654-190a-4da3-8d19-b32b7797cf57 ro quiet splash scsi_scan.mode=sync vt.handoff=1
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic root=UUID=d9b4d654-190a-4da3-8d19-b32b7797cf57 ro quiet splash scsi_scan.mode=sync vt.handoff=1
cactusc@cactusc-H81H3-EM2:~$ lspci -nn -k | grep -i vga -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 760 OEM] [10de:118e] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] GK104 [GeForce GTX 760 OEM] [1462:284b]
	Kernel modules: nvidiafb, nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation GK104 HDMI Audio Controller [10de:0e0a] (rev a1)
cactusc@cactusc-H81H3-EM2:~$ 

Désolé de ne pas tout comprendre... d'autant que mon faible niveau d'anglais ne me donne pas accès aux explications dans cette langue!

Après avoir passé les commandes, j'ai voulu mettre en veille: impossible.
Est apparue une ligne en haut de l'écran sur fond noir que je retranscris:
[277.011316] Freezing of tasks failed after 20.003 seconds (1 tasks refusing to freeze, wq_busy=0):
j'ai fait entrée et la page sur laquelle j'étais avant de demander la mise en veille est réapparue.
J'ai redemandé la mise en veille: l'écran noir est apparu mais le témoin de mon ordinateur est resté allumé au lieu de clignoter comme lorsqu'il est en état de veille.
J'ai tenté les touches magiques pour redémarrer sans plus de succès! Mais n'y a-t-il pas plusieurs sortes d'écran noir?
J'ai donc éteint en force.

Dernière modification par jemo (Le 18/07/2018, à 20:55)

Hors ligne

#44 Le 18/07/2018, à 20:59

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

La ligne de commande a bien été modifiée pour y inclure l'option scsi_scan.mode=sync.

Concernant les messages d'erreur que tu cites, désolé mais ça dépasse largement mes compétences. Il faudra faire des recherches spécifiques en ce sens.
Possible que ce soit une tâche tournant en toile de fond qui refuse de se terminer normalement, nuisant au bon fonctionnement de la mise / sortie de veille. Si c'est le cas, je ne sais comment le déterminer....

Par contre, le retour de la commande lspci me semble curieux: À mon avis, il devrait y avoir en plus une ligne du genre de:

Kernel driver in use: nouveau

Que donne le retour de:

lsmod | grep -E "nvidia|nouveau"

Si ta session graphique fonctionne normalement hormis la mise en veille, essaie d'ouvrir "Logiciels et mises à jour", onglet "Pilotes additionnels" pour voir ce qui y est sélectionné et/ou proposé. Tu pourrais tenter de passer sous une version du pilote proprio nvidia, si possible ?

La commande:

ubuntu-drivers devices

...devrait aussi fournir les pilotes disponibles pour ton matériel, sans pour autant indiquer ce qui est installé et utilisé sur ton système par contre.

A+

Dernière modification par ylag (Le 18/07/2018, à 21:33)

Hors ligne

#45 Le 18/07/2018, à 21:59

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Voici le résultat:

cactusc@cactusc-H81H3-EM2:~$ lsmod | grep -E "nvidia|nouveau"
cactusc@cactusc-H81H3-EM2:~$ 

et:

cactusc@cactusc-H81H3-EM2:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd0000118Esv00001462sd0000284Bbc03sc00i00
vendor   : NVIDIA Corporation
model    : GK104 [GeForce GTX 760 OEM]
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

cactusc@cactusc-H81H3-EM2:~$ 

Je pourrais, comme je l'avais tenté, remettre la distribution propriétaire.

Hors ligne

#46 Le 18/07/2018, à 22:39

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonsoir,
J'ai remplacé la distribution libre par la distribution propriétaire nvidia.
J'ai aussi, par synaptic, supprimé XScreensaver, un économiseur d'écran qui intervenait parfois bizarrement: je n'en ai pas besoin car mon ordi est habituellement soit actif soit en veille.

Depuis, après plusieurs essais, la mise en veille et la sortie de veille fonctionnent parfaitement.
Je crois que je peux mettre [résolu]!

Merci beaucoup à vous pour votre expertise et votre patience!...

Hors ligne

#47 Le 18/07/2018, à 22:50

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Content que ça marche enfin!! smile

Il semblerait qu'aucun des pilotes "nouveau" ou propriétaire NVIDIA n'était configuré pour ta carte graphique, tu devais tourner sous un pilote générique genre "mesa" pour avoir un affichage fonctionnel...?

Pourrais-tu spécifier ce que tu as tenté ?
Es-tu passé par "Logiciels et mises à jour" pour sélectionner un pilote à installer ?
Ce serait bon de le savoir au cas où d'autres ayant le même problème passent sur ce fil de discussion.

Si ce n'est pas déjà fait, tu pourrais aussi probablement retirer l'option scsi_scan.mode=sync de la ligne de commande et voir si ça fonctionne toujours...

Redonne donc les retours de:

lsmod | grep -E "nvidia|nouveau"

...et de:

lspci -nn -k | grep -i vga -A3

A+

Dernière modification par ylag (Le 18/07/2018, à 22:56)

Hors ligne

#48 Le 18/07/2018, à 23:34

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Oui, je suis passé par Logiciel et mise à jour et j'ai choisi la version 340 106 de nvidia. Je fonctionnais sur le pilote libre.

cactusc@cactusc-H81H3-EM2:~$ lsmod | grep -E "nvidia|nouveau"
nvidia_uvm             36864  0
nvidia              10559488  32 nvidia_uvm
drm                   401408  4 nvidia
cactusc@cactusc-H81H3-EM2:~$ lspci -nn -k | grep -i vga -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 760 OEM] [10de:118e] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] GK104 [GeForce GTX 760 OEM] [1462:284b]
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia
cactusc@cactusc-H81H3-EM2:~$ 

Merci encore.
Je vais tenter de retirer scsi_scan.mode=sync

Hors ligne

#49 Le 18/07/2018, à 23:49

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Suite:
J'ai retiré scsi_scan.mode=sync et la mise en veille ainsi que la sortie de veille fonctionnent ...
Bonne nuit.

Hors ligne

#50 Le 19/07/2018, à 00:00

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

+1 pour les retours au #48.

Par contre si on se fie au retour du #45:

driver   : nvidia-driver-390 - distro non-free recommended

C'est probablement celui que tu devrais privilégier: recommended
Ta carte graphique GeForce GTX 760 est quand même relativement récente, et NVIDIA recommande les pilotes de série 390 pour ce modèle sur son site. Les 340 sont des pilotes "Legacy" pour les GPU beaucoup plus anciens non-supportés par les pilotes courants, tel ma vielle GeForce 8600GT qui ne peut en utiliser de plus récents. En plus, cette série 340 ne devrait plus être supportée par NVIDIA à partir de 2020...

En conclusion, si tout fonctionne normalement, passe le sujet en [Résolu]... smile

A+

Dernière modification par ylag (Le 19/07/2018, à 00:05)

Hors ligne