Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/07/2018, à 09:02

Louis23

Le terminal est un bon outil, pas pour moi

Bonjour,
La énième fois que je tente d'installer un serveur LAMP, notre ami krodelabestiole m'a indiqué ce tuto
donc avec le terminal je tape la première ligne de commande: "ou si vous préférez opter pour MariaDB au lieu de MySQ"L :

sudo apt install libapache2-mod-php mariadb-server php-mysql

et comme réponse j'ai :

louis@louis-R530-R730-P530:~$ sudo apt install libapache2-mod-php mariadb-server php-mysql
[sudo] Mot de passe de louis : 
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.
louis@louis-R530-R730-P530:

autrement dit le répertoire est semble-t-il occupé par quelqu'un d'autre à cet heure ci il y a personne chez moi. voilà dois-je définitivement renoncer à installer LAMP, je pense qu'il y a des explications, si je pouvais en avoir ce serait génial,
Merci

Hors ligne

#2 Le 18/07/2018, à 09:06

xubu1957

Re : Le terminal est un bon outil, pas pour moi

Bonjour,

Tu as consulté la Doc probleme_apt#impossible_de_verrouillervarlibdpkglock ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 18/07/2018, à 12:45

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

cette erreur n'a pas de rapport avec LAMP ni avec le terminal directement.
c'est une erreur très classique liée à APT.

mais tu fais bien de poser la question ici, parce que la plupart des gens conseillent de supprimer sauvagement le fichier embêtant sans se poser de question. Ce qui peut éventuellement engendrer des problèmes plus conséquents.

j'ai modifié la doc proposée par xubu1957 qui n'était ni détaillée ni à jour :
https://doc.ubuntu-fr.org/probleme_apt# … ibdpkglock

Hors ligne

#4 Le 18/07/2018, à 13:57

Louis23

Re : Le terminal est un bon outil, pas pour moi

donc j'appellé

sudo apt install -f 

et comme réponse

louis@louis-R530-R730-P530:~$ sudo apt install -f 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait bon
0 mis à jour, 0 nouvellement installés, 0 à enlever et 593 non mis à jour.
louis@louis-R530-R730-P530:~$ 

ça semble bon, j'avance avec prudence
@+

Hors ligne

#5 Le 18/07/2018, à 14:15

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

Louis23 a écrit :

donc j'appellé

sudo apt install -f 

tu as trouvé ça où ?
le chapitre qu'on t'a envoyé c'est Impossible de verrouiller /var/lib/dpkg/lock, c'est tout.
le placement de la doc avec ces liens est peut-être un peu foireux, mais au pire lis le nom du chapitre dans l'url.

bon en tout cas si cette commande ne te retourne pas d'erreur, c'est que tu peux relancer :

sudo apt install libapache2-mod-php mariadb-server php-mysql

c'était sûrement ton gestionnaire de mise à jour qui tournait au même moment...

Hors ligne

#6 Le 18/07/2018, à 14:23

grandtoubab

Re : Le terminal est un bon outil, pas pour moi

Louis23 a écrit :

donc j'appellé

 593 non mis à jour.
louis@louis-R530-R730-P530:~$ 

ça semble bon,
@+

c'est pas ce que j'appelerai une installation en bon état.
593 paquets !!ça doit faire assez longtemps que tu n'as pas mis à jour

depuis quand est-ce verrouillé?

ls -alrt /var/lib/dpkg/lock

pour voir l'étendu des dégâts

sudo apt-get dist-upgrade

Dernière modification par grandtoubab (Le 18/07/2018, à 14:24)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#7 Le 18/07/2018, à 15:55

Louis23

Re : Le terminal est un bon outil, pas pour moi

@ krodelabestiole
j'ai suivi le lien que du m'a indiqué

https://doc.ubuntu-fr.org/probleme_apt# … ibdpkglock

J'ai suivi ton lien

sudo apt install libapache2-mod-php mariadb-server php-mysql

résultat:

louis@louis-R530-R730-P530:~$ sudo apt install libapache2-mod-php mariadb-server php-mysql
[sudo] Mot de passe de louis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants vont être installés :
  apache2 apache2-bin apache2-data apache2-utils libaio1 libapache2-mod-php7.0
  libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libdbd-mysql-perl libdbi-perl libhtml-template-perl liblua5.1-0
  libmysqlclient20 libreadline5 libterm-readkey-perl mariadb-client-10.0
  mariadb-client-core-10.0 mariadb-common mariadb-server-10.0
  mariadb-server-core-10.0 mysql-common php-common php7.0-cli php7.0-common
  php7.0-json php7.0-mysql php7.0-opcache php7.0-readline
Paquets suggérés :
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom php-pear
  libmldbm-perl libnet-daemon-perl libsql-statement-perl
  libipc-sharedcache-perl mailx mariadb-test tinyca
Les NOUVEAUX paquets suivants seront installés :
  apache2 apache2-bin apache2-data apache2-utils libaio1 libapache2-mod-php
  libapache2-mod-php7.0 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libdbd-mysql-perl libdbi-perl libhtml-template-perl
  liblua5.1-0 libmysqlclient20 libreadline5 libterm-readkey-perl
  mariadb-client-10.0 mariadb-client-core-10.0 mariadb-common mariadb-server
  mariadb-server-10.0 mariadb-server-core-10.0 mysql-common php-common
  php-mysql php7.0-cli php7.0-common php7.0-json php7.0-mysql php7.0-opcache
  php7.0-readline
0 mis à jour, 33 nouvellement installés, 0 à enlever et 593 non mis à jour.
Il est nécessaire de prendre 21,6 Mo dans les archives.
Après cette opération, 166 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libapr1 amd64 1.5.2-3 [86,0 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libaprutil1 amd64 1.5.4-1build1 [77,1 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libaprutil1-dbd-sqlite3 amd64 1.5.4-1build1 [10,6 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libaprutil1-ldap amd64 1.5.4-1build1 [8 720 B]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 liblua5.1-0 amd64 5.1.5-8ubuntu1 [102 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apache2-bin amd64 2.4.18-2ubuntu3.9 [925 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apache2-utils amd64 2.4.18-2ubuntu3.9 [81,8 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apache2-data all 2.4.18-2ubuntu3.9 [162 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apache2 amd64 2.4.18-2ubuntu3.9 [86,6 kB]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-common all 5.7.22-0ubuntu0.16.04.1 [15,4 kB]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-common all 10.0.34-0ubuntu0.16.04.1 [16,0 kB]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libdbi-perl amd64 1.634-1build1 [743 kB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmysqlclient20 amd64 5.7.22-0ubuntu0.16.04.1 [809 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libdbd-mysql-perl amd64 4.033-1ubuntu0.1 [84,3 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libterm-readkey-perl amd64 2.33-1build1 [27,2 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libaio1 amd64 0.3.110-2 [6 356 B]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libreadline5 amd64 5.2+dfsg-3build1 [99,5 kB]
Réception de:18 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-client-core-10.0 amd64 10.0.34-0ubuntu0.16.04.1 [4 289 kB]
Réception de:19 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-client-10.0 amd64 10.0.34-0ubuntu0.16.04.1 [1 173 kB]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-server-core-10.0 amd64 10.0.34-0ubuntu0.16.04.1 [4 851 kB]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-server-10.0 amd64 10.0.34-0ubuntu0.16.04.1 [4 268 kB]
Réception de:22 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php-common all 1:35ubuntu6.1 [10,8 kB]
Réception de:23 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-common amd64 7.0.30-0ubuntu0.16.04.1 [840 kB]
Réception de:24 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-json amd64 7.0.30-0ubuntu0.16.04.1 [16,9 kB]
Réception de:25 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-opcache amd64 7.0.30-0ubuntu0.16.04.1 [77,2 kB]
Réception de:26 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-readline amd64 7.0.30-0ubuntu0.16.04.1 [12,8 kB]
Réception de:27 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-cli amd64 7.0.30-0ubuntu0.16.04.1 [1 282 kB]
Réception de:28 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libapache2-mod-php7.0 amd64 7.0.30-0ubuntu0.16.04.1 [1 224 kB]
Réception de:29 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libapache2-mod-php all 1:7.0+35ubuntu6.1 [2 990 B]
Réception de:30 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-template-perl all 2.95-2 [60,4 kB]
Réception de:31 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 mariadb-server all 10.0.34-0ubuntu0.16.04.1 [13,1 kB]
Réception de:32 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php7.0-mysql amd64 7.0.30-0ubuntu0.16.04.1 [125 kB]
Réception de:33 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 php-mysql all 1:7.0+35ubuntu6.1 [1 928 B]
21,6 Mo réceptionnés en 22s (955 ko/s)                                         
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
Sélection du paquet libapr1:amd64 précédemment désélectionné.
(Lecture de la base de données... 182694 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libapr1_1.5.2-3_amd64.deb ...
Dépaquetage de libapr1:amd64 (1.5.2-3) ...
Sélection du paquet libaprutil1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libaprutil1_1.5.4-1build1_amd64.deb ...
Dépaquetage de libaprutil1:amd64 (1.5.4-1build1) ...
Sélection du paquet libaprutil1-dbd-sqlite3:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libaprutil1-dbd-sqlite3_1.5.4-1build1_amd64.deb ...
Dépaquetage de libaprutil1-dbd-sqlite3:amd64 (1.5.4-1build1) ...
Sélection du paquet libaprutil1-ldap:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libaprutil1-ldap_1.5.4-1build1_amd64.deb ...
Dépaquetage de libaprutil1-ldap:amd64 (1.5.4-1build1) ...
Sélection du paquet liblua5.1-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../liblua5.1-0_5.1.5-8ubuntu1_amd64.deb ...
Dépaquetage de liblua5.1-0:amd64 (5.1.5-8ubuntu1) ...
Sélection du paquet apache2-bin précédemment désélectionné.
Préparation du dépaquetage de .../apache2-bin_2.4.18-2ubuntu3.9_amd64.deb ...
Dépaquetage de apache2-bin (2.4.18-2ubuntu3.9) ...
Sélection du paquet apache2-utils précédemment désélectionné.
Préparation du dépaquetage de .../apache2-utils_2.4.18-2ubuntu3.9_amd64.deb ...
Dépaquetage de apache2-utils (2.4.18-2ubuntu3.9) ...
Sélection du paquet apache2-data précédemment désélectionné.
Préparation du dépaquetage de .../apache2-data_2.4.18-2ubuntu3.9_all.deb ...
Dépaquetage de apache2-data (2.4.18-2ubuntu3.9) ...
Sélection du paquet apache2 précédemment désélectionné.
Préparation du dépaquetage de .../apache2_2.4.18-2ubuntu3.9_amd64.deb ...
Dépaquetage de apache2 (2.4.18-2ubuntu3.9) ...
Sélection du paquet mysql-common précédemment désélectionné.
Préparation du dépaquetage de .../mysql-common_5.7.22-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de mysql-common (5.7.22-0ubuntu0.16.04.1) ...
Sélection du paquet mariadb-common précédemment désélectionné.
Préparation du dépaquetage de .../mariadb-common_10.0.34-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de mariadb-common (10.0.34-0ubuntu0.16.04.1) ...
Sélection du paquet libdbi-perl précédemment désélectionné.
Préparation du dépaquetage de .../libdbi-perl_1.634-1build1_amd64.deb ...
Dépaquetage de libdbi-perl (1.634-1build1) ...
Sélection du paquet libmysqlclient20:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libmysqlclient20_5.7.22-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de libmysqlclient20:amd64 (5.7.22-0ubuntu0.16.04.1) ...
Sélection du paquet libdbd-mysql-perl précédemment désélectionné.
Préparation du dépaquetage de .../libdbd-mysql-perl_4.033-1ubuntu0.1_amd64.deb ...
Dépaquetage de libdbd-mysql-perl (4.033-1ubuntu0.1) ...
Sélection du paquet libterm-readkey-perl précédemment désélectionné.
Préparation du dépaquetage de .../libterm-readkey-perl_2.33-1build1_amd64.deb ...
Dépaquetage de libterm-readkey-perl (2.33-1build1) ...
Sélection du paquet libaio1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libaio1_0.3.110-2_amd64.deb ...
Dépaquetage de libaio1:amd64 (0.3.110-2) ...
Sélection du paquet libreadline5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libreadline5_5.2+dfsg-3build1_amd64.deb ...
Dépaquetage de libreadline5:amd64 (5.2+dfsg-3build1) ...
Sélection du paquet mariadb-client-core-10.0 précédemment désélectionné.
Préparation du dépaquetage de .../mariadb-client-core-10.0_10.0.34-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mariadb-client-core-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Sélection du paquet mariadb-client-10.0 précédemment désélectionné.
Préparation du dépaquetage de .../mariadb-client-10.0_10.0.34-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mariadb-client-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Sélection du paquet mariadb-server-core-10.0 précédemment désélectionné.
Préparation du dépaquetage de .../mariadb-server-core-10.0_10.0.34-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mariadb-server-core-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu3) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu7) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour ufw (0.35-0ubuntu2) ...
Paramétrage de mysql-common (5.7.22-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /etc/mysql/my.cnf.fallback » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
Paramétrage de mariadb-common (10.0.34-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /etc/mysql/mariadb.cnf » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
Sélection du paquet mariadb-server-10.0 précédemment désélectionné.
(Lecture de la base de données... 183745 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mariadb-server-10.0_10.0.34-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mariadb-server-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Sélection du paquet php-common précédemment désélectionné.
Préparation du dépaquetage de .../php-common_1%3a35ubuntu6.1_all.deb ...
Dépaquetage de php-common (1:35ubuntu6.1) ...
Sélection du paquet php7.0-common précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-common_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-common (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet php7.0-json précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-json_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-json (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet php7.0-opcache précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-opcache_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-opcache (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet php7.0-readline précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-readline_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-readline (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet php7.0-cli précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-cli_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-cli (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet libapache2-mod-php7.0 précédemment désélectionné.
Préparation du dépaquetage de .../libapache2-mod-php7.0_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de libapache2-mod-php7.0 (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet libapache2-mod-php précédemment désélectionné.
Préparation du dépaquetage de .../libapache2-mod-php_1%3a7.0+35ubuntu6.1_all.deb ...
Dépaquetage de libapache2-mod-php (1:7.0+35ubuntu6.1) ...
Sélection du paquet libhtml-template-perl précédemment désélectionné.
Préparation du dépaquetage de .../libhtml-template-perl_2.95-2_all.deb ...
Dépaquetage de libhtml-template-perl (2.95-2) ...
Sélection du paquet mariadb-server précédemment désélectionné.
Préparation du dépaquetage de .../mariadb-server_10.0.34-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de mariadb-server (10.0.34-0ubuntu0.16.04.1) ...
Sélection du paquet php7.0-mysql précédemment désélectionné.
Préparation du dépaquetage de .../php7.0-mysql_7.0.30-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de php7.0-mysql (7.0.30-0ubuntu0.16.04.1) ...
Sélection du paquet php-mysql précédemment désélectionné.
Préparation du dépaquetage de .../php-mysql_1%3a7.0+35ubuntu6.1_all.deb ...
Dépaquetage de php-mysql (1:7.0+35ubuntu6.1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu7) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de libapr1:amd64 (1.5.2-3) ...
Paramétrage de libaprutil1:amd64 (1.5.4-1build1) ...
Paramétrage de libaprutil1-dbd-sqlite3:amd64 (1.5.4-1build1) ...
Paramétrage de libaprutil1-ldap:amd64 (1.5.4-1build1) ...
Paramétrage de liblua5.1-0:amd64 (5.1.5-8ubuntu1) ...
Paramétrage de apache2-bin (2.4.18-2ubuntu3.9) ...
Paramétrage de apache2-utils (2.4.18-2ubuntu3.9) ...
Paramétrage de apache2-data (2.4.18-2ubuntu3.9) ...
Paramétrage de apache2 (2.4.18-2ubuntu3.9) ...
Enabling module mpm_event.
Enabling module authz_core.
Enabling module authz_host.
Enabling module authn_core.
Enabling module auth_basic.
Enabling module access_compat.
Enabling module authn_file.
Enabling module authz_user.
Enabling module alias.
Enabling module dir.
Enabling module autoindex.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module filter.
Enabling module deflate.
Enabling module status.
Enabling conf charset.
Enabling conf localized-error-pages.
Enabling conf other-vhosts-access-log.
Enabling conf security.
Enabling conf serve-cgi-bin.
Enabling site 000-default.
Paramétrage de libdbi-perl (1.634-1build1) ...
Paramétrage de libmysqlclient20:amd64 (5.7.22-0ubuntu0.16.04.1) ...
Paramétrage de libdbd-mysql-perl (4.033-1ubuntu0.1) ...
Paramétrage de libterm-readkey-perl (2.33-1build1) ...
Paramétrage de libaio1:amd64 (0.3.110-2) ...
Paramétrage de libreadline5:amd64 (5.2+dfsg-3build1) ...
Paramétrage de mariadb-client-core-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Paramétrage de mariadb-client-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Paramétrage de mariadb-server-core-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Paramétrage de mariadb-server-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Paramétrage de php-common (1:35ubuntu6.1) ...
Paramétrage de php7.0-common (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/mods-available/calendar.ini with new version

Creating config file /etc/php/7.0/mods-available/ctype.ini with new version

Creating config file /etc/php/7.0/mods-available/exif.ini with new version

Creating config file /etc/php/7.0/mods-available/fileinfo.ini with new version

Creating config file /etc/php/7.0/mods-available/ftp.ini with new version

Creating config file /etc/php/7.0/mods-available/gettext.ini with new version

Creating config file /etc/php/7.0/mods-available/iconv.ini with new version

Creating config file /etc/php/7.0/mods-available/pdo.ini with new version

Creating config file /etc/php/7.0/mods-available/phar.ini with new version

Creating config file /etc/php/7.0/mods-available/posix.ini with new version

Creating config file /etc/php/7.0/mods-available/shmop.ini with new version

Creating config file /etc/php/7.0/mods-available/sockets.ini with new version

Creating config file /etc/php/7.0/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/7.0/mods-available/sysvsem.ini with new version

Creating config file /etc/php/7.0/mods-available/sysvshm.ini with new version

Creating config file /etc/php/7.0/mods-available/tokenizer.ini with new version
Paramétrage de php7.0-json (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/mods-available/json.ini with new version
Paramétrage de php7.0-opcache (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/mods-available/opcache.ini with new version
Paramétrage de php7.0-readline (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/mods-available/readline.ini with new version
Paramétrage de php7.0-cli (7.0.30-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /usr/bin/php7.0 » pour fournir « /usr/bin/php » (php) en mode automatique
update-alternatives: utilisation de « /usr/bin/phar7.0 » pour fournir « /usr/bin/phar » (phar) en mode automatique
update-alternatives: utilisation de « /usr/bin/phar.phar7.0 » pour fournir « /usr/bin/phar.phar » (phar.phar) en mode automatique

Creating config file /etc/php/7.0/cli/php.ini with new version
Paramétrage de libapache2-mod-php7.0 (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/apache2/php.ini with new version
Module mpm_event disabled.
Enabling module mpm_prefork.
apache2_switch_mpm Switch to prefork
apache2_invoke: Enable module php7.0
Paramétrage de libapache2-mod-php (1:7.0+35ubuntu6.1) ...
Paramétrage de libhtml-template-perl (2.95-2) ...
Paramétrage de mariadb-server (10.0.34-0ubuntu0.16.04.1) ...
Paramétrage de php7.0-mysql (7.0.30-0ubuntu0.16.04.1) ...

Creating config file /etc/php/7.0/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.0/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.0/mods-available/pdo_mysql.ini with new version
Paramétrage de php-mysql (1:7.0+35ubuntu6.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu3) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu7) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Traitement des actions différées (« triggers ») pour ufw (0.35-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour libapache2-mod-php7.0 (7.0.30-0ubuntu0.16.04.1) ...
louis@louis-R530-R730-P530:~$ 

il semble qu'il n'y a pas d'erreur

@grandtoubab
désolé si je ne suis pas tes indications, je crains de m'embrouiller

Hors ligne

#8 Le 18/07/2018, à 18:03

Louis23

Re : Le terminal est un bon outil, pas pour moi

Donc je repart avec:

sudo systemctl disable apache2

et:

louis@louis-R530-R730-P530:~$ sudo systemctl disable apache2
[sudo] Mot de passe de louis : 
apache2.service is not a native service, redirecting to systemd-sysv-install
Executing /lib/systemd/systemd-sysv-install disable apache2
insserv: warning: current start runlevel(s) (empty) of script `apache2' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache2' overrides LSB defaults (0 1 6).

ensuite

sudo systemctl disable mysql

et

louis@louis-R530-R730-P530:~$ sudo systemctl disable mysql
mysql.service is not a native service, redirecting to systemd-sysv-install
Executing /lib/systemd/systemd-sysv-install disable mysql
insserv: warning: current start runlevel(s) (empty) of script `mysql' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mysql' overrides LSB defaults (0 1 6).

je pense que tout va bien, mais pour la suite je comprends pas tellement entre désactiver et réactiver le démarrage automtique

Hors ligne

#9 Le 18/07/2018, à 18:15

michel_04

Re : Le terminal est un bon outil, pas pour moi

Bonjour,

Louis23 a écrit :

@grandtoubab
désolé si je ne suis pas tes indications, je crains de m'embrouiller

Et pourtant, avant tout il est essentiel d'avoir un système à jour.

grandtoubab a écrit :
Louis23 a écrit :

donc j'appellé

593 non mis à jour.
louis@louis-R530-R730-P530:~$ 

ça semble bon,
@+

c'est pas ce que j'appelerai une installation en bon état.
593 paquets !!ça doit faire assez longtemps que tu n'as pas mis à jour

depuis quand est-ce verrouillé? 593 non mis à jour.

ls -alrt /var/lib/dpkg/lock

pour voir l'étendu des dégâts

sudo apt-get dist-upgrade

A+

Dernière modification par michel_04 (Le 18/07/2018, à 18:16)

Hors ligne

#10 Le 18/07/2018, à 18:28

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

Louis23 a écrit :

je pense que tout va bien, mais pour la suite je comprends pas tellement entre désactiver et réactiver le démarrage automtique

perso je ne comprends pas ce que tu ne comprends pas.
cette page n'est pas vraiment un tuto mais une documentation. il ne faut pas taper toutes les lignes de commande que tu rencontres, mais surtout lire et comprendre ce qui est indiqué entre les commandes !


Un exemple type : un internaute veut afficher son profil sur un site web. Au moyen de son navigateur il effectue une requête sur un serveur web en appelant une URL sur le domaine du serveur. Le module PHP d'Apache va interpréter un script qui envoie une requête au serveur MySQL en lui demandant les informations de l'utilisateur. Une fois ces informations récupérées, le script PHP met en forme le résultat sous forme de page web (HTML) qui est envoyée au navigateur web.

voilà donc si tu désactives le démarrage automatique de Apache et de MariaDB comme tu viens de le faire, ton serveur web (le comportement décrit ici) ne fonctionnera simplement pas au redémarrage de ton ordi.


la question maintenant que tu as installé la pile LAMP (je te confirme : c'est fait) c'est : qu'est-ce que tu veux en faire ?
tu veux installer un script PHP ? lequel ?
ou développer ton propre projet et t'initier à PHP ?


en attendant tu peux effectivement mettre ton système à jour (la commande indiquée par grandtoubab n'est pas très actuelle) :

sudo apt update

et éventuellement :

sudo apt full-upgrade

Hors ligne

#11 Le 18/07/2018, à 18:59

Louis23

Re : Le terminal est un bon outil, pas pour moi

effectivement localhost est presque opérationnel sauf que je ne peux installer de dossier

Impossible de copier le dossier « spip » car vous n'avez pas la permission de le créer dans la destination.

Hors ligne

#12 Le 18/07/2018, à 19:05

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

tu t'y prends comment ?

Hors ligne

#13 Le 18/07/2018, à 19:06

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

si jamais il y a une liste de CMS là : https://doc.ubuntu-fr.org/cms

et la plupart (tous les autres) sont beaucoup plus actuels que spip...

Hors ligne

#14 Le 18/07/2018, à 19:18

Louis23

Re : Le terminal est un bon outil, pas pour moi

comme d'habitude sur ma page téléchargement je fais un clic droit sur "spip"=> déplacer vers =>ordinateur => var => www => html
en ce moment jy ai ma page

It works! 

Hors ligne

#15 Le 18/07/2018, à 19:50

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

tu suis un tutoriel ?
la doc à ce sujet c'est un peu n'importe quoi : https://doc.ubuntu-fr.org/spip

je te conseille de continuer avec la page lamp : https://doc.ubuntu-fr.org/lamp#creation … te_virtuel

créés un hôte virtuel pour spip, donc un fichier /etc/apache2/sites-available/spip.conf qui contient :

<VirtualHost *:80>
	ServerName spip
	DocumentRoot "/var/www/spip"
	<Directory "/var/www/spip">
		Options FollowSymLinks
		AllowOverride all
		Require all granted
	</Directory>
	ErrorLog /var/log/apache2/error.spip.com.log
	CustomLog /var/log/apache2/access.spip.com.log combined
</VirtualHost>

et tu places les fichiers de spip dans /var/www/spip avec sudo mv pour déplacer : https://doc.ubuntu-fr.org/tutoriel/cons … ommande#mv

ensuite tu actives cet hôte virtuel :

sudo a2ensite spip
sudo systemctl reload apache2

et tu ajoutes le domaine spip à tes noms d'hôte :

sudo sed -i "2i127.0.0.1 spip" /etc/hosts

et à partir de là tu devrais pouvoir accéder à ton CMS à l'adresse http://spip/

Hors ligne

#16 Le 18/07/2018, à 20:01

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

krodelabestiole a écrit :

la doc à ce sujet c'est un peu n'importe quoi : https://doc.ubuntu-fr.org/spip

j'ai ajouté un tag vétuste du coup.

par contre j'ai écrit / réécrit les docs de wordpress ou grav récemment si tu veux :
https://doc.ubuntu-fr.org/wordpress
https://doc.ubuntu-fr.org/grav

Hors ligne

#17 Le 19/07/2018, à 08:45

Louis23

Re : Le terminal est un bon outil, pas pour moi

Bonjour,
Le terminal est maudit pour moi, pourtant j'ai bien suivi tes instructions, portant dans mon localhost précédant j'avais les droits "data" et pour cela je n'avais aucun problème pour rajouter des dossiers pas de création de VirtualHost désolé mais je crois que je vais renoncer tu vas passer du temps inutile pour moi,merci @+

Hors ligne

#18 Le 19/07/2018, à 09:48

Louis23

Re : Le terminal est un bon outil, pas pour moi

J'ai trouvé!
Il suffisait d'utiliser "nautilus" peux-tu m'indiquer la commande pour l'installer sur le tableau de bord S.V.P.
Je ne passerai plus des heurs à chercher
Merci @+

Hors ligne

#19 Le 19/07/2018, à 16:21

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

il y a 2 problèmes :

- en l'état la doc de spip ne propose pas de procédure à suivre pas à pas pour son installation sur ubuntu, et requiert donc une certaine autonomie avec la ligne de commande (mon message en #15 y ressemble plus, mais c'est pas encore complet non plus).

- tes connaissances en ligne de commande sont pour le moment trop limitées pour que tu sois autonome.
je te conseille d'essayer de te former un minimum en lisant l'intégralité de cette documentation : https://doc.ubuntu-fr.org/tutoriel/cons … e_commande
en particulier les chapitres concernant les commande ls cd mkdir mv cp et rm.
également cette documentation qui montre comment éditer un fichier depuis une console : https://doc.ubuntu-fr.org/nano (nano est l'éditeur le plus simple à prendre en main dans ce contexte, très utiles pour éditer en tant qu'administrateur, ou - plus important - via ssh - indispensable quand on gère un VPS)
et aussi cette documentation concernant la commande sudo : https://doc.ubuntu-fr.org/utilisateurs/roschan/sudo
avec ça tu devrais être paré pour le gros du boulot. je conviens parfaitement du fait que la ligne de commande n'est pas l'outil le plus intuitif, mais c'est celui qui est principalement utilisé pour gérer des serveurs, parce qu'il est rapide, léger, et utilisable à distance (ssh).
et mettre en place un serveur lamp, c'est gérer un serveur.


maintenant je comprends pas trop où tu en es exactement, ce qui fonctionne et ce qui ne fonctionne pas.
en tout cas il reste encore au moins à mettre en place une base de données et à configurer spip.

Hors ligne

#20 Le 19/07/2018, à 17:19

rogn...

Re : Le terminal est un bon outil, pas pour moi

Louis23 a écrit :
[sudo] Mot de passe de louis : 
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.
louis@louis-R530-R730-P530:

autrement dit le répertoire est semble-t-il occupé par quelqu'un d'autre à cet heure ci il y a personne chez moi. voilà dois-je définitivement renoncer à installer LAMP, je pense qu'il y a des explications, si je pouvais en avoir ce serait génial,
Merci

Résultat de processus fantômes, chose qui n'arrive jamais quand tu utilises apt en ligne de commande, en supposant que tes sources.list sont corrects.


Manjaro XFCE / Xubuntu 18.04 (rollback from 18.10 Ubuntu Mate).
Le mariage homo pourrait être une bonne chose si Kim et Donald s'entendent bien.

Hors ligne

#21 Le 19/07/2018, à 17:33

krodelabestiole

Re : Le terminal est un bon outil, pas pour moi

rogn... a écrit :

Résultat de processus fantômes

pas forcément.
j'ai tout expliqué dans la doc : https://doc.ubuntu-fr.org/probleme_apt# … ibdpkglock

Hors ligne

#22 Le 19/07/2018, à 17:46

rogn...

Re : Le terminal est un bon outil, pas pour moi

Tu peux avoir un gestionnaire de paquets qui ne fait rien mais continue à bloquer le verrou.


Manjaro XFCE / Xubuntu 18.04 (rollback from 18.10 Ubuntu Mate).
Le mariage homo pourrait être une bonne chose si Kim et Donald s'entendent bien.

Hors ligne

#23 Le 29/07/2018, à 12:39

moissan

Re : Le terminal est un bon outil, pas pour moi

je tombe par hasard sur ce post ... c'est peu etre ce qu'il m'est arrivé aujourdh'ui ... après un cafouillage d'instalation de lamp sur ubuntu , j'essaie sur un debian qui n'a pas servi depuis longtemps : instalation impossible pour je ne me rapelle plus quel  truc verrouillé ... peut etre parce que beaucoup de mise a jours en retard ... dommage que comme toujours l'informatique donne des message trompeur vers des fausse piste ... ne pourait pas dire occupé par mise a jours ?

Hors ligne

#24 Le 29/07/2018, à 14:04

bruno

Re : Le terminal est un bon outil, pas pour moi

moissan a écrit :

... dommage que comme toujours l'informatique donne des message trompeur vers des fausse piste ...

Il n'y a aucun message trompeur, ni fausse piste. Le message d'erreur indique exactement ce qui ne va pas (contrairement à d'autre système d'exploitation qui envoie des codes d'erreurs abscons).

Hors ligne

#25 Le 30/07/2018, à 11:28

Louis23

Re : Le terminal est un bon outil, pas pour moi

rogn... a écrit :

Tu peux avoir un gestionnaire de paquets qui ne fait rien mais continue à bloquer le verrou.

Je ne sais pas si  tu as suivi la discussion mais krodelabestiole m'a indiqué de mettre à jour les paquets

sudo apt update

et éventullement

sudo apt full-upgrade

ce que j'ai fais et tout c'est bien passé.

Hors ligne