Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 16/09/2018, à 01:21

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Bonsoir metalux,
Merci beaucoup de ta contribution. Je ne me souviens pas avoir lu ce message sur la page indiquée, mais il semble effectivement répondre au problème que je rencontre avec playonlinux... Je viens juste d'essayer de cliquer sur le bouton "Essayer ce patch", mais je tombe ensuite sur une page m'indiquant que l'adresse n'a pas été reconnue... Est-ce le cas pour toi aussi ?

Hors ligne

#27 Le 16/09/2018, à 01:27

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Salut melixgaro,
Merci de ton aide. Effectivement, après avoir essuyé des échecs dans l'installation d'Office 2010, j'ai tenté d'autres version MS Office, en pensant que cela pourrait éventuellement débloqué la situation... sans résultat... et je me suis, après cela, redirigé vers Office 2010 et maintenu ceci...

Hors ligne

#28 Le 16/09/2018, à 01:44

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Que donnent ces commandes ?

wine --version
dpkg --get-selections | grep "wine\|winbind"

Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#29 Le 16/09/2018, à 02:17

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Alors voici le retour des commandes suggérées :

sat@sat-XPS-15-9560:~$ wine --version

La commande « wine » n'a pas été trouvée, mais peut être installée avec :

sudo apt install wine-development
sudo apt install wine-stable     

sat@sat-XPS-15-9560:~$ dpkg --get-selections | grep "wine\|winbind"
winbind						install
sat@sat-XPS-15-9560:~$ 

Pour rappel, j'avais finalement supprimer "wine", car on m'a dit qu'il était bourré d'erreurs ? #14

Hors ligne

#30 Le 16/09/2018, à 09:43

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

salut,

ah oui, sans wine, ça sera compliqué big_smile
Bon et que donne

apt show -a wine-stable
apt show -a wine-development

Les retours peuvent être un peu long, copie bien tout.

PS : dans le message précédent, ça va car les retours de commandes étaient courts mais sinon prend l'habitude de séparer les retours de commandes (par exemple pour ta prochaine réponse) dans des blocs [ code ] différents.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#31 Le 16/09/2018, à 11:05

metalux

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Satire a écrit :

Bonsoir metalux,
Merci beaucoup de ta contribution. Je ne me souviens pas avoir lu ce message sur la page indiquée, mais il semble effectivement répondre au problème que je rencontre avec playonlinux... Je viens juste d'essayer de cliquer sur le bouton "Essayer ce patch", mais je tombe ensuite sur une page m'indiquant que l'adresse n'a pas été reconnue... Est-ce le cas pour toi aussi ?

Non, j'arrives sur la fenêtre suivante qui me demande le chemin de playonlinux au 1er lancement, après ça sera automatique:
1537089534.png
Regarde cette page: http://kb.mozillazine.org/Network.proto … expose-all
Dans about:config, vérifie que la valeur de network.protocol-handler.expose-all est bien sur true
Si oui et que tu n'as pas la fenêtre ci-dessus, essaye d'ajouter une valeur boléenne avec ce contenu: network.protocol-handler.expose.playonlinux

Une autre solution est de sauvegarder le script et de l'utiliser à partir de playonlinux avec le menu Outils/Exécuter un script local.

Dernière modification par metalux (Le 16/09/2018, à 11:30)

Hors ligne

#32 Le 16/09/2018, à 11:43

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Salut Melixgaro,
Alors comme recommandé, voici les retours des deux commandes indiquées, disposées séparément :

sat@sat-XPS-15-9560:~$ apt show -a wine-stable
Package: wine-stable
Version: 3.0.3~bionic
Priority: optional
Section: otherosfs
Maintainer: WineHQ Builds <webmaster@fds-team.de>
Original-Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Installed-Size: 6172 kB
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Depends: libc6 (>= 2.17), wine-stable-amd64 (= 3.0.3~bionic), wine-stable-i386 (= 3.0.3~bionic)
Download-Size: 1115 kB
APT-Sources: https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
Description: WINE Is Not An Emulator - runs MS Windows programs
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
 consists of a program loader which loads and executes a Microsoft
 Windows binary, and a library (called Winelib) that implements Windows
 API calls using their Unix or X11 equivalents.  The library may also
 be used for porting Win32 code into native Unix executables.

Package: wine-stable
Version: 3.0.2~bionic
Priority: optional
Section: otherosfs
Maintainer: WineHQ Builds <webmaster@fds-team.de>
Original-Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Installed-Size: 6172 kB
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Depends: libc6 (>= 2.17), wine-stable-amd64 (= 3.0.2~bionic), wine-stable-i386 (= 3.0.2~bionic)
Download-Size: 1115 kB
APT-Sources: https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
Description: WINE Is Not An Emulator - runs MS Windows programs
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
 consists of a program loader which loads and executes a Microsoft
 Windows binary, and a library (called Winelib) that implements Windows
 API calls using their Unix or X11 equivalents.  The library may also
 be used for porting Win32 code into native Unix executables.

Package: wine-stable
Version: 3.0.1~bionic
Priority: optional
Section: otherosfs
Maintainer: WineHQ Builds <webmaster@fds-team.de>
Original-Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Installed-Size: 6172 kB
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Depends: libc6 (>= 2.17), wine-stable-amd64 (= 3.0.1~bionic), wine-stable-i386 (= 3.0.1~bionic)
Download-Size: 1115 kB
APT-Sources: https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
Description: WINE Is Not An Emulator - runs MS Windows programs
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
 consists of a program loader which loads and executes a Microsoft
 Windows binary, and a library (called Winelib) that implements Windows
 API calls using their Unix or X11 equivalents.  The library may also
 be used for porting Win32 code into native Unix executables.

Package: wine-stable
Version: 3.0-1ubuntu1
Built-Using: khronos-api (= 0~svn33340-0.1), unicode-data (= 10.0.0-3)
Priority: optional
Section: universe/otherosfs
Source: wine
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Wine Party <pkg-wine-party@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 189 kB
Provides: wine
Depends: wine64 (>= 3.0-1ubuntu1) | wine32 (>= 3.0-1ubuntu1), wine64 (<< 3.0-1ubuntu1.1~) | wine32 (<< 3.0-1ubuntu1.1~)
Suggests: winbind, winetricks, playonlinux, wine-binfmt, dosbox (>= 0.74-4.2~)
Conflicts: wine (>= 1:1)
Breaks: wine1.6 (<< 1:1.8.4ubuntu1~), wine1.6-i386 (<< 1:1.8.4ubuntu1~)
Replaces: wine1.6 (<< 1:1.8.4ubuntu1~), wine1.6-i386 (<< 1:1.8.4ubuntu1~)
Homepage: https://www.winehq.org
Download-Size: 51,4 kB
APT-Sources: http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: Windows API implementation - standard suite
 Wine is a free MS-Windows API implementation.
 This is still a work in progress and many applications may still not work.
 .
 This package provides essential wrappers and convenience tools for the
 standard Wine components. It also employs the Debian alternatives system to
 provide the usual command names, e.g. "wine" instead of "wine-stable".
sat@sat-XPS-15-9560:~$ apt show -a wine-development
Package: wine-development
Version: 3.6-1
Built-Using: khronos-api (= 0~svn33340-0.1), unicode-data (= 10.0.0-3)
Priority: optional
Section: universe/otherosfs
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Wine Party <wine@tracker.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 194 kB
Provides: wine
Depends: wine64-development (>= 3.6-1) | wine32-development (>= 3.6-1), wine64-development (<< 3.6-1.1~) | wine32-development (<< 3.6-1.1~)
Suggests: winbind, winetricks, playonlinux, wine-binfmt, dosbox (>= 0.74-4.2~)
Breaks: wine1.6 (<< 1:1.8.4ubuntu1~), wine1.6-i386 (<< 1:1.8.4ubuntu1~)
Replaces: wine1.6 (<< 1:1.8.4ubuntu1~), wine1.6-i386 (<< 1:1.8.4ubuntu1~)
Homepage: https://www.winehq.org
Download-Size: 51,5 kB
APT-Sources: http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: Windows API implementation - standard suite
 Wine is a free MS-Windows API implementation.
 This is still a work in progress and many applications may still not work.
 .
 This package provides essential wrappers and convenience tools for the
 standard Wine components. It also employs the Debian alternatives system to
 provide the usual command names, e.g. "wine" instead of "wine-development".

Hors ligne

#33 Le 16/09/2018, à 11:50

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Salut Metalux,

Ça y'est ! j'ai trouvé comment accéder à "about.config." !

Alors network.protocol-handler.expose-all est bien sur "true", son statut est "par défaut", et son type "booléen"

Je viens de trouver également comment ajouter une valeur booléen.... j'ai donc mis la valeur de network.protocol-handler.expose.playonlinux sur "true", son statut est "modifié", et sa valeur "booléen".

Je viens de réessayer de cliquer sur "téléchargé' le patch, sans résultat...

PS: désolé, il semble que  nos messages se sont croisés...

Dernière modification par Satire (Le 16/09/2018, à 12:10)

Hors ligne

#34 Le 16/09/2018, à 11:55

metalux

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Tu dois le taper directement dans la barre d'adresse.
Ensuite tu as une barre de recherche ou tu tapes: network.protocol-handler.expose-all

Hors ligne

#35 Le 16/09/2018, à 12:12

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Alors selon la dernière solution proposée dans #31, il faudrait avant tout que j'installe "Playonlinux", puis aller dans menu Outils/Exécuter un script local et utiliser le network.protocol-handler.expose.playonlinux ?

Aussi,  pour préciser que le message d'erreur en entier qui apparaît est le suivant :

L’adresse n’a pas été reconnue

Firefox ne sait pas ouvrir cette adresse car l’un des protocoles suivants (playonlinux) n’est associé à aucun programme ou n’est pas autorisé dans ce contexte.

    Il est peut-être nécessaire d’installer une autre application pour ouvrir ce type d’adresse.

Dernière modification par Satire (Le 16/09/2018, à 12:15)

Hors ligne

#36 Le 16/09/2018, à 12:26

metalux

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Non, tu installes playonlinux, tu copies le script playonlinux qui se trouve sur https://www.playonlinux.com/fr/app-801-Microsoft_Office_2010.html dans le message de rbelo (tu le verras en cliquant sur nouveau code source) puis tu l'enregistres dans un fichier texte en lui donnant un nom explicite genre "office" par exemple. Sans doute qu'il faudra le rendre exécutable avant de l'utiliser avec la commande chmod +x ou bien accessible avec un clic droit sur ton fichier/propriété/permissions.
Ensuite c'est ce fichier qu'il faut sélectionner à partir de playonlinux "Outils/Exécuter un script local"

network.protocol-handler.expose.playonlinux c'est simplement pour que firefox associe directement les protocoles playonlinux en cliquant sur le bouton avec le programme playonlinux.
Si tu enregistres le code dans un fichier texte et que tu l'exécutes avec "Outils/Exécuter un script local" , ça revient au même.

Il faut commencer par installer playonlinux pour que firefox puisse faire l'association.
Qu'as-tu comme valeur pour network.protocol-handler.expose-all dans about:config? C'est bien true?

Dernière modification par metalux (Le 16/09/2018, à 12:29)

Hors ligne

#37 Le 16/09/2018, à 12:47

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Très bien.
Alors je viens juste d'installer  Playonlinux en ligne de commande, suivant les indications de la page suivante : https://doc.ubuntu-fr.org/playonlinux

Voici le retour des commandes :

sat@sat-XPS-15-9560:~$ sudo add-apt-repository http://deb.playonlinux.com/
[sudo] Mot de passe de sat : 
Réception de:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Ign:2 http://deb.playonlinux.com bionic InRelease                              
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Err:4 http://deb.playonlinux.com bionic Release                                
  404  Not Found [IP : 51.254.83.230 80]
Atteint:5 http://fr.archive.ubuntu.com/ubuntu bionic InRelease                 
Atteint:6 http://dl.google.com/linux/chrome/deb stable Release                 
Réception de:7 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Atteint:8 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease            
Réception de:9 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Réception de:11 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Réception de:12 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [6832 B]
Réception de:13 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [9090 B]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [139 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [31,4 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [56,9 kB]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [166 kB]
Réception de:18 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [172 kB]
Réception de:19 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [280 kB]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2468 B]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5100 B]
Lecture des listes de paquets... Fait                                  
E: Le dépôt http://deb.playonlinux.com bionic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
sat@sat-XPS-15-9560:~$ wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -
OK
sat@sat-XPS-15-9560:~$ sudo apt-get update
Atteint:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Atteint:2 http://fr.archive.ubuntu.com/ubuntu bionic InRelease                 
Ign:3 http://deb.playonlinux.com bionic InRelease                              
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                   
Err:5 http://deb.playonlinux.com bionic Release                                
  404  Not Found [IP : 51.254.83.230 80]
Atteint:6 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease         
Atteint:7 http://dl.google.com/linux/chrome/deb stable Release                 
Atteint:8 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease       
Atteint:10 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease           
Lecture des listes de paquets... Fait                          
E: Le dépôt http://deb.playonlinux.com bionic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
sat@sat-XPS-15-9560:~$ sudo apt -V install playonlinux wine
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet wine est un paquet virtuel fourni par :
  winehq-staging 3.16.0~bionic
  winehq-stable 3.0.3~bionic
  winehq-devel 3.16.0~bionic
  wine-development 3.6-1
Vous devez explicitement sélectionner un paquet à installer.

E: Le paquet « wine » n'a pas de version susceptible d'être installée

Puis, lorsque j'essaye de coller le nouveau code source dans un fichier texte, cela ressemble à ce qui suit :

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
	
#!/bin/bash
 
# CHANGELOG
# [Quentin PÂRIS] (2012-05-05 14-45)
#   Wine version set to 1.5.3, Outlook 2010 compatiblity
# [Quentin PÂRIS] (2012-05-05 15-05)
#   Check winbind presence on Linux, required to install
#   Adding gettext support
# [Quentin PÂRIS] (2012-05-12 18-36)
#   Requires 4.0.18
# [SuperPlumus] (2013-06-09 14-44)
#   gettext
# [Quentin PÂRIS] (2014-07-21 17-09)
#   Updating with the latest WineHQ version
# [rbelo] (2018-07-22 15-50)
#   Updating with the latest stable WineHQ version (3.0.2), ver 1.7.52 does not seem to work.
 
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
 
PREFIX="Office2010"
WINEVERSION="3.0.2"
TITLE="Microsoft Office 2010"
 
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/Office/top.jpg" "http://files.playonlinux.com/resources/setups/Office/left.png" "$TITLE"
 
POL_SetupWindow_Init
POL_SetupWindow_SetID 801
 
POL_SetupWindow_presentation "$TITLE" "Microsoft" "http://www.microsoft.com" "Quentin PÂRIS" "$PREFIX"
 
POL_RequiredVersion 4.0.18 || POL_Debug_Fatal "$TITLE won't work with $APPLICATION_TITLE $VERSION\nPlease update"
 
if [ "$POL_OS" = "Linux" ]; then
        wbinfo -V || POL_Debug_Fatal "Please install winbind before installing $TITLE"
fi
POL_Debug_Init
POL_System_SetArch "x86"
 
 
POL_SetupWindow_InstallMethod "LOCAL,DVD"
 
if [ "$INSTALL_METHOD" = "DVD" ]; then
        POL_SetupWindow_cdrom
        POL_SetupWindow_check_cdrom "x86/setup.exe" "setup.exe"
        SetupIs="$CDROM_SETUP"
        cd "$CDROM"
else
        POL_SetupWindow_browse "$(eval_gettext 'Please select the setup file to run')" "$TITLE"
        SetupIs="$APP_ANSWER"
fi
 
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"
 
if [ "$POL_OS" = "Mac" ]; then
    # Samba support
    POL_Call POL_GetTool_samba3
    source "$POL_USER_ROOT/tools/samba3/init"
fi
 
 
POL_Wine_WaitBefore "$TITLE"
[ "$CDROM" ] && cd "$CDROM"
 
if [ ! "$(file $SetupIs | grep 'x86-64')" = "" ]; then
    POL_Debug_Fatal "$(eval_gettext "The 64bits version is not compatible! Sorry")";
fi
POL_Wine "$SetupIs"
POL_Wine_WaitExit "$TITLE"
 
# See http://forum.winehq.org/viewtopic.php?f=8&t=23126&p=95555#p95555
POL_Wine_OverrideDLL "native,builtin" "riched20"
 
# Fix a crash when loading a file
POL_Call POL_Install_msxml6
 
POL_Shortcut "WINWORD.EXE" "Microsoft Word 2010" "" "" "Office;WordProcessor;"
POL_Shortcut "EXCEL.EXE" "Microsoft Excel 2010" "" "" "Office;Spreadsheet;"
POL_Shortcut "POWERPNT.EXE" "Microsoft Powerpoint 2010" "" "" "Office;Presentation;"
POL_Shortcut "ONENOTE.EXE" "Microsoft OneNote 2010" "" "" "Network;InstantMessaging;" # No category for collaborative work?
POL_Shortcut "OUTLOOK.EXE" "Microsoft Outlook 2010" "" "" "Network;Email;" # Calendar;ContactManagement; ? :p
 
POL_Extension_Write doc "Microsoft Word 2010"
POL_Extension_Write docx "Microsoft Word 2010"
POL_Extension_Write xls "Microsoft Excel 2010"
POL_Extension_Write xlsx "Microsoft Excel 2010"
POL_Extension_Write ppt "Microsoft Powerpoint 2010"
POL_Extension_Write pptx "Microsoft Powerpoint 2010"
 
if [ "$POL_OS" = "Mac" ]; then
    POL_Shortcut_InsertBeforeWine "Microsoft Word 2010" "source \"$POL_USER_ROOT/tools/samba3/init\""
    POL_Shortcut_InsertBeforeWine "Microsoft Excel 2010" "source \"$POL_USER_ROOT/tools/samba3/init\""
    POL_Shortcut_InsertBeforeWine "Microsoft Powerpoint 2010" "source \"$POL_USER_ROOT/tools/samba3/init\""
    POL_Shortcut_InsertBeforeWine "Microsoft OneNote 2010" "source \"$POL_USER_ROOT/tools/samba3/init\""
    POL_Shortcut_InsertBeforeWine "Microsoft Outlook 2010" "source \"$POL_USER_ROOT/tools/samba3/init\""
fi
 
POL_SetupWindow_message "$(eval_gettext '$TITLE has been installed successfully\n\nIf an installation Windows prevent your programs from running, you must remove and reinstall $TITLE')" "$TITLE"
POL_SetupWindow_Close
exit

Est-ce les nombres doivent suivre les commandes ? et qu'en est-il de la barre verticale qui n'est pas présente dans le collage ?

Hors ligne

#38 Le 16/09/2018, à 13:07

alex2423

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Satire, tu fais la même erreur qu'hier. Souvent pour installer un logiciel, tu as 2 moyens de le faire, soit par le dépot officiel de Ubuntu soit par le PPA. Comme tu es sous Ubuntu 18.04, très récente, ne passe pas par le dépot officiel.

https://forum.ubuntu-fr.org/viewtopic.p … #p21972438

Je te remets le message d'hier de GammaGrommis

GammaDraconis a écrit :

Bah ton problème est clairement indiqué dans le message : le dépot n'est plus disponible.

En effet, quand tu ajoutes un dépot externe (cad pas un dépot officiel), celui-ci est fait pour une ou des versions précises d'Ubuntu mais pas forcément les dernières versions.

Et si tu regardes ici : http://deb.playonlinux.com/dists/
Tu vois que la version la plus récente géré d'Ubuntu par ce dépot est "Xenial" (Ubuntu 16.04) donc ce dépot ne peux pas marcher en 17.10 (artful) ni en 18.04 (bionic).

En faite ça ne sert a rien ajouter ce dépot sur une version récente d'Ubuntu car tu auras déjà une version récente du logiciel dans les dépots officiels.

Idem pour Wine, tu as une version relativement récente dans la 18.04, ça ne sert pas a grand chose d'ajouter un dépot externe pour ça, il y a eu certe quelques maj depuis mais ça ne changera rien pour un logiciel aussi vieux qu'office 2010 (8 ans).

En faite c'est une erreur régulière de debutant : il faut éviter d'ajouter des dépots externe ou PPA sans raison. N'oublie pas que la 18.04 est récente (Avril 2018), tes logiciels ne peuvent pas être très ancien dessus ou alors c'est que le logiciel a été abandonné.

Sur une vieille version d'Ubuntu comme la 16.04 par exemple, là ça peux être utile car il y a beaucoup de difference en terme de versionnage des logiciels.

De plus, comme l'avais mentionné GrammaDraconis, le PPA n'est pas disponible pour ta version de Ubuntu. Ne pas oublié les messages d'avant.


Comme tu as ajouté le PPA de playonlinux, supprime le :

sudo add-apt-repository --remove ppa:http://deb.playonlinux.com/

https://doc.ubuntu-fr.org/ppa#la_methode_classique_apt

Puis installe playOnlinux uniquement via les dépots officiel :
https://doc.ubuntu-fr.org/playonlinux#p … _officiels

Dernière modification par alex2423 (Le 16/09/2018, à 13:08)

Hors ligne

#39 Le 16/09/2018, à 13:14

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Il est impératif que tu comprennes ce que tu tapes (la raison) et ce qui s'affiche sur le terminal (résultat), et en particulier que tu comprennes si l'action que tu demandes s'est effectuée.

Par exemple, tu a voulu installer playonlinux et wine mais rien ne s'est passé

sat@sat-XPS-15-9560:~$ sudo apt -V install playonlinux wine
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet wine est un paquet virtuel fourni par :
  winehq-staging 3.16.0~bionic
  winehq-stable 3.0.3~bionic
  winehq-devel 3.16.0~bionic
  wine-development 3.6-1
Vous devez explicitement sélectionner un paquet à installer.

E: Le paquet « wine » n'a pas de version susceptible d'être installée

C'est marqué blanc sur noir !

Donne le retour de

ls -lh /etc/apt/sources.list.d

Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#40 Le 16/09/2018, à 13:20

metalux

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Déjà la doc n'a pas l'air à jour, il n'y a pas de version bionic dans leur dépôt: http://deb.playonlinux.com/dists/ , il faut installer la version des dépôts officiels d'ubuntu et supprimer le dépôt que tu as ajouté. On le voit clairement ici:

Err:4 http://deb.playonlinux.com bionic Release                                
  404  Not Found [IP : 51.254.83.230 80]

Edit: Je n'ai pas bien lu vos messages, cela a déjà été dit.

Dernière modification par metalux (Le 16/09/2018, à 13:21)

Hors ligne

#41 Le 16/09/2018, à 13:45

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Et mince alors... désolé de ne pas avoir saisi tout ceci... il y a des subtilités dans le langage informatique que j'ai effectivement du mal à intégrer...

Donc, d'après ce que j'ai pu comprendre, il est préférable de passer par le dépôt officiel Ubuntu plutôt que par le dépôt officiel (PPA externe) du logiciel en question...

Voici le retour de la commande de suppression :

sat@sat-XPS-15-9560:~$ sudo add-apt-repository --remove ppa:http://deb.playonlinux.com/
[sudo] Mot de passe de sat : 
Cannot add PPA: 'ppa:~http/ubuntu/ppa'.
The user named '~http' does not have any PPA
sat@sat-XPS-15-9560:~$ 

Je suis pas sûr de comprendre le retour, est-ce que cela a fonctionné ? Je pense qu'il est plus sage d'attendre ta réponse sur ce point, avant de poursuivre avec l'installation du dépôt officiel Playonlinux..

Hors ligne

#42 Le 16/09/2018, à 13:50

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Aîe, aîe, aîe... effectivement Melixgaro... mon manque d'aisance informatique est tel qu'il me submerge d'incertitude quand au sens à donner à une phrase aussi simple que celle-là... Je vais tâcher de redoubler d'efforts dans cette direction...

Voici le retour de la commande suggérée :

sat@sat-XPS-15-9560:~$ ls -lh /etc/apt/sources.list.d
total 8,0K
-rw-r--r-- 1 root root 189 sept. 16 12:36 google-chrome.list
-rw-r--r-- 1 root root 189 sept. 16 12:36 google-chrome.list.save
sat@sat-XPS-15-9560:~$ 

Dernière modification par Satire (Le 16/09/2018, à 14:02)

Hors ligne

#43 Le 16/09/2018, à 13:52

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

N'oublie pas : -> ok vu

melixgaro a écrit :

Donne le retour de

ls -lh /etc/apt/sources.list.d

Non, ppa:http://deb.playonlinux.com/ n'est pas une adresse valide de ppa. Le message te dit d'ailleurs « cannot add » = ne peux pas ajouter.

PS : Es-tu sûr d'avoir jamais réussi à installé office dans wine ? Car si oui, il a bien fallu que tu passes par ce genre d'étape. Or, là, tu semble vraiment novice (ça n'est pas une insulte, je l'ai été et le suis toujours dans certains domaines). Et, l'aide qu'on apporte doit se faire en fonction du niveau de la personne aidée. Les instructions seront plus ou moins détaillées.

Dernière modification par melixgaro (Le 16/09/2018, à 13:53)


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#44 Le 16/09/2018, à 13:55

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

ok donc aucun n'ajout de ppa n'a marché. Par exemple sur ma machine, j'ai mis le ppa officiel de wine et j'obtiens:

$ ls -lh /etc/apt/sources.list.d
-rw-r--r-- 1 root root 122 août  26 15:06 wine.list
-rw-r--r-- 1 root root 122 juil. 31 01:09 wine.list.save

Le seul ppa que tu as - et qui n'est pas notre souci pour cette affaire - est celui de chrome. Donc rien à nettoyer côté ppa.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#45 Le 16/09/2018, à 13:59

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Merci Melixgaro,
Effectivement, je suis un total novice en matière d'informatique... j'ai du mal à comprendre le langage et à en déchiffrer le sens... je crois que tu l'as bien vu...

Pour ce qui est de l'installation d'office dans wine, je ne suis pas certain, j'ai poursuivi les étapes correspondantes d'installation de la page suivante : https://doc.ubuntu-fr.org/microsoft_office

Mais, je n'ai jamais pu faire démarrer word...

Hors ligne

#46 Le 16/09/2018, à 14:40

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Je te propose de te passer de playonlinux (je ne sais pas m'en servir). Pour toutes les commandes, donne le retour complet dans des blocs séparés.

sudo apt install --no-install-recommends wine-stable wine32

pour installer wine


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#47 Le 16/09/2018, à 14:43

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

donne aussi

du -sh ~/{.cache,.config}/*wine* ~/.wine*

pour voir ce que tes tentatives précédentes ont laissé

Dernière modification par melixgaro (Le 16/09/2018, à 14:44)


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#48 Le 16/09/2018, à 14:51

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Alors voici le retour de la commande suggérée pour installer wine :

sat@sat-XPS-15-9560:~$ sudo apt install --no-install-recommends wine-stable wine32
[sudo] Mot de passe de sat : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libcap2:i386 libexif12:i386 libflac8:i386
  libfontconfig1:i386 libgd3:i386 libglib2.0-0:i386 libgphoto2-6:i386
  libgphoto2-port12:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhx509-5-heimdal:i386 libicu60:i386 libjack-jackd2-0:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libkrb5-26-heimdal:i386 libldap-2.4-2:i386
  libltdl7:i386 libmpg123-0:i386 libogg0:i386 libopenal-data libopenal1
  libopenal1:i386 liborc-0.4-0:i386 libpcap0.8:i386 libpulse0:i386
  libroken18-heimdal:i386 libsamplerate0:i386 libsasl2-2:i386
  libsasl2-modules-db:i386 libsndfile1:i386 libsndio6.1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libtiff5:i386 libusb-1.0-0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwebp6:i386 libwind0-heimdal:i386 libwine:i386
  libwrap0:i386 libxml2:i386 libxpm4:i386 ocl-icd-libopencl1:i386
  wine-stable-amd64 wine-stable-i386:i386
Paquets suggérés :
  libgd-tools:i386 gphoto2:i386 libvisual-0.4-plugins:i386
  gstreamer1.0-tools:i386 jackd2:i386 libportaudio2 libportaudio2:i386
  sndiod:i386 ttf-mscorefonts-installer:i386 libwine-gecko-2.47:i386
  wine32-preloader:i386
Paquets recommandés :
  gstreamer1.0-plugins-base:i386 libsasl2-modules:i386 libcapi20-3:i386
  libgsm1:i386 libodbc1:i386 libosmesa6:i386 libsane1:i386 libv4l-0:i386
  libxcomposite1:i386 libxinerama1:i386 libxslt1.1:i386 fonts-wine:i386
  libcapi20-3 libodbc1 libosmesa6 wine-stable:i386
Les NOUVEAUX paquets suivants seront installés :
  libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libcap2:i386 libexif12:i386 libflac8:i386
  libfontconfig1:i386 libgd3:i386 libglib2.0-0:i386 libgphoto2-6:i386
  libgphoto2-port12:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhx509-5-heimdal:i386 libicu60:i386 libjack-jackd2-0:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libkrb5-26-heimdal:i386 libldap-2.4-2:i386
  libltdl7:i386 libmpg123-0:i386 libogg0:i386 libopenal-data libopenal1
  libopenal1:i386 liborc-0.4-0:i386 libpcap0.8:i386 libpulse0:i386
  libroken18-heimdal:i386 libsamplerate0:i386 libsasl2-2:i386
  libsasl2-modules-db:i386 libsndfile1:i386 libsndio6.1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libtiff5:i386 libusb-1.0-0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwebp6:i386 libwind0-heimdal:i386 libwine:i386
  libwrap0:i386 libxml2:i386 libxpm4:i386 ocl-icd-libopencl1:i386 wine-stable
  wine-stable-amd64 wine-stable-i386:i386 wine32:i386
0 mis à jour, 58 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 35,5 Mo/80,9 Mo dans les archives.
Après cette opération, 637 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libogg0 i386 1.3.2-1 [16,2 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 libopenal-data all 1:1.18.2-2 [102 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 libopenal1 amd64 1:1.18.2-2 [266 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main i386 libglib2.0-0 i386 2.56.2-0ubuntu0.18.04.1 [1234 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libexif12 i386 0.6.21-4 [76,0 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libfontconfig1 i386 2.12.6-0ubuntu2 [146 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libjpeg8 i386 8c-2ubuntu8 [2188 B]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libjbig0 i386 2.1-3.1build1 [27,3 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libtiff5 i386 4.0.9-5 [164 kB]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libwebp6 i386 0.6.1-2 [197 kB]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libxpm4 i386 1:3.5.12-1 [35,8 kB]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libltdl7 i386 2.4.6-2 [40,5 kB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libusb-1.0-0 i386 2:1.0.21-2 [46,7 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libgphoto2-port12 i386 2.5.16-2 [52,0 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libicu60 i386 60.2-3ubuntu3 [8193 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libgphoto2-6 i386 2.5.16-2 [860 kB]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libcap2 i386 1:2.25-1.2 [13,4 kB]
Réception de:18 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 liborc-0.4-0 i386 1:0.4.28-1 [148 kB]
Réception de:19 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libroken18-heimdal i386 7.5.0+dfsg-1 [44,8 kB]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libasn1-8-heimdal i386 7.5.0+dfsg-1 [183 kB]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libheimbase1-heimdal i386 7.5.0+dfsg-1 [32,1 kB]
Réception de:22 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libhcrypto4-heimdal i386 7.5.0+dfsg-1 [92,6 kB]
Réception de:23 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libwind0-heimdal i386 7.5.0+dfsg-1 [48,3 kB]
Réception de:24 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libhx509-5-heimdal i386 7.5.0+dfsg-1 [118 kB]
Réception de:25 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libsqlite3-0 i386 3.22.0-1 [531 kB]
Réception de:26 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libkrb5-26-heimdal i386 7.5.0+dfsg-1 [232 kB]
Réception de:27 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libheimntlm0-heimdal i386 7.5.0+dfsg-1 [16,4 kB]
Réception de:28 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libgssapi3-heimdal i386 7.5.0+dfsg-1 [106 kB]
Réception de:29 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libsasl2-modules-db i386 2.1.27~101-g0780600+dfsg-3ubuntu2 [15,6 kB]
Réception de:30 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libsasl2-2 i386 2.1.27~101-g0780600+dfsg-3ubuntu2 [52,8 kB]
Réception de:31 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libldap-2.4-2 i386 2.4.45+dfsg-1ubuntu1 [167 kB]
Réception de:32 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libmpg123-0 i386 1.25.10-1 [129 kB]
Réception de:33 http://fr.archive.ubuntu.com/ubuntu bionic/universe i386 libsndio6.1 i386 1.1.0-3 [25,5 kB]
Réception de:34 http://fr.archive.ubuntu.com/ubuntu bionic/universe i386 libopenal1 i386 1:1.18.2-2 [273 kB]
Réception de:35 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libpcap0.8 i386 1.8.1-6ubuntu1 [124 kB]
Réception de:36 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libasyncns0 i386 0.8-6 [12,5 kB]
Réception de:37 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libflac8 i386 1.3.2-1 [152 kB]
Réception de:38 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libvorbis0a i386 1.3.5-4.2 [84,4 kB]
Réception de:39 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libvorbisenc2 i386 1.3.5-4.2 [64,5 kB]
Réception de:40 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libsndfile1 i386 1.0.28-4 [191 kB]
Réception de:41 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libwrap0 i386 7.6.q-27 [47,2 kB]
Réception de:42 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libsamplerate0 i386 0.1.9-1 [938 kB]
Réception de:43 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libjack-jackd2-0 i386 1.9.12~dfsg-2 [290 kB]
Réception de:44 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libspeexdsp1 i386 1.2~rc1.2-1ubuntu2 [82,4 kB]
Réception de:45 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 libasound2-plugins i386 1.1.1-1ubuntu1 [57,2 kB]
Réception de:46 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 ocl-icd-libopencl1 i386 2.2.11-1ubuntu1 [31,3 kB]
Réception de:47 http://fr.archive.ubuntu.com/ubuntu bionic/universe i386 libwine i386 3.0-1ubuntu1 [19,5 MB]
Réception de:48 http://fr.archive.ubuntu.com/ubuntu bionic/universe i386 wine32 i386 3.0-1ubuntu1 [196 kB]
35,5 Mo réceptionnés en 44s (804 ko/s)                                         
Extraction des modèles depuis les paquets : 100%
Sélection du paquet libjpeg-turbo8:i386 précédemment désélectionné.
(Lecture de la base de données... 182633 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libjpeg-turbo8_1.5.2-0ubuntu5.18.04.1_i386.deb ...
Dépaquetage de libjpeg-turbo8:i386 (1.5.2-0ubuntu5.18.04.1) ...
Sélection du paquet libogg0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../01-libogg0_1.3.2-1_i386.deb ...
Dépaquetage de libogg0:i386 (1.3.2-1) ...
Sélection du paquet libopenal-data précédemment désélectionné.
Préparation du dépaquetage de .../02-libopenal-data_1%3a1.18.2-2_all.deb ...
Dépaquetage de libopenal-data (1:1.18.2-2) ...
Sélection du paquet libopenal1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../03-libopenal1_1%3a1.18.2-2_amd64.deb ...
Dépaquetage de libopenal1:amd64 (1:1.18.2-2) ...
Sélection du paquet wine-stable-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-wine-stable-amd64_3.0.3~bionic_amd64.deb ...
Dépaquetage de wine-stable-amd64 (3.0.3~bionic) ...
Sélection du paquet libasound2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../05-libasound2_1.1.3-5ubuntu0.1_i386.deb ...
Dépaquetage de libasound2:i386 (1.1.3-5ubuntu0.1) ...
Sélection du paquet libglib2.0-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../06-libglib2.0-0_2.56.2-0ubuntu0.18.04.1_i386.deb ...
Dépaquetage de libglib2.0-0:i386 (2.56.2-0ubuntu0.18.04.1) ...
Sélection du paquet libexif12:i386 précédemment désélectionné.
Préparation du dépaquetage de .../07-libexif12_0.6.21-4_i386.deb ...
Dépaquetage de libexif12:i386 (0.6.21-4) ...
Sélection du paquet libfontconfig1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../08-libfontconfig1_2.12.6-0ubuntu2_i386.deb ...
Dépaquetage de libfontconfig1:i386 (2.12.6-0ubuntu2) ...
Sélection du paquet libjpeg8:i386 précédemment désélectionné.
Préparation du dépaquetage de .../09-libjpeg8_8c-2ubuntu8_i386.deb ...
Dépaquetage de libjpeg8:i386 (8c-2ubuntu8) ...
Sélection du paquet libjbig0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../10-libjbig0_2.1-3.1build1_i386.deb ...
Dépaquetage de libjbig0:i386 (2.1-3.1build1) ...
Sélection du paquet libtiff5:i386 précédemment désélectionné.
Préparation du dépaquetage de .../11-libtiff5_4.0.9-5_i386.deb ...
Dépaquetage de libtiff5:i386 (4.0.9-5) ...
Sélection du paquet libwebp6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../12-libwebp6_0.6.1-2_i386.deb ...
Dépaquetage de libwebp6:i386 (0.6.1-2) ...
Sélection du paquet libxpm4:i386 précédemment désélectionné.
Préparation du dépaquetage de .../13-libxpm4_1%3a3.5.12-1_i386.deb ...
Dépaquetage de libxpm4:i386 (1:3.5.12-1) ...
Sélection du paquet libgd3:i386 précédemment désélectionné.
Préparation du dépaquetage de .../14-libgd3_2.2.5-4ubuntu0.2_i386.deb ...
Dépaquetage de libgd3:i386 (2.2.5-4ubuntu0.2) ...
Sélection du paquet libltdl7:i386 précédemment désélectionné.
Préparation du dépaquetage de .../15-libltdl7_2.4.6-2_i386.deb ...
Dépaquetage de libltdl7:i386 (2.4.6-2) ...
Sélection du paquet libusb-1.0-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../16-libusb-1.0-0_2%3a1.0.21-2_i386.deb ...
Dépaquetage de libusb-1.0-0:i386 (2:1.0.21-2) ...
Sélection du paquet libgphoto2-port12:i386 précédemment désélectionné.
Préparation du dépaquetage de .../17-libgphoto2-port12_2.5.16-2_i386.deb ...
Dépaquetage de libgphoto2-port12:i386 (2.5.16-2) ...
Sélection du paquet libicu60:i386 précédemment désélectionné.
Préparation du dépaquetage de .../18-libicu60_60.2-3ubuntu3_i386.deb ...
Dépaquetage de libicu60:i386 (60.2-3ubuntu3) ...
Sélection du paquet libxml2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../19-libxml2_2.9.4+dfsg1-6.1ubuntu1.2_i386.deb ...
Dépaquetage de libxml2:i386 (2.9.4+dfsg1-6.1ubuntu1.2) ...
Sélection du paquet libgphoto2-6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../20-libgphoto2-6_2.5.16-2_i386.deb ...
Dépaquetage de libgphoto2-6:i386 (2.5.16-2) ...
Sélection du paquet libcap2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../21-libcap2_1%3a2.25-1.2_i386.deb ...
Dépaquetage de libcap2:i386 (1:2.25-1.2) ...
Sélection du paquet libgstreamer1.0-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../22-libgstreamer1.0-0_1.14.1-1~ubuntu18.04.1_i386.deb ...
Dépaquetage de libgstreamer1.0-0:i386 (1.14.1-1~ubuntu18.04.1) ...
Sélection du paquet liborc-0.4-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../23-liborc-0.4-0_1%3a0.4.28-1_i386.deb ...
Dépaquetage de liborc-0.4-0:i386 (1:0.4.28-1) ...
Sélection du paquet libgstreamer-plugins-base1.0-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../24-libgstreamer-plugins-base1.0-0_1.14.1-1ubuntu1~ubuntu18.04.1_i386.deb ...
Dépaquetage de libgstreamer-plugins-base1.0-0:i386 (1.14.1-1ubuntu1~ubuntu18.04.1) ...
Sélection du paquet libroken18-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../25-libroken18-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libroken18-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libasn1-8-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../26-libasn1-8-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libasn1-8-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libheimbase1-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../27-libheimbase1-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libheimbase1-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libhcrypto4-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../28-libhcrypto4-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libhcrypto4-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libwind0-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../29-libwind0-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libwind0-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libhx509-5-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../30-libhx509-5-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libhx509-5-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libsqlite3-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../31-libsqlite3-0_3.22.0-1_i386.deb ...
Dépaquetage de libsqlite3-0:i386 (3.22.0-1) ...
Sélection du paquet libkrb5-26-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../32-libkrb5-26-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libkrb5-26-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libheimntlm0-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../33-libheimntlm0-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libheimntlm0-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libgssapi3-heimdal:i386 précédemment désélectionné.
Préparation du dépaquetage de .../34-libgssapi3-heimdal_7.5.0+dfsg-1_i386.deb ...
Dépaquetage de libgssapi3-heimdal:i386 (7.5.0+dfsg-1) ...
Sélection du paquet libsasl2-modules-db:i386 précédemment désélectionné.
Préparation du dépaquetage de .../35-libsasl2-modules-db_2.1.27~101-g0780600+dfsg-3ubuntu2_i386.deb ...
Dépaquetage de libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Sélection du paquet libsasl2-2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../36-libsasl2-2_2.1.27~101-g0780600+dfsg-3ubuntu2_i386.deb ...
Dépaquetage de libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Sélection du paquet libldap-2.4-2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../37-libldap-2.4-2_2.4.45+dfsg-1ubuntu1_i386.deb ...
Dépaquetage de libldap-2.4-2:i386 (2.4.45+dfsg-1ubuntu1) ...
Sélection du paquet libmpg123-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../38-libmpg123-0_1.25.10-1_i386.deb ...
Dépaquetage de libmpg123-0:i386 (1.25.10-1) ...
Sélection du paquet libsndio6.1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../39-libsndio6.1_1.1.0-3_i386.deb ...
Dépaquetage de libsndio6.1:i386 (1.1.0-3) ...
Sélection du paquet libopenal1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../40-libopenal1_1%3a1.18.2-2_i386.deb ...
Dépaquetage de libopenal1:i386 (1:1.18.2-2) ...
Sélection du paquet libpcap0.8:i386 précédemment désélectionné.
Préparation du dépaquetage de .../41-libpcap0.8_1.8.1-6ubuntu1_i386.deb ...
Dépaquetage de libpcap0.8:i386 (1.8.1-6ubuntu1) ...
Sélection du paquet libasyncns0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../42-libasyncns0_0.8-6_i386.deb ...
Dépaquetage de libasyncns0:i386 (0.8-6) ...
Sélection du paquet libflac8:i386 précédemment désélectionné.
Préparation du dépaquetage de .../43-libflac8_1.3.2-1_i386.deb ...
Dépaquetage de libflac8:i386 (1.3.2-1) ...
Sélection du paquet libvorbis0a:i386 précédemment désélectionné.
Préparation du dépaquetage de .../44-libvorbis0a_1.3.5-4.2_i386.deb ...
Dépaquetage de libvorbis0a:i386 (1.3.5-4.2) ...
Sélection du paquet libvorbisenc2:i386 précédemment désélectionné.
Préparation du dépaquetage de .../45-libvorbisenc2_1.3.5-4.2_i386.deb ...
Dépaquetage de libvorbisenc2:i386 (1.3.5-4.2) ...
Sélection du paquet libsndfile1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../46-libsndfile1_1.0.28-4_i386.deb ...
Dépaquetage de libsndfile1:i386 (1.0.28-4) ...
Sélection du paquet libwrap0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../47-libwrap0_7.6.q-27_i386.deb ...
Dépaquetage de libwrap0:i386 (7.6.q-27) ...
Sélection du paquet libpulse0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../48-libpulse0_1%3a11.1-1ubuntu7.1_i386.deb ...
Dépaquetage de libpulse0:i386 (1:11.1-1ubuntu7.1) ...
Sélection du paquet libsamplerate0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../49-libsamplerate0_0.1.9-1_i386.deb ...
Dépaquetage de libsamplerate0:i386 (0.1.9-1) ...
Sélection du paquet libjack-jackd2-0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../50-libjack-jackd2-0_1.9.12~dfsg-2_i386.deb ...
Dépaquetage de libjack-jackd2-0:i386 (1.9.12~dfsg-2) ...
Sélection du paquet libspeexdsp1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../51-libspeexdsp1_1.2~rc1.2-1ubuntu2_i386.deb ...
Dépaquetage de libspeexdsp1:i386 (1.2~rc1.2-1ubuntu2) ...
Sélection du paquet libasound2-plugins:i386 précédemment désélectionné.
Préparation du dépaquetage de .../52-libasound2-plugins_1.1.1-1ubuntu1_i386.deb ...
Dépaquetage de libasound2-plugins:i386 (1.1.1-1ubuntu1) ...
Sélection du paquet wine-stable-i386:i386 précédemment désélectionné.
Préparation du dépaquetage de .../53-wine-stable-i386_3.0.3~bionic_i386.deb ...
Dépaquetage de wine-stable-i386:i386 (3.0.3~bionic) ...
Sélection du paquet wine-stable précédemment désélectionné.
Préparation du dépaquetage de .../54-wine-stable_3.0.3~bionic_amd64.deb ...
Dépaquetage de wine-stable (3.0.3~bionic) ...
Sélection du paquet ocl-icd-libopencl1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../55-ocl-icd-libopencl1_2.2.11-1ubuntu1_i386.deb ...
Dépaquetage de ocl-icd-libopencl1:i386 (2.2.11-1ubuntu1) ...
Sélection du paquet libwine:i386 précédemment désélectionné.
Préparation du dépaquetage de .../56-libwine_3.0-1ubuntu1_i386.deb ...
Dépaquetage de libwine:i386 (3.0-1ubuntu1) ...
Sélection du paquet wine32:i386 précédemment désélectionné.
Préparation du dépaquetage de .../57-wine32_3.0-1ubuntu1_i386.deb ...
Dépaquetage de wine32:i386 (3.0-1ubuntu1) ...
Paramétrage de libfontconfig1:i386 (2.12.6-0ubuntu2) ...
Paramétrage de libicu60:i386 (60.2-3ubuntu3) ...
Paramétrage de libasyncns0:i386 (0.8-6) ...
Paramétrage de libjbig0:i386 (2.1-3.1build1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.56.2-0ubuntu0.18.04.1) ...
Paramétrage de libglib2.0-0:i386 (2.56.2-0ubuntu0.18.04.1) ...
Paramétrage de libcap2:i386 (1:2.25-1.2) ...
Paramétrage de libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Paramétrage de libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Paramétrage de libjpeg-turbo8:i386 (1.5.2-0ubuntu5.18.04.1) ...
Paramétrage de libroken18-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libxml2:i386 (2.9.4+dfsg1-6.1ubuntu1.2) ...
Paramétrage de libasound2:i386 (1.1.3-5ubuntu0.1) ...
Paramétrage de libopenal-data (1:1.18.2-2) ...
Paramétrage de libogg0:i386 (1.3.2-1) ...
Paramétrage de libusb-1.0-0:i386 (2:1.0.21-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Traitement des actions différées (« triggers ») pour udev (237-3ubuntu10.3) ...
Paramétrage de libheimbase1-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libltdl7:i386 (2.4.6-2) ...
Paramétrage de libsqlite3-0:i386 (3.22.0-1) ...
Paramétrage de libxpm4:i386 (1:3.5.12-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2) ...
Paramétrage de libopenal1:amd64 (1:1.18.2-2) ...
Paramétrage de liborc-0.4-0:i386 (1:0.4.28-1) ...
Paramétrage de ocl-icd-libopencl1:i386 (2.2.11-1ubuntu1) ...
Paramétrage de libsamplerate0:i386 (0.1.9-1) ...
Paramétrage de libsndio6.1:i386 (1.1.0-3) ...
Paramétrage de libvorbis0a:i386 (1.3.5-4.2) ...
Paramétrage de libmpg123-0:i386 (1.25.10-1) ...
Paramétrage de libexif12:i386 (0.6.21-4) ...
Paramétrage de libspeexdsp1:i386 (1.2~rc1.2-1ubuntu2) ...
Paramétrage de libwrap0:i386 (7.6.q-27) ...
Paramétrage de libpcap0.8:i386 (1.8.1-6ubuntu1) ...
Paramétrage de libwebp6:i386 (0.6.1-2) ...
Paramétrage de libjpeg8:i386 (8c-2ubuntu8) ...
Paramétrage de wine-stable-amd64 (3.0.3~bionic) ...
Paramétrage de libgphoto2-port12:i386 (2.5.16-2) ...
Paramétrage de libgstreamer1.0-0:i386 (1.14.1-1~ubuntu18.04.1) ...
Setcap worked! gst-ptp-helper is not suid!
Paramétrage de libwind0-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libasn1-8-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libhcrypto4-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libflac8:i386 (1.3.2-1) ...
Paramétrage de libtiff5:i386 (4.0.9-5) ...
Paramétrage de libhx509-5-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libjack-jackd2-0:i386 (1.9.12~dfsg-2) ...
Paramétrage de libopenal1:i386 (1:1.18.2-2) ...
Paramétrage de libkrb5-26-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libvorbisenc2:i386 (1.3.5-4.2) ...
Paramétrage de libheimntlm0-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libgstreamer-plugins-base1.0-0:i386 (1.14.1-1ubuntu1~ubuntu18.04.1) ...
Paramétrage de libgd3:i386 (2.2.5-4ubuntu0.2) ...
Paramétrage de libsndfile1:i386 (1.0.28-4) ...
Paramétrage de libgssapi3-heimdal:i386 (7.5.0+dfsg-1) ...
Paramétrage de libgphoto2-6:i386 (2.5.16-2) ...
Paramétrage de libpulse0:i386 (1:11.1-1ubuntu7.1) ...
Paramétrage de libldap-2.4-2:i386 (2.4.45+dfsg-1ubuntu1) ...
Paramétrage de libwine:i386 (3.0-1ubuntu1) ...
Paramétrage de wine32:i386 (3.0-1ubuntu1) ...
Paramétrage de libasound2-plugins:i386 (1.1.1-1ubuntu1) ...
Paramétrage de wine-stable-i386:i386 (3.0.3~bionic) ...
Paramétrage de wine-stable (3.0.3~bionic) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
sat@sat-XPS-15-9560:~$ 

Par "donne le retour complet dans des blocs séparés', je comprends "donne le retour de chacune des commandes entrées de façon séparée"... j'espère que j'ai bien compris...

Hors ligne

#49 Le 16/09/2018, à 14:52

Satire

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Voici le retour de la commande servant à voir ce que mes tentatives précédentes ont laissées :

sat@sat-XPS-15-9560:~$ du -sh ~/{.cache,.config}/*wine* ~/.wine*
du: impossible d'accéder à '/home/sat/.cache/*wine*': Aucun fichier ou dossier de ce type
du: impossible d'accéder à '/home/sat/.config/*wine*': Aucun fichier ou dossier de ce type
du: impossible d'accéder à '/home/sat/.wine*': Aucun fichier ou dossier de ce type
sat@sat-XPS-15-9560:~$ 

Hors ligne

#50 Le 16/09/2018, à 15:06

melixgaro

Re : Installation impossible de Microsoft Office sur Ubuntu 18.04

Ok. Pour être sûr, redonne

dpkg --get-selections | grep "wine\|winbind"

mais cette fois-ci, wine semble bien installé.

Maintenant pour l'installation d'Office, toutes les commandes doivent être exécutées dans le même terminal

export WINEARCH="win32"

pour régler wine en architecture 32 bits (pas le choix)

export WINEPREFIX="${HOME}/.wine-office2010"

pour installer office dans un dossier réservé

puis

winecfg

et choisis Windows XP dans le petit menu déroulant

Si à un moment, une fenêtre te propose d'installer mono ou gecko, tu peux refuser.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne