Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/09/2018, à 14:07

TheSun

Problème bizarre partage Samba sur un serveur

Bonjour,

Sur les postes Linux nous avons un montage samba, depuis le gestionnaire de fichier Thunar (car Xfce comme environnement mais de toute façon c'est pareil avec Gnome/Nautilus) quand je vais sur ce point de montage, je peux y accéder et si je créer un dossier et que je le supprime ça fonctionne, idem je peux dupliquer un fichier déjà présent sur le partage mais par contre ce qui est bizarre c'est que je ne peux pas par exemple copier un fichier de ma machine locale dans ce répertoire partagé.

Ainsi par exemple :
si je copie un fichier de mon dossier perso (/home/toto/test) vers mon dossier partagé : ça ne fonctionne pas
si je fais l'inverse : je copie un fichier de mon dossier partagé vers mon dossier perso dans mon home en local : ça fonctionne
si créer un fichier txt directement dans le dossier partagé ça fonctionne mais si je l'édite pour ajouter du texte je ne peux pas, je n'ai pas les droits

voici comment le répertoire est monté dans le gestionnaire de fichier (sauvegardé en signet dans le gestionnaire de fichier) :

smb://DOMAINE\monlogin@adresse-du-serveur/home/users/monlogin/

Par contre si je monte ce répertoire avec la commande mount en utilisant cifs, là cela fonctionne avec tous les droits comme il faut :

sudo mkdir /media/point-de-montage
mount -t cifs //adresse-du-serveur/home/users/monlogin /media/point-de-montage -o username=monlogin,domain=DOMAINE,uid=mon-uid,vers=3.0

Savez-vous si il est possible de préciser l'UID et le "vers=3.0" pour samba directement dans le chemin d'accès dans le gestionnaire de fichier cad dans :

smb://DOMAINE\monlogin@adresse-du-serveur/home/users/monlogin/

Avez le fstab ce n'est pas pratique car il faut créer un fichier contenant le login et le mdp en clair (en effet il faut confirmer son mdp pour se connecter avec mount -t cifs....)


Merci d'avance.


cordialement;

Dernière modification par TheSun (Le 24/09/2018, à 14:17)

Hors ligne

#2 Le 24/09/2018, à 15:21

bruno

Re : Problème bizarre partage Samba sur un serveur

Bonjour,

Cela ne me semble pas si étrange que cela.
Avec le gestionnaire de fichier et une URL de type smb:// tu accèdes au partage avec les droits de l'utilisateur monlogin Il faut donc vérifier les permissions de cet utilisateur (et éventuellement les ACL) sur le serveur (au niveau de la configuration Samba et au niveau des dossiers partagés).

Avec un montage avec l'option uid=mon-uid, le dossier partagé est monté avec mon-uid comme propriétaire de l'ensemble des fichiers et dossiers. Il peut donc y faire ce qu'il veut.

Avez le fstab ce n'est pas pratique car il faut créer un fichier contenant le login et le mdp en clair

Ce n'est pas un problème si le fichier n'est lisible que par root.

Hors ligne

#3 Le 24/09/2018, à 15:43

TheSun

Re : Problème bizarre partage Samba sur un serveur

Oui mais le problème c'est que j'ai donné un exemple mais ça doit s'appliquer à des centaines d'utilisateurs dans l'organisation ou je travail et on ne veux pas créer des fichiers locaux contenant les mdp.

Justement il faut qu'il y ai l'UID car on veux que l'utilisateur puisse tout faire dans son dossier samba (le dossier de partage correspond en faite a un dossier perso propre à eux).

Comment intégrer l'UID (et éventuellement le "vers=3.0" mais je sais pas si c'est obligatoire pour que ça marche) directement dans le chemin url dans le gestionnaire de fichier

smb://DOMAINE\monlogin@adresse-du-serveur/home/users/monlogin/

?

A noté que ça ne pose pas de problème depuis un poste cliebnt Windows pour accès a son partage avec les bons droits donc je pense pas que ça soit la configuration du serveur le problème.

Dernière modification par TheSun (Le 24/09/2018, à 15:45)

Hors ligne

#4 Le 24/09/2018, à 16:36

bruno

Re : Problème bizarre partage Samba sur un serveur

Je ne pense pas que tu puisses passer ces arguments dans l'URL utilisée par le gestionnaire de fichier.
L'option uid est spécifique au montage (cf man mount.cifs) et la version du protocole est par défaut la 3 sur les systèmes récents. En général on a plutôt besoin de faire l’inverse, c'est à dire de préciser vers=1.0 pour arriver à monter des partages venant d'anciens systèmes.

Ton problème est encore fois soit un problème de droits sur le serveur, soit un problème de mise en correspondance (usermap) entre les utilisateurs Samba (ou LDAP) et les utilisateurs des postes clients., ou à la limite un bug dans la bibliothèque qui gère le pseudo protocole smb://

N.B. : il serait sans doute plus simple et plus efficace de poser la question à l'administrateur système qui gère le serveur Samba de ton organisation.

Dernière modification par bruno (Le 24/09/2018, à 16:38)

Hors ligne

#5 Le 16/10/2018, à 16:00

TheSun

Re : Problème bizarre partage Samba sur un serveur

et dans le fichier de configuration /etc/samba/smb.conf, n'y a t'il pas une solution ou un ajout possible ?

voici mon fichier actuel :

[global]
        workgroup = WORKGROUP
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        client use spnego = no
        client ntlmv2 auth = no
[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root[global]
        workgroup = WORKGROUP
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        client use spnego = no
        client ntlmv2 auth = no
[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

Mais je tiens à préciser qu'avec exactement ce même fichier sur une ancienne version de Xubuntu (donc avec une vieille version de samba) cela fonctionnait.

Hors ligne