Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 30/09/2018, à 14:04

bruno

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

Si tu as modifié le fichier apache2.conf je t'invite à le remttre à son état d'origine (tel que fourni par les mainteneurs Debian/Ubuntu).

Bon cela élimine au moins une cause possible : la rotation des logs apache. Il reste le problème évoqué en #2 qui devrait appara^itre dans les logs mais pas obligatoirement. Et il faut regarder aussi dans les logs spécifiques à l'hôte virtuel.

Pour voir les modules utilisés par apache et notamment le MPM, donnes-nous le retour de :

sudo apache2ctl -M

Dernière modification par bruno (Le 30/09/2018, à 19:32)

Hors ligne

#27 Le 30/09/2018, à 19:29

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

alors cela me retourne :

/etc/apache2/sites-enabled/domain.org.conf: line 1: syntax error near unexpected token `newline'
/etc/apache2/sites-enabled/domaine.org.conf: line 1: `<VirtualHost www.domaine.org:443>'

Hors ligne

#28 Le 30/09/2018, à 19:33

bruno

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

J'ai corrigé la faute dans ma commande en #26.

Hors ligne

#29 Le 30/09/2018, à 20:05

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

ok merci smile :

 sudo apache2ctl -M
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 filter_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 php7_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)

Hors ligne

#30 Le 30/09/2018, à 21:18

bruno

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

Ok. Tu peux essayer d'augmenter certaines valeurs dans /etc/apache2/mods-available/mpm_prefork.conf mais je ne garanti pas le résultat, exemple :

<IfModule mpm_prefork_module>
	StartServers		 10
	MinSpareServers		 10
	MaxSpareServers		 20
	MaxRequestWorkers	  300
	MaxConnectionsPerChild   0
</IfModule>

Voir la doc apache pour la signification des directives : https://httpd.apache.org/docs/2.4/mod/mpm_common.html

Dernière modification par bruno (Le 30/09/2018, à 21:19)

Hors ligne

#31 Le 01/10/2018, à 09:49

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

bon alors cette nuit le serveur apache n'est pas tombé.
je vais surveiller encore un peu avant de mettre un résolu.

J'avoue que je suis surpris (j'héberge juste un blog basique wordpress avec un "audimat" de 5-6 lecteurs lol
donc très peu utilisé je n'aurai jamais pensé à augmenter les valeurs du mod prefork...

Je vous tiens au courant, quoi qu'il en soit merci vraiment pour le coup de main j'ai appris plein de trucs smile
Je mettrai un "résolu" demain (si ça tient deux jours je pense que ça devrait être bon signe).

Dernière modification par phiibuntu (Le 01/10/2018, à 10:36)

Hors ligne

#32 Le 02/10/2018, à 12:10

jlmas

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

phiibuntu a écrit :

edit : à la commande  apache2ctl fullstatus j'obtiens le résultat ci-dessous.
/usr/sbin/apache2ctl: 101: /usr/sbin/apache2ctl: www-browser: not found
'www-browser -dump http://localhost:80/server-status' failed.
Maybe you need to install a package providing www-browser or you
need to adjust the APACHE_LYNX variable in /etc/apache2/envvars

Il faut deux choses: activer le mode status dans apache et installer lynx (un navigateur en mode  console)

# a2enmod status
# apt install lynx

et la commande apache2ctl fullstatus  devrait fonctionner

J'arrive après la bataille, mais pour les scripts lancés par cron, tu les trouvera ici

# ls -l /etc/cron.*

Pour savoir à quelles heures s'exécutent ces taches cron, c'est ici, par exemple :

# cat /etc/crontab
# /etc/crontab: system-wide crontab
# Unlike any other crontab you don't have to run the `crontab'
# command to install the new version when you edit this file
# and files in /etc/cron.d. These files also have username fields,
# that none of the other crontabs do.

SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

# m h dom mon dow user	command
17 *	* * *	root    cd / && run-parts --report /etc/cron.hourly
25 6	* * *	root	test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
47 6	* * 7	root	test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
52 6	1 * *	root	test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )

Ajouter des taches dans la crontab de l'utilisateur c'est pourri car difficile à vérifier

Si je me souviens bien les crontab utilisateurs sont ici

ls -l /var/spool/cron/crontabs/

Dernière modification par jlmas (Le 02/10/2018, à 12:22)

Hors ligne

#33 Le 02/10/2018, à 15:07

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

merci pour ces infos, je vais tester car ce matin 6h25 le site est tombé encore sans raison (enfin pas que je comprenne)...

bon j'ai rigoureusement la même chose avec la commande "cat /etc/crontab"
et il semblerait que ça plante à 6h25....
du coup j'imagine que c'est le cron.daily qui pose problème le voici pour apache2 :

#!/bin/sh

# run htcacheclean

set -e
set -u

type htcacheclean > /dev/null 2>&1 || exit 0
[ -e /etc/default/apache2 ]   || exit 0


# edit /etc/default/apache2 to change this
HTCACHECLEAN_MODE=daemon
HTCACHECLEAN_RUN=auto
HTCACHECLEAN_SIZE=300M
HTCACHECLEAN_PATH=/var/cache/apache2/mod_cache_disk
HTCACHECLEAN_OPTIONS=""

. /etc/default/apache2

[ "$HTCACHECLEAN_MODE" = "cron" ] || exit 0

[ "$HTCACHECLEAN_RUN" = "yes"	] || 
( [ "$HTCACHECLEAN_RUN" = "auto" ] && \
  [ -e /etc/apache2/mods-enabled/cache_disk.load ] )  || exit 0

htcacheclean ${HTCACHECLEAN_OPTIONS}	\
		-p${HTCACHECLEAN_PATH}	\
		-l${HTCACHECLEAN_SIZE}

et retour de la première commande :

 apache2ctl fullstatus
               Apache Server Status for localhost (via 127.0.0.1)

   Server Version: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g
   Server MPM: prefork
   Server Built: 2018-06-07T19:43:03
     __________________________________________________________________

   Current Time: Tuesday, 02-Oct-2018 15:13:34 CEST
   Restart Time: Tuesday, 02-Oct-2018 15:13:24 CEST
   Parent Server Config. Generation: 1
   Parent Server MPM Generation: 0
   Server uptime: 10 seconds
   Server load: 0.00 0.00 0.00
   Total accesses: 0 - Total Traffic: 0 kB
   CPU Usage: u0 s0 cu0 cs0
   0 requests/sec - 0 B/second -
   1 requests currently being processed, 9 idle workers

W_________......................................................
................................................................
................................................................
................................................................

   Scoreboard Key:
   "_" Waiting for Connection, "S" Starting up, "R" Reading Request,
   "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
   "C" Closing connection, "L" Logging, "G" Gracefully finishing,
   "I" Idle cleanup of worker, "." Open slot with no current process

   Srv PID Acc M CPU SS Req Conn Child Slot Client VHost Request
   0-0 25641 0/0/0 W 0.00 0 0 0.0 0.00 0.00 127.0.0.1 vpsxxxxxx.ovh.net:80
   GET /server-status HTTP/1.0
     __________________________________________________________________

    Srv  Child Server number - generation
    PID  OS process ID
    Acc  Number of accesses this connection / this child / this slot
     M   Mode of operation
    CPU  CPU usage, number of seconds
    SS   Seconds since beginning of most recent request
    Req  Milliseconds required to process most recent request
   Conn  Kilobytes transferred this connection
   Child Megabytes transferred this child
   Slot  Total megabytes transferred this slot
     __________________________________________________________________

   SSL/TLS Session Cache Status:
   cache type: SHMCB, shared memory: 512000 bytes, current entries: 0
   subcaches: 32, indexes per subcache: 88
   index usage: 0%, cache usage: 0%
   total entries stored since starting: 0
   total entries replaced since starting: 0
   total entries expired since starting: 0
   total (pre-expiry) entries scrolled out of the cache: 0
   total retrieves since starting: 0 hit, 0 miss
   total removes since starting: 0 hit, 0 miss
     __________________________________________________________________


    Apache/2.4.18 (Ubuntu) Server at localhost Port 80

Dernière modification par phiibuntu (Le 02/10/2018, à 15:15)

Hors ligne

#34 Le 02/10/2018, à 15:27

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

j'ai regardé aussi sur le wordpress un plugin de sécurité qui scanne le blog pour éviter les problèmes, celui-ci "shedule" quand il veut j'ai laissé la sécurité active mais j'ai désactivé le scan aléatoire du site (je le ferai à la main)
pour tester si c'et pas lui qui me pose problème.

J'essaye d'éliminer par déduction toutes les tâches automatique de mon serveur, j'aimerai vraiment bien trouver le pourquoi du comment! grrr

Hors ligne

#35 Le 02/10/2018, à 16:31

jlmas

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

Rapidement, pour désactiver un script dans /etc/cron.daily/, il suffit de faire par exemple pour apache2

$ sudo chmod -x /etc/cron.daily/apache2

Sinon j'ai fait un diff sur entre mon /etc/cron.daily/apache2 et le tien et ils sont identiques

Je regarderais ce que remonte  apache2ctl fullstatus un peu plus tard

Tu peux procéder par élimination en désactivant les scripts dans /etc/cron.daily/
N'oublie pas de regarder dans /etc/cron.d/ si par le plus grand des hasards un script ne tournerai pas également  à 6h25 exactement

Hors ligne

#36 Le 02/10/2018, à 19:38

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

ok je vais creuser par là, mais le site est déjà tombé, apache est down bien avant 6h25...
je vais désactiver certains plugins wordpress ...peut être une mise à jour qui à posé problème car côté ubuntu j'ai l'impression d'avoir fait le tour ...:(

Hors ligne

#37 Le 04/10/2018, à 11:15

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

j'ai désactivé toutes les tach planifié cron.daily etc.
j'ai désactivé lesp lugins avec taches planifié dans wordpress.

et ça plante toujours. Là j'avoue que je patauge complet smile incompréhensible!
les ressources n'explosent pas.

Après dans fail2ban les attaques sur le ssh sont bien flippantes pour un serveur qui contient rien sad
j'ai à peu pres 600 ip bannis...

Bref c'est des attaques peut être mais je devrait saturer les ressources mémoires et cpu avant que le serveur Apache tombe, et c'est pas le cas.

Un truc tout bête (vraiment bête attention) un serveur apache n'a pas de time out pour inactivité normalement?
(c'est idiot car vu mon blog peu lu, j'aurai eu le problème depuis bien longtemps...).

Bon merci en tout cas pour tous les coups de mains, si ça continue je vais carrément réinstallé mon vps ovh!

Hors ligne

#38 Le 04/10/2018, à 11:26

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

je sais pas si ça peut aider... mais un truc assez dingue arrive: )
après les mise à jour de sécurité il fallait redemarrer le vps, je reboot, et la je m'aperçois que le serveur Apache démarre puis s'éteint au démarrage du serveur.
donc aucune raison pour ça rien dans le log d'erreur, juste il s'arrête apres avoir démarré sans erreur...

Y a un fantome dans mon serveur OVH? lol

Hors ligne

#39 Le 09/10/2018, à 09:33

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

Bonjour, évidemment ça a continué à planté une à deux fois par jour.
Et depuis hier ça à l'air de tenir.
En fait après de longues recherches sur tous les forums possible j'ai trouvé une piste...aussi étonnant que cela puisse paraître j'ai sans doute merdouillé (et oui je me doutais bien d'ou venait l'erreur mais la trouver hum une autre paire de manche)
sur mon dernier renouvellement certbot (mal réalisé manuellement je pense).
J'ai tout refait hier en tout début d'après midi, j'ai rajouté le cron certbot renew et je n'ai plus de vautrage depuis. Je mettrai un résolu demain (je croise tous ce que je peux) si ça tiens.
En tout cas si ça peut aider un jour je le note ici donc...

Encore merci à tous pour le coup de main!

Hors ligne

#40 Le 09/10/2018, à 09:37

bruno

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

Ah ? Normalement certbot installe automatiquement la tâche cron de renouvellement, pas besoin de le faire à la main.

Hors ligne

#41 Le 09/10/2018, à 09:59

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

et bien c’était peut être ça mon problème (mais toute les heures ca aurait planté encore plus) en tout cas le serveur tient encore et c'est la plus grande durée depuis le renew
d'ailleurs maintenant que j'y pense le problème est apparu  à peu prêt à ce moment là mais j'avais pas forcément fait le rapprochement).

Hors ligne

#42 Le 10/10/2018, à 10:17

phiibuntu

Re : [RESOLU] arrêt du service Apache Aléatoire sans erreur.

je mets donc un résolu, en ayant compris 40 du problème smile

Merci à tous comme d'hab heureux d'avoir posté sur ce forum, faut dire qu'en général je trouve la solution en cherchant un peu donc je poste peu lol!

En résumé problème lors du renouvellement du certificat certbot letsencrypt.

Solution, renouveler le certificat à la main, et refaire les commande ci dessous pour s'assurer que le cron certbot est bien en place!
je mets les commandes (histoire de me rendre utile si jamais ma petite aventure pouvait dépanner quelqu'un un de ces quatre...

sudo certbot renew --dry-run
sudo crontab -e

saisir ça dans le cron :

59 * * * * sudo certbot renew

redémarrer le service apache.

Je n'avais aucune erreur dans aucun log juste apache qui se fermait...avouez c'était bizarre même pour un amateur comme moi !

Hors ligne