Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/09/2018, à 11:27

samwise

Lubuntu 18.04 et Nvidia GT 8600M

Bonjour à tous,

J'ai fouillé le forum en long, en large et en travers mais je ne trouve pas de réponse très satisfaisante à mon problème. Des pistes qui impliquent surtout des problèmes plus francs (quelque chose qui ne fonctionne pas du tout, or ce n'est pas tout à fait mon cas)

J'ai un ordinateur portable assez ancien, mais largement suffisant (j'ai aussi un fixe, mais plus récent et sur lequel Mate 18.04 fonctionne à merveille) sur lequel j'ai installé une version 64bits Lubuntu.
Jusqu'à la version 17.04 de Lubuntu, je n'ai pas jamais vraiment eu de soucis. Mais depuis la 17.10, et encore plus aujourd'hui avec la 18.04, les démarrages deviennent de plus en plus aléatoires. Il ne démarre jamais vraiment bien qu'au bout d'une dizaine de tentatives, voire plus. Une fois l'ordinateur démarré, je n'ai pas à me plaindre, (ce n'est pas une bête de course, mais pour ce que j'ai à faire, ça suffit - quoique, il commence à freezer un peu plus qu'avant mais ça reste assez marginal). Mais parfois, c'est très pénible.

J'ai 4 Go de Ram, un processeur Intel T5750 et une carte graphique Geforce 8600M GT. La bonne version du driver Nvidia est installée (340.107).

Quand l'ordinateur ne démarre pas, soit il bloque sur "Chargement du disque mémoire initial" (dans le cas où j'ai affiché Grub via la touche Échap), soit il n'affiche rien et quand il démarre, souvent, il m'affiche l'écran avec une résolution inférieure à celle dont l'écran est capable (1440x900).

A priori, j'ai quand même plutôt l'impression que c'est l'ordinateur (a priori la carte graphique) qui commence à faiblir. mais avant d'envisager un changement de machine (vers quelques chose de plus ou moins équivalent mais plus récent), je voulais savoir si c'est un genre de problème qui dit quelque chose à quelqu'un, je peux être passé à côté d'un paramètre important (j'ai tenté une réparation de grub, une installation en 32bits, d'autres distributions, mais rien n'y fait, mais si aux premiers démarrages ça peut sembler fonctionner, il y a toujours un moment où ça coince). J'ajoute que la carte mère ne possède pas de carte graphique intégrée (j'ai aussi envisagé la piste du conflit entre 2 cartes graphiques).

En espérant avoir été clair, merci d'avance pour vos réponses / pistes.

Dernière modification par samwise (Le 27/09/2018, à 11:29)

Hors ligne

#2 Le 27/09/2018, à 11:53

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Salut,

Si le même problème a lieu sur plusieurs distributions, j'aurais tendance à dire que ça doit être un souci matériel... normalement, tu dois pouvoir le visualiser dans les logs du système.

Est-ce que tu as essayé de regarder dans /var/log/kern.log ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#3 Le 27/09/2018, à 12:03

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Merci.
Alors j'y suis, dans le kern.log, mais je ne sais pas trop quels indices chercher qui pourraient indiquer ou non la présence d'un problème matériel.
J'ai un

NVRM : installed in this system is not supported by the 340.107

Dernière modification par samwise (Le 27/09/2018, à 12:11)

Hors ligne

#4 Le 27/09/2018, à 12:19

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

C'est déjà une bonne piste pour commencer à trouver une solution smile

Le kern.log peut éventuellement t'en dire plus au moment d'un crash au démarrage. Tu remarques que le fichier comprend les dates et heures, note l'heure où ton démarrage est impossible, puis quand tu parviens à arriver à ton système, relis le kern.log pour retrouver les entrées correspondantes.

Pour ce souci de NVRM, j'ai trouvé ceci : https://devtalk.nvidia.com/default/topi … tek-g20aj/

Ce n'est pas la même carte, mais ça ne coûte rien d'essayer de modifier les paramètres noyau au démarrage de GRUB. Lorsque tu es dans GRUB, édite l'entrée Ubuntu en appuyant sur la touche "e". Tu verras alors le script de démarrage du noyau. En bas à droite, tu devrais trouver les paramètres quiet splash. Tu peux les enlever (ça te permettra de voir toutes les étapes du démarrage en ligne de commande et éventuellement repérer d'autres soucis) et à la place, tu mets  pci=nocrs pci=realloc. Attention, ton clavier sera en qwerty dans GRUB, donc pour le a, tu tapes q, etc.

Cette modification n'est valable que pour la session en cours. Si ça fonctionne, on pérennisera l'opération.

Question pour détailler... les démarrages difficiles se produisent dès l'allumage de l'ordinateur ? Ton logo de BIOS s'affiche quand même ? Ou ça coince avant, après, au moment d'afficher GRUB... ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#5 Le 27/09/2018, à 14:05

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Merci encore une fois :-)
Ça coince après affichage du Grub (qui ne s'affiche qu'avec la touche  échap, mais j'ai cru comprendre que c'était normal  quand on n'avait qu'un seul système installé et donc pas de dual boot). Pas de soucis (apparent) avec le BIOS.
Il arrive que le recovery mode ne fonctionne pas non plus
Je suis en train de tenter un redémarrage propre, pour pouvoir voir ce que le kern.log en dit.

Pour l'instant, pas réussi à voir si le remplacement du quiet splash fonctionne (mais je fais la modification à chaque tentative de démarrage).

EDIT : La solution du quiet splash ne semble pas fonctionner pour l'histoire du NVRM.

Dernière modification par samwise (Le 27/09/2018, à 14:40)

Hors ligne

#6 Le 27/09/2018, à 15:13

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Est-ce que tu as quand même un démarrage qui s'opère en enlevant quiet splash ? Il coince à ce moment, ou le système plante quand l'interface graphique est déjà démarrée ?

Essaie d'être plus précis pour nous indiquer à quel moment ça gèle, histoire de savoir si c'est au démarrage, durant l'utilisation du système, etc. Ça permet d'être plus ciblé pour trouver l'origine du problème.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#7 Le 27/09/2018, à 15:17

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

En recovery MODE, l'ordinateur bloque ici :

1538053162.jpg

J'ai réussi à démarrer normalement le portable (bonne résolution et pas de plantage au démarrage). Chose que je n'avais pas précisé avant, l'ordinateur semble également beaucoup plus rapide (flagrant au niveau du chargement du kern.log dans l'éditeur de texte).

Donc, visiblement, pour le début du log est identique dans le cas du démarrage réussi et dans le cas d'un d'un échec. Mais la dernière ligne dans le cas d'un échec est celle qui contient R13: xxxx R14: xxxx R15: xxxx

Hors ligne

#8 Le 27/09/2018, à 15:22

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Mornagest a écrit :

Est-ce que tu as quand même un démarrage qui s'opère en enlevant quiet splash ? Il coince à ce moment, ou le système plante quand l'interface graphique est déjà démarrée ?

Essaie d'être plus précis pour nous indiquer à quel moment ça gèle, histoire de savoir si c'est au démarrage, durant l'utilisation du système, etc. Ça permet d'être plus ciblé pour trouver l'origine du problème.

(je viens de voir que tu avais de nouveau posté, du coup cette réponse-ci répond plus directement à ta question).
Le démarrage coince aussi quand j'enlève le quiet splash (j'avais déjà tenté avant). Le plantage arrive avant le démarrage de l'interface graphique. À peine quelques instant après la sélection du noyau à utiliser dans Grub. Quand c'est le Recovery Mode que je sélectionne, ça bloque sur l'image que je viens de poster, juste avant.

Je peux poster l'extrait du log qui correspond au moment ou ça plante, si besoin.

Hors ligne

#9 Le 27/09/2018, à 15:35

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Et avec les options pci=nocrs pci=realloc en lieu et place de quiet splash, ça bloque également ? À quel moment ?

Si les plantages ont toujours lieu APRÈS le démarrage depuis GRUB, ce n'est peut-être pas matériel mais logiciel, sans quoi tu aurais des problèmes avant, au moins de temps en temps.

Si tu as l'extrait du log au moment où ça plante, poste-le, c'est probablement la partie la plus importante smile

Dernière modification par Mornagest (Le 27/09/2018, à 15:36)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#10 Le 27/09/2018, à 15:50

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Oui, blocage au même endroit avec pci=nocrs et pci=realloc en lieu et place de  quiet splash.

Et voilà ce que j'ai, quand il y a erreur.

Sep 27 12:31:56 stewen-N-A kernel: [  159.984055] proc_dir_entry 'driver/nvidia' already registered
Sep 27 12:31:56 stewen-N-A kernel: [  159.984082] WARNING: CPU: 1 PID: 6718 at /build/linux-SlLHxe/linux-4.15.0/fs/proc/generic.c:337 proc_register+0xc6/0x140
Sep 27 12:31:56 stewen-N-A kernel: [  159.984083] Modules linked in: nvidia(POE+) ccm uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev media wmi_bmof arc4 input_leds r592 memstick compal_laptop joydev serio_raw drm iwl4965 iwlegacy coretemp lpc_ich snd_hda_codec_si3054 mac80211 cfg80211 wmi snd_hda_codec_realtek snd_hda_codec_generic shpchp snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_timer snd soundcore tpm_infineon mac_hid sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid firewire_ohci tg3 pata_acpi firewire_core psmouse sdhci_pci ahci sdhci crc_itu_t libahci ptp pps_core video
Sep 27 12:31:56 stewen-N-A kernel: [  159.984142] CPU: 1 PID: 6718 Comm: modprobe Tainted: P        W  OE    4.15.0-34-generic #37-Ubuntu
Sep 27 12:31:56 stewen-N-A kernel: [  159.984144] Hardware name: - N/A                                            /JFL92         , BIOS 1.16 12/31/2007
Sep 27 12:31:56 stewen-N-A kernel: [  159.984147] RIP: 0010:proc_register+0xc6/0x140
Sep 27 12:31:56 stewen-N-A kernel: [  159.984148] RSP: 0018:ffffad1f80e93b80 EFLAGS: 00010282
Sep 27 12:31:56 stewen-N-A kernel: [  159.984151] RAX: 0000000000000000 RBX: ffff8d1ff8c12c48 RCX: 0000000000000006
Sep 27 12:31:56 stewen-N-A kernel: [  159.984153] RDX: 0000000000000007 RSI: 0000000000000086 RDI: ffff8d1fffd16490
Sep 27 12:31:56 stewen-N-A kernel: [  159.984154] RBP: ffffad1f80e93bb0 R08: 0000000000000001 R09: 00000000000122f5
Sep 27 12:31:56 stewen-N-A kernel: [  159.984156] R10: 00000000001fffff R11: 0000000000000000 R12: ffff8d1ffb118780
Sep 27 12:31:56 stewen-N-A kernel: [  159.984157] R13: ffff8d1ffb1187b8 R14: 0000000000000000 R15: ffff8d1ff4f3b0c0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984159] FS:  00007fdad4dbf540(0000) GS:ffff8d1fffd00000(0000) knlGS:0000000000000000
Sep 27 12:31:56 stewen-N-A kernel: [  159.984161] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Sep 27 12:31:56 stewen-N-A kernel: [  159.984163] CR2: 00007ffff10e9238 CR3: 0000000137240000 CR4: 00000000000006e0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984164] Call Trace:
Sep 27 12:31:56 stewen-N-A kernel: [  159.984173]  proc_mkdir_data+0x67/0x90
Sep 27 12:31:56 stewen-N-A kernel: [  159.984175]  proc_mkdir_mode+0x13/0x20
Sep 27 12:31:56 stewen-N-A kernel: [  159.984435]  nv_register_procfs+0x4c/0x1d0 [nvidia]
Sep 27 12:31:56 stewen-N-A kernel: [  159.984519]  nvidia_init_module+0x298/0x760 [nvidia]
Sep 27 12:31:56 stewen-N-A kernel: [  159.984601]  ? nv_drm_init+0x1a/0x1a [nvidia]
Sep 27 12:31:56 stewen-N-A kernel: [  159.984680]  nvidia_frontend_init_module+0x52/0x886 [nvidia]
Sep 27 12:31:56 stewen-N-A kernel: [  159.984684]  do_one_initcall+0x52/0x19f
Sep 27 12:31:56 stewen-N-A kernel: [  159.984687]  ? __vunmap+0x81/0xb0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984690]  ? _cond_resched+0x19/0x40
Sep 27 12:31:56 stewen-N-A kernel: [  159.984693]  ? kmem_cache_alloc_trace+0xa6/0x1b0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984696]  ? do_init_module+0x27/0x209
Sep 27 12:31:56 stewen-N-A kernel: [  159.984699]  do_init_module+0x5f/0x209
Sep 27 12:31:56 stewen-N-A kernel: [  159.984701]  load_module+0x191e/0x1f10
Sep 27 12:31:56 stewen-N-A kernel: [  159.984705]  ? ima_post_read_file+0x96/0xa0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984708]  SYSC_finit_module+0xfc/0x120
Sep 27 12:31:56 stewen-N-A kernel: [  159.984710]  ? SYSC_finit_module+0xfc/0x120
Sep 27 12:31:56 stewen-N-A kernel: [  159.984713]  SyS_finit_module+0xe/0x10
Sep 27 12:31:56 stewen-N-A kernel: [  159.984715]  do_syscall_64+0x73/0x130
Sep 27 12:31:56 stewen-N-A kernel: [  159.984718]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
Sep 27 12:31:56 stewen-N-A kernel: [  159.984721] RIP: 0033:0x7fdad48e3839
Sep 27 12:31:56 stewen-N-A kernel: [  159.984722] RSP: 002b:00007ffff10ec318 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
Sep 27 12:31:56 stewen-N-A kernel: [  159.984725] RAX: ffffffffffffffda RBX: 000055d630433aa0 RCX: 00007fdad48e3839
Sep 27 12:31:56 stewen-N-A kernel: [  159.984726] RDX: 0000000000000000 RSI: 000055d630075c2e RDI: 0000000000000003
Sep 27 12:31:56 stewen-N-A kernel: [  159.984728] RBP: 000055d630075c2e R08: 0000000000000000 R09: 000055d630433aa0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984729] R10: 0000000000000003 R11: 0000000000000246 R12: 0000000000000000
Sep 27 12:31:56 stewen-N-A kernel: [  159.984731] R13: 000055d630433c50 R14: 0000000000040000 R15: 000055d630433aa0
Sep 27 12:31:56 stewen-N-A kernel: [  159.984732] Code: 48 8b 75 d0 48 8d 53 b8 e8 f8 fd ff ff 85 c0 78 e9 75 c5 48 8b 55 d0 49 8d b4 24 8d 00 00 00 48 c7 c7 e0 52 0f b2 e8 7a 59 d9 ff <0f> 0b c6 05 19 db 7e 01 00 41 8b 37 48 c7 c7 a0 bc 53 b2 81 c6 
Sep 27 12:31:56 stewen-N-A kernel: [  159.984778] ---[ end trace eb24599fc2f0da65 ]---
Sep 27 12:31:56 stewen-N-A kernel: [  159.984782] NVRM: failed to register procfs!
Sep 27 12:31:56 stewen-N-A kernel: [  159.984991] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=io+mem
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407)
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: installed in this system is not supported by the 340.107
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: NVIDIA Linux driver release.  Please see 'Appendix
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: A - Supported NVIDIA GPU Products' in this release's
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: README, available on the Linux driver download page
Sep 27 12:31:56 stewen-N-A kernel: [  159.985068] NVRM: at www.nvidia.com.
Sep 27 12:31:56 stewen-N-A kernel: [  159.985147] nvidia: probe of 0000:01:00.0 failed with error -1
Sep 27 12:31:56 stewen-N-A kernel: [  159.985578] NVRM: The NVIDIA probe routine failed for 1 device(s).
Sep 27 12:31:56 stewen-N-A kernel: [  159.985580] NVRM: None of the NVIDIA graphics adapters were initialized!
Sep 27 12:31:56 stewen-N-A kernel: [  159.985581] [drm] Module unloaded

Hors ligne

#11 Le 27/09/2018, à 16:01

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

C'est bizarre, le log dit que les pilotes ne sont pas adaptés à ton modèle, pourtant, si j'en crois cette page, c'est bien la bonne version : https://www.nvidia.com/object/IO_32667.html on y trouve ta carte (GeForce 8600M GT).

As-tu essayé avec les pilotes Nouveau ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#12 Le 27/09/2018, à 16:05

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Pour le pilote Nvidia, j'avais également vérifié sur le site Nvidia et installé le pilote en fonction des infos données. Moi aussi je trouve ça bizarre !
J'ai déjà essayé avec le pilote "Nouveau", mais je vais retenter, au cas où.

Hors ligne

#13 Le 27/09/2018, à 16:39

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Même comportement au démarrage...

Hors ligne

#14 Le 27/09/2018, à 16:41

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Si tu arrives à démarrer en graphique ou en mode recovery, tape la commande sudo lshw -class video avec les pilotes Nouveau utilisés.

Ça permettra d'être sûr que c'est bien eux qui sont employés (des fois, la cohabitation Nouveau >< nVidia ne se fait pas bien...).

edit : voilà chez moi pour te donner une idée

sudo lshw -class video
  *-display                 
       description: VGA compatible controller
       produit: GF119 [NVS 310]
       fabriquant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       ressources: irq:28 mémoire:f6000000-f6ffffff mémoire:e0000000-e7ffffff mémoire:e8000000-e9ffffff portE/S:e000(taille=128) mémoire:f7000000-f707ffff

L'avant-dernière ligne t'indique le pilote réellement utilisé.

Dernière modification par Mornagest (Le 27/09/2018, à 16:42)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#15 Le 27/09/2018, à 17:02

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

La commande indique que c'est bien le pilote "nouveau" qui est actif.
Par contre quand les démarrages réussissent, visiblement je n'ai plus de soucis de résolution.
Au prochain démarrage réussi, je tente une désinstallation du pilote Nvidia.

Hors ligne

#16 Le 27/09/2018, à 17:30

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

La purge des pilotes Nvidia de change rien.
Et quand même des problèmes de résolution, parfois (mais moins, on dirait, et seulement quand je fais des tentatives avec des noyaux plus vieux).

Déroutant et un peu rageant parce qu'une fois l'ordinateur démarré, je peux l'utiliser normalement...

Dernière modification par samwise (Le 27/09/2018, à 17:38)

Hors ligne

#17 Le 27/09/2018, à 20:17

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Donc le souci n'est pas forcément lié à ton matériel graphique...

Peux-tu poster les entrées de kern.log pour le dernier plantage ? Comme tu as changé de pilote, on devrait voir d'autres types d'informations.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#18 Le 28/09/2018, à 09:17

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Merci pour le suivi !
Voilà le log du dernier plantage en date :

l: [   36.982498] proc_dir_entry 'driver/nvidia' already registered
Sep 27 14:47:36 stewen-N-A kernel: [   36.982525] WARNING: CPU: 0 PID: 1243 at /build/linux-SlLHxe/linux-4.15.0/fs/proc/generic.c:337 proc_register+0xc6/0x140
Sep 27 14:47:36 stewen-N-A kernel: [   36.982526] Modules linked in: nvidia(POE+) drm arc4 wmi_bmof uvcvideo r592 iwl4965 videobuf2_vmalloc videobuf2_memops compal_laptop memstick videobuf2_v4l2 videobuf2_core videodev media iwlegacy joydev input_leds mac80211 serio_raw coretemp cfg80211 lpc_ich snd_hda_codec_si3054 shpchp snd_hda_codec_realtek snd_hda_codec_generic wmi mac_hid tpm_infineon snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_timer snd soundcore sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid firewire_ohci psmouse ahci libahci pata_acpi firewire_core sdhci_pci sdhci tg3 crc_itu_t ptp pps_core video
Sep 27 14:47:36 stewen-N-A kernel: [   36.982573] CPU: 0 PID: 1243 Comm: modprobe Tainted: P        W  OE    4.15.0-34-generic #37-Ubuntu
Sep 27 14:47:36 stewen-N-A kernel: [   36.982575] Hardware name: - N/A                                            /JFL92         , BIOS 1.16 12/31/2007
Sep 27 14:47:36 stewen-N-A kernel: [   36.982577] RIP: 0010:proc_register+0xc6/0x140
Sep 27 14:47:36 stewen-N-A kernel: [   36.982579] RSP: 0018:ffffb20040de3b80 EFLAGS: 00010282
Sep 27 14:47:36 stewen-N-A kernel: [   36.982581] RAX: 0000000000000000 RBX: ffff911ef552f648 RCX: 0000000000000002
Sep 27 14:47:36 stewen-N-A kernel: [   36.982582] RDX: 0000000000000001 RSI: 0000000000000002 RDI: 0000000000000246
Sep 27 14:47:36 stewen-N-A kernel: [   36.982583] RBP: ffffb20040de3bb0 R08: 0000000000000000 R09: 0000000000000031
Sep 27 14:47:36 stewen-N-A kernel: [   36.982585] R10: 00000000001fffff R11: 0000000000002554 R12: ffff911efb118780
Sep 27 14:47:36 stewen-N-A kernel: [   36.982586] R13: ffff911efb1187b8 R14: 0000000000000000 R15: ffff911ef303ef00
Sep 27 14:47:36 stewen-N-A kernel: [   36.982588] FS:  00007f9351c61540(0000) GS:ffff911effc00000(0000) knlGS:0000000000000000
Sep 27 14:47:36 stewen-N-A kernel: [   36.982589] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Sep 27 14:47:36 stewen-N-A kernel: [   36.982591] CR2: 00007f4bcc68e024 CR3: 000000013506e000 CR4: 00000000000006f0
Sep 27 14:47:36 stewen-N-A kernel: [   36.982592] Call Trace:
Sep 27 14:47:36 stewen-N-A kernel: [   36.982601]  proc_mkdir_data+0x67/0x90
Sep 27 14:47:36 stewen-N-A kernel: [   36.982603]  proc_mkdir_mode+0x13/0x20
Sep 27 14:47:36 stewen-N-A kernel: [   36.982878]  nv_register_procfs+0x4c/0x1d0 [nvidia]
Sep 27 14:47:36 stewen-N-A kernel: [   36.982958]  nvidia_init_module+0x298/0x760 [nvidia]
Sep 27 14:47:36 stewen-N-A kernel: [   36.983038]  ? nv_drm_init+0x1a/0x1a [nvidia]
Sep 27 14:47:36 stewen-N-A kernel: [   36.983116]  nvidia_frontend_init_module+0x52/0x886 [nvidia]
Sep 27 14:47:36 stewen-N-A kernel: [   36.983120]  do_one_initcall+0x52/0x19f
Sep 27 14:47:36 stewen-N-A kernel: [   36.983124]  ? __vunmap+0x81/0xb0
Sep 27 14:47:36 stewen-N-A kernel: [   36.983127]  ? _cond_resched+0x19/0x40
Sep 27 14:47:36 stewen-N-A kernel: [   36.983130]  ? kmem_cache_alloc_trace+0xa6/0x1b0
Sep 27 14:47:36 stewen-N-A kernel: [   36.983133]  ? do_init_module+0x27/0x209
Sep 27 14:47:36 stewen-N-A kernel: [   36.983135]  do_init_module+0x5f/0x209
Sep 27 14:47:36 stewen-N-A kernel: [   36.983138]  load_module+0x191e/0x1f10
Sep 27 14:47:36 stewen-N-A kernel: [   36.983142]  ? ima_post_read_file+0x96/0xa0
Sep 27 14:47:36 stewen-N-A kernel: [   36.983145]  SYSC_finit_module+0xfc/0x120
Sep 27 14:47:36 stewen-N-A kernel: [   36.983147]  ? SYSC_finit_module+0xfc/0x120
Sep 27 14:47:36 stewen-N-A kernel: [   36.983149]  SyS_finit_module+0xe/0x10
Sep 27 14:47:36 stewen-N-A kernel: [   36.983151]  do_syscall_64+0x73/0x130
Sep 27 14:47:36 stewen-N-A kernel: [   36.983154]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
Sep 27 14:47:36 stewen-N-A kernel: [   36.983156] RIP: 0033:0x7f9351785839
Sep 27 14:47:36 stewen-N-A kernel: [   36.983158] RSP: 002b:00007ffe57616d28 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
Sep 27 14:47:36 stewen-N-A kernel: [   36.983160] RAX: ffffffffffffffda RBX: 00005581df102ce0 RCX: 00007f9351785839
Sep 27 14:47:36 stewen-N-A kernel: [   36.983161] RDX: 0000000000000000 RSI: 00005581dddbec2e RDI: 0000000000000003
Sep 27 14:47:36 stewen-N-A kernel: [   36.983162] RBP: 00005581dddbec2e R08: 0000000000000000 R09: 00005581df102ac0
Sep 27 14:47:36 stewen-N-A kernel: [   36.983164] R10: 0000000000000003 R11: 0000000000000246 R12: 0000000000000000
Sep 27 14:47:36 stewen-N-A kernel: [   36.983165] R13: 00005581df102ba0 R14: 0000000000040000 R15: 00005581df102ac0
Sep 27 14:47:36 stewen-N-A kernel: [   36.983166] Code: 48 8b 75 d0 48 8d 53 b8 e8 f8 fd ff ff 85 c0 78 e9 75 c5 48 8b 55 d0 49 8d b4 24 8d 00 00 00 48 c7 c7 e0 52 8f 85 e8 7a 59 d9 ff <0f> 0b c6 05 19 db 7e 01 00 41 8b 37 48 c7 c7 a0 bc d3 85 81 c6 
Sep 27 14:47:36 stewen-N-A kernel: [   36.983200] ---[ end trace ca619da7e9c4909f ]---
Sep 27 14:47:36 stewen-N-A kernel: [   36.983204] NVRM: failed to register procfs!
Sep 27 14:47:36 stewen-N-A kernel: [   36.983405] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=io+mem
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407)
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: installed in this system is not supported by the 340.107
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: NVIDIA Linux driver release.  Please see 'Appendix
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: A - Supported NVIDIA GPU Products' in this release's
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: README, available on the Linux driver download page
Sep 27 14:47:36 stewen-N-A kernel: [   36.983465] NVRM: at www.nvidia.com.
Sep 27 14:47:36 stewen-N-A kernel: [   36.983538] nvidia: probe of 0000:01:00.0 failed with error -1
Sep 27 14:47:36 stewen-N-A kernel: [   36.995128] NVRM: The NVIDIA probe routine failed for 1 device(s).
Sep 27 14:47:36 stewen-N-A kernel: [   36.995129] NVRM: None of the NVIDIA graphics adapters were initialized!
Sep 27 14:47:36 stewen-N-A kernel: [   36.995131] [drm] Module unloaded

Hors ligne

#19 Le 28/09/2018, à 09:56

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Là, ça parle de pilotes nVidia, donc a priori, c'est antérieur au changement de pilote vers Nouveau, ou je me trompe ?

J'ai bien l'impression que ça vient d'autre chose, mais ce qui m'étonne, c'est qu'on ne voit rien dans le kern.log. Peux-tu le recopier en entier ici, de même que le résultat de dmesg -lerr (c'est un L minuscule) ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#20 Le 28/09/2018, à 10:04

samwise

Re : Lubuntu 18.04 et Nvidia GT 8600M

Oups, c'est une erreur de ma part.
Je trouvais bizarre aussi... J'ai ouvert le mauvais kern.log (j'ai fait une copie de celui d'hier au cas où et c'est celui là que j'ai ouvert).
Je reposte ça tout à l'heure.

Dernière modification par samwise (Le 28/09/2018, à 10:04)

Hors ligne

#21 Le 28/09/2018, à 10:05

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Ça me rassure un peu, j'avais peur qu'on ait vraiment du mal à trouver l'origine du souci ! smile


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#22 Le 28/09/2018, à 11:15

NicoApi73

Re : Lubuntu 18.04 et Nvidia GT 8600M

Bonjour Mornagest, bonjour samwise,

Je ne crois pas que le problème vienne de l'alimentation. Si j'ai bien compris, on parle d'un PC portable. Quand l'alim externe ne fonctionne plus (ou plus correctement), la charge de la batterie est affectée. Le PC fonctionne tant que la batterie est suffisamment chargée et ensuite il s'arrête. D'autant qu'il y a beaucoup de protection, tant par rapport à la surcharge, vu les risques encourus que la décharge profonde.

Par rapport au message de dmesg, (ou kern.log), le problème semble vraiment venir de la carte graphique. Ca ressemble vraiment à un problème de driver.

Tu pourrais essayer de démarrer en blacklistant à la fois nouveau et nvidia, pour voir si ça démarre à chaque fois.

Pourrais tu regarder aussi si le secure boot est désactivé. Parfois il interagit avec certains drivers.

Hors ligne

#23 Le 28/09/2018, à 11:22

Mornagest

Re : Lubuntu 18.04 et Nvidia GT 8600M

Merci pour ta réponse, Nico smile

Ce serait vraiment pas de chance que ni nVidia ni Nouveau ne fonctionne, mais pourquoi pas essayer, en effet smile d'un autre côté, s'il faut passer par les pilotes mesa (ou vesa, je ne sais plus), ça va être abominable comme affichage...

Dernière modification par Mornagest (Le 28/09/2018, à 11:22)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#24 Le 28/09/2018, à 12:56

NicoApi73

Re : Lubuntu 18.04 et Nvidia GT 8600M

Pour éviter toute incompréhension, ma proposition n'est pas de se passer du driver nvidia ou nouveau, mais de tester une partie de la chaine graphique. Si ça plante sans aucun driver, un problème HW est à envisager. (Le contraire n'est pas vrai)

Hors ligne

#25 Le 28/09/2018, à 13:20

lepetit

Re : Lubuntu 18.04 et Nvidia GT 8600M

je ne sais pas si c'est un problème hardware ou software mais as tu entendu parler de ça ?
a l'époque ça avait pas mal gueuler
https://www.tomshardware.fr/articles/Ge … 11722.html


-mini pc: amd 5350 mini itx fanless, 8go de ram, ssd
-mini pc 2: intel core 2 duo t7200, 1.5 go de ram, gforce 710 (pilote libre) @ xubuntu 18.10, kernel xanmod
-netbook samsung nc20, via nano 1.3ghz+, 2go de ram, via vx800 @ xubuntu 18.04

Hors ligne