Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/10/2018, à 21:47

Fygero

Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Bonsoir,

je viens d'acheter un nouvel ordinateur, sur lequel j'ai installé Ubuntu 18.04.1. L'installation s'est bien passée et j'ai pu utiliser l'ordinateur. Le lendemain, après redémarrage, Ubuntu n'arrive pas à afficher le bureau, mais affiche un terminal à la place. J'arrive à me connecter à ma session et mes fichiers sont présents.

Suivant le diagnostic, j'en déduis que j'ai un problème avec ma carte graphique. En utilisant les commandes ici, je trouve que j'ai une carte graphique GP107 [GeForce GTX 1050]. Toujours en suivant la procédure, j'essai de voir mes drivers et je constate que le fichier /etc/log/Xorg.0.conf n'existe pas, ce qui me surprend un peu. Xorg est bien installé (version 1.19.6). A partir de là, j'essai d'installer les drivers en ligne de commande, et je tente la méthode pour installer les drivers propriétaires en utilisant

sudo ubuntu-drivers autoinstall

J'installe bien quelque chose (nvidia-driver-390 selon ubuntu-drivers list). Je redémarre, je remplie le Enroll MOK, et je retombe sur le terminal au démarrage d'Ubuntu.

Et là, je ne sais plus quoi faire: j'aimerais activer le mode graphique, mais je ne sais pas quoi tenter comme diagnostic ou comme manipulation. Pourriez-vous m'aider ? Merci.

Dernière modification par Fygero (Le 03/10/2018, à 19:26)

Hors ligne

#2 Le 01/10/2018, à 21:53

toitoinebzh

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

salut

est ce que tu as tenter un

startx

?

En ligne

#3 Le 01/10/2018, à 21:59

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Salut,

je viens de le tenter, j'obtiens

xauth : file /home/fygero/.Xauthority does not exist

ainsi que des infos sur Xorg.

Sur la fin, j'ai

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
      xinit: connection to X server lost

Dernière modification par Fygero (Le 01/10/2018, à 22:02)

Hors ligne

#4 Le 01/10/2018, à 22:06

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Visiblement, la commande a créé le fichier Xorg.0.conf. Les drivers chargés sont

[  3475.093] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  3475.093] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  3475.093] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  3475.093] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so

Dernière modification par Fygero (Le 02/10/2018, à 18:26)

Hors ligne

#5 Le 02/10/2018, à 18:34

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Après recherche, je constate que le fichier /etc/X11/xorg.conf n'existe pas, ce que je suppose être anormal.
Suivant la procédure de configuration automatique de Xorg, je tente d'abord

sudo dpkg-reconfigure -phigh xserver-xorg

puis un

sudo nvidia-xconfig

qui me renvoie

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing 'xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

Un redémarrage ne donne rien.

Question: c'est quoi ce fichier 'xorg-server.pc'? Et est-ce-que le trouver (comment) permettrait de résoudre mon problème?

Hors ligne

#6 Le 02/10/2018, à 20:59

Mornagest

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Salut,

Xorg n'est plus employé, maintenant, c'est Wayland qui gère l'affichage. En tout cas pour Ubuntu smile

Est-ce que tu peux recopier le résultat de ces commandes, s'il te plaît ?

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX (pour écrire le | il faut faire Alt Gr + 6 sur ton clavier français, ou Alt Gr + 1 sur ton clavier belge)
sudo lshw -C video (L minuscule, pas i majuscule)

Dernière modification par Mornagest (Le 02/10/2018, à 21:00)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#7 Le 02/10/2018, à 21:09

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Salut,

pour la première commande

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

pour la seconde commande

sudo lshw -C video
*-display
  description: VGA compatible controller
  produit: GP107 [GeForce GTX 1050]
  fabriquant: NVIDIA Corporation
  identifiant matériel: 0
  information bus: pci@0000:01:00.0
  version: a1
  bits: 64 bits
  horloge: 33MHz
  fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom
  configuration: driver=nvidia latency=0
  ressources: irq:16 mémoire:de000000-deffffff mémoire:c0000000-cfffffff mémoire:d0000000-d1ffffff portE/S:e000(taille=128) mémoire:c0000-dffff

Hors ligne

#8 Le 02/10/2018, à 21:41

Mornagest

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Normalement, ta carte est utilisable, les pilotes sont installés et reconnus, et tu n'as pas d'option qui pourrait les brider...

As-tu essayé sudo apt update ; sudo apt full-upgrade pour voir s'il n'y a pas une mise à jour à faire ? Tu n'as pas désinstallé de paquets suite à l'installation du système, des fois que tu aurais supprimé le bureau Gnome 3 ?

Cette commande te dira s'il y a des paquets "devenus inutiles et qui peuvent être désinstallés", ça tendrait à confirmer cette hypothèse de désinstallation inopportune.

Au cas où, essaie aussi sudo apt install gnome-shell


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#9 Le 02/10/2018, à 21:56

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Alors, update me dit que tous les paquets sont à jour et full-upgrade me renvoie 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Par contre, un install gnome-shell me propose d'installer 6 paquets pour un total de 13.9 Mo. Après installer et redémarrage, retour sur le terminal. Un ps -aux | grep -i "gnome" confirme que gnome ne s'est pas lancé.

Dernière modification par Fygero (Le 02/10/2018, à 22:01)

Hors ligne

#10 Le 03/10/2018, à 07:52

Mornagest

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Essaie d'installer également le bureau entier : sudo apt install ubuntu-desktop

Tu as bien installé Ubuntu classique ? Si c'est le cas, c'est bien que tu as dû désinstaller des paquets. Tu peux visualiser l'historique de tes modifications de paquets (installation, suppression...) avec less /var/log/apt/history.log | grep Remove (tu te déplaces avec les flèches haut et bas et tu quittes avec "q"). Regarde le nom des paquets, si ça parle de Gnome ou d'Ubuntu...

Il est possible que le fichier soit vide : il est archivé le 1er de chaque mois, et si tes modifications datent du 30 septembre, elles se trouvent ailleurs. Dans ce cas, essaie zless /var/log/apt/history.1.log (là, malheureusement, je ne sais pas comment sélectionner uniquement les lignes qui parlent de désinstallation hmm ).


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#11 Le 03/10/2018, à 08:39

biloute_c

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Salut,

eu le même problème , résolu comme ceçi

Edit ton fichier grub et modifie cette ligne

GRUB_CMDLINE_LINUX=

comme ceçi

GRUB_CMDLINE_LINUX="nomodeset"

puis tu fais un sudo update-grub
et reboot

Hors ligne

#12 Le 03/10/2018, à 19:04

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Normalement, j'ai installé une version classique d'Ubuntu.

Après vérification:

  • Un less /var/log/apt/history.* | grep Remove me confirme que j'ai bien désinstallé des paquets gnome. En particulier, une énorme ligne me dit que furent enlevés

    gnome-calendar
    gnome-control-center
    gir1.2-geoclue-2.0
    ubuntu-session
    ubuntu-desktop
    gnome-settings-daemon
    gdm3
    geoclue-2.0
    libgeoclue-2-0
    gnome-initial-setup
    gnome-shell
    ubuntu-web-launcher
    mutter

    Ceci est également confirmé par grep -i "remove" /var/log/dpkg.log*, qui me renvoie des info similaires.

  • A tout hasard, j'ai regardé si je n'avais pas retiré par erreur le bureau. J'ai donc fait un grep -i "apt" ~/bash_history
    qui me renvoie en particulier

    sudo apt install geoclue
    sudo apt remove geoclue
    sudo apt install geoclue-2.0
    sudo apt install redshift*
    sudo apt remove redshift
    sudo apt install geoclue
    sudo apt install geoclue-2.0
    sudo apt autoremove

    Autant que je me souvienne, j'avais lancé ces commandes durant la même session (j'ai eu des problèmes avec RedShift). J'imagine que ce sont ces commandes qui ont désinstallé le bureau, mais je reste quand même surpris.

  • Bizarrement, en faisant un zless /var/log/apt/history.log.1.gz | grep -i "remove", je voie que la ligne indiquant que les paquets gnomes sont enlevés est précédée d'un

    Commandline: apt remove geoclue-2.0

    alors que mon bash_history ne m'indique pas une telle commande.

Hors ligne

#13 Le 03/10/2018, à 19:10

Mornagest

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

OK, cherche pas plus loin : gdm3 est le gestionnaire de connexion tongue

Tu l'installes et tu redémarres, tu devrais avoir une interface graphique smile


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#14 Le 03/10/2018, à 19:24

Fygero

Re : Problème au démarrage d'Ubuntu: arrive sur un terminal [Résolu]

Joie, bonheur, amour et volupté. Après réinstallation du bureau (sudo apt install ubuntu-desktop) et un redémarrage, le bureau est revenu. Pour info, le paquet gdm3 était déjà réinstallé.

Merci à vous tous, et en particulier à toi Mornagest.

Pour ceux qui auront un problème similaire:

  • Diagnostic: le bureau est désinstallé

  • Traitement: réinstaller le bureau

Et au passage, RedShift n'arrive toujours pas à se lancer. Mais bon, c'est un problème moins grave.

Dernière modification par Fygero (Le 03/10/2018, à 19:26)

Hors ligne