Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/10/2018, à 19:49

Piteur

[Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Bonjour.

Sur les dépôts officiels, la version d'Audacity est 2.1.2. J'utilisais depuis un bon moment la version 2.2.2 (dépôt ppa:ubuntuhandbook1/audacity). La version 2.3.0 étant disponible, je l'ai installée, avec son lot de bugs inattendus...

Je voudrais revenir à la version 2.2.2, qui marchait bien dans l'ensemble. Comment s'y prendre ? Mille pardons : je n'arrive pas à saisir comment faire...

Merci d'éclairer ma lanterne... smile

Dernière modification par Piteur (Le 08/10/2018, à 22:39)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#2 Le 05/10/2018, à 00:45

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Salut

Mis à part la compilation, je ne te promets rien...

Tout d'abord, si tu n'as jamais vidé le cache des paquets, il est possible que le paquet d'Audacity 2.2.2 se trouve encore dans tes archives depuis sa précédente installation. Il suffit de  regarder le résultat de la commande :

ls /var/cache/apt/archives/audacity*

Tu trouveras sûrement celui que tu viens d'installer (2.3.0) mais regarde en cas si le 2.2.2 ne s'y trouve pas aussi.

Sinon, le PPA que tu cites contient aussi la version 2.2.2... mais pour Ubuntu 17.10 (alors qu'à priori tu es sur 16.04). Tu pourrais essayer d'installer ce paquet-là, voir si les dépendances fonctionnent.

Dernière modification par xabilon (Le 05/10/2018, à 00:45)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 05/10/2018, à 03:34

moko138

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Et que montre

snap list

?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#4 Le 07/10/2018, à 21:53

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

xabilon a écrit :
ls /var/cache/apt/archives/audacity*

Tu trouveras sûrement celui que tu viens d'installer (2.3.0) mais regarde en cas si le 2.2.2 ne s'y trouve pas aussi.

Hélas non... Merci pour la suggestion. Je retiens la méthode.

moko138 a écrit :

Et que montre

snap list

?

Euh... strictement rien... neutral

Dernière modification par Piteur (Le 07/10/2018, à 21:57)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#5 Le 07/10/2018, à 23:03

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Les bugs seront corrigés dans les prochaines versions, mais si tu tiens absolument à installer la 2.2.2, tu peux essayer celle du PPA qui est dispo pour Ubuntu 17.10

Il faut localiser la liste de sources où se trouve l'adresse du PPA. Que donne :

ls /etc/apt/sources.list.d/

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#6 Le 08/10/2018, à 11:02

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

piteur@ACER:~$ ls /etc/apt/sources.list.d/
jtaylor-ubuntu-keepass-xenial.list
jtaylor-ubuntu-keepass-xenial.list.save
nextcloud-devs-ubuntu-client-xenial.list
nextcloud-devs-ubuntu-client-xenial.list.save
phoerious-ubuntu-keepassxc-xenial.list
phoerious-ubuntu-keepassxc-xenial.list.save
spotify.list
spotify.list.save

Du reste ça m'étonne, parce que j'ai aussi, dans "Logiciels et mises à jour", deux dépôts pour Audacity, un pour Vivaldi, etc...

https://i.goopics.net/wQVww.png


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre, TDCT'Pix et pix.debian-fr le permettent).

Dernière modification par cqfd93 (Le 08/10/2018, à 12:10)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#7 Le 08/10/2018, à 11:18

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Alors c'est que tu l'a mis directement dans le sources.list principal, sans passer par add-apt-repository.
Que donne donc :

cat /etc/apt/sources.list

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#8 Le 08/10/2018, à 11:23

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

piteur@ACER:~$ cat /etc/apt/sources.list
# deb cdrom:[Xubuntu 16.04.5 LTS _Xenial Xerus_ - Release amd64 (20180731)]/ xenial main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial restricted universe main multiverse

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates restricted universe main multiverse

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://security.ubuntu.com/ubuntu xenial-security restricted universe main multiverse
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu xenial main
# deb-src http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu xenial main
deb http://ppa.launchpad.net/tsbarnes/indicator-keylock/ubuntu xenial main
# deb-src http://ppa.launchpad.net/tsbarnes/indicator-keylock/ubuntu xenial main
deb http://repo.vivaldi.com/stable/deb/ stable main
# deb-src http://repo.vivaldi.com/stable/deb/ stable main
deb http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
# deb-src http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu artful main

Au passage, si, dans Synaptic, je tente de forcer l'installation 2.2.2 depuis le dépôt ARTFUL, j'ai :
Capture2
c'est à dire un avis indiquant sur cette version est cassée. Installation impossible, du coup.

Merci, en tout cas, Xabilon, de t'être penché sur mon "cas" : je me contenterai d'Audacity 2.1.2 jusqu'à ce que la version 2.3 soit débuggée... C'est un peu moins "confortable" que la version 2.2.2, mais tant pis ! -- Je regrette juste que ce soit si difficile d'annuler une MàJ...

Dernière modification par Piteur (Le 08/10/2018, à 11:39)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#9 Le 08/10/2018, à 11:49

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

C'est un peu ce que je craignais, c'est pour ça que je ne te promettais rien.

Et si il est compliqué d'annuler une mise à jour, c'est parce qu'il faut voir le système Ubuntu et les logiciels comme un écosystème de briques dépendantes les unes des autres, et non comme des logiciels indépendants qu'on empile. Audacity 2.2.2 du PPA pour Artful est adaptée pour Artful, et à priori pas pour Xenial.

Tu as donc changé la ligne du PPA dans les sources.list pour qu'elle pointe sur Artful plutôt que sur Xenial (que tu l'ais fait directement dans le sources.list ou via Synaptic ne change rien) ?
Tu as une idée de quelles dépendances empêchent l'installation ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#10 Le 08/10/2018, à 13:14

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

xabilon a écrit :

Tu as une idée de quelles dépendances empêchent l'installation ?

Si, dans Synaptic, je regarde dans les dépendances correspondant à la version 2.2.2 (artful) qui est réputée "cassée", je ne vois rien dans la liste qui m'alerte, SAUF la dernière ligne : "conflit avec Audacity" ! Or, j'ai pris soin de désinstaller Audacity avant de tenter une installation de 2.2.2 Artful... — Perso, je n'y comprends vraiment rien.

Comme dit, j'ai renoncé à 2.2.2 et ai réinstallé la version 2.1.2, moins confortable mais fonctionnelle, depuis les dépôts officiels. Restons-en là !

Mais je ne saisis pas pourquoi je ne peux pas retrouver sur le Web le DEB correspondant à la version 2.2.2 (pour Xenial), c'est ça qui me turlupine ! big_smile . En local, sans doute a-t-il été viré du cache des applis (voir plus haut dans ce fil), probablement quand j'ai désinstallé la version 2.1.2 en faisant sudo apt-get autoremove --purge audacity pour être sûr que tout soit propre avant d'installer 2.3.0... Une mauvaise idée en somme ! roll Si j'ai bien compris, j'aurais dû copier le fichier DEB du cache AVANT de faire le ménage, pour le cas où...

Un truc qui me dépasse quand même vraiment : l'équipe d'Audacity est au courant du bug majeur qui concerne certains "filtres" dans la version 2.3.0 (voir son forum en anglais). Pourquoi, plutôt que de faire attendre une correction de cette version, ne reproposent-ils pas la version 2.2.2 qui marchait très bien ? — Pas tout saisi à la "politique" de Linux/Ubuntu (si c'est elle qui impose une telle démarche, ce qui n'est pas avéré !)...

Dernière modification par Piteur (Le 08/10/2018, à 13:22)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#11 Le 08/10/2018, à 16:12

moko138

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Commence par installer ppa-purge

sudo apt-get install ppa-purge

puis purger ton ppa pour artful :

sudo ppa-purge ppa:(...)  # Tu complèteras.

et purger (normalement ce sera déjà fait, mais...) tes 2 paquets audacity :

sudo apt-get remove --purge audacity  audacity-data

Enfin
http://ubuntuhandbook.org/index.php/201 … l-upgrade/ dit :

how to install it in Ubuntu 16.04, Ubuntu 17.10, and Ubuntu 18.04.

  - -

Bien entendu, tu donnes tous les retours de commande complets.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#12 Le 08/10/2018, à 19:07

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

C'est "sudo apt-get clean" qui vide le cache des paquets.

Mais plus la peine de te prendre la tête, tu peux passer en [Résolu], cet après-midi le responsable du PPA a remis la version 2.2.2 pour Xenial big_smile !
https://launchpad.net/~ubuntuhandbook1/ … ter=xenial

Donc garde le PPA, section xenial (à modifier si tu l'avais remplacé par artful), et réinstalle Audacity.

Dernière modification par xabilon (Le 08/10/2018, à 19:08)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#13 Le 08/10/2018, à 22:38

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

En voilà une bonne nouvelle ! Il y a quand même des gens compatissants ET raisonnables ! smile

Merci pour tout !


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#14 Le 10/10/2018, à 12:56

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

Bonjour.

Dans le droit fil de ce topic, je voudrais savoir si, après avoir fait des copies de sauvegarde des .DEB correspondant à la version 2.2.2 d'Audacity (qui sont maintenant présents dans /var/cache/apt/archives/ [audacity et audacity-data]), je peux escompter les utiliser en cas de bug faisant suite à une MàJ ultérieure, toujours sur le même système évidemment (dans mon cas, Xenial) ?

Si oui, pourquoi ne pas faire de sauvegarde systématique des .DEB contenus dans le cache de APT ? Bonne ou mauvaise idée ?

Merci (dès maintenant, encore merci à Xabilon de m'avoir fait découvrir le contenu de /var/cache/apt/archives/ !)...


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#15 Le 10/10/2018, à 15:43

xabilon

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

En fait, la réponse à la première question est : ça dépend, mais globalement oui, tant que ses dépendances sont satisfaites.

La deuxième : /var/cache/apt/archives est la sauvegarde des paquets. Elle ne sera effacée que si tu fais un "sudo apt-get clean" (ou "VIder le cache des paquets" sur Synaptic).
Mais au cours du temps ça prend de la place, et si en plus tu les sauvegardes ailleurs ça prendra le double. Donc pour moi mauvaise idée...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#16 Le 10/10/2018, à 15:47

Piteur

Re : [Résolu] Audacity : 2.3.0 buggé > comment retrouver la version 2.2.2 ?

OK, merci beaucoup, Xabilon. C'est bien noté ! Je prendrai garde à NE PAS vider le cache des paquets avec Synaptic, tant que la nouvelle version n'est pas testée et "approuvée" ! ;-)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne