Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 08/10/2018, à 12:50

Flashe

Re : Plus de son en version 18.04

lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 04)
	Subsystem: Hewlett-Packard Company 6 Series/C200 Series Chipset Family High Definition Audio Controller [103c:165a]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

Hors ligne

#27 Le 08/10/2018, à 13:00

xubu1957

Re : Plus de son en version 18.04

Si l'on suit le tutoriel donné en #23 :

Vous pouvez ajouter options snd-hda-intel model=generic à la fin de /etc/modprobe.d/alsa-base.conf en exécutant cette commande:

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

N'exécutez cette commande qu'une seule fois, car elle ajoute cette ligne à chaque exécution ! Si vous souhaitez le modifier, ouvrez-le en /etc/modprobe.d/alsa-base.conftant que root avec un éditeur de texte.

2. Ensuite, redémarrez votre système. J'espère que votre son fonctionne maintenant dans Ubuntu et que vous n'obtenez plus qu'un périphérique de sortie factice System Settings > Sound.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#28 Le 08/10/2018, à 13:10

Flashe

Re : Plus de son en version 18.04

Problème,je crois que j'ai appliqué la commande plusieurs fois,ne voyant un méssage me disant que celà a été ajouter.Faut que j'édite le fichier alsa-base.conf je fais comment ? Je supprimerait la ou les lignes en plus manuellement.

Hors ligne

#29 Le 08/10/2018, à 13:13

xubu1957

Re : Plus de son en version 18.04

Éditeur de texte nano

Essaye d'ouvrir le fichier avec nano :

sudo nano /etc/modprobe.d/alsa-base.conf

Commande rectifiée.
_ _ _


Voici les raccourcis les plus importants :

Ctrl + G : afficher l'aide ;

Ctrl + K : couper la ligne de texte (et la mettre dans le presse-papier) ;

Ctrl + U : coller la ligne de texte que vous venez de couper ;

Ctrl + C : afficher à quel endroit du fichier votre curseur est positionné (numéro de ligne…) ;

Ctrl + W : rechercher dans le fichier ;

Ctrl + O : enregistrer le fichier (écrire) ;

Ctrl + X : quitter Nano.

> nano-l-editeur-de-texte-du-debutant

addendum

Le 04/03/2018, moko138 a écrit :

Attention !   Pour nano :

Pour enregistrer, après
Ctrl o
il faut valider avec la touche "Entrée".

Dernière modification par xubu1957 (Le 08/10/2018, à 16:19)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#30 Le 08/10/2018, à 13:25

Flashe

Re : Plus de son en version 18.04

Heu c 'est normal que le fichier soit vierge (vide) il y a rien d'écrit dedans une fois ouvert.Etrange non ?

1538998138-capture-d.png

Dernière modification par Flashe (Le 08/10/2018, à 13:29)

Hors ligne

#31 Le 08/10/2018, à 13:30

xubu1957

Re : Plus de son en version 18.04

C'est :

sudo nano /etc/modprobe.d/alsa-base.conf

Commande rectifiée.

J'ai mal recopié ! sad

Me sers pas de tous ces outils.

Dernière modification par xubu1957 (Le 08/10/2018, à 16:18)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#32 Le 08/10/2018, à 13:51

Flashe

Re : Plus de son en version 18.04

Pareil le fichier est vide.

Hors ligne

#33 Le 08/10/2018, à 13:57

xubu1957

Re : Plus de son en version 18.04

Au #18, Flashe a écrit :

il y a un voyant qui indique que le son est coupé mais le pire c'est qu'il y a aucun pilote son installé dans paramètre

Il y a une cohérence.

_ _ _

Tu as ton support d'installation d'Ubuntu (DVD ou clé USB) ?

Pour appliquer la procédure > amorcer_sur_cd_ubuntu#amorcage et arriver à cette étape : essayer_ubuntu_sans_rien_changer_dans_votre_ordinateur et tester en session live.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#34 Le 08/10/2018, à 14:01

Flashe

Re : Plus de son en version 18.04

Non,j'ai pas de support d'installation Ubuntu.Ok donc je vais en crée un et procédé comme indiquer.

Hors ligne

#35 Le 08/10/2018, à 16:07

lynn

Re : Plus de son en version 18.04

xubu1957 a écrit :

C'est :

sudo nano /etc/modprobe.d/alsa-base conf

J'ai mal recopié ! sad

Me sers pas de tous ces outils.

Il manque le point (.)
C'est

sudo nano /etc/modprobe.d/alsa-base.conf

«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#36 Le 08/10/2018, à 16:17

xubu1957

Re : Plus de son en version 18.04

Oups !

Je vais corriger les #29 et #31.

Merci lynn smile


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#37 Le 08/10/2018, à 17:40

Flashe

Re : Plus de son en version 18.04

@xubu1957
Avec le.voilà ce que j'ai décrit dans le fichier mais je ne vois pas la ligne qu'il faut modifier.

sudo nano /etc/modprobe.d/alsa-base conf# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modpro$
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbi$
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { $
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbi$
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS &$

Hors ligne

#38 Le 08/10/2018, à 19:19

xubu1957

Re : Plus de son en version 18.04

Il faut maximiser ta fenêtre du terminal pour le copier/coller, je viens de tester sur mon ordi :

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#39 Le 08/10/2018, à 19:28

Flashe

Re : Plus de son en version 18.04

Ok d'accord.C'est fait,à la fin du fichier j'ai trouvé les lignes en question,je fais quoi ?

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=hp-bpc

options snd-hda-intel model=generic

Je suppose qu'il y a au moins 2 voir 3 lignes qu'il faut supprimer.Il y a un peu de tout quand on regardes ses dernières....

Dernière modification par Flashe (Le 08/10/2018, à 19:33)

Hors ligne

#40 Le 08/10/2018, à 19:36

xubu1957

Re : Plus de son en version 18.04

Dans le texte :

N'exécutez cette commande qu'une seule fois, car elle ajoute cette ligne à chaque exécution ! Si vous souhaitez le modifier, ouvrez-le en /etc/modprobe.d/alsa-base.conf tant que root avec un éditeur de texte.

2. Ensuite, redémarrez votre système. J'espère que votre son fonctionne maintenant dans Ubuntu et que vous n'obtenez plus qu'un périphérique de sortie factice System Settings > Sound.

Si vous continuez à ne produire aucune sortie audio et que vous ne voyez toujours que la sortie fictive dans les paramètres système, vous pouvez essayer de définir le model sur auto au lieu de generic, alors éditez le /etc/modprobe.d/alsa-base.conf fichier avec un éditeur de texte (en tant que root) et modifiez-le. Vous pouvez trouver une liste d'autres modèles que vous pouvez essayer en fonction de votre matériel informatique ici


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#41 Le 08/10/2018, à 20:13

Flashe

Re : Plus de son en version 18.04

xubu1957 a écrit :
Au #18, Flashe a écrit :

il y a un voyant qui indique que le son est coupé mais le pire c'est qu'il y a aucun pilote son installé dans paramètre

Il y a une cohérence.

_ _ _

Tu as ton support d'installation d'Ubuntu (DVD ou clé USB) ?

Pour appliquer la procédure > amorcer_sur_cd_ubuntu#amorcage et arriver à cette étape : essayer_ubuntu_sans_rien_changer_dans_votre_ordinateur et tester en session live.

J'ai essaie cette procédure et une fois arriver sur le bureau,un pilote par défaut est installé (Speakers- Built-in audio) pas vraiment celle de la carte mais en live-cd il est possible d'avoir le son.
Par contre meme en rajoutant auto à la place de généric après avoir redémarrer ça fonctionne pas.

Hors ligne

#42 Le 08/10/2018, à 20:20

xubu1957

Re : Plus de son en version 18.04

Fournis le noyau actif :

uname -a

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#43 Le 08/10/2018, à 20:33

Flashe

Re : Plus de son en version 18.04

uname -a Linux-Notebook 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Dernière modification par Flashe (Le 08/10/2018, à 20:33)

Hors ligne

#44 Le 08/10/2018, à 20:41

xubu1957

Re : Plus de son en version 18.04

Que répond :

sudo modprobe -v snd-hda-intel

?

> [SOLVED] Sound not working. Card not recognized.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#45 Le 08/10/2018, à 20:46

Flashe

Re : Plus de son en version 18.04

Rien pas de réponse.

Hors ligne

#46 Le 08/10/2018, à 21:28

xubu1957

Re : Plus de son en version 18.04

Pour tester :

sudo rmmod snd-hda-intel -f && modprobe snd-hda-intel model=auto

> [SOLVED] Pulseaudio and internal microphone in laptop... Again.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#47 Le 08/10/2018, à 21:37

Flashe

Re : Plus de son en version 18.04

sudo rmmod snd-hda-intel -f && modprobe snd-hda-intel model=auto
rmmod: ERROR: ../libkmod/libkmod-module.c:793 kmod_module_remove_module() could not remove 'snd_hda_intel': Resource temporarily unavailable
rmmod: ERROR: could not remove module snd-hda-intel: Resource temporarily unavailable

Hors ligne

#48 Le 08/10/2018, à 21:42

xubu1957

Re : Plus de son en version 18.04

Dans la discussion, au dernier commentaire :

lomapur a écrit :

I don't know what I did (I gave my laptop a few shakes, that's all), but it works again ! thanks for help
Je ne sais pas ce que j'ai fait (j'ai donné quelques secousses à mon ordinateur portable, c'est tout), mais ça fonctionne à nouveau! Merci pour l'aide

Mais je déconseille.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#49 Le 08/10/2018, à 21:45

Flashe

Re : Plus de son en version 18.04

xubu1957 a écrit :

Dans la discussion, au dernier commentaire :

lomapur a écrit :

I don't know what I did (I gave my laptop a few shakes, that's all), but it works again ! thanks for help
Je ne sais pas ce que j'ai fait (j'ai donné quelques secousses à mon ordinateur portable, c'est tout), mais ça fonctionne à nouveau! Merci pour l'aide

Mais je déconseille.

Ah ouais quand meme ils existent de sacré phénomène,t inquitète à aucun moment celà à traversé mon esprit. lol

Hors ligne

#50 Le 08/10/2018, à 21:55

xubu1957

Re : Plus de son en version 18.04

Et avant, tu avais une version 16.04 ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne