Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/10/2018, à 16:25

morane

HPLIP bug avec Ubuntu 18.04 Mate

Bonjour à tous,

Le problème est assez simple : je n'arrive pas à faire fonctionner correctement Hplip sur Ubuntu Mate 18.04
Naturellement, j'ai téléchargé la dernière version proposée par HP et je l'ai installée sur 3 PC différents (2 avec Ubuntu 18.04 et le troisième avec Ubuntu 16.04, via sh dans un terminal).

Sur tous les PC, l'icone Hplip Toolbox est présente dans le menu Préférence et la plupart du temps dans la barre supérieure en haut de l'écran

Sur le PC Ubuntu 16.04, aucun souci, je clique sur l'icone, j'ai accès au menu pour ajouter une imprimante, je choisi Imprimante réseau, je clique sur OK, Hplip la trouve, je la sélectionne et elle s'installe.

Sur les PC avec Ubuntu 18.04,je clique sur l'icone, j'ai accès au menu pour ajouter une imprimante, je choisi Imprimante réseau, je clique sur OK, et à ce niveau, la fenêtre s'affiche à nouveau pour me demander quel type d'imprimante ... (le message tourne en boucle). Je pense que c'est la fonction hp-setup qui bug de hplip-gui.

Pourtant, si je vais voir dans les paramètres système d'Ubuntu, l'imprimante est reconnue.

J'ai déjà essayé un paquet de solutions proposées sur le web et hormis le fait d'obtenir des messages d'erreur, je n'ai pas obtenu grand chose.

Une idée ?

Merci

Dernière modification par morane (Le 09/10/2018, à 16:30)


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#2 Le 09/10/2018, à 16:37

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour,
Pourquoi as-tu installé la dernière version, ton imprimante n'était pas reconnu par le hplip des dépôts officiels?

sudo apt install hplip-gui

Après avoir désinstallé correctement la dernière version comme indiqué sur la page hplip de la doc.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#3 Le 09/10/2018, à 16:47

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour,

Non ma vieille imprimante HP a rendu l'âme dimanche dernier, les têtes d'impression ne voulaient plus rien savoir (même après un démontage complet et un nettoyage ad-hoc), alors j'ai cassé ma tirelire et acheté une HP Laser Jet MFP M281fdw
Comme elle n'était pas reconnue par la version d'Hplip sur mon PC Ubuntu 16.04, j'y ai installé la dernière version d'Hplip (qui a détecté mon imprimante sur ce PC).

J'ai oublié de dire que l'un des deux PC sous Ubuntu 18.04 est fraîchement installé et qu'aucun Hplip n'y a été installé auparavant.
Concernant l'autre PC sous Ubuntu 18.04, j'ai rencontré ce bug avec des version d'Hplip datant de début juin.

Je vais tenter ta suggestion ce soir.

Dernière modification par morane (Le 09/10/2018, à 16:48)


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#4 Le 09/10/2018, à 17:01

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

As-tu pensé au plugin proprio? C'est peut-être ça  qui manque.  hplip est installé par défaut sur tout les ubuntu. C'est hplip-gui qui n'est pas installé. Je soupçonne le plugin proprio.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#5 Le 09/10/2018, à 18:31

grigouille

Re : HPLIP bug avec Ubuntu 18.04 Mate

Non, pas besoin de plugin proprio.


Xubuntu 18.04

Hors ligne

#6 Le 09/10/2018, à 18:32

grigouille

Re : HPLIP bug avec Ubuntu 18.04 Mate

Donne nous :

hp-setup -ir

et

hp-setup -ia

Xubuntu 18.04

Hors ligne

#7 Le 09/10/2018, à 19:10

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonsoir,

Sur un des PC avec Ubuntu 18.04 , j'ai d'abord réinstallé hplip-gui mais cela n'a rien changé.

Ensuite, dans un terminal, j'ai lancé hp-setup.
La fenêtre pour choisir le type d'imprimante (USB, réseau ou WiFi) s'est ouverte et j'ai pu installer l'imprimante convenablement.

Sur l'autre PC Ubuntu 18.04 les instructions donnent:

hp-setup -ir

HP Linux Imaging and Printing System (ver. 3.18.9)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


----------------------------
| REMOVING PRINT/FAX QUEUE |
----------------------------

error: No device found that support this feature.
Removing 'None : None' Queue
error: Failed to delete None Print/Fax queue. Error : client-error-not-found
hp-setup -ia

HP Linux Imaging and Printing System (ver. 3.18.9)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 

Je ne vais pas installer l'imprimante tout de suite sur ce PC (en utilisant la même méthode qu'avec le précédent) au cas où quelqu’un aurait une idée à tester.

Dernière modification par morane (Le 09/10/2018, à 19:24)


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#8 Le 09/10/2018, à 19:45

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

Tu peux installer l'imprimante sur un pc pour la partager via le réseau, donc si on réussit sur une les autres y auront accès.
Mais perso j'ai pas d'idée.


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#9 Le 10/10/2018, à 06:24

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour à tous,

Mon imprimante est une imprimante réseau, connectée au routeur avec une ip fixe, elle est donc accessible par n'importe quel PC, qu'il soit sur Ubuntu ou Windows.

Je pense qu'il s'agit d'un problème concernant hplip-gui car lorsque je passe par le terminal pour exécuter hp-setup, l'affichage de la page de sélection du type d'imprimante (wifi, réseau, usb) se fait sans problème, ainsi que les pages suivantes.
Il n'y a que lorsque je passe par l'icone HP, que je bloque sur cette page et que celle-ci s'affiche en boucle dès que je sélectionne OK (après avoir indiqué que l'imprimante est de type réseau).

De plus, ce problème concernant hplip-gui, ne concerne que Ubuntu 18.04 (version Mate dans mon cas).


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#10 Le 10/10/2018, à 06:52

grigouille

Re : HPLIP bug avec Ubuntu 18.04 Mate

hplip-gui, c'est de la déco pour moi. Si tu veux installer ton imprimante hp-setup -i suffit.
Pour ton imprimante réseau :

hp-setup -i adresse_ip_imprimante

Lire la page hplip.


Xubuntu 18.04

Hors ligne

#11 Le 10/10/2018, à 06:57

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Grigouille,

Je suis d'accord, effectivement, en passant par le terminal, j'installe l'imprimante mais ce que je veux désormais, c'est comprendre pourquoi lorsque l'on passe par hplip-gui cela ne fonctionne pas et trouver une solution à ce problème.

Merci


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#12 Le 25/10/2018, à 20:10

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour,
As-tu résolu ton problème?


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#13 Le 26/10/2018, à 09:00

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour,

Le problème concernant le gui n'est pas résolu, aujourd'hui j'ai installé Hplip 3.18.5 sur tous les PC (Ubuntu 16.04 Mate ou 18.04 Mate), et j'ai été obligé de passer par un Hp-setup dans le terminal pour installer les imprimantes.
Comme j'ai une nouvelle imprimante HP laser qui a besoin d'un addon Hp complémentaire, je suis obligé de garder la version Hplip 3.18.5, car l'addon n'est pas disponible pour les versions suivantes.

De toutes façons, avec Ubuntu Mate 18.04, toutes les versions d'Hplip sont concernées par le problème. Je pense qu'il s'agit d'un problème concernant le gui d'Hplip et la version Mate. Comme je ne suis pas assez calé pour résoudre le problème, j'ai ouvert un bug dans launchpad, mais pour l'instant je n'ai pas de solution.

Merci


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#14 Le 26/10/2018, à 14:05

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

Tu peux nous donner le lien vers ton rapport de bug. Je n'ai pas encore totalement bien compris le problème (j'ai pas trop de temps, là) smile
J'ai aussi fait un rapport de bug au sujet de l'icone dans le tableau de bord (indépendant de Mate d'ailleurs) qui s'affiche mais quand on cliques dessus il y une fenêtre noire. Tu as aussi constaté ça, si oui tu peux t'ajouter à ceux qui ont le problème.

Dernière modification par L'Africain (Le 26/10/2018, à 16:28)


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#15 Le 26/10/2018, à 19:37

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#16 Le 26/10/2018, à 20:22

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

OK bizarre comme truc. Au fait au sujet de ce bug ça le fait aussi chez toi? Si oui merci de faire chauffer en t'ajoutant au personne concernées smile


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#17 Le 27/10/2018, à 10:21

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour, non, avec le clic droit, j'ai toujours eu le menu, par contre, quelques fois, c'est l'icône HP qui a du mal à apparaître.


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#18 Le 27/10/2018, à 12:36

L'Africain

Re : HPLIP bug avec Ubuntu 18.04 Mate

Tu as fait une migration de ton mate? Dans mon cas c'est toujours des installations nouvelles.

Dernière modification par L'Africain (Le 27/10/2018, à 13:12)


Ubuntu 16.04 LDLC (clevo) X/Lubuntu (Mate) 16.04 sur asus.
"Donne à celui qui te demande…" Mt 5, 42

Hors ligne

#19 Le 30/10/2018, à 14:41

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Bonjour,

Non je ne fais jamais de migration mais toujours des installations "fraiches" avec formatage du Home et du /
J'ai le problème sur 3 PC contenant Ubuntu Mate 18.04 mais pas sur 2 autres PC tournant sur Mate 16.04


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne

#20 Le 30/10/2018, à 14:51

morane

Re : HPLIP bug avec Ubuntu 18.04 Mate

Sincèrement, la commande Hp-setup fonctionne dans le terminal, en appelant la fenêtre ad-hoc permettant de faire le choix du type d'imprimante, puis en permettant de choisir cette imprimante.
Lorsque j'utilise l'icone HP pour appeler cette même fenêtre permettant de faire le choix du type d'imprimante, tout part en vrille.

Je pense donc qu'il s'agit d'un problème d'interface ou de couche graphique lié à hplip-gui, je me demande d'ailleurs, si par hasard, nous n'aurions pas deux fenêtres identiques mais différentes;
Je m'explique:
* une première fenêtre commandée par hp-setup dans le terminal, qui fonctionne
* une deuxième fenêtre, identique à la précédente, commandée par hplip-gui et qui est buggée

C'est peut être idiot mais si non je n'explique pas pourquoi le fait de cliquer sur Next, fonctionne dans un cas et pas dans l'autre...

Il est possible que ton problème et le mien soient liés : un hplip-gui buggé

Dernière modification par morane (Le 30/10/2018, à 14:52)


Ubuntu 12.04 , 16.04 et 18.04 MATE installés en dual boot avec Seven et Win 8 sur 10 PC différents
Un serveur raid avec Ubuntu 12.04
bricole sur Ubuntu depuis la version 7.04

Hors ligne