Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/11/2018, à 14:42

Mathématix

[Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Bonjour à tous,

J'ai en a ma possession une imprimante CANON PIXIMA MG5300 series, seulement elle n'est pas à portée de câble de mon ordinateur. C'est pour cela que je voudrais la configurer en Wi-Fi.
Je tiens à préciser que je suis déjà allé dans les paramètres de l'imprimante et que j'ai réussi à la connecter à ma box Internet. Sur ma partition Windows, je suis allé dans le panneau de configuration et j'ai réussi à trouver le bon driver pour pouvoir imprimer à distance. Cependant, Canon ne fournit aucun driver officiel compatible Linux : alors je ne peux pas connecter mon ordinateur à l'imprimante...

J'ai quand même fait des recherches et je suis tombé sur cette URL : https://www.cannon-drivers.com/canon-pi … -download/ et j'ai choisi de télécharger un driver à la section "Canon MG5300 IJ Printer Driver for Linux" tout en bas de la page. Cependant ce driver .deb, n'est en fait qu'un dossier dans lequel je trouve deux dossier et un fichier install.sh. J'ai donc tapé quelques commandes pour essayer d'installer le driver mais cela m'affiche une erreur...

maxime@maxime-X756UWK:~$ cd Téléchargements/scangearmp-mg5300series-1.80-1-deb/
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb$ dir
install.sh  packages  resources
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb$ sudo ./install.sh 
[sudo] Mot de passe de maxime : 
==================================================

ScanGear MP
Version 1.80
Copyright CANON INC. 2007-2011
Tous droits réservés.

==================================================
Une erreur s'est produite. Impossible d'identifier le gestionnaire de paquets.
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb$ 

Le fichier packages contient une multitude de paquets que j'ai essayé d'installer mais il y en a deux que je n'arrive pas à installer.. cela m'affiche un problème de dépendance qui se résout en supprimant les deux packages qui ont été précédemment installés :

maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb$ cd packages/
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb/packas$ dir
scangearmp-common_1.80-1_amd64.deb  scangearmp-mg5300series_1.80-1_amd64.deb
scangearmp-common_1.80-1_i386.deb   scangearmp-mg5300series_1.80-1_i386.deb
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb/packas$ sudo dpkg -i *.deb
Sélection du paquet scangearmp-common précédemment désélectionné.
(Lecture de la base de données... 336832 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de scangearmp-common_1.80-1_amd64.deb ...
Dépaquetage de scangearmp-common (1.80-1) ...
Préparation du dépaquetage de scangearmp-common_1.80-1_i386.deb ...
Dépaquetage de scangearmp-common:i386 (1.80-1) sur (1.80-1) ...
Sélection du paquet scangearmp-mg5300series précédemment désélectionné.
Préparation du dépaquetage de scangearmp-mg5300series_1.80-1_amd64.deb ...
Dépaquetage de scangearmp-mg5300series (1.80-1) ...
Préparation du dépaquetage de scangearmp-mg5300series_1.80-1_i386.deb ...
Dépaquetage de scangearmp-mg5300series:i386 (1.80-1) sur (1.80-1) ...
Plus d'une copie du paquet scangearmp-common:i386 ont été dépaquetées
 lors de ce traitement. Une seule configuration effectuée.
Plus d'une copie du paquet scangearmp-mg5300series:i386 ont été dépaquetées
 lors de ce traitement. Une seule configuration effectuée.
dpkg: des problèmes de dépendances empêchent la configuration de scangearmp-common:i386 :
 scangearmp-common:i386 dépend de libatk1.0-0 (>= 1.9.0).
 scangearmp-common:i386 dépend de libgtk2.0-0 (>= 2.8.0).
 scangearmp-common:i386 dépend de libpango1.0-0 (>= 1.12.3).
 scangearmp-common:i386 dépend de libpng12-0 (>= 1.2.8rel).
 scangearmp-common:i386 dépend de libusb-0.1-4 (>= 2:0.1.10a).

dpkg: erreur de traitement du paquet scangearmp-common:i386 (--install) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de scangearmp-mg5300series:i386 :
 scangearmp-mg5300series:i386 dépend de scangearmp-common (>= 1.80) ; cependant :
 Le paquet scangearmp-common:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet scangearmp-mg5300series:i386 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 scangearmp-common:i386
 scangearmp-mg5300series:i386
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb/packas$ sudo apt -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  scangearmp-common:i386 scangearmp-mg5300series:i386
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 2306 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 336893 fichiers et répertoires déjà installés.)
Suppression de scangearmp-mg5300series:i386 (1.80-1) ...
Suppression de scangearmp-common:i386 (1.80-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
maxime@maxime-X756UWK:~/Téléchargements/scangearmp-mg5300series-1.80-1-deb/packas$ 

Cependant, il me semble que le site que je viens de vous fournir est le seul qui donne accès à un driver "compatible"... Dans mon plus grand désespoir je me dis que les imprimantes ne sont pas si différentes les unes des autres et donc qu'il doit bien y avoir un programme sous Linux qui est capable de toutes les gérer, mais qui ne gère que les taches basiques dont j'attends que mon imprimante fasse ..?
Est-ce que quelqu'un pourrait m'aider ?

PS : je tiens à préciser que je dispose de la dernière version en date d'Ubuntu, et que je suis déjà allé dans les paramètre section imprimantes et que cela n'a rien donné...
Voici ce qui est affiché dans les paramètres :

Capture-du-2018-11-01-14-50-05.png

Dernière modification par Mathématix (Le 06/02/2019, à 17:23)

Hors ligne

#2 Le 01/11/2018, à 14:54

Tristan07

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Bonjour,
Sous quel environnement de bureau es-tu ?
as-tu vu :
http://doc.kubuntu-fr.org/tutoriel/ppa_canon
ou :
https://forum.ubuntu-fr.org/viewtopic.p … #p21994592
cordialement,


Debian 9 Stable sur portable et poste fixe

Hors ligne

#3 Le 01/11/2018, à 15:07

Tristan07

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

N'yb a t-il pas une histoire de pare-feu ? Gufw est il installer ?


Debian 9 Stable sur portable et poste fixe

Hors ligne

#4 Le 01/11/2018, à 15:11

grandtoubab

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Salut
pour une imprimante MG3650  j'ai fait comme ça en utilisant les paquets fournis par Canon
https://bidouilledebian.wordpress.com/2 … on-mg3650/

tout fonctionne impression et scan en wifi cool


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#5 Le 01/11/2018, à 15:39

Mathématix

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Merci pour vos réponses...

Merci Tristan07 pour ton lien... et les paquets qu'il faut installer sont les mêmes que ceux du blog de grandtoubab...
Cependant, @grandtoubab, je n'arrive à suivre complètement l'article de blog... dans la partie configuration, tu nous demande de lancer le programme canon, et j'ai essayer de le lancer(cnijfilter2) mais cela ne fait rien...
De plus, lorsque je fait la configuration nmap, je ne trouve aucune adresse IP...

maxime@maxime-X756UWK:~$ nmap -sP 192.168.0.1/24

Starting Nmap 7.60 ( https://nmap.org ) at 2018-11-01 15:28 CET
Stats: 0:01:09 elapsed; 0 hosts completed (0 up), 256 undergoing Ping Scan
Ping Scan Timing: About 67.38% done; ETC: 15:30 (0:00:34 remaining)
Nmap done: 256 IP addresses (0 hosts up) scanned in 104.20 seconds
maxime@maxime-X756UWK:~$ 

Et oui, j'ai bien Gufw d'installé...
Peux tu m'expliquer @grandtoubab comment lancer le programme canon ?

Merci beaucoup pour vos réponses !

Mon environnement de bureau est Budgie...

Dernière modification par Mathématix (Le 01/11/2018, à 15:45)

Hors ligne

#6 Le 01/11/2018, à 17:20

grandtoubab

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Mathématix a écrit :

Merci pour vos réponses...


Peux tu m'expliquer @grandtoubab comment lancer le programme canon ?

.

Quand tu as récupéré l'archive depuis le site canon et décompressé,  il y a un dossier cnijfilter2-5.20-1-deb où tu trouves le script d'installation

exemple j'ai mis tout ca dans un dossier canon de mon home

~/canon/cnijfilter2-5.20-1-deb$ ls 
install.sh  install.txt  packages  resources

Dernière modification par grandtoubab (Le 01/11/2018, à 17:21)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#7 Le 01/11/2018, à 17:24

grandtoubab

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

grandtoubab a écrit :
Mathématix a écrit :

Merci pour vos réponses...


Peux tu m'expliquer @grandtoubab comment lancer le programme canon ?

.

Quand tu as récupéré l'archive depuis le site canon et décompressé,  il y a un dossier cnijfilter2-5.20-1-deb où tu trouves le script d'installation

exemple j'ai mis tout ca dans un dossier canon de mon home

~/canon/cnijfilter2-5.20-1-deb$ ls 
install.sh  install.txt  packages  resources

pour nmap il ne faut pas copier bestialement la commande qui corresponds à mon cas
quel est TON adresse ip dans TON réseau local

ip ad

Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#8 Le 06/02/2019, à 17:14

Mathématix

Re : [Résolu] Imprimer en Wi-Fi avec une imprimante CANON MG5300 series

Excusez moi pour ma réponse tardive..

Suite à un changement de disque dur sur mon ordinateur, j'ai installé une version fraîche de ubuntu.
J'ai ensuite téléchargé le driver "MG5300 series IJ Printer Driver Ver. 3.60 for Linux (debian Packagearchive)" sur le site de Canon.
En désarchivant le fichier téléchargé, j'ai exécuté le fichier install.sh :

maxime@maxime-X756UWK:~/Téléchargements/cnijfilter-mg5300series-3.60-1-deb$ sudo ./install.sh
[sudo] Mot de passe de maxime : 
==================================================

Pilote d'imprimante Canon Inkjet
Version 3.60
Copyright CANON INC. 2001-2011
Tous droits réservés.

==================================================
Commande exécutée = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Sélection du paquet cnijfilter-common précédemment désélectionné.
(Lecture de la base de données... 166120 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cnijfilter-common_3.60-1_amd64.deb ...
Dépaquetage de cnijfilter-common (3.60-1) ...
Paramétrage de cnijfilter-common (3.60-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Commande exécutée = sudo dpkg -iG ./packages/cnijfilter-mg5300series_3.60-1_amd64.deb
Sélection du paquet cnijfilter-mg5300series précédemment désélectionné.
(Lecture de la base de données... 166136 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cnijfilter-mg5300series_3.60-1_amd64.deb ...
Dépaquetage de cnijfilter-mg5300series (3.60-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de cnijfilter-mg5300series :
 cnijfilter-mg5300series dépend de libpng12-0 (>= 1.2.8rel) ; cependant :
  Le paquet libpng12-0 n'est pas installé.
 cnijfilter-mg5300series dépend de libtiff4 ; cependant :
  Le paquet libtiff4 n'est pas installé.

dpkg: erreur de traitement du paquet cnijfilter-mg5300series (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 cnijfilter-mg5300series
Commande exécutée = sudo dpkg -P cnijfilter-mg5300series
(Lecture de la base de données... 166339 fichiers et répertoires déjà installés.)
Suppression de cnijfilter-mg5300series (3.60-1) ...
Purge des fichiers de configuration de cnijfilter-mg5300series (3.60-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Commande exécutée = sudo dpkg -P cnijfilter-common
(Lecture de la base de données... 166135 fichiers et répertoires déjà installés.)
Suppression de cnijfilter-common (3.60-1) ...
Purge des fichiers de configuration de cnijfilter-common (3.60-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...

L'installation ne fonctionnait pas car il manquait les dépendances libpng12-0 et libtiff4, qui ne sont plus disponible sur les dépôts officiels. Voilà un lien de téléchargement pour chacune d'elles :
libpng12-0
libtiff4
Je les ai installés à l'aide de la commande dpkg et j'ai relancé le fichier install.sh, et l'installation s'est déroulé à merveille.

Je m'excuse encore une fois de ne pas voir répondu rapidement.

Dernière modification par Mathématix (Le 14/02/2019, à 18:23)

Hors ligne