Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 13/11/2018, à 22:58

xubu1957

Re : ports USB connexion difficile sur lenovo B50-70

@moko138

Je cherchais avec :

ID 0cf3:3004

pour le Bluetooth.

Je trouve une anomalie avec les ports USB > Souris Logitech détectée une fois sur 5

_ _ _

@xtrice

Ouvre une nouvelle discussion en section Accès internet et réseaux.

Il faudra fournir, en te servant du  Retour utilisable de commande, un wificheck rassemblant les informations > Configuration wifi.

Nota : un fichier wificheck.log est créé dans votre répertoire personnel, collez l'intégralité de son contenu dans votre discussion.

et :

dmesg | grep -i bluetooth; dmesg | grep -i firmware; lsmod | grep bluetooth
sudo service bluetooth status
dpkg -l | grep blue

Dernière modification par xubu1957 (Le 13/11/2018, à 23:05)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#27 Le 14/11/2018, à 08:52

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :

= =

Récapitulons les pistes
  Creuser "RAPL" (une option dans le bios ?)
  Un conflit bluetooth/wifi ? Les lumières de xubu1957 nous seront utiles.
  Un conflit graphique déclaré.
  Un conflit lpc_ich /  gpio_ich (j'ignore encore ce que c'est).
  Une alim trop sollicitée ? D'ailleurs en #8, pour le démarrage réussi avec usb, on ne voit pas d'imprimante (mais il est vrai que ce dmesg commençait à 0.537300", et qu'il y en a, des lignes, dans la première demi-seconde).
  Blacklister le module ideapad_laptop ?
  Enfin, j'ai l'intuition qu'un contournement pourrait marcher : blacklister le module xhci ; si l'usb3 ne t'est pas indispensable, ça peut dépanner.

  Dans l'immédiat,
je t'engage à brancher ta souris ailleurs qu'en usb3 et à démarrer sans la clef usb bluetooth ni l'imprimante, ni l'écran secondaire, avec un minimum de périphériques. (Après démarrage réussi, tu branches ton 2ème écran).

Merci pour toutes ces précisions, n'étant pas informaticien, toutes ces infos étaient pour moi du chinois.

Je ne sais pas ce qu'est le RAPL

Les problèmes d'usb se produisent même quand j'utilise l'ord sans rien y brancher.
L'imprimante est en réseau, elle n'est donc pas branché en usb.

Ce que je peux faire avec le bluetooth c'est de le désinstaller je n'en n'ai pas l'utilité, ce qui j'espère réglerait au moins un problème.

Que la souris soit en usb 3 ou 2 ne doit pas changer grand chose, car même quand rien n'est branché, les prises usb ne fonctionnent pas non plus.

Quand je suis au bureau l'ordi démarre avec un clavier, une souris, l'internet, l'écran et l'alimentation de la machine, et parfois un dd externe, qui lui de toute façon n'est jamais reconnu au démarrage, je suis obligé de le débrancher et de le rebrancher pour qu'il fonctionne. Je pense que ce problème spécifique à un rapport avec le post 2.

Enfin, je ne sais pas blacklister, ni dans quel fichier intervenir.

Et là un nouveau souci vient de faire son apparition, le clavier numérique de la machine se met lui aussi aux abonnés absents, et même quand les usb fonctionnent, le pavé numérique du clavier externe ne fonctionne pas non plus. Cette panne est elle aussi aléatoire, ce qui fait que maintenant je dois vérifier que les prises usb et le pavé numérique fonctionnent en même temps. Ça devient de plus en plus compliqué. Là j'écris sans pavé numérique, il va donc falloir que je fasse un énième redémarrage !

Hors ligne

#28 Le 14/11/2018, à 08:57

xubu1957

Re : ports USB connexion difficile sur lenovo B50-70

Bonjour,

Pour RAPL, je viens de trouver > 01.org/blogs/2014/running-average-power-limit-%E2%80%93-rapl


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#29 Le 14/11/2018, à 09:05

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :

Même avec un noyau 4.4 de Xenial ou 4.15 de Bionic, tu auras probablement le même problème.


Par contre ton dmesg dit :

[    0.382565] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.383157] acpi PNP0A08:00: _OSC: OS now controls [PCIeHotplug PME AER PCIeCapability]

alors le lien trouvé par inbox m'invite à te suggérer fortement ceci :

Dans /etc/default/grub, tu remplaces

"quiet splash vt.handoff=7"

par

"quiet splash pci=nomsi vt.handoff=7"

ou par

"quiet splash pci=noaer vt.handoff=7"

Puis tu fais

sudo update-grub ; sudo update-initramfs -u -k all

et tu redémarres.

Alors j'aimerai bien mais dans le fichier /etc/default/grub il n'y a pas de trace de la ligne

"quiet splash vt.handoff=7"

la seul trace de quiet splash est

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

. Je n'ai pas trouvé d'autres occurrences.

Voici le fichier en question en copie ci-dessous :

 # If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Hors ligne

#30 Le 14/11/2018, à 09:24

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

xubu1957 a écrit :

@moko138

Je cherchais avec :

ID 0cf3:3004

pour le Bluetooth.

Je trouve une anomalie avec les ports USB > Souris Logitech détectée une fois sur 5

_ _ _

@xtrice

Ouvre une nouvelle discussion en section Accès internet et réseaux.

Il faudra fournir, en te servant du  Retour utilisable de commande, un wificheck rassemblant les informations > Configuration wifi.

Nota : un fichier wificheck.log est créé dans votre répertoire personnel, collez l'intégralité de son contenu dans votre discussion.

et :

dmesg | grep -i bluetooth; dmesg | grep -i firmware; lsmod | grep bluetooth
sudo service bluetooth status
dpkg -l | grep blue

Après recherche je n'ai pas de fichier wificheck.log, je n'ai trouvé qu'un wificheck qui en plus se trouve dans un drôle de répertoire celui des téléchargements.

Hors ligne

#31 Le 14/11/2018, à 09:43

moko138

Re : ports USB connexion difficile sur lenovo B50-70

Très intéressant, xubu1957 !  smile

  - -

xtrice a écrit :

Et là un nouveau souci vient de faire son apparition, le clavier numérique de la machine se met lui aussi aux abonnés absents, et même quand les usb fonctionnent, le pavé numérique du clavier externe ne fonctionne pas non plus. Cette panne est elle aussi aléatoire

/!\ Pannes multiples et aléatoires : forte suspicion de problème matériel.

Pour le pavé numérique :
débranche ton clavier externe et active la touche VerrNum
ça change quelque chose ?
  > Si oui, OK, tu peux rebrancher le clavier externe ;
  > Si non, Ctrl Maj VerrNum
Résultat ?

  - -

même quand rien n'est branché, les prises usb ne fonctionnent pas non plus.

Quand rien n'est branché, à quoi vois-tu que les prises usb ne fonctionnent pas ?

  - -

Quand je suis au bureau l'ordi démarre avec un clavier, une souris, l'internet, l'écran et l'alimentation de la machine, et parfois un dd externe

Eh bien, justement,
en #24, je t'ai invité à

Dans l'immédiat,
je t'engage à brancher ta souris ailleurs qu'en usb3 et à démarrer sans la clef usb bluetooth ni l'imprimante, ni l'écran secondaire, avec un minimum de périphériques. (Après démarrage réussi, tu branches ton 2ème écran).

Et j'ajoute : puisque c'est un portable, démarre provisoirement sans la souris.
Résultat ?

Et en #25, je t'ai fait une autre "forte suggestion", et avec alternative :
Résultats ?

Comme ce dépannage procède par essais et éliminations, si tu ne donnes pas les résultats, on ne peut guère avancer.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#32 Le 14/11/2018, à 09:52

moko138

Re : ports USB connexion difficile sur lenovo B50-70

Veuilles m'excuser : je viens seulement de découvrir ton #29.
Donc

1) Copie de sécurité, pour pouvoir faire facilement machine arrière :

sudo cp -av /etc/default/grub   /etc/default/grub2018-11-13

2) Modification
Remplace
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

ou par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

Puis tu fais

sudo update-grub ; sudo update-initramfs -u -k all

et tu redémarres.
Si la première variante ne réussit pas, tu appliques l'autre.  smile

Dernière modification par moko138 (Le 14/11/2018, à 09:56)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#33 Le 14/11/2018, à 14:04

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :

Très intéressant, xubu1957 !  smile

  - -

xtrice a écrit :

Et là un nouveau souci vient de faire son apparition, le clavier numérique de la machine se met lui aussi aux abonnés absents, et même quand les usb fonctionnent, le pavé numérique du clavier externe ne fonctionne pas non plus. Cette panne est elle aussi aléatoire

/!\ Pannes multiples et aléatoires : forte suspicion de problème matériel.

Pour le pavé numérique :
débranche ton clavier externe et active la touche VerrNum
ça change quelque chose ?
  > Si oui, OK, tu peux rebrancher le clavier externe ;
  > Si non, Ctrl Maj VerrNum
Résultat ?

Ça ne change rien. Mais j'ai fait une découverte grâce à mon patron à qui j'ai parlé de mes soucis informatiques. Il m'a dit que j'avais sûrement fait une fausse manip sans m'en rendre compte et qu'avec un raccourci clavier j'aurais basculé  interrupteur de  «Touches de la souris/ Contrôle du pointeur à l'aide du pavé numérique» sur actif. J'en doute fort, je n'aurais jamais commis cette erreur en 5 ans et après je l'aurais faite à plusieurs reprises. Admettons ! J'ai donc découvert dans «accès universel» cette commande. Pour le moment considérons que le problème du pavé numérique est réglé.

- -

même quand rien n'est branché, les prises usb ne fonctionnent pas non plus.

Quand rien n'est branché, à quoi vois-tu que les prises usb ne fonctionnent pas ?

Oui comment je le sais ? Tout simplement j'ai fais des essais de démarrages sans rien de branchés sur l'ordi et lorsque j'ai voulu brancher quelque chose sur les prises usb, rien ne fonctionnait (clé usb, clavier, souris, dd externe)

  - -

Quand je suis au bureau l'ordi démarre avec un clavier, une souris, l'internet, l'écran et l'alimentation de la machine, et parfois un dd externe

Eh bien, justement,
en #24, je t'ai invité à

Dans l'immédiat,
je t'engage à brancher ta souris ailleurs qu'en usb3 et à démarrer sans la clef usb bluetooth ni l'imprimante, ni l'écran secondaire, avec un minimum de périphériques. (Après démarrage réussi, tu branches ton 2ème écran).

Et j'ajoute : puisque c'est un portable, démarre provisoirement sans la souris.
Résultat ?

Il n'y a pas de clé bluetooth sur cette ordi donc je ne peux pas la débrancher, la seule chose que je puisse faire c'est désinstaller le bluetooth.

Je reprécise qu'avec ou sans rien de branché sur l'ordi, le résultat est toujours le même, les ports usb se connectent quand ils en ont envie, ça ne change rien. J'ai déjà dû procéder à 5 ou redémarrages d'affilés sans rien brancher, car je devait récupérer un fichier sur une clé usb.

Ma souris ne se trouve pas sur les usb 3, elle est sur le seul port usb2  de l'ordi

Et en #25, je t'ai fait une autre "forte suggestion", et avec alternative :
Résultats ?

Comme ce dépannage procède par essais et éliminations, si tu ne donnes pas les résultats, on ne peut guère avancer.

répondu dans le post 29

Hors ligne

#34 Le 14/11/2018, à 14:08

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :

Veuilles m'excuser : je viens seulement de découvrir ton #29.
Donc

1) Copie de sécurité, pour pouvoir faire facilement machine arrière :

sudo cp -av /etc/default/grub   /etc/default/grub2018-11-13

2) Modification
Remplace
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

ou par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

Puis tu fais

sudo update-grub ; sudo update-initramfs -u -k all

et tu redémarres.
Si la première variante ne réussit pas, tu appliques l'autre.  smile

Comme je ne suis pas informaticien, et que je ne maîtrise pas toutes les subtilités de la console et de la ligne commande, je m'occuperai de cette manip un peu plus tard à tête reposée, car si je plante la machine je serais bien avancé.

Mais merci pour toute cette aide et ces précisions

Dernière modification par xtrice (Le 19/11/2018, à 08:42)

Hors ligne

#35 Le 21/11/2018, à 13:42

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

Bonjour,

Je n'ai pas oublié mais je n'ai pas encore eu le temps de m'en occuper, je pense pouvoir le faire la semaine prochaine

Hors ligne

#36 Le 26/11/2018, à 14:14

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

Bonjour,

Je viens de faire les manips proposées par moko138, alors la première n'a pas fonctionné puisqu'au redémarrage je n'avais ni clavier, ni souris, je suis donc passé à la seconde. Ce n'est pas encore une preuve de réussite mais au redémarrage le clavier et la souris étaient au rendrez-vous, il ne reste plus qu'à voir si ça va tenir dans le temps. Je vous tiens au courant dans les prochains jours.

Quoi qu'il arrive, encore une fois te tiens à remercier tous ceux qui m'ont aidés.

Hors ligne

#37 Le 26/11/2018, à 14:52

moko138

Re : ports USB connexion difficile sur lenovo B50-70

xtrice a écrit :

Je viens de faire les manips proposées par moko138, alors la première n'a pas fonctionné puisqu'au redémarrage je n'avais ni clavier, ni souris, je suis donc passé à la seconde.

Qu'entends-tu par "la première"et "la seconde" ?
Est-ce la première = ...pci=nomsi
et la seconde = ...pci=noaer ?
l'une comme l'autre devant être suivie de

sudo update-grub ; sudo update-initramfs -u -k all

Ou bien parlais-tu d'autre chose ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#38 Le 26/11/2018, à 17:02

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :
xtrice a écrit :

Je viens de faire les manips proposées par moko138, alors la première n'a pas fonctionné puisqu'au redémarrage je n'avais ni clavier, ni souris, je suis donc passé à la seconde.

Qu'entends-tu par "la première"et "la seconde" ?
Est-ce la première = ...pci=nomsi
et la seconde = ...pci=noaer ?
l'une comme l'autre devant être suivie de

sudo update-grub ; sudo update-initramfs -u -k all

Ou bien parlais-tu d'autre chose ?

Oui j'ai suivi à la lettre tes préconisations et ça semble avoir fonctionné avec la deuxième solution, nous verrons ça avec le temps. Et j'ai bien fait à chaque fois un 

sudo update-grub ; sudo update-initramfs -u -k all

puis un redémarrage de la machine.

Hors ligne

#39 Le 28/11/2018, à 08:24

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

Bonjour,

Ma joie aura été de courte durée, ce matin, mise en route de l'ordi, et crak pas d'usb. Il ne m'aura suffit que d'un seul redémarrage pour les retrouver. Donc je crois que je vais envisager le changement de version d'ubuntu. De toute façon il est à faire puisque ma version ne sera plus soutenue en avril prochain alors autant faire les changements rapidement. Espère que cela résoudra les problèmes.

Encore une fois merci pour votre aide.

Hors ligne

#40 Le 28/11/2018, à 09:34

moko138

Re : ports USB connexion difficile sur lenovo B50-70

C'est peut-être une mise à jour de grub qui a supprimé notre modification ; pour voir si c'est le cas ou non, montre simplement :

cat /etc/default/grub | grep X_D

%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#41 Le 29/11/2018, à 16:00

xtrice

Re : ports USB connexion difficile sur lenovo B50-70

moko138 a écrit :

C'est peut-être une mise à jour de grub qui a supprimé notre modification ; pour voir si c'est le cas ou non, montre simplement :

cat /etc/default/grub | grep X_D

Voici la réponse

 cat /etc/default/grub | grep X_D
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

Hors ligne

#42 Le 29/11/2018, à 22:21

moko138

Re : ports USB connexion difficile sur lenovo B50-70

Donc le réglage n'a pas été écrasé. Tu peux refaire

sudo update-grub ; sudo update-initramfs -u -k all

sans risque mais sans garantie de résultat non plus sad

J'appelle du renfort.
Retire le "Résolu".


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#43 Le 30/11/2018, à 19:47

NicoApi73

Re : ports USB connexion difficile sur lenovo B50-70

Bonjour à Tous,

Je vois bien un lien potentiel avec nomsi, pas avec noaer (Ce n'est pas parce que je ne vois pas de lien qu'il n'y en as pas smile ).

Les messages suivants m'ont interpelé :

[    1.022534] pcieport 0000:00:1c.0: device [8086:9c10] has invalid IRQ; check vendor BIOS
[    1.022683] pcieport 0000:00:1c.0: irq 56 for MSI/MSI-X
[    1.022741] pcieport 0000:00:1c.1: device [8086:9c12] has invalid IRQ; check vendor BIOS
[    1.022855] pcieport 0000:00:1c.1: irq 57 for MSI/MSI-X
[    1.022917] pcieport 0000:00:1c.2: device [8086:9c14] has invalid IRQ; check vendor BIOS
[    1.023025] pcieport 0000:00:1c.2: irq 58 for MSI/MSI-X
[    1.023078] pcieport 0000:00:1c.3: device [8086:9c16] has invalid IRQ; check vendor BIOS
[    1.023185] pcieport 0000:00:1c.3: irq 59 for MSI/MSI-X
[    1.023264] pcieport 0000:00:1c.0: Signaling PME through PCIe PME interrupt
[    1.023269] pcie_pme 0000:00:1c.0:pcie01: service driver pcie_pme loaded
[    1.023290] pcieport 0000:00:1c.1: Signaling PME through PCIe PME interrupt
[    1.023293] pci 0000:02:00.0: Signaling PME through PCIe PME interrupt
[    1.023298] pcie_pme 0000:00:1c.1:pcie01: service driver pcie_pme loaded
[    1.023316] pcieport 0000:00:1c.2: Signaling PME through PCIe PME interrupt
[    1.023318] pci 0000:08:00.0: Signaling PME through PCIe PME interrupt
[    1.023323] pcie_pme 0000:00:1c.2:pcie01: service driver pcie_pme loaded
[    1.023340] pcieport 0000:00:1c.3: Signaling PME through PCIe PME interrupt
[    1.023342] pci 0000:09:00.0: Signaling PME through PCIe PME interrupt
[    1.023347] pcie_pme 0000:00:1c.3:pcie01: service driver pcie_pme loaded
[    1.023360] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    1.023394] pciehp 0000:00:1c.1:pcie04: HPC vendor_id 8086 device_id 9c12 ss_vid 17aa ss_did 3978
[    1.023423] pciehp 0000:00:1c.1:pcie04: service driver pciehp loaded
[    1.023428] pciehp: PCI Express Hot Plug Controller Driver version: 0.4

Il semble y avoir un conflit ou du moins un problème d'attribution sur les interruptions sur les ports pci. Par contre, pour l'instant je ne vois pas de lien avec l'usb (les ports pci concernés semblent sans rapport avec l'usb)

Pour essayer de voir un peu mieux les erreurs, pourrais tu donner le retour de

dmesg -lerr -lcrit

et ceci pour les 2 cas de figure : USB ok et USB ko

Peux tu donner aussi le retour de

sudo lshw -numeric

STP

Hors ligne

#44 Le 30/11/2018, à 20:10

NicoApi73

Re : ports USB connexion difficile sur lenovo B50-70

@moko :
sais tu à quoi correspond ceci :

[   21.390097] WARNING: CPU: 1 PID: 41 at /build/linux-bVXkJZ/linux-3.13.0/drivers/usb/host/xhci-ring.c:1590 handle_cmd_completion+0xe56/0xe60()
[   21.390099] Modules linked in: bnep rfcomm nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_hdmi uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel cryptd joydev serio_raw arc4 snd_hda_intel snd_hda_codec snd_hwdep ath9k ath9k_common snd_pcm ath9k_hw ath mac80211 snd_page_alloc snd_seq_midi snd_seq_midi_event cfg80211 lpc_ich snd_rawmidi rtsx_pci_ms memstick snd_seq snd_seq_device snd_timer ath3k btusb i915 snd drm_kms_helper bluetooth drm mei_me mei shpchp i2c_algo_bit soundcore parport_pc ppdev ideapad_laptop sparse_keymap lp parport video mac_hid hid_generic usbhid hid rtsx_pci_sdmmc psmouse ahci libahci r8169 rtsx_pci mii
[   21.390157] CPU: 1 PID: 41 Comm: khubd Not tainted 3.13.0-161-generic #211-Ubuntu
[   21.390159] Hardware name: LENOVO 80EU/Lenovo B50-70, BIOS 9DCN20WW(V2.01) 06/09/2014
[   21.390161]  0000000000000000 ffff88015f243d90 ffffffff8173be78 0000000000000000
[   21.390165]  0000000000000009 ffff88015f243dc8 ffffffff8106da6d ffff880154e85650
[   21.390168]  ffff880154e83140 0000000000000005 0000000154e83140 ffff880158f86000
[   21.390172] Call Trace:
[   21.390174]  <IRQ>  [<ffffffff8173be78>] dump_stack+0x64/0x80
[   21.390185]  [<ffffffff8106da6d>] warn_slowpath_common+0x7d/0xa0
[   21.390189]  [<ffffffff8106db4a>] warn_slowpath_null+0x1a/0x20
[   21.390193]  [<ffffffff81592586>] handle_cmd_completion+0xe56/0xe60
[   21.390196]  [<ffffffff81593eab>] xhci_irq+0x33b/0xa50
[   21.390202]  [<ffffffff810cfdb0>] ? __note_gp_changes+0x20/0x60
[   21.390206]  [<ffffffff815945d1>] xhci_msi_irq+0x11/0x20
[   21.390210]  [<ffffffff810c7704>] handle_irq_event_percpu+0x54/0x220
[   21.390214]  [<ffffffff810c790d>] handle_irq_event+0x3d/0x60
[   21.390219]  [<ffffffff810ca423>] handle_edge_irq+0x83/0x150
[   21.390222]  [<ffffffff81016ed4>] handle_irq+0x24/0x30
[   21.390228]  [<ffffffff8175154d>] do_IRQ+0x4d/0xc0
[   21.390233]  [<ffffffff81744611>] common_interrupt+0x191/0x191
[   21.390234]  <EOI>  [<ffffffff814a680e>] ? dev_printk_emit+0x3e/0x40
[   21.390242]  [<ffffffff8158f716>] ? xhci_cancel_cmd+0x86/0x2b0
[   21.390246]  [<ffffffff81743e0b>] ? _raw_spin_unlock_irqrestore+0x1b/0x40
[   21.390250]  [<ffffffff8158f6e9>] xhci_cancel_cmd+0x59/0x2b0
[   21.390253]  [<ffffffff81589074>] xhci_address_device+0x434/0x690
[   21.390259]  [<ffffffff8155308f>] hub_port_init+0x1ff/0xb50
[   21.390264]  [<ffffffff814b7d69>] ? update_autosuspend+0x39/0x60
[   21.390267]  [<ffffffff814b7dd5>] ? pm_runtime_set_autosuspend_delay+0x45/0x90
[   21.390271]  [<ffffffff8155482d>] hub_port_connect_change+0x17d/0xb40
[   21.390276]  [<ffffffff8155bc64>] ? usb_control_msg+0xd4/0x110
[   21.390280]  [<ffffffff815556c4>] hub_events+0x4d4/0xa20
[   21.390284]  [<ffffffff81555c45>] hub_thread+0x35/0x150
[   21.390289]  [<ffffffff810b2920>] ? prepare_to_wait_event+0x100/0x100
[   21.390292]  [<ffffffff81555c10>] ? hub_events+0xa20/0xa20
[   21.390298]  [<ffffffff810928fb>] kthread+0xcb/0xf0
[   21.390301]  [<ffffffff8173fe7e>] ? __schedule+0x30e/0x780
[   21.390305]  [<ffffffff81092830>] ? kthread_create_on_node+0x1c0/0x1c0
[   21.390309]  [<ffffffff8174cf4e>] ret_from_fork+0x6e/0xa0
[   21.390313]  [<ffffffff81092830>] ? kthread_create_on_node+0x1c0/0x1c0
[   21.390315] ---[ end trace 6a94c5c98f9f9e20 ]---

Ca apparaît dans le dmesg pour lequel l'USB est planté, ça n'apparaît pas que l'USB fonctionne.

Hors ligne

#45 Le 30/11/2018, à 20:28

moko138

Re : ports USB connexion difficile sur lenovo B50-70

Ceci

[   21.390097] WARNING: CPU: 1 PID: 41 at /build/linux-bVXkJZ/linux-3.13.0/drivers/usb/host/xhci-ring (...)
[   21.390196]  [<ffffffff81593eab>] xhci_irq+0x33b/0xa50
[   21.390206]  [<ffffffff815945d1>] xhci_msi_irq+0x11/0x20
[   21.390242]  [<ffffffff8158f716>] ? xhci_cancel_cmd+0x86/0x2b0
[   21.390246]  [<ffffffff81743e0b>] ? _raw_spin_unlock_irqrestore+0x1b/0x40

indique un plantage sévère du module en charge de l'usb3 (en lien, tu as raison, avec l'attribution d'IRQ), raison pour laquelle j'avais proposé comme contournement provisoire de blacklister ce module (cf. le "Récapitulons les pistes" du #24).


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#46 Le 30/11/2018, à 20:40

NicoApi73

Re : ports USB connexion difficile sur lenovo B50-70

Effectivement, je ne l'avais pas vu (la fin de ton post #24)

https://forums.linuxmint.com/viewtopic.php?t=185071

Well, I can now say that for me, the problem has disappeared since the upgrade to the 3.16-series kernel. I have had more than 30 boot-ups since then, and no more unresponsive mouse or keyboard on USB port.

Ca ne concerne pas Ubuntu... Néanmoins, il y a peut être quelque chose à prendre dedans.

Dernière modification par NicoApi73 (Le 30/11/2018, à 20:41)

Hors ligne

#47 Le 30/11/2018, à 21:35

moko138

Re : ports USB connexion difficile sur lenovo B50-70

Si c'est le cas, inbox avait bien vu ! Et j'ai eu tort de le contredire !

inbox a écrit :

Le message suivant m'a permis de trouver un bug déclaré sur Launchpad :

xhci_hcd 0000:00:14.0: Timeout while waiting for address device command
La personne ayant déclaré le problème indique : a écrit :

Chris Halse Rogers (raof) wrote on 2015-10-09:     #15

FWIW I can't recall getting this error on the 4.2 kernels currently in Wily. This might be fixed in 15.10.

Il écrit donc que le problème ne se produit à partir du noyau 4.2.

Je pense donc qu'il serait utile d'installer un version d'Ubuntu, plus récente, comme la 16.04.

À tester en live, comme toujours avant d'installer


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#48 Le 30/11/2018, à 21:36

NicoApi73

Re : ports USB connexion difficile sur lenovo B50-70

Comme tu dis, à tester en live avant toute chose

Hors ligne

#49 Le 30/11/2018, à 23:41

Naziel

Re : ports USB connexion difficile sur lenovo B50-70

Tu peux aussi tenter de mettre en veille le pc, puis après la sortie de veille voir si le les ports fonctionnent


[ poster correctement un retour de commande ] [ poster correctement une photo ]
Nouvel adhérent FDN
thinkpad x220, Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Pour reprendre le contrôle des semences: https://kokopelli-semences.fr/fr/

Hors ligne

#50 Le 01/12/2018, à 11:18

moko138

Re : ports USB connexion difficile sur lenovo B50-70

1) Comme je suis très intrigué par "cache line size of 64 is not supported" dans

[    1.127776] xhci_hcd 0000:00:14.0: cache line size of 64 is not supported

merci de montrer :

lspci -nnk | grep -iEA4 "00:14|usb"
dmesg | grep " 255 "  # à copier-coller telle quelle, espaces comprises.
cat /etc/modules

et

lsusb ; echo ; lsusb -t

  - -

"cache line size of 64 is not supported" est déjà signalé comme bug avec plusieurs noyaux, (3.2, 3.5, 3.8, 4.6.3) en https://bugs.launchpad.net/ubuntu/+sour … ug/1072918. Dans ce fil,
  eric pfaffhauser signalait le 2013-01-29:

pci=noacpi -> breaks other hardware, but enables USB3 ports

pci=noacpi

perd un autre périphérique, mais active les ports usb3

  Marco Scacchi signalait le 2013-03-10:

acpi=noirq      solve this issue on hp 8570p without breaking other hardware

acpi=noirq

résout la question sur le HP 8570P, sans perdre d'autre périphérique

  Plus récemment (janvier 2018), https://github.com/coreos/bugs/issues/1019 recommande :

The device correctly works if you pass iommu=soft to kernel
En passant

iommu=soft

au noyau, le périphérique fonctionne.



2) Probable contournement rapide et provisoire :
(Ceci est facilement réversible.)
Montre

echo -e "#\n# Blacklister le module xhci_hcd de l'usb3\n# ajout manuel en date du 2018-12-01\nblacklist xhci_hcd\n#" | sudo tee /etc/modprobe.d/blacklist-xhci.conf

puis redémarre et raconte.

Dernière modification par moko138 (Le 01/12/2018, à 12:29)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne