Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous souhaite d'excellentes fêtes de fin d'année !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/11/2018, à 19:58

stephane13

Imprimante Canon IP1800 qui ne fonctionne plus

Bonjour,

J'ai eu un temps un problème pour installer le pilote de mon imprimante, ça a été résolu, mais là rebelotte.

J'ai voulu faire une réinstallation mais il n'est pas dans la base alors que je le voit installé quand je consulte le synaptic.

J'ai lu cette méthode mais j'ai le message suivant:

stephane@pcbureau:~$ sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
rmdir: impossible de supprimer '/usr/share/ghostscript/9.25/iccprofiles': N'est pas un dossier
stephane@pcbureau:~$ 

J'ai regardé, le dossier est bien présent.

Merci.

Hors ligne

#2 Le 11/11/2018, à 20:05

xubu1957

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Bonjour,

Ces commandes sont à utiliser dans le cas d'une migration entre la version 16.04 vers la version 18.04.

_ _ _


Source :

Le 26/10/2018, L'Africain a écrit :

Je pense que j'ai trouvé la solution!!!
Il semble que ceci fonctionne, alors fait:

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
sudo apt-get install --reinstall libgs9-common

> [Résolu] Problème d'impression après mise à niveau 18.04

Dernière modification par xubu1957 (Le 11/11/2018, à 20:08)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 11/11/2018, à 20:11

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

xubu1957 a écrit :

Bonjour,

Ces commandes sont à utiliser dans le cas d'une migration entre la version 16.04 vers la version 18.04.

_ _ _


Source :

Le 26/10/2018, L'Africain a écrit :

Je pense que j'ai trouvé la solution!!!
Il semble que ceci fonctionne, alors fait:

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
sudo apt-get install --reinstall libgs9-common

> [Résolu] Problème d'impression après mise à niveau 18.04


OK, j'ai lu trop vite.

Hors ligne

#4 Le 11/11/2018, à 20:19

xubu1957

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Tu as essayé le final de ta précédente solution, si le PPA est toujours installé ?

Le 03/11/2018, stephane13 a écrit :

C'est bon, ça marche, formidable! Merci L'Africain.

Je me suis embrouillé tout seul. Il suffit:

- d'ajouter le ppa

sudo add-apt-repository ppa:thierry-f/fork-michael-gruz
sudo apt-get update

- installer le gestionnaire de paquets Synaptic

- le lancer, taper 1800 dans la recherche, sélectionner le pilote et installer.

- ouvrir le centre de contrôle, cliquer sur l'imprimante et lancer la recherche

- imprimer la page test pour le principe

Dernière modification par xubu1957 (Le 11/11/2018, à 20:23)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 11/11/2018, à 20:38

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Oui. L'imprimante est bien reconnue, mais rien ne se passe lorsque je lance une impression.

Il y a moyen de lancer une impression par la console? On aurait peut-être un message.

Hors ligne

#6 Le 12/11/2018, à 10:54

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Vérifie qu'elle est bien activée clic droit sur l'imprimante → Activer


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#7 Le 12/11/2018, à 11:40

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Elle l'est, merci.

Hors ligne

#8 Le 12/11/2018, à 14:16

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Désinstalle et réinstalle, et vérifie que le c'est le bon pilote qui est choisi.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#9 Le 02/12/2018, à 17:55

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Bonjour,

J'ai désinstallé et réinstallé sans succès. Ce qui est bizarre c'est que lorsque je veux sélectionner le pilote dans la base de donnée, et bien il n'y est pas. La dernière fois que j'avais installé, lancer la recherche avait suffit pour détecter l'imprimante.

J'ai essayé avec le pilote de la doc, ça me répond un problème de dépendance. Le plus drôle c'est que j'ai regardé via le synaptique, elles y sont.

stephane@pcbureau:~/Téléchargements/Canon-Pixma-iP1900-iP1800$ sudo dpkg -i cnijfilter-ip1900series_3.00-1_i386.deb
(Lecture de la base de données... 218883 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de cnijfilter-ip1900series_3.00-1_i386.deb ...
Dépaquetage de cnijfilter-ip1900series:i386 (3.00-1) sur (3.00-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de cnijfilter-ip1900series:i386 :
 cnijfilter-ip1900series:i386 dépend de libatk1.0-0 (>= 1.9.0).
 cnijfilter-ip1900series:i386 dépend de libcairo2 (>= 1.0.2-2).
 cnijfilter-ip1900series:i386 dépend de libfontconfig1 (>= 2.3.0).
 cnijfilter-ip1900series:i386 dépend de libglib2.0-0 (>= 2.10.0) ; cependant :
  Le paquet libglib2.0-0:i386 n'est pas installé.
 cnijfilter-ip1900series:i386 dépend de libgtk2.0-0 (>= 2.8.0) ; cependant :
  Le paquet libgtk2.0-0:i386 n'est pas installé.
 cnijfilter-ip1900series:i386 dépend de libpango1.0-0 (>= 1.12.3) ; cependant :
 cnijfilter-ip1900series:i386 dépend de libpng12-0 (>= 1.2.8rel) ; cependant :
 cnijfilter-ip1900series:i386 dépend de libtiff4 ; cependant :
 cnijfilter-ip1900series:i386 dépend de libx11-6 ; cependant :
 cnijfilter-ip1900series:i386 dépend de libxcursor1 (>> 1.1.2) ; cependant :
 cnijfilter-ip1900series:i386 dépend de libxext6 ; cependant :
  Le paquet libxext6:i386 n'est pas installé.
 cnijfilter-ip1900series:i386 dépend de libxfixes3 ; cependant :
 cnijfilter-ip1900series:i386 dépend de libxi6 ; cependant :
 cnijfilter-ip1900series:i386 dépend de libxinerama1 ; cependant :
  Le paquet libxinerama1:i386 n'est pas installé.
 cnijfilter-ip1900series:i386 dépend de libxrandr2 ; cependant :
 cnijfilter-ip1900series:i386 dépend de libxrender1 ; cependant :
 cnijfilter-ip1900series:i386 dépend de cnijfilter-common (>= 3.00) ; cependant :

dpkg: erreur de traitement du paquet cnijfilter-ip1900series:i386 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 cnijfilter-ip1900series:i386

Hors ligne

#10 Le 02/12/2018, à 18:17

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

As-tu remis à jour la liste des paquets:

sudo apt update

Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#11 Le 02/12/2018, à 18:23

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Oui.

Hors ligne

#12 Le 02/12/2018, à 20:38

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Ce que je comprends pas, c'est malgré avoir installé le ppa d'Ordissimo, je ne l'ai pas dans la base de données.

Hors ligne

#13 Le 02/12/2018, à 20:41

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Il y a une erreur avec le ppa, le paquet n'est pas installé. Je pense qu'il faudrait purger toutes les dépendances et recommencer...


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#14 Le 02/12/2018, à 20:58

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Il est installé

stephane@pcbureau:~$ sudo apt-get update
[sudo] Mot de passe de stephane : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
Réception de:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Atteint:3 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu bionic InRelease
Atteint:4 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease         
Atteint:5 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease       
Atteint:6 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease    
83,2 ko réceptionnés en 1s (88,0 ko/s)                                         
Lecture des listes de paquets... Fait

J'ai déjà purgé, essayé comme ceci, comme cela...

Hors ligne

#15 Le 03/12/2018, à 09:17

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Pourquoi tu as le dépôt backports et webup8team activé? Ça peut sérieusement poser problème pour les dépendances.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#16 Le 03/12/2018, à 10:15

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Le backports devait être d'origine, le webup8team c'est pour la version java d'Oracle.

Hors ligne

#17 Le 03/12/2018, à 10:20

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Le backports n'est pas d'origine tu peux le décocher, webup8team aussi. Ordissimo travail sur le paquet, dès que c'est prêt je t'informe.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#18 Le 05/12/2018, à 09:47

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Je viens de faire un update et upgrade, mon imprimante n'apparaît toujours pas dans la liste.

Hors ligne

#19 Le 05/12/2018, à 10:46

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Oui mais il faut aussi que tu réinstalles le pilote car il était désinstallé.
Fait d'abord un apt purge, et autoremove puis réinstalle tout ça.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#20 Le 08/12/2018, à 19:16

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Toujours rien.

1544292427.png


Je ne comprends pas: il est présent dans le paquet synaptique, mais il ne l'est pas dans la liste. Lorsque je l'installe les pilotes, les 2 fichiers, par le synaptique, et que je lance la recherche d'imprimante, il trouve rien.

Hors ligne

#21 Le 10/12/2018, à 12:09

L'Africain

Re : Imprimante Canon IP1800 qui ne fonctionne plus

tu peux nous donner la version de ton paquet installer stp (complète).


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#22 Le 10/12/2018, à 21:33

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

cnijfilter-ip1800series:i386 4.10-18.04+3ubuntu3

Hors ligne

#23 Le 12/12/2018, à 17:27

Ordissimo1

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Bonjour Stephane13,

peux tu taper cette commande et me donner le résultat :

dpkg -L cnijfilter-ip1800series

Hors ligne

#24 Le 12/12/2018, à 18:01

Ordissimo1

Re : Imprimante Canon IP1800 qui ne fonctionne plus

Synaptic est ton gestionnaire de paquet ça te donne la liste des paquets disponibles en fonction des dépôts présents.
Systeme-config-printer te liste les ppds qui sont disponibles sur ton système.
De ce que j'ai vu dans les échanges  plus haut si ton installation ne se termine pas bien, les postinst du paquet debian ne sont pas exécuter et donc çà ne peux pas fonctionner.

Dernière modification par Ordissimo1 (Le 13/12/2018, à 07:22)

Hors ligne

#25 Le 12/12/2018, à 22:00

stephane13

Re : Imprimante Canon IP1800 qui ne fonctionne plus

stephane@pcbureau:~$ dpkg -L cnijfilter-ip1800series
Le paquet « cnijfilter-ip1800series:i386 » ne contient aucun fichier (!)

Merci.

Hors ligne