Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/12/2018, à 20:56

davidtreviz

[Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Bonjour et merci d'avance à toute la communauté ubuntu pour tous ces posts.
Ceci est mon premier post sur ce forum. Je suis un béotien... Aussi j'espère que je poste au bon endroit. Si tel n'était pas le cas, je vous prierais de m'en excuser...

Comme le titre l'indique, j'ai un problème avec Scribus.

Pour infos concernant mon matériel et mes logiciels :
- Je suis sous Xubuntu 18.04 LTS à jour.
- J'ai un Asus Corei3 en x86_64 avec un SSD 256 Go.

J'avais installé Scribus 1.4.6 avec la logithèque et je l'avais lancé une première fois sans problème, il y a quelques semaines.

Depuis hier, lorsque j'essaie de le lancer, rien ne se passe.
Il ne démarre plus du tout.

J'ai tenté de le désinstaller, de le réinstaller, de l'installer complètement avec le terminal puis de le réinstaller en téléchargeant les paquets sur le site de Scribus, etc...
Rien n'y fait. ça ne se lance pas.
A noter : sur un Acer avec Pentium et DD physique 1Go, j'ai également le même Xubuntu et Scribus démarre correctement...

Je cherche partout sur le net mais rien qui puisse répondre à mon problème. Je cale totalement. Quelqu'un pourrait-il m'aider ? Merci d'avance !

Dernière modification par davidtreviz (Le 23/12/2018, à 07:13)

Hors ligne

#2 Le 12/12/2018, à 21:12

xubu1957

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Bonjour,

En lançant en commande :

scribus

ressort-il un message d'erreur ?

A restituer en te servant du Retour utilisable de commande.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 12/12/2018, à 21:22

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Bonjour,
En effet, ça me donne le message d'erreur suivant :

scribus: symbol lookup error: scribus: undefined symbol: _ZN12QApplication10commitDataER15QSessionManager

Hors ligne

#4 Le 12/12/2018, à 21:38

xubu1957

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Montre les retours :

sudo apt update
sudo apt full-upgrade

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 12/12/2018, à 21:59

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Alors, j'ai exécuté les commandes recommandées ci-dessus.

Scribus ne se lance toujours pas.

Voici la copie de tout le processus :

david@david-ASUSLINUX:~$ sudo apt update
[sudo] Mot de passe de david : 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
Réception de:2 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]                                        
Atteint:3 http://archive.canonical.com/ubuntu bionic InRelease                                                               
Réception de:4 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]         
Réception de:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]              
Réception de:6 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Réception de:7 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14,5 kB]
Réception de:8 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [9084 B]
Réception de:9 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [36,7 kB]
307 ko réceptionnés en 1s (279 ko/s)                                  
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
10 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
david@david-ASUSLINUX:~$ apt list --upgradable
En train de lister... Fait
gnome-software/bionic-updates 3.28.1-0ubuntu4.18.04.8 amd64 [pouvant être mis à jour depuis : 3.28.1-0ubuntu4.18.04.4]
gnome-software-common/bionic-updates,bionic-updates 3.28.1-0ubuntu4.18.04.8 all [pouvant être mis à jour depuis : 3.28.1-0ubuntu4.18.04.4]
gnome-software-plugin-snap/bionic-updates 3.28.1-0ubuntu4.18.04.8 amd64 [pouvant être mis à jour depuis : 3.28.1-0ubuntu4.18.04.4]
python3-software-properties/bionic-updates,bionic-updates 0.96.24.32.6 all [pouvant être mis à jour depuis : 0.96.24.32.5]
python3-update-manager/bionic-updates,bionic-updates 1:18.04.11.8 all [pouvant être mis à jour depuis : 1:18.04.11.7]
software-properties-common/bionic-updates,bionic-updates 0.96.24.32.6 all [pouvant être mis à jour depuis : 0.96.24.32.5]
software-properties-gtk/bionic-updates,bionic-updates 0.96.24.32.6 all [pouvant être mis à jour depuis : 0.96.24.32.5]
unattended-upgrades/bionic-updates,bionic-updates 1.1ubuntu1.18.04.7 all [pouvant être mis à jour depuis : 1.1ubuntu1.18.04.5]
update-manager/bionic-updates,bionic-updates 1:18.04.11.8 all [pouvant être mis à jour depuis : 1:18.04.11.7]
update-manager-core/bionic-updates,bionic-updates 1:18.04.11.8 all [pouvant être mis à jour depuis : 1:18.04.11.7]
david@david-ASUSLINUX:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  gnome-software gnome-software-common gnome-software-plugin-snap python3-software-properties python3-update-manager
  software-properties-common software-properties-gtk unattended-upgrades update-manager update-manager-core
10 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 3721 ko dans les archives.
Après cette opération, 20,5 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-update-manager all 1:18.04.11.8 [35,1 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 update-manager-core all 1:18.04.11.8 [8500 B]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 update-manager all 1:18.04.11.8 [551 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-plugin-snap amd64 3.28.1-0ubuntu4.18.04.8 [28,3 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software amd64 3.28.1-0ubuntu4.18.04.8 [490 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-common all 3.28.1-0ubuntu4.18.04.8 [2482 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 software-properties-common all 0.96.24.32.6 [9916 B]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 software-properties-gtk all 0.96.24.32.6 [53,6 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-software-properties all 0.96.24.32.6 [22,1 kB]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 unattended-upgrades all 1.1ubuntu1.18.04.7 [40,2 kB]
3721 ko réceptionnés en 1s (3493 ko/s)          
Préconfiguration des paquets...
(Lecture de la base de données... 233603 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-python3-update-manager_1%3a18.04.11.8_all.deb ...
Dépaquetage de python3-update-manager (1:18.04.11.8) sur (1:18.04.11.7) ...
Préparation du dépaquetage de .../1-update-manager-core_1%3a18.04.11.8_all.deb ...
Dépaquetage de update-manager-core (1:18.04.11.8) sur (1:18.04.11.7) ...
Préparation du dépaquetage de .../2-update-manager_1%3a18.04.11.8_all.deb ...
Dépaquetage de update-manager (1:18.04.11.8) sur (1:18.04.11.7) ...
Préparation du dépaquetage de .../3-gnome-software-plugin-snap_3.28.1-0ubuntu4.18.04.8_amd64.deb ...
Dépaquetage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.8) sur (3.28.1-0ubuntu4.18.04.4) ...
Préparation du dépaquetage de .../4-gnome-software_3.28.1-0ubuntu4.18.04.8_amd64.deb ...
Dépaquetage de gnome-software (3.28.1-0ubuntu4.18.04.8) sur (3.28.1-0ubuntu4.18.04.4) ...
Préparation du dépaquetage de .../5-gnome-software-common_3.28.1-0ubuntu4.18.04.8_all.deb ...
Dépaquetage de gnome-software-common (3.28.1-0ubuntu4.18.04.8) sur (3.28.1-0ubuntu4.18.04.4) ...
Préparation du dépaquetage de .../6-software-properties-common_0.96.24.32.6_all.deb ...
Dépaquetage de software-properties-common (0.96.24.32.6) sur (0.96.24.32.5) ...
Préparation du dépaquetage de .../7-software-properties-gtk_0.96.24.32.6_all.deb ...
Dépaquetage de software-properties-gtk (0.96.24.32.6) sur (0.96.24.32.5) ...
Préparation du dépaquetage de .../8-python3-software-properties_0.96.24.32.6_all.deb ...
Dépaquetage de python3-software-properties (0.96.24.32.6) sur (0.96.24.32.5) ...
Préparation du dépaquetage de .../9-unattended-upgrades_1.1ubuntu1.18.04.7_all.deb ...
Dépaquetage de unattended-upgrades (1.1ubuntu1.18.04.7) sur (1.1ubuntu1.18.04.5) ...
Paramétrage de gnome-software-common (3.28.1-0ubuntu4.18.04.8) ...
Traitement des actions différées (« triggers ») pour gconf2 (3.2.6-4ubuntu1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Paramétrage de python3-update-manager (1:18.04.11.8) ...
Traitement des actions différées (« triggers ») pour systemd (237-3ubuntu10.9) ...
Paramétrage de unattended-upgrades (1.1ubuntu1.18.04.7) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.9-2) ...
Paramétrage de python3-software-properties (0.96.24.32.6) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour dbus (1.12.2-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Paramétrage de software-properties-common (0.96.24.32.6) ...
Paramétrage de update-manager-core (1:18.04.11.8) ...
Paramétrage de software-properties-gtk (0.96.24.32.6) ...
Paramétrage de gnome-software (3.28.1-0ubuntu4.18.04.8) ...
Paramétrage de update-manager (1:18.04.11.8) ...
Paramétrage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.8) ...
david@david-ASUSLINUX:~$ 

Dernière modification par davidtreviz (Le 12/12/2018, à 22:00)

Hors ligne

#6 Le 12/12/2018, à 23:40

xubu1957

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Tente :

sudo apt-get install --reinstall scribus

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 13/12/2018, à 00:37

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Merci pour toutes ces pistes mais malheureusement, toujours rien. Scribus ne se lance toujours pas.

Hors ligne

#8 Le 15/12/2018, à 15:40

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Bonjour,

peut-être une ou plusieurs librairies non trouvées. Peux tu, stp, poster le retour de

ldd /usr/bin/scribus

Hors ligne

#9 Le 16/12/2018, à 08:09

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Bonjour Chobbes,
Voici le résultat :

david@david-ASUSLINUX:~$ ldd /usr/bin/scribus
	linux-vdso.so.1 (0x00007ffe3f5aa000)
	libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007fc1e14e6000)
	libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0x00007fc1e077b000)
	libQtXml.so.4 => /usr/lib/x86_64-linux-gnu/libQtXml.so.4 (0x00007fc1e0535000)
	libQtNetwork.so.4 => /usr/local/lib/libQtNetwork.so.4 (0x00007fc1e0220000)
	libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0x00007fc1dfd3f000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fc1dfa8b000)
	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fc1df846000)
	libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007fc1df5cf000)
	libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007fc1df367000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fc1df14a000)
	libcups.so.2 => /usr/lib/x86_64-linux-gnu/libcups.so.2 (0x00007fc1deebe000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fc1decba000)
	liblcms2.so.2 => /usr/lib/x86_64-linux-gnu/liblcms2.so.2 (0x00007fc1dea62000)
	libpodofo.so.0.9.5 => /usr/lib/libpodofo.so.0.9.5 (0x00007fc1de6bf000)
	libhyphen.so.0 => /usr/lib/x86_64-linux-gnu/libhyphen.so.0 (0x00007fc1de4b9000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fc1de130000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc1ddd92000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fc1ddb7a000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc1dd789000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fc1dd56a000)
	libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007fc1dd2c5000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007fc1dd093000)
	libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007fc1dce90000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fc1dcc68000)
	libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007fc1dca5b000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fc1dc851000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fc1dc519000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fc1dc307000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fc1dc0ff000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc1e2666000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fc1dbecd000)
	liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007fc1dbca7000)
	libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007fc1dba99000)
	libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007fc1db84e000)
	libgnutls.so.30 => /usr/lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007fc1db4e9000)
	libavahi-common.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-common.so.3 (0x00007fc1db2dd000)
	libavahi-client.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-client.so.3 (0x00007fc1db0cc000)
	libidn.so.11 => /lib/x86_64-linux-gnu/libidn.so.11 (0x00007fc1dae99000)
	libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007fc1daa21000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fc1da81d000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fc1da617000)
	libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007fc1da341000)
	libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007fc1da10f000)
	libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007fc1d9f0b000)
	libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007fc1d9d00000)
	libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007fc1d99d1000)
	libidn2.so.0 => /usr/lib/x86_64-linux-gnu/libidn2.so.0 (0x00007fc1d97b4000)
	libunistring.so.2 => /usr/lib/x86_64-linux-gnu/libunistring.so.2 (0x00007fc1d9436000)
	libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007fc1d9223000)
	libnettle.so.6 => /usr/lib/x86_64-linux-gnu/libnettle.so.6 (0x00007fc1d8fed000)
	libhogweed.so.4 => /usr/lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007fc1d8db9000)
	libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007fc1d8b38000)
	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fc1d88eb000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fc1d86d6000)
	libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007fc1d84d2000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007fc1d82b7000)
	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fc1d80af000)
	libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007fc1d7e2b000)
	liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007fc1d7c0f000)
	libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007fc1d78f4000)
	libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007fc1d76df000)

Hors ligne

#10 Le 16/12/2018, à 11:19

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Les librairies Qt ne pointent pas vers le bon répertoire. Elles devraient pointer vers /usr/lib/x86_64-linux-gnu et non vers /usr/local/lib/. Mais peut-être que ce problème est dû à ton essai de réinstallation depuis le site de Scribus.
Place toi dans le dossier /usr :

cd /usr

puis cherche, par exemple, la librairie libQtGui.so.4

find -name libQtGui.so.4

Poste nous le résultat stp.

Hors ligne

#11 Le 16/12/2018, à 21:51

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Merci pour ces précisions. J'ai exécuté le code proposé et j'obtiens le résultat suivant :

david@david-ASUSLINUX:~$ cd /usr
david@david-ASUSLINUX:/usr$ find -name libQtGui.so.4
./lib/x86_64-linux-gnu/libQtGui.so.4
./local/lib/libQtGui.so.4

Dernière modification par davidtreviz (Le 16/12/2018, à 21:51)

Hors ligne

#12 Le 16/12/2018, à 22:13

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

OK.
Il faudrait donc renommer temporairement les 3 librairies Qt qui se trouvent dans /usr/local/lib afin que Scribus se serve des librairies installées par défaut dans /usr/lib.

cd /usr/local/lib

puis

sudo mv libQtGui.so.4 libQtGui.so.4.old ; sudo mv libQtNetwork.so.4 libQtNetwork.so.4.old ; sudo mv libQtCore.so.4 libQtCore.so.4.old 

Ensuite, relance Scribus depuis le terminal pour voir :

scribus

Attention toutefois, si tu as installé d'autres logiciels depuis le net qui utilisent ces 3 librairies situées dans /usr/local/lib, il se peut qu'ils ne fonctionnent plus (peu probable).

Dernière modification par chobbes (Le 16/12/2018, à 22:14)

Hors ligne

#13 Le 16/12/2018, à 22:28

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Chobbes a écrit :

Attention toutefois, si tu as installé d'autres logiciels depuis le net qui utilisent ces 3 librairies situées dans /usr/local/lib, il se peut qu'ils ne fonctionnent plus (peu probable).

Et malheureusement, je crois que c'est le cas pour des logiciels que j'utilise plus souvent que Scribus. Du moins c'est un risque assez important.

J'ai plusieurs question qui me viennent :
- Serait-il possible de copier coller la bibliothèque indiquée dans le dossier souhaité par Scribus ? Si oui, que copier précisément et comment le faire ?
- Comment cela se fait-il que Scribus va chercher, sur cet ordi, cette bibliothèque et dans un autre ordi, ne se comporte pas pareil ? Alors que ce sont les 2 mêmes versions de Xubuntu et du logiciel Scirbus.

Merci d'avance pour vos réponses. smile Et surtout merci pour le temps passé à essayé de résoudre ce problème.

Dernière modification par davidtreviz (Le 16/12/2018, à 22:28)

Hors ligne

#14 Le 16/12/2018, à 22:44

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

davidtreviz a écrit :

Et malheureusement, je crois que c'est le cas pour des logiciels que j'utilise plus souvent que Scribus. Du moins c'est un risque assez important.

Pas sûr, c'est pour ça que je te propose de renommer temporairement les fichiers et de voir si scribus se lance. Si ce n'est pas le cas, le problème vient d'ailleurs.

davidtreviz a écrit :

- Serait-il possible de copier coller la bibliothèque indiquée dans le dossier souhaité par Scribus ? Si oui, que copier précisément et comment le faire ?

Pas besoin, les librairies se trouvent déjà dans /usr/lib/x86_64-linux-gnu/

davidtreviz a écrit :

- Comment cela se fait-il que Scribus va chercher, sur cet ordi, cette bibliothèque et dans un autre ordi, ne se comporte pas pareil ? Alors que ce sont les 2 mêmes versions de Xubuntu et du logiciel Scirbus.

C'est ce que je voudrais vérifier. Les librairies situées dans /usr/local/lib sont des librairies installées par l'utilisateur (volontairement ou involontairement par l'installation d'un logiciel depuis le net par exemple). Ca permet à certains logiciels d'utiliser leurs propres librairies plutôt que celles installées "par défaut". Ces chemins de librairies "personnalisés" sont paramétrés dans le dossier /etc/ld.so.conf.d.
Je ne sais pas ce que tu as essayé exactement mais il est probable que ton essai d'installation via le site internet de scribus ait engendré la copie des librairies dans /usr/local/lib. Ca ne veut pas dire que le problème vienne de là...

Dernière modification par chobbes (Le 16/12/2018, à 22:49)

Hors ligne

#15 Le 16/12/2018, à 23:30

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Chobbes a écrit :

Je ne sais pas ce que tu as essayé exactement mais il est probable que ton essai d'installation via le site internet de scribus ait engendré la copie des librairies dans /usr/local/lib. Ca ne veut pas dire que le problème vienne de là...

Je comprends.

Par contre, très sincèrement, je ne pense pas que cela vienne de là. Pourquoi ?
Si j'ai tenté de ré_installer par le site de l'éditeur, c'est justement parce que cela ne fonctionnait déjà plus avant.
Au départ, j'avais installé avec la logithèque Ubuntu.
Et cela ne fonctionnait déjà pas.
C'est pourquoi j'avais tout désinstallé et tout réinstallé.
Je pense donc que cela vient d'autre chose que ma réinstallation.

Mais je vais quand même faire ce que vous me proposez et je reviens vers vous dès que c'est fait pour vous dire ce que cela a donné.
Merci à vous pour toutes ces pistes.

Dernière modification par davidtreviz (Le 16/12/2018, à 23:31)

Hors ligne

#16 Le 17/12/2018, à 03:57

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

PS : Précision importante. Tout ce que je fais là, est fait avec une version officielle, installée depuis les paquets de la logithèque Ubuntu. Car la version de l'éditeur n'avait été qu'un essai mais ensuite, cela ne fonctionnant pas mieux, j'avais tout désinstallé par le terminal pour réinstaller la version de la logithèque Ubuntu. On est donc bien sur la version de la logithèque Ubuntu. Dans les 2 cas, cela ne fonctionne pas.

Dernière modification par davidtreviz (Le 17/12/2018, à 03:59)

Hors ligne

#17 Le 17/12/2018, à 04:15

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Alors... J'ai essayé de renommer les bibliothèque en OLD, comme demandé et ça marche ! Merci à vous !

Par contre j'espère que cela ne va pas impacter d'autres programmes. J'ai tenté d'ouvrir la plupart de mes programmes les plus importants et pour l'instant pas de problème remarqué.
Si tel était le cas, si je comprends bien, il faudrait que je renomme de nouveau les anciennes librairie passée en OLD, c'est bien ça ?

Dans ce cas, il faudrait que je fasse cela :

cd /usr/local/lib

puis

sudo mv libQtGui.so.4.old libQtGui.so.4 ; sudo mv  libQtNetwork.so.4.old libQtNetwork.so.4 ; sudo mv libQtCore.so.4.old libQtCore.so.4

Pouvez-vous me confirmer que j'ai bien compris le truc ?

Merci encore pour votre aide précieuse car pour l'instant, cela a résolu mon problème.

Dernière modification par davidtreviz (Le 17/12/2018, à 04:16)

Hors ligne

#18 Le 17/12/2018, à 09:42

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

davidtreviz a écrit :
cd /usr/local/lib

puis

sudo mv libQtGui.so.4.old libQtGui.so.4 ; sudo mv  libQtNetwork.so.4.old libQtNetwork.so.4 ; sudo mv libQtCore.so.4.old libQtCore.so.4

Pouvez-vous me confirmer que j'ai bien compris le truc ?

C'est bien ça. Mais c'est peu probable. Les logiciels que tu as installés n'ont pas forcément besoin de ces librairies Qt. Et dans tous les cas, ils iront avant tout piocher dans /usr/lib/x86_64-linux-gnu. Mais on verra en temps voulu...
Peux-tu passer le sujet en [résolu] en éditant ton premier message? Merci.

Hors ligne

#19 Le 20/12/2018, à 20:01

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Désolé de revenir vers vous mais depuis ce soir et une nouvelle mise à jour, ça ne fonctionne de nouveau plus...

Je n'ai absolument rien modifié depuis...

J'ai refait les opérations précédemment conseillées et voici ce que j'obtiens :

david@david-ASUSLINUX:~$ ldd /usr/bin/scribus
	linux-vdso.so.1 (0x00007ffe514bf000)
	libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007f930ae21000)
	libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0x00007f930a0b6000)
	libQtXml.so.4 => /usr/lib/x86_64-linux-gnu/libQtXml.so.4 (0x00007f9309e70000)
	libQtNetwork.so.4 => /usr/local/lib/libQtNetwork.so.4 (0x00007f9309b5b000)
	libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0x00007f930967a000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f93093c6000)
	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f9309181000)
	libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f9308f0a000)
	libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f9308ca2000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f9308a85000)
	libcups.so.2 => /usr/lib/x86_64-linux-gnu/libcups.so.2 (0x00007f93087f9000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f93085f5000)
	liblcms2.so.2 => /usr/lib/x86_64-linux-gnu/liblcms2.so.2 (0x00007f930839d000)
	libpodofo.so.0.9.5 => /usr/lib/libpodofo.so.0.9.5 (0x00007f9307ffa000)
	libhyphen.so.0 => /usr/lib/x86_64-linux-gnu/libhyphen.so.0 (0x00007f9307df4000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f9307a6b000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f93076cd000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f93074b5000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f93070c4000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9306ea5000)
	libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007f9306c00000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f93069ce000)
	libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007f93067cb000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f93065a3000)
	libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007f9306396000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f930618c000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f9305e54000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f9305c42000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f9305a3a000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f930bfa1000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f9305808000)
	liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f93055e2000)
	libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007f93053d4000)
	libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f9305189000)
	libgnutls.so.30 => /usr/lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007f9304e24000)
	libavahi-common.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-common.so.3 (0x00007f9304c18000)
	libavahi-client.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-client.so.3 (0x00007f9304a07000)
	libidn.so.11 => /lib/x86_64-linux-gnu/libidn.so.11 (0x00007f93047d4000)
	libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007f930435c000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f9304158000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f9303f52000)
	libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f9303c7c000)
	libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f9303a4a000)
	libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f9303846000)
	libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f930363b000)
	libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f930330c000)
	libidn2.so.0 => /usr/lib/x86_64-linux-gnu/libidn2.so.0 (0x00007f93030ef000)
	libunistring.so.2 => /usr/lib/x86_64-linux-gnu/libunistring.so.2 (0x00007f9302d71000)
	libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f9302b5e000)
	libnettle.so.6 => /usr/lib/x86_64-linux-gnu/libnettle.so.6 (0x00007f9302928000)
	libhogweed.so.4 => /usr/lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007f93026f4000)
	libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f9302473000)
	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f9302226000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f9302011000)
	libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f9301e0d000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f9301bf2000)
	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f93019ea000)
	libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f9301766000)
	liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007f930154a000)
	libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f930122f000)
	libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f930101a000)
david@david-ASUSLINUX:~$ cd /usr
david@david-ASUSLINUX:/usr$ find -name libQtGui.so.4
./lib/x86_64-linux-gnu/libQtGui.so.4
./local/lib/libQtGui.so.4
david@david-ASUSLINUX:/usr$ cd /usr/local/lib
david@david-ASUSLINUX:/usr/local/lib$ sudo mv libQtGui.so.4 libQtGui.so.4.old ; sudo mv libQtNetwork.so.4 libQtNetwork.so.4.old ; sudo mv libQtCore.so.4 libQtCore.so.4.old
[sudo] Mot de passe de david : 
mv: 'libQtGui.so.4' et 'libQtGui.so.4.old' identifient le même fichier
mv: 'libQtNetwork.so.4' et 'libQtNetwork.so.4.old' identifient le même fichier
mv: 'libQtCore.so.4' et 'libQtCore.so.4.old' identifient le même fichier
david@david-ASUSLINUX:/usr/local/lib$ scribus
scribus: symbol lookup error: scribus: undefined symbol: _ZN12QApplication10commitDataER15QSessionManager 

Dernière modification par davidtreviz (Le 20/12/2018, à 20:02)

Hors ligne

#20 Le 20/12/2018, à 20:20

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

davidtreviz a écrit :
david@david-ASUSLINUX:/usr$ cd /usr/local/lib
david@david-ASUSLINUX:/usr/local/lib$ sudo mv libQtGui.so.4 libQtGui.so.4.old ; sudo mv libQtNetwork.so.4 libQtNetwork.so.4.old ; sudo mv libQtCore.so.4 libQtCore.so.4.old
[sudo] Mot de passe de david : 
mv: 'libQtGui.so.4' et 'libQtGui.so.4.old' identifient le même fichier
mv: 'libQtNetwork.so.4' et 'libQtNetwork.so.4.old' identifient le même fichier
mv: 'libQtCore.so.4' et 'libQtCore.so.4.old' identifient le même fichier

Oui, les fichiers ".old" existant déjà, il n'est pas possible de donner le même nom aux autres fichiers.

En les supprimant, ça devrait refonctionner mais avant de faire cela, merci de nous poster la liste des dernières mises à jour effectuées. Tu (je continue de te tutoyer mais si ça te gêne, dis-le moi wink) trouveras cela dans le fichier /var/log/apt/history.log. Poste nous les dernières en date (à la fin du fichier).

Edit : en attendant, tu peux te créer un lanceur sur le bureau ou le tableau de bord en mettant la commande ci-dessous. Ca devrait permettre à scribus d'utiliser les bonnes librairies.

LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu /usr/bin/scribus

Dernière modification par chobbes (Le 20/12/2018, à 21:30)

Hors ligne

#21 Le 20/12/2018, à 21:29

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Pas de soucis big_smile OK pour le tutoiement.
J'obtiens ça pour la dernière mise à jour de ce soir :

Start-Date: 2018-12-20  18:43:55
Commandline: aptdaemon role='role-commit-packages' sender=':1.57'
Upgrade: gnome-desktop3-data:amd64 (3.28.2-0ubuntu1.1, 3.28.2-0ubuntu1.2), libgnome-desktop-3-17:amd64 (3.28.2-0ubuntu1.1, 3.28.2-0ubuntu1.2)
End-Date: 2018-12-20  18:43:57

Hors ligne

#22 Le 20/12/2018, à 21:39

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Voici un screen de mon dossier /usr/local/lib

Il a recréé les fichiers précédemment mis en old.

Qu'est-ce qui selon toi cause cette restauration ? Et comment pourrais je l'éviter ?
http://formation-conseil.net/Capture d’écran_2018-12-20_20-31-27.png

Dernière modification par davidtreviz (Le 20/12/2018, à 21:40)

Hors ligne

#23 Le 20/12/2018, à 21:57

chobbes

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

J'ai édité mon post précédent juste avant ta réponse. Je te remets une solution provisoire ici :
En attendant, tu peux te créer un lanceur sur le bureau ou le tableau de bord en mettant la commande ci-dessous. Ca devrait permettre à scribus d'utiliser les bonnes librairies.

LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu /usr/bin/scribus

Tu peux tester cette commande avant dans le terminal pour voir si cela fonctionne.

Tu n'as rien d'autre entre le 17/12 et aujourd’hui dans /var/log/apt/history.log?
Je ne vois pas ce qui peut remettre les librairies dans /usr/local/lib (liens symboliques en fait). Ca dépasse mes compétences.

Pour la suite, peux tu, stp, nous poster le résultat de la commande ci-dessous, en répondant non à la demande de confirmation.

sudo apt remove libqtgui4

Dernière modification par chobbes (Le 20/12/2018, à 22:09)

Hors ligne

#24 Le 20/12/2018, à 22:10

nam1962

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Peux-tu nous donner :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1
snap list
scribus -v

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#25 Le 21/12/2018, à 03:02

davidtreviz

Re : [Résolu]Scribus ne se lance plus sur Xubuntu 18;04

Chobbes a écrit :

Tu n'as rien d'autre entre le 17/12 et aujourd’hui dans /var/log/apt/history.log?

Voilà tout ce que j'ai depuis le 17 décembre :

Start-Date: 2018-12-17  00:50:11
Commandline: apt-get remove scribus
Requested-By: david (1000)
Remove: scribus:amd64 (1.4.6+dfsg-4build1)
End-Date: 2018-12-17  00:50:12

Start-Date: 2018-12-17  00:50:27
Commandline: apt autoremove
Requested-By: david (1000)
Remove: libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-7ubuntu1), qt-at-spi:amd64 (0.4.0-8), libqt4-declarative:amd64 (4:4.8.7+dfsg-7ubuntu1), qdbus:amd64 (4:4.8.7+dfsg-7ubuntu1), qtcore4-l10n:amd64 (4:4.8.7+dfsg-7ubuntu1), libqtcore4:amd64 (4:4.8.7+dfsg-7ubuntu1), scribus-data:amd64 (1.4.6+dfsg-4build1), libqtgui4:amd64 (4:4.8.7+dfsg-7ubuntu1), libqt4-script:amd64 (4:4.8.7+dfsg-7ubuntu1), libqtdbus4:amd64 (4:4.8.7+dfsg-7ubuntu1), libqt4-sql:amd64 (4:4.8.7+dfsg-7ubuntu1), icc-profiles-free:amd64 (2.0.1+dfsg-1), libqt4-xml:amd64 (4:4.8.7+dfsg-7ubuntu1), libqt4-dbus:amd64 (4:4.8.7+dfsg-7ubuntu1), libqt4-sql-mysql:amd64 (4:4.8.7+dfsg-7ubuntu1), qtchooser:amd64 (64-ga1b6736-5), libmng2:amd64 (2.0.2-0ubuntu3), libqt4-network:amd64 (4:4.8.7+dfsg-7ubuntu1)
End-Date: 2018-12-17  00:50:32

Start-Date: 2018-12-17  00:51:24
Commandline: apt-get install scribus
Requested-By: david (1000)
Install: libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), qt-at-spi:amd64 (0.4.0-8, automatic), libqt4-declarative:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), qdbus:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), scribus:amd64 (1.4.6+dfsg-4build1), qtcore4-l10n:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqtcore4:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), scribus-data:amd64 (1.4.6+dfsg-4build1, automatic), libqtgui4:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqt4-script:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqtdbus4:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqt4-sql:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), icc-profiles-free:amd64 (2.0.1+dfsg-1, automatic), libqt4-xml:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqt4-dbus:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), libqt4-sql-mysql:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic), qtchooser:amd64 (64-ga1b6736-5, automatic), libmng2:amd64 (2.0.2-0ubuntu3, automatic), libqt4-network:amd64 (4:4.8.7+dfsg-7ubuntu1, automatic)
End-Date: 2018-12-17  00:51:34

Start-Date: 2018-12-17  00:52:19
Commandline: apt-get upgrade
Requested-By: david (1000)
Upgrade: libreoffice-wiki-publisher:amd64 (1.2.0+LibO6.0.6-0ubuntu0.18.04.1, 1.2.0+LibO6.0.7-0ubuntu0.18.04.2), libreoffice-math:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-script-provider-js:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-report-builder-bin:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-sdbc-postgresql:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-gtk3:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-java-common:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-base:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-core:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-l10n-en-gb:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-l10n-en-za:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-l10n-fr:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-librelogo:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), python3-uno:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-script-provider-python:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-style-galaxy:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-base-core:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-ogltrans:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-impress:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-help-fr:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), ure:amd64 (6.0.6-0ubuntu0.18.04.1, 6.0.7-0ubuntu0.18.04.2), libreoffice-sdbc-hsqldb:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-writer:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-common:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-script-provider-bsh:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-nlpsolver:amd64 (0.9+LibO6.0.6-0ubuntu0.18.04.1, 0.9+LibO6.0.7-0ubuntu0.18.04.2), libreoffice:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), fonts-opensymbol:amd64 (2:102.10+LibO6.0.6-0ubuntu0.18.04.1, 2:102.10+LibO6.0.7-0ubuntu0.18.04.2), libreoffice-report-builder:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), uno-libs3:amd64 (6.0.6-0ubuntu0.18.04.1, 6.0.7-0ubuntu0.18.04.2), libreoffice-style-tango:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-help-en-gb:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-help-en-us:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-gnome:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-calc:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-base-drivers:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-draw:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2), libreoffice-avmedia-backend-gstreamer:amd64 (1:6.0.6-0ubuntu0.18.04.1, 1:6.0.7-0ubuntu0.18.04.2)
End-Date: 2018-12-17  00:52:43

Start-Date: 2018-12-17  01:01:19
Commandline: apt-get install --reinstall scribus
Requested-By: david (1000)
Reinstall: scribus:amd64 (1.4.6+dfsg-4build1)
End-Date: 2018-12-17  01:01:20

Start-Date: 2018-12-20  18:43:55
Commandline: aptdaemon role='role-commit-packages' sender=':1.57'
Upgrade: gnome-desktop3-data:amd64 (3.28.2-0ubuntu1.1, 3.28.2-0ubuntu1.2), libgnome-desktop-3-17:amd64 (3.28.2-0ubuntu1.1, 3.28.2-0ubuntu1.2)
End-Date: 2018-12-20  18:43:57

Start-Date: 2018-12-20  18:55:11
Commandline: apt-get install --reinstall scribus
Requested-By: david (1000)
Reinstall: scribus:amd64 (1.4.6+dfsg-4build1)
End-Date: 2018-12-20  18:55:12

__________________________________

Chobbes a écrit :

En attendant, tu peux te créer un lanceur sur le bureau ou le tableau de bord en mettant la commande ci-dessous. Ca devrait permettre à scribus d'utiliser les bonnes librairies.

LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu /usr/bin/scribus

Tu peux tester cette commande avant dans le terminal pour voir si cela fonctionne.

Alors, j'ai exécuté cette commande et je te confirme que cela le lance bien. L'icone ne se lance cependant toujours pas mais par ta ligne de commande, dans le terminal, il se lance.

__________________________________

chobbes a écrit :

Pour la suite, peux tu, stp, nous poster le résultat de la commaLD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu /usr/bin/scribusnde ci-dessous, en répondant non à la demande de confirmation.

sudo apt remove libqtgui4

Alors j'obtiens ça en répondant non.

david@david-ASUSLINUX:~$ sudo apt remove libqtgui4
[sudo] Mot de passe de david : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  icc-profiles-free libmng2 libqt4-dbus libqt4-network libqt4-script
  libqt4-sql libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4
  libqtdbus4 qdbus qtchooser qtcore4-l10n scribus-data
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libqt4-declarative libqtgui4 qt-at-spi scribus
0 mis à jour, 0 nouvellement installés, 4 à enlever et 0 non mis à jour.
Après cette opération, 36,9 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n
Annulation.
david@david-ASUSLINUX:~$ 

__________________________________

Nam1962 a écrit :

Peux-tu nous donner :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1
snap list
scribus -v

Pour ces lignes de commande, j'obtiens ça :

david@david-ASUSLINUX:~$ cat /etc/apt/sources.list
# deb cdrom:[Xubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725)]/ bionic main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic universe
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
david@david-ASUSLINUX:~$ ls /etc/apt/sources.list.d -1
david@david-ASUSLINUX:~$ snap list
Name               Version         Rev   Tracking  Publisher     Notes
0ad                0.0.23-alpha    61    stable    osomon        -
core               16-2.36.3       6130  stable    canonical✓    core
core18             18              536   stable    canonical✓    base
gimp               2.10.8          94    stable    snapcrafters  -
gtk-common-themes  0.1-4-g88bc1b2  818   stable    canonical✓    -
notepad-plus-plus  7.6.1           171   stable    mmtrt         -
skype              8.34.0.78       66    stable    skype✓        classic
wine-platform      3.0.4-4.0~rc2   56    stable    mmtrt         -
david@david-ASUSLINUX:~$ scribus -v
scribus: symbol lookup error: scribus: undefined symbol: _ZN12QApplication10commitDataER15QSessionManager

Dernière modification par davidtreviz (Le 21/12/2018, à 03:18)

Hors ligne